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Malformed Help File Causes Help Utility to Stop Responding

Article ID:231605
Last Review:November 1, 2006
Revision:3.4
This article was previously published under Q231605
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SYMPTOMS

A specially-malformed Microsoft Help file may be used to exploit a security vulnerability on a Windows NT-based computer. When a user activates the Windows Help file tool (for example, by pressing the F1 key) this vulnerability may be used to run a program and may cause the Help file tool to stop responding (hang).

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CAUSE

The Help tool parses and displays Help information for programs. The Help information is contained in several file types that are generated by the Microsoft Help Compiler program and are stored (by default) in the %SystemRoot%\Help folder. Users have both Read and Write permissions to this folder by default. An unchecked buffer exists in the Help utility, and a Help file that has been carefully modified could be used to run a program on the local computer using a buffer overrun technique. Because the Help Compiler program's output files do not generate the specific malformation at issue here, this vulnerability could not be accidentally exploited.

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RESOLUTION

Windows NT Server or Workstation 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
http://www.microsoft.com/windows/servicepacks/ (http://www.microsoft.com/Windows/ServicePacks/) -or-

152734 (http://support.microsoft.com/kb/152734/EN-US/) how to obtain the latest windows nt 4.0 service pack
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)
NOTE: This hotfix can be applied to computers running Windows NT 4.0 Service Pack 4 or Windows NT 4.0 Service Pack 5.

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Windows NT Server 4.0, Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 (http://support.microsoft.com/kb/152734/EN-US/) How to Obtain the Latest Windows NT 4.0 Service Pack

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows NT Server version 4.0, Terminal Server Edition Service Pack 6.

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MORE INFORMATION

Computers primarily at risk from this vulnerability are workstations, terminal servers, and other computers that allow users to log on interactively and add or modify Help files. Servers generally do not allow normal users to interactively log on. Note that this vulnerability would affect only the local computer; there is no capability to directly attack a remote computer by means of this vulnerability.

For related information on this problem, please visit the Web site at:
http://www.microsoft.com/security/bulletins/MS99-015.asp (http://www.microsoft.com/security/bulletins/MS99-015.asp)
For additional security-related information about Microsoft products, please visit the Web site at:
http://www.microsoft.com/security/ (http://www.microsoft.com/security/)

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APPLIES TO
Microsoft Windows NT Server 4.0, Terminal Server Edition
Microsoft Windows NT Workstation 4.0 Developer Edition
Microsoft Windows NT Server 4.0 Standard Edition
Microsoft Windows NT 4.0 Service Pack 1
Microsoft Windows NT 4.0 Service Pack 2
Microsoft Windows NT 4.0 Service Pack 3
Microsoft Windows NT 4.0 Service Pack 4
Microsoft Windows NT Server 4.0 Enterprise Edition

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Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbqfe KB231605

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