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You receive an "Installer terminated prematurely" error message when you install Office 2000

Article ID:234928
Last Review:February 15, 2007
Revision:5.3
This article was previously published under Q234928
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SYMPTOMS

When you attempt to install Office 2000, the following symptoms may occur:
You receive the following error message:
Installer terminated prematurely.
When you click OK, Setup terminates.

You create a verbose log file using a command line similar to the following:
d:\setup.exe /L*V c:\verboselog.txt
When you open the Verboselog.txt log file in WordPad and scroll to the bottom of the log file, you see text similar to the following:
MSI (c) (C9:A5): Executing op: ActionStart(Name=RemoveODBC,,)
Action 12:03:14: RemoveODBC. 
MSI (c) (C9:A5): Executing op: ODBCDriverManager()
MSI (c) (C9:A5): Generating exception report.
=====================================================
Exception code: C0000005 ACCESS_VIOLATION
Module: C:\WINDOWS\SYSTEM\KERNEL32.DLL
Function: 0xbff9a3c0
=====================================================
						

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CAUSE

This problem can occur when your ODBC Control Panel files are damaged.

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RESOLUTION

To resolve this problem, follow the steps in Method 1. If this does not resolve the problem, try Method 2, and then, if necessary, Method 3.

Note Use methods 1 and 2 only if your operating system is Microsoft Windows 95, Microsoft Windows 98 (original), or Microsoft Windows NT 4.0. Do NOT rename ODBC files on Windows 2000, Microsoft Windows XP, or Microsoft Windows 2003. Instead, use Method 3.

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Method 1: Install Microsoft Internet Explorer 5

1.Insert the Office 2000 CD into your CD-ROM drive.
2.Click Start, point to Programs, and then click Windows Explorer.
3.Using Windows Explorer, open the \IE5\En folder on the Office CD, and double-click Ie5setup.exe.
4.Proceed through the Internet Explorer 5 installation, and then restart your computer if prompted to do so.
5.When Internet Explorer 5 is installed, run Office Setup again.
If the problem still occurs, follow the steps in Method 2.

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Method 2: Rename the ODBC Files

If you do not want to install Internet Explorer 5, or if Method 1 does not resolve the problem, follow these steps:
1.Quit all running programs.
2.Click Start, point to Find, and click Files or Folders.
3.In the Look in list, click My Computer. Select the Include subfolders check box. In the Named box, type each of the following file names, separated by a space:
Odbccp32.dll
Odbcint.dll
Msdasql.dll
4. In the list of files found, right-click each file. On the shortcut menu that appears, click Rename.
5.Rename each file by changing the file name extension to .old. If you do not have one of these files, go to the next one.
6.Run Office Setup again.
If the problem still occurs, follow the steps in Method 3.

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Method 3: Install the Latest Version of MDAC

If Methods 1 and 2 fail to correct this problem, you may be able to correct this problem by downloading and installing the latest version of the Microsoft Data Access Components (MDAC).

To download the latest MDAC version, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/data/aa937730.aspx (http://msdn2.microsoft.com/en-us/data/aa937730.aspx)

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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MORE INFORMATION

This problem should not occur if you install by using the Office 2000 SR-1 Full Install Product. To order this CD-ROM set, call the Microsoft Order Desk at (800) 360-7561.

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REFERENCES

For additional information about the following Setup error message, click the article number below to view the article in the Microsoft Knowledge Base:
230895 (http://support.microsoft.com/kb/230895/EN-US/) OFF2000: "Installation Ended Prematurely Because of an Error" When You Run Office Setup
For more articles about how to troubleshoot specific errors in Office Setup:
Click here to view a list of Windows Installer Errors for Office 2000 articles (http://support.microsoft.com/search/default.aspx?catalog=lcid%3d1033&spid=2484&query=xlwinsetup%2band%2bkberrmsg&adv=&mode=s&cat=false)
For more articles with general information about how to troubleshoot Office errors:
Click here to view a list of Office 2000 Troubleshooting articles (http://support.microsoft.com/search/default.aspx?catalog=lcid%3d1033&spid=2484&query=kbdtatshoot&adv=&mode=s&cat=false)

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APPLIES TO
Microsoft Office 2000 Premium Edition
Microsoft Office 2000 Professional Edition
Microsoft Office 2000 Standard Edition
Microsoft Office 2000 Small Business Edition
Microsoft Office 2000 Developer Edition
Microsoft Access 2000 Standard Edition
Microsoft Excel 2000 Standard Edition
Microsoft FrontPage 2000 Standard Edition
Microsoft Outlook 2000 Standard Edition
Microsoft PowerPoint 2000 Standard Edition
Microsoft Word 2000 Standard Edition

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Keywords: 
kbsetup kbtshoot kbprb kbpending KB234928

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