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Problems Using SCSI Scanner Without an Updated ASPI Layer

Article ID:300674
Last Review:October 18, 2001
Revision:1.0
This article was previously published under Q300674

SYMPTOMS

You may experience one or more of the following SCSI scanner-related symptoms:
After you install a SCSI scanner that does not contain Windows Imaging Acquisition (WIA) drivers, the scanner may not be recognized by the software that is included with the scanner and that is provided by the scanner manufacturer.
After you install the software that is provided by the scanner manufacturer, you may receive the following Configuration Manager error message:
Error Reading SCSI Devices.
After you start the software that is included with the scanner and try to preview an image, you may receive the following error message:
No configured device found. Please run configuration utility.
The scanner may not be listed in Device Manager.

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CAUSE

This problem can occur if an updated ASPI layer has not been installed on your computer. By default, Windows XP does not include ASPI support.

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RESOLUTION

To resolve this problem, obtain and install ASPI version 4.57 or later. For information about how to do so, please view the following Adaptec Web site:
http://www.adaptec.com (http://www.adaptec.com)
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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MORE INFORMATION

ASPI provides the ability to extend the capabilities and number of devices supported by the operating system. You can determine what version of ASPI you have by viewing the version number of the Aspi.sys or Aspi32.sys files. Note that these files are typically located in the Windows\System32\Drivers folder.

By default, a SCSI scanner appears in the Other Devices branch in Device Manager even if the scanner is working correctly.

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APPLIES TO
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional

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Keywords: 
kberrmsg kbenv kbprb KB300674

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