Help and Support

"Help and Support Center" Does Not Collect All the Hardware Information

Article ID:307733
Last Review:January 8, 2002
Revision:1.0
This article was previously published under Q307733
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SYMPTOMS

When you click Find information about the hardware installed on his computer under My Computer Information in Help and Support Center, you may receive the following error message:
'all.part2' is null, or it is not an object.
This message occurs when the information collection is 9 percent complete (when Help and Support is collecting local disk information). When this occurs, the collecting of information stops, and the mouse pointer becomes a "busy" (or hourglass) pointer. However, you can still move the mouse pointer and continue working in Help and Support Center.

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CAUSE

The following items can cause this issue:
You are logged on with a non-administrator account.
A removable drive (such as a Zip drive, memory stick, or Jazz drive) is attached to the computer.
One of the drives does not have a valid partition.

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WORKAROUND

To work around this issue, use either of the following methods to view information about the installed hardware.

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Use Device Manager

1.Click Start, and then click Control Panel.
2.If Control Panel starts in Category view, click Performance and Maintenance, and then click System. If Control Panel is in Classic view, double-click System.
3.Click System, and then click the Hardware tab.
4.Click Device Manager.
NOTE: Click Show Hidden Devices on the View menu to see non-Plug and Play devices.

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Use Msinfo32.exe

1.In Help and Support Center, click Use Tools to view your computer information and diagnose problems in the Pick a Task list.
2.Click Advanced System Information in the Tools list.
3.Click View detailed system information (Msinfo32.exe) (on the right side of the screen).
4.Click the plus sign (+) next to Components to view the hardware details.
Or, you can use the following steps:
1.Click Start, and then click Run.
2.Type msinfo32.exe, and then click OK.
3.Click the plus sign (+) next to Components to view the hardware details.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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APPLIES TO
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional

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Keywords: 
kbprb KB307733

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