Windows 8で自動修復が失敗した後に PC を更新またはリセットできない

この記事では、自動修復が失敗した後に PC を更新またはリセットできない問題を修正します。

適用対象: Windows 8
元の KB 番号: 2823223

現象

次のような状況で問題が発生します。

  • PC にWindows 8またはWindows 8 Proがインストールされている。
  • お使いの PC が Windows で起動に失敗し、自動修復を起動して Windows の修復を試みます。
  • 自動修復は、お使いのPCを修復することはできませんし、 高度なオプションを選択します。
  • [ トラブルシューティング] を選択したら、[PC の 更新] または [ PC のリセット] のいずれかを選択します。

このシナリオでは、復旧が失敗し、メイン WinRE 画面に戻ります。

原因

この問題は、システムまたはソフトウェアレジストリハイブが破損または破損した場合に発生する可能性があります。

解決方法

この問題を解決するには、次の手順に従います。

注:

これらの手順は、システムが起動できない状態であるため、[PC の更新] または [Windows REで PC をリセットする] オプションを使用しようとしている場合にのみ使用する必要があります。

  1. 自動修復で PC の修復に失敗した後、[ 詳細オプション ] を選択し、[ トラブルシューティング] を選択します。

  2. [ 詳細オプション ] を選択し、[コマンド プロンプト] を選択します。

  3. メッセージが表示されたら、ユーザー名のパスワードを入力します。

  4. コマンド プロンプトで、次のコマンドを入力して\windows\system32\config フォルダーに移動します。

    cd %windir%\system32\config
    
  5. 次のコマンドを使用して、System および Software レジストリ ハイブの名前を System.001 と Software.001 に変更します。

    ren system system.001  
    ren software software.001
    

    注:

    ソフトウェア ハイブの名前を変更しても、"PC の更新" オプションを使用することはできません。 [PC の更新] オプションを使用する場合は、システム ハイブの名前のみを変更します。 ソフトウェア ハイブも破損している場合は、"PC の更新" オプションを使用できない可能性があります。

  6. 引用符なしで 「exit 」と入力してコマンド プロンプトを終了し、PC を再起動して [自動修復] 画面に戻ります。

  7. [詳細オプション] を選択し、[トラブルシューティング] を選択した後、[PC の更新] または [PC のリセット] を選択します。

詳細

[PC のリセット] オプションを使用すると、ハード ドライブ上のすべてのファイルが削除され、PC の OEM によってプレインストールされたWindows 8のバージョンに PC がリセットされます。 購入後に PC にインストールされたすべての新しいアプリケーションを再インストールする必要があります。