Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

L'installazione di un aggiornamento per Microsoft .NET Framework versione 4 potrebbe non riuscire se si verificano le seguenti condizioni:

  • È stato già installato Microsoft .NET Framework 4 o Microsoft .NET Framework 4 Client Profile.

  • Il sistema richiede un riavvio ma non è stato ancora riavviato prima dell'installazione del nuovo aggiornamento.

Nota Se l'aggiornamento viene installato tramite il sito Windows Update, l'aggiornamento potrebbe sembrare proposto e installato. Dopo il riavvio del computer, tuttavia, viene riproposto lo stesso aggiornamento.

Sintomi

Ciò si verifica perché con l'installazione di Microsoft .NET Framework 4 determinati componenti sono bloccati o utilizzati fino a quando il sistema non viene riavviato. Questi componenti non possono essere aggiornati fino a quando il sistema non viene riavviato. Per tale motivo, nello scenario descritto nella sezione Sintomi, la versione dello shim (mscoree.dll) corrisponde a Microsoft .NET Framework versione 3.5 SP1 o precedente. Con l'installazione di Microsoft .NET Framework 4, vengono distribuite determinate impostazioni che impediscono il corretto funzionamento dello shim meno recente fino a quando non viene aggiornato dopo il riavvio del sistema. In questo scenario, se si tenta di installare un altro aggiornamento per Microsoft .NET Framework senza che il sistema sia stato riavviato, l'aggiornamento tenterà di utilizzare una distribuzione GAC (Global Assembly Cache) per i file inclusi nell'aggiornamento. L'operazione GAC richiede lo shim. Tuttavia, poiché lo stato dello shim è incoerente prima del riavvio, l'operazione GAC non riesce. Per questa ragione, l'aggiornamento non riesce.

Cause

Per evitare questo problema, riavviare il sistema prima di installare i nuovi aggiornamenti di Microsoft .NET Framework. Se questa condizione si è già verificata e l'installazione di un aggiornamento non è riuscita a causa di questo problema, riavviare il computer e reinstallare i nuovi aggiornamenti.

Workaround

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Le informazioni in questo articolo si applicano a".

Status

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×