Jak administratorzy systemu mogą rozwiązać problem związany z komunikatem o błędzie „HTTP 404 — Nie odnaleziono pliku” wyświetlanym na serwerze z programem IIS

Ten artykuł pomaga rozwiązać problem polegający na tym, że na serwerze z uruchomionymi usługami Internet Information Services (IIS) wystąpił błąd HTTP 404 nie znaleziono pliku.

Uwaga

Ten artykuł jest przeznaczony dla administratorów witryn sieci Web. Użytkownicy końcowi, którzy doświadczają tych błędów, powinni powiadomić administratora witryny sieci Web o problemie.

Oryginalna wersja produktu: Internet Information Services
Oryginalny numer KB: 248033

Symptomy

Po zażądaniu strony sieci Web w górnej części przeglądarki internetowej zostanie wyświetlony następujący komunikat o błędzie:

Nie można odnaleźć strony
Strona, którą szukasz, mogła zostać usunięta, jej nazwa została zmieniona lub jest tymczasowo niedostępna.

Poniżej na stronie sieci Web pojawia się następujący komunikat o błędzie:

HTTP 404 — nie znaleziono pliku
Internet Information Services

Przyczyna

Serwer sieci Web zwraca komunikat o błędzie HTTP 404 — plik nie został znaleziony, gdy nie może pobrać żądanej strony.

Poniżej podano typowe przyczyny wyświetlania tego komunikatu o błędzie:

  • Zażądany plik ma zmienioną nazwę.
  • Żądany plik został przeniesiony do innej lokalizacji i/lub usunięty.
  • Żądany plik jest tymczasowo niedostępny z powodu konserwacji, uaktualnień lub innych nieznanych przyczyn.
  • Zażądany plik nie istnieje.
  • IIS 6.0: Nie włączono odpowiedniego rozszerzenia usługi sieci Web lub typu MIME.
  • Katalog wirtualny jest mapowany na katalog główny dysku na innym serwerze.

Rozwiązanie

Aby rozwiązać ten problem, sprawdź, czy plik żądany w adresie URL przeglądarki istnieje na komputerze usług IIS i czy znajduje się we właściwej lokalizacji.

Użyj przystawki programu Microsoft Management Console (MMC) usług IIS, aby określić, gdzie żądany plik musi istnieć w systemie plików komputera usług IIS.

Jest to ważne, jeśli witryna sieci Web używa katalogu wirtualnego (VDIR). VDIR to katalog, który nie znajduje się w katalogu macierzystym witryny sieci Web, ale dla przeglądarki klienta wydaje się, że tak jest. Ten katalog wirtualny musi być mapowany na podfolder na dysku lub odwoływać się do plików według nazwy.

Załóżmy na przykład, że adres URL, który spowodował błąd 404, to http://Microsoft.Com/Test/File1.htm, a przystawka usług IIS pokazuje, że dla witryny sieci Web Microsoft.Com katalog /Test/ jest w rzeczywistości katalogiem wirtualnym mapowanym na lokalizację c:\Information na komputerze usług IIS. Oznacza to, że należy sprawdzić, czy plik File1.htm znajduje się w katalogu c:\Information (i czy nazwa pliku jest poprawnie zapisana).

Wpis "IIS Dynamic Content: A 404.2" w rozszerzonym pliku dziennika W3C jest rejestrowany, gdy rozszerzenie sieci Web nie jest włączone. Użyj przystawki programu Microsoft Management Console (MMC) usług IIS, aby włączyć odpowiednie rozszerzenie sieci Web. Domyślne rozszerzenia sieci Web obejmują m. in.: ASP, ASP.NET, po stronie serwera np. publikowanie WebDAV, rozszerzenia serwera FrontPage, wspólny interfejs bramy (CGI). Rozszerzenia niestandardowe muszą być dodane i jawnie włączone. Aby uzyskać więcej informacji, zapoznaj się z plikiem pomocy programu IIS.

Wpis "IIS Static Content: A 404.3" w pliku dziennika rozszerzonego W3C jest rejestrowany, gdy rozszerzenie nie jest mapowane na znane rozszerzenie we właściwości mapowania MIME. Użyj przystawki programu Microsoft Management Console (MMC) usług IIS, aby skonfigurować odpowiednie rozszerzenie w mapowaniu MIME. Aby uzyskać więcej informacji, zapoznaj się z plikiem pomocy programu IIS.

Aby uzyskać więcej informacji o innych, mniej typowych przyczynach tego komunikatu o błędzie, zobacz artykuł Ukryte pliki statyczne usług IIS zwracają błędy HTTP 404 lub Odmowa dostępu.

Więcej informacji