كيفية إرسال نموذج InfoPath إلى مكتبة مستندات Windows SharePoint Services


مقدمة


في الإصدار الأصلي من Microsoft Office InfoPath 2003، لا يمكن إرسال بيانات النموذج إلى مكتبة مستندات Microsoft Windows SharePoint Services مباشرة. توضح هذه المقالة كيفية تصميم قالب نموذج يستخدم برنامج نصي لإرسال بيانات النموذج إلى مكتبة مستندات Windows SharePoint Services. في InfoPath 2003 Service Pack 1 (SP1) والإصدارات الأحدث من InfoPath، يمكنك إرسال بيانات النموذج إلى مكتبة مستندات Windows SharePoint Services مباشرة باستخدام واجهة المستخدم. تتضمن هذه المقالة الخطوات التي يجب عليك استخدامها للقيام بذلك.


مزيد من المعلومات


تصميم النموذج مصدر البيانات والتخطيط في InfoPath 2003

  1. بدء تشغيل InfoPath. تصميم نموذج فارغ جديد.
  2. في جزء المهام مصدر البيانات ، إضافة مصدر بيانات إلى النموذج الخاص بك. للقيام بذلك، اتبع الخطوات التالية:
    1. انقر بالزر الأيمن myFieldsومن ثم انقر فوق إضافة.

      يظهر مربع الحوار إضافة حقل أو مجموعة .
    2. اكتب الاسم الأول اسم الحقل ومن ثم انقر فوق موافق.
    3. كرر الخطوة أ. نوع MiddleInitial كاسم الحقل ومن ثم انقر فوق موافق.
    4. كرر الخطوة أ. نوع "اسم العائلة" كاسم الحقل ومن ثم انقر فوق موافق.
  3. قم بإضافة myFields إلى النموذج الخاص بك.
  4. انقر فوق مقطع ذو عناصر تحكم.

تصميم النموذج مصدر البيانات والتخطيط في InfoPath 2007

  1. بدء تشغيل InfoPath 2007.
  2. انقر فوق تصميم "قالب نموذج"، انقر فوق فارغ، وثم انقر فوق موافق.
  3. في جزء المهام تصميم ، انقر فوق مصدر البيانات.
  4. انقر بالزر الأيمن myFieldsومن ثم انقر فوق إضافة.
  5. في إطار إضافة حقل أو مجموعة ، اكتب الاسم الأول اسم الحقل، ومن ثم انقر فوق موافق.
  6. في إطار إضافة حقل أو مجموعة ، اكتب MiddleInitial كاسم الحقل ومن ثم انقر فوق موافق.
  7. في إطار إضافة حقل أو مجموعة ، اكتب اسم الحقل "اسم العائلة" ومن ثم انقر فوق موافق.
  8. إضافة مجموعة myFields إلى النموذج، ومن ثم انقر فوق عناصر التحكم في "جدول التخطيط".

تصميم النموذج مصدر البيانات والتخطيط في InfoPath 2010

  1. بدء تشغيل InfoPath 2010.
  2. في قوالب النماذج شيوعاً، انقر فوق فارغ، ومن ثم انقر فوق تصميم هذا النموذج.
  3. إذا لم يكن هناك جزء مهام التصميم ، انقر فوق مصدر البيانات.
  4. إذا لم يكن هناك جزء الحقول المعروضة إلى اليمين، ثم ضمن علامة التبويب بيانات ، انقر فوق إظهار الحقول.
  5. في إطار إضافة حقل أو مجموعة ، اكتب الاسم الأول اسم الحقل، ومن ثم انقر فوق موافق.
  6. إضافة حقل آخر. في إطار إضافة حقل أو مجموعة ، اكتب MiddleInitial كاسم الحقل ومن ثم انقر فوق موافق.
  7. إضافة حقل آخر. في إطار إضافة حقل أو مجموعة ، اكتب اسم الحقل "اسم العائلة" ومن ثم انقر فوق موافق.
  8. إضافة مجموعة myFields إلى النموذج.

إرسال بيانات النموذج إلى مكتبة مستندات SharePoint Services

يمكنك استخدام برنامج نصي أو واجهة المستخدم بإرسال بيانات النموذج إلى مكتبة مستندات SharePoint Services.

استخدام برنامج نصي لإرسال بيانات النموذج إلى مكتبة مستندات SharePoint Services في InfoPath 2003

  1. من القائمة أدوات ، انقر فوق إرسال النماذج.

    يظهر مربع الحوار إرسال النماذج .
  2. في مربع الحوار إرسال النماذج ، انقر فوق تمكين الإرسال.
  3. في مربع الحوار إرسال ، انقر فوق إرسال باستخدام برنامج نصي مخصص.
  4. انقر فوق فتح محرر البرامج النصية ل Microsoftومن ثم انقر فوق موافق.

    يبدأ محرر البرامج النصية ل Microsoft.
  5. تعديل الحدث OnSubmitRequest كما يلي.

    ملاحظة: يجب تغيير قيمة المتغير strURL إلى محدد موقع معلومات صحيح في التعليمات البرمجية. يشير محدد موقع المعلومات في نموذج التعليمات البرمجية التالي ملقم اسم موقع SharePoint تسمى اسم الموقعو اسم الخادممكتبة مستندات تسمى دوكومينتليبرارينامي.
    function XDocument::OnSubmitRequest(eventObj)
    {
    // If the submit operation is successful, set
    // eventObj.ReturnStatus = true.
    var fSuccessful = false;

    // Set the URL of the file that you want to submit here.
    var strUrl = "http://ServerName/SiteName/DocumentLibraryName/testform.xml";

    try
    {
    // Create an xmlhttp object.
    var oXmlHttp = new ActiveXObject("MSXML2.XMLHTTP");

    // See whether the document with the same name already exists in the Windows SharePoint Services (WSS) document library.
    oXmlHttp.Open("HEAD", strUrl, false);
    oXmlHttp.Send();

    // No document with the URL has been found. Continue to submit.
    // If you must replace the original file, you must call
    // oXmlHttp.Open("DELETE", strUrl, false) to delete the document
    // in the WSS document library.
    if (oXmlHttp.Status == 404)
    {
    // Put the document in the WSS document library.
    oXmlHttp.Open("PUT", strUrl, false);
    oXmlHttp.Send(XDocument.DOM.xml);

    // A 200 status code or a 201 status code indicates that the form has been submitted successfully.
    if (oXmlHttp.Status == 200 || oXmlHttp.Status == 201)
    {
    fSuccessful = true;
    }
    }
    }
    catch (ex){}

    if (fSuccessful)
    {
    XDocument.UI.Alert("Document submitted successfully.");
    eventObj.ReturnStatus = true;
    }
    else
    {
    eventObj.ReturnStatus = false;
    }
    }
  6. حفظ البرنامج النصي. قم بإغلاق "محرر البرامج".
  7. حفظ قالب النموذج ك SubmitToWSS.xsn.

استخدام واجهة المستخدم لإرسال بيانات النموذج إلى مكتبة مستندات SharePoint Services في InfoPath 2003 Service Pack 1

  1. من القائمة أدوات ، انقر فوق إرسال النماذج.

    يظهر مربع الحوار إرسال النماذج .
  2. في مربع الحوار إرسال النماذج ، انقر فوق "تمكين إرسال" الأوامر والأزرار.
  3. في المقطع إرسال إلى ، انقر فوق مكتبة نماذج SharePoint.
  4. في مربع الحوار إرسال النماذج ، انقر فوق إضافة.

    يبدأ تشغيل "معالج اتصال البيانات" .
  5. إدخال ارتباط مكتبة نموذج خدمات SharePoint الخاص بك في المربع نموذج المكتبة .

    ارتباط المكتبة الخاصة بك قد تبدو مشابهة لما يلي:

    http://ServerName/SiteName/DocumentLibraryName
  6. اكتب اسم المستند في المربع اسم الملف .

    يمكنك استخدام اسم مستند مثل TestForm.

    انقر فوق التالي.
  7. في معالج اتصال البيانات، انقر فوق " إنهاء".
  8. في مربع الحوار إرسال النماذج ، انقر فوق "موافق".
  9. حفظ قالب النموذج باسم "SubmitToWSS.xsn".

استخدام واجهة المستخدم لإرسال بيانات النموذج إلى مكتبة مستندات SharePoint Services في InfoPath 2007

  1. من القائمة أدوات ، انقر فوق خيارات الإرسال.

    يظهر مربع الحوار خيارات الإرسال .
  2. في مربع الحوار خيارات الإرسال ، انقر فوق السماح للمستخدمين بإرسال هذا النموذج.
  3. انقر لتحديد خانة الاختيار إرسال بيانات النموذج إلى وجهة واحدة .
  4. في القائمة المنسدلة، انقر فوق مكتبة مستندات SharePoint.
  5. في مربع الحوار خيارات الإرسال ، انقر فوق إضافة.

    يبدأ تشغيل "معالج اتصال البيانات" .
  6. اكتب الارتباط مكتبة مستندات SharePoint الخاص بك في المربع مكتبة المستندات .

    ارتباط مكتبة المستند الخاص بك ما يلي:
    http://ServerName/SiteName/DocumentLibraryName
  7. اكتب اسم المستند في المربع اسم الملف .

    يمكنك استخدام اسم مستند مثل TestForm.
  8. انقر فوق التالي.
  9. في المربع أدخل اسماً لاتصال البيانات هذا ، اكتب اسماً لاتصال البيانات هذا.
  10. في "معالج اتصال البيانات"، انقر فوق " إنهاء".
  11. في مربع الحوار خيارات الإرسال ، انقر فوق "موافق".
  12. حفظ قالب النموذج ك SubmitToWSS2007.xsn.

استخدام واجهة المستخدم لإرسال بيانات النموذج إلى مكتبة مستندات SharePoint Services في InfoPath 2010

  1. ضمن علامة التبويب بيانات ، انقر فوق خيارات الإرسال.

    يظهر مربع الحوار خيارات الإرسال .
  2. في مربع الحوار خيارات الإرسال ، انقر فوق السماح للمستخدمين بإرسال هذا النموذج.
  3. انقر لتحديد خانة الاختيار إرسال بيانات النموذج إلى وجهة واحدة .
  4. في القائمة المنسدلة، انقر فوق مكتبة مستندات SharePoint.
  5. في مربع الحوار خيارات الإرسال ، انقر فوق إضافة.

    يبدأ تشغيل "معالج اتصال البيانات" .
  6. اكتب الارتباط مكتبة مستندات SharePoint الخاص بك في المربع مكتبة المستندات .

    ارتباط مكتبة المستند الخاص بك ما يلي:
    http://ServerName/SiteName/DocumentLibraryName
  7. اكتب اسم المستند في المربع اسم الملف .

    يمكنك استخدام اسم مستند مثل TestForm.
  8. انقر فوق التالي.
  9. في المربع أدخل اسماً لاتصال البيانات هذا ، اكتب اسماً لاتصال البيانات هذا.
  10. في "معالج اتصال البيانات"، انقر فوق " إنهاء".
  11. في مربع الحوار خيارات الإرسال ، انقر فوق "موافق".
  12. حفظ قالب النموذج ك SubmitToWSS2010.xsn.

اختبار النموذج في InfoPath 2003

  1. من القائمة ملف ، انقر فوق تعبئة نموذج.
  2. في جزء المهام تعبئة النموذج ، انقر فوق سوبميتووس.
  3. أكمل النموذج.
  4. من القائمة ملف ، انقر فوق " إرسال".

    إذا تم إرسال النموذج بنجاح، تتلقى رسالة تشير إلى ذلك.
  5. قم بإنهاء InfoPath. إذا تم مطالبتك بحفظ التغييرات إلى النموذج، انقر فوق " لا".
  6. بدء تشغيل برنامج Microsoft Internet Explorer. تحديد موقع مكتبة النماذج المستند الخاص بك.

    على سبيل المثال، قد يكون النموذج المكتبة http://ServerName/SiteName/DocumentLibraryName.

    عنصر جديد يسمى testform في مكتبة المستندات.
  7. انقر فوق testform.

    يتم فتح النموذج تم إرساله في InfoPath 2003.

اختبار النموذج في InfoPath 2007

  1. من القائمة ملف ، انقر فوق تعبئة نموذج.
  2. في جزء المهام تعبئة النموذج ، انقر فوق SubmitToWSS2007.
  3. أكمل النموذج.
  4. من القائمة ملف ، انقر فوق " إرسال".

    إذا تم إرسال النموذج بنجاح، تتلقى رسالة تشير إلى ذلك.
  5. قم بإنهاء InfoPath. إذا تم مطالبتك بحفظ التغييرات إلى النموذج، انقر فوق " لا".
  6. بدء تشغيل Windows Internet Explorer. تحديد موقع مكتبة النماذج المستند الخاص بك.

    على سبيل المثال، قد يكون النموذج المكتبة http://ServerName/اسم الموقع/دوكومينتليبرارينامي.

    عنصر جديد يسمى testform في مكتبة المستندات.
  7. انقر فوق testform.

    يتم فتح النموذج تم إرساله في InfoPath 2007.

اختبار النموذج في InfoPath 2010

  1. بدء تشغيل InfoPath Filler 2010
  2. انقر فوق البحث عن نموذج.
  3. البحث عن SubmitToWSS2010.xsnوقم بتحديده ثم انقر فوق فتح.
  4. أكمل النموذج.
  5. من القائمة ملف ، انقر فوق " إرسال".

    إذا تم إرسال النموذج بنجاح، تتلقى رسالة تشير إلى ذلك.
  6. قم بإنهاء InfoPath Filler. إذا تم مطالبتك بحفظ التغييرات إلى النموذج، انقر فوق عدم الحفظ.
  7. بدء تشغيل Windows Internet Explorer. تحديد موقع مكتبة المستندات الذي قمت بتوفيره في الخطوة 6 من "استخدام واجهة المستخدم لإرسال بيانات النموذج إلى مكتبة مستندات SharePoint Services في InfoPath 2010."

    سوف تشاهد عنصر نموذج جديد في مكتبة المستندات، وسيظهر اسمك في العمود تعديل من قبل .
  8. انقر فوق عنصر نموذج جديد.

    يتم فتح النموذج تم إرساله في InfoPath 2010.

المراجع


لمزيد من المعلومات حول كيفية الحصول على أحدث حزمة خدمة ل Microsoft Office، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

كيفية الحصول على أحدث حزمة خدمة ل Office 2003 870924

لمزيد من المعلومات حول كيفية تشغيل البرامج النصية باستخدام نماذج InfoPath 2003، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

كيفية تغيير لغة البرنامج النصي لنموذج InfoPath 828853

كيفية تصحيح برنامج نصي لنموذج Microsoft Office InfoPath 2003 827002