قد لا تظهر اسم المجال بشكلها الصحيح في سجل DNS لوحدة تحكم المجال المستندة إلى Windows Server 2003 أو نظام التشغيل Windows 2000

ينطبق على: Windows Servers

الأعراض


عند استخدام وحدة تحكم مجال المستندة إلى نظام التشغيل Microsoft Windows 2000 Server أو المستندة إلى نظام التشغيل Microsoft Windows Server 2003، بعض الخدمات من خدمة الدليل "Active Directory"، مثل خدمات بروتوكول الوصول الخفيف إلى الدليل (LDAP)، قد لا تعمل بشكل صحيح. عند محاولة استكشاف أخطاء وحدة تحكم المجال، قد تواجه الأعراض التالية أيضا:
  • عند فحص ملف Netlogon.dns، شاهدت إدخالات النص التي تعرض اسم المضيف لوحدة التحكم بالمجال فقط وليس اسم المجال المؤهل بالكامل (FQDN).
  • عند تشغيل أداة سطر الأوامر Dcdiag.exe في موجه الأوامر، الإخراج يشير إلى أنه لا يمكن حل FQDN لوحدة تحكم المجال.
  • عند استخدام الأداة الإضافية DNS لفحص سجل DNS في منطقة DNS _msdcs، يظهر FQDN وحدة تحكم المجال ك اسم الخادم، حيث أن ServerName هو اسم الملقم Windows DNS.
  • عند إعادة تشغيل وحدة تحكم المجال، يتعرف نظام التشغيل Windows Server 2003 وحدة تحكم المجال كمضيف يحتوي اسم مجال. على سبيل المثال، إذا كان FQDN وحدة تحكم المجال host.domain.com، يتعرف نظام التشغيل اسم المضيف ("المضيف") وليس اسم المجال ("domain.com").
  • عند بدء تشغيل خدمة DNS، يتم تسجيل الحدث التالي في سجل أحداث الملقم DNS:
  • عند محاولة إعادة تشغيل خدمة ما يصاحب نظام Exchange على كمبيوتر الذي يقوم بتشغيل Microsoft Exchange 2000 Server، لم يتم تشغيل الخدمة.

السبب


قد تحدث هذه المشكلة بسبب إدخال تسجيل تالفة في مفتاح التسجيل الفرعي التالي:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
قد يكون واحد أو أكثر من إدخالات التسجيل التالية في مفتاح التسجيل الفرعي هذا تالفاً:
  • المجال
  • اسم المضيف
  • المجال NV
  • اسم المضيف NV
إذا كانت سجلات مورد موقع خدمة الدليل النشط (SRV) تشير إلى اسم مجال غير صحيحة، وحدة التحكم بالمجال يتعذر حل اسم المجال. ولهذا السبب، خدمات "Active Directory" قد لا تعمل بشكل صحيح.

الحل


هام: يحتوي هذا المقطع أو الأسلوب أو المهمة على الخطوات التي توضح كيفية تعديل التسجيل. ومع ذلك، قد تحدث مشكلات خطيرة إذا قمت بتعديل التسجيل بشكل غير صحيح. لذلك، تأكد من اتباع الخطوات التالية بعناية. للحماية الإضافية، قم بعمل نسخة احتياطية للسجل قبل تعديله. بعد ذلك، يمكنك استعادة السجل في حالة حدوث مشكلة. لمزيد من المعلومات حول كيفية عمل نسخة احتياطية من السجل واستعادته، انقر فوق رقم المقالة التالية لعرضها في "قاعدة معارف Microsoft":
322756 كيفية عمل نسخة احتياطية من السجل واستعادته في نظام التشغيل Windows
لحل هذه المشكلة، استخدم "محرر التسجيل" لإزالة وإعادة إنشاء إدخالات التسجيل الموضحة في قسم "السبب". للقيام بذلك، اتبع الخطوات التالية:
  1. انقر فوق ابدأ، ثم انقر فوق تشغيل، اكتب regedit في المربع فتح ، وثم انقر فوق موافق.
  2. في "محرر التسجيل"، حدد موقع ومن ثم انقر فوق مفتاح التسجيل الفرعي التالي:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. في الجزء الأيسر، انقر نقراً مزدوجاً فوق المجال، ومن ثم انقر فوق حذف.
  4. عندما تتم مطالبتك بتأكيد الحذف، انقر فوق " نعم".
  5. كرر الخطوتين 3 و 4 لإدخالات اسم المضيف والمجال NV NV Hostname.
  6. من القائمة تحرير ، أشر إلى جديد، ومن ثم انقر فوق قيمة سلسلة.
  7. اكتب المجالومن ثم انقر نقراً مزدوجاً فوق المجال.
  8. في المربع " بيانات القيمة "، اكتب اسم مجال "Active Directory"، ومن ثم انقر فوق موافق. على سبيل المثال، قد تكتب contoso.com اسم المجال.
  9. كرر الخطوات من 6 إلى 8 لإدخال التسجيل المجال NV.
  10. من القائمة تحرير ، أشر إلى جديد، ومن ثم انقر فوق قيمة سلسلة.
  11. اكتب اسم المضيف، ومن ثم انقر نقراً مزدوجاً فوق اسم المضيف.
  12. في المربع " بيانات القيمة "، اكتب اسم الكمبيوتر، ومن ثم انقر فوق موافق.
  13. كرر الخطوات من 10 إلى 12 لقيمة التسجيل اسم المضيف NV.
  14. قم بإنهاء "محرر السجل".
  15. انقر فوق ابدأ، ثم انقر فوق تشغيل، ثم اكتب services.msc في المربع فتح ، وثم انقر فوق موافق.
  16. في الجزء الأيسر من الإطار " الخدمات "، حدد موقع ومن ثم انقر فوق Net Logon.
  17. في القائمة إجراء ، انقر فوق إيقاف.
  18. في القائمة إجراء ، انقر فوق " ابدأ".

مزيد من المعلومات


الدعم الفني لإصدارات Windows x64

. Microsoft Windows x64 توفر الشركة المصنعة للجهاز الدعم التقني والمساعدة لإصدارات يوفر مصنعو الأجهزة الدعم نظراً لتضمين الأجهزة إصدار Windows x64. الشركة المصنعة للجهاز قد تخصيص تثبيت إصدار Windows x64 بمكونات فريدة. مكونات فريدة قد تتضمن برامج تشغيل أجهزة خاصة أو قد تتضمن إعدادات اختيارية لتحقيق أفضل أداء للأجهزة. توفر لك شركة Microsoft مساعدة مناسبة إذا كنت في حاجة إلى مساعدة تقنية يتعلق بالإصدار Windows x64. ومع ذلك، قد يلزم الاتصال مباشرة بالشركة المصنعة. الشركة المصنعة أفضل مصدر مؤهل لدعم البرامج المثبتة على الجهاز الشركة المصنعة. للحصول على معلومات المنتج حول Microsoft Windows XP Professional x64 Edition، قم بزيارة موقع Microsoft التالي على الويب:للحصول على معلومات المنتج حول إصدارات Microsoft Windows Server 2003 x64، قم بزيارة موقع Microsoft التالي على الويب: