ظهور رسالة خطأ عند بدء تشغيل عميل Microsoft Dynamics AX 4.0 Service Pack 1: "اسم شبكة الاتصال المحدد لم يعد متوفراً"

ينطبق على: Microsoft Dynamics AX 4.0Axapta Object Server

الأعراض


عند بدء تشغيل Microsoft Dynamics AX 4.0 Service Pack 1 (SP1) على جهاز كمبيوتر عميل، تتلقى رسالة الخطأ التالية:
خطأ في الملف: \\ \appl\standard\axsys.aodمسار تثبيت Microsoft Dynamics AXأثناء القراءة في سجل = 0

خطأ Windows: =

رمز الخطأ: 64 = المحدد لم يعد اسم شبكة الاتصال متوفرة.

حاول مرة أخرى؟
بالإضافة إلى ذلك، يتم تسجيل الحدث التالي على جهاز الكمبيوتر العميل:الملاحظات
  • في رسالة الخطأ هذه الكلمة "حدث" هو الكلمة الخاطئة عن الكلمة "أثناء."

  • يمثل العنصر النائب file_name في وصف الخطأ ملفات الموجودة في المجلد المشترك الذي يحتوي على ملفات تثبيت البرامج.

السبب


قد تحدث هذه المشكلة إذا تحقق أحد الشروط التالية:
  • تم إيقاف خدمة خادم كائن التطبيق (AOS).
  • حدث فشل في أجهزة أو خطأ تبديل انقطاع التيار الكهربائي الذي تسبب في توقف فجأة الاتصال.
  • الفحص بحثاً عن فيروسات أو برامج نسخ احتياطي تأمين بعض الملفات.
  • انقطع اتصال شبكة الاتصال بالمجلد المشترك الذي يحتوي على ملفات تثبيت البرامج.
  • وتم نشر تغييرات التعليمات البرمجية أثناء استخدموا مستخدمي Microsoft Dynamics AX.
ملاحظة: لمزيد من المعلومات حول كيفية نشر تغييرات التعليمات البرمجية، راجع دليل المطورين Microsoft Dynamics AX. لعرض هذا الدليل، انقر فوق تعليمات، ومن ثم انقر فوق دليل Microsoft Dynamics AX المطور.

الحل


لحل هذه المشكلة، اتبع الخطوات التالية:
  1. قم بإيقاف خدمة AOS. للقيام بذلك، انقر فوق ابدأ، ثم انقر فوق تشغيل، اكتب services.msc، وثم انقر فوق موافق. تحديد موقع خدمة AOS. إذا كانت الخدمة قيد التشغيل، انقر بزر ومن ثم انقر فوق إيقاف.

    ملاحظة: يستخدم اسم خدمة AOS بالتنسيق التالي:
    رقم مثيل AOS-ديناميات $ ملقماسم المثيل
  2. بدء تشغيل وحدة تحكم مسؤول الدعم أو محلل استعلام SQL ل Microsoft SQL Server إدارة Studio. للقيام بذلك، استخدم إحدى الطرق التالية استناداً إلى البرنامج الذي تستخدمه.

    الطريقة الأولى: لمشغل SQL Server سطح المكتب

    إذا كنت تستخدم SQL Server Desktop Engine (تعرف أيضا باسم MSDE 2000)، بدء تشغيل وحدة تحكم مسؤول الدعم. للقيام بذلك، انقر فوق ابدأوأشر إلى كافة البرامج، أشر إلى وحدة تحكم المسؤول ل Microsoft، وثم انقر فوق وحدة تحكم مسؤول الدعم.

    الطريقة الثانية: ل SQL Server 2000

    إذا كنت تستخدم SQL Server 2000، بدء محلل استعلام SQL. للقيام بذلك، انقر فوق ابدأوأشر إلى كافة البرامج، أشر إلى Microsoft SQL Server، وثم انقر فوق استعلام محلل.

    الطريقة الثالثة: ل SQL Server 2005

    إذا كنت تستخدم SQL Server 2005، ابدأ Studio إدارة ملقم SQL. للقيام بذلك، انقر فوق ابدأوأشر إلى كافة البرامج، أشر إلى Microsoft SQL Server 2005، وثم انقر فوق إدارة Studio SQL Server.
  3. قم بإغلاق كافة الاتصالات المفتوحة إلى خادم قاعدة بيانات Microsoft Dynamics AX.
  4. قم بإعادة تشغيل خدمة AOS.
  5. قم بإعادة تشغيل عميل Microsoft Dynamics AX.

مزيد من المعلومات


لمنع حدوث هذه المشكلة، استخدم واحد أو أكثر من الطرق التالية:
  • في إعدادات تكوين AOS، استخدم عنوان IP بدلاً من اسم نظام اسم مجال (DNS) أو محرك أقراص معين أو مجلد مشترك مخفي يحتوي على ملفات تثبيت البرامج.
  • أثناء اتصال الخوادم التي تقوم بتشغيل خدمة AOS، قم بتعطيل فحص الفيروسات في الوقت الحقيقي من المجلد المشترك الذي يحتوي على ملفات البرنامج المشترك.
  • قد يؤدي التكوين غير الصحيح لمحولات الشبكة تعاونت مشكلات الاتصال. تأكد من أن الإعداد خيار حفظ الطاقة غير ممكن على محول الشبكة. استخدام خدمة AOS والعميل الأول محول شبكة الاتصال المتوفرة. تأكد من أن محولات الشبكة المحلية (LAN) الأول في ترتيب الربط قبل أي محولات الشبكة اللاسلكية.
  • مراقبة الملفات المقفلة والملفات المتوفرة باستخدام وحدة تحكم إدارة الكمبيوتر على ملقم ملفات البرنامج. للقيام بذلك، اتبع الخطوات التالية:
    1. انقر فوق ابدأ، ثم انقر فوق تشغيل، اكتب compmgmt.msc، وثم انقر فوق موافق.
    2. في شجرة وحدة تحكم "إدارة الكمبيوتر"، انقر فوق المجلدات المشتركة.