كيفية استكشاف أخطاء المستندات التالفة وإصلاحها في Word

الموجز

تصف هذه المقالة كيفية التعرف على المستند التالف في Word 2007 والإصدارات الأحدث. بالإضافة إلى ذلك، تتضمن هذه المقالة خطوات تشرح كيفية استرداد النص والبيانات المضمنة في أحد المستندات بعد تحديد المستند كمستند تالف.

تم إعداد هذه المقالة لمستخدمي الكمبيوتر المبتدئين والمتوسطين.
إذا طبعت هذه المقالة أولاً، فسيكون اتباع الخطوات أسهل لك.

كيفية تحديد مستند تالف

الطريقة الأولى: فحص السلوك الغريب

العديد من المستندات التالفة تُظهر سلوكًا غريبًا. قد يكون هذا السلوك متعلقًا بتلف المستند أو القالب الذي يستند إليه المستند. قد يتضمن هذا السلوك ما يلي:
  • إعادة ترقيم الصفحات الموجودة في المستند بشكل متكرر
  • إعادة إدراج فواصل الصفحات بشكل متكرر في المستند
  • وجود تخطيط وتنسيق غير صحيحين للمستند
  • ظهور رموز تتعذر قراءتها على الشاشة
  • ظهور رسائل خطأ أثناء المعالجة
  • توقف جهاز الكمبيوتر عن الاستجابة عند فتح الملف
  • حدوث أي سلوك غير متوقع لا يمكن أن ينتج عن إجراء عملية معتادة للبرنامج
في حالة ظهور أي من هذه الأعراض على المستند أو تعذر فتحه، انتقل إلى الطريقة الثانية.

الطريقة الثانية: فحص المستندات والبرامج الأخرى

أحيانًا يحدث هذا السلوك نتيجة لعوامل أخرى غير تلف المستندات. للتخلص من هذه العوامل الأخرى، اتبع الخطوتين التاليتين:
  1. ابحث عن سلوك مماثل يحدث في مستندات أخرى.
  2. ابحث عن سلوك مشابه في برامج Microsoft Office الأخرى.
إذا أشارت إحدى هاتين الخطوتين إلى أن المشكلة لا تكمن في المستند، فسيلزم استكشاف الأخطاء في Word أو مجموعة Office أو نظام التشغيل الموجود على جهاز الكمبيوتر وإصلاحها.

خطوات استكشاف الأخطاء وإصلاحها في حالة إمكانية فتح المستند التالف

الطريقة الأولى: تغيير القالب الذي يستخدمه المستند

الخطوة 1: تحديد القالب الذي يستخدمه المستند

  1. افتح المستند الذي توجد به المشكلة في Word.
  2. في Word، انقر فوق ملف على الشريط، ثم انقر فوق خيارات.
  3. انقر فوق الوظائف الإضافية.
  4. في المربع إدارة، انقر فوق قوالب ضمن عرض وظائف Office الإضافية وإدارتها.
  5. انقر فوق انتقال.
يسرد المربع قالب المستند القالب الذي يستخدمه المستند. إذا كان القالب المسرود هو Normal، فانتقل إلى الخطوة 2. بخلاف ذلك، انتقل إلى الخطوة 3.

الخطوة 2: إعادة تسمية القالب العمومي (Normal.dot)

اتبع الخطوات الخاصة بنظام التشغيل الذي تستخدمه:
  1. قم بإنهاء برنامج Word.
  2. انقر فوق ابدأالزر ابدأ .
  3. عند البحث عن في نظام تشغيلك عن القالب normal.dotm، فستجده عادة في:
    %userprofile%\appdata\roaming\microsoft\templates
  4. انقر بزر الماوس الأيمن فوق Normal.dotm، ثم انقر فوق إعادة تسمية.
  5. اكتب Oldword.old، ثم اضغط مفتاح ENTER.
  6. قم بإغلاق "مستكشف Windows".
  7. ابدأ تشغيل Word، ثم افتح المستند.

الخطوة 3: تغيير قالب المستند

  1. افتح المستند الذي توجد به المشكلة في Word.
  2. في Word، انقر فوق ملف على الشريط، ثم انقر فوق خيارات.
  3. انقر فوق الوظائف الإضافية.
  4. في المربع إدارة، انقر فوق قوالب، ثم انقر فوق انتقال.
  5. انقر فوق إرفاق.
  6. في المجلد القوالب، انقر فوق Normal.dotm، ثم انقر فوق فتح.
  7. انقر فوق موافق لإغلاق مربع الحوار قوالب ووظائف إضافية.
  8. قم بإنهاء برنامج Word.

الخطوة 4: التحقق من عمل القوالب التي تم تغييرها

  1. ابدأ تشغيل Word.
  2. في Word، انقر فوق ملف على الشريط، ثم انقر فوق خيارات.
  3. انقر فوق المستند التالف، ثم انقر فوق فتح.
في حالة استمرار السلوك غير المعتاد للمستند، انتقل إلى الطريقة الثانية.

الطريقة الثانية: بدء تشغيل برنامج Word باستخدام الإعدادات الافتراضية

يمكنك استخدام الأمر الفرعي /a لبدء تشغيل Word باستخدام الإعدادات الافتراضية فقط في Word. عند استخدام الأمر الفرعي /a، لا يقوم Word بتحميل أية وظيفة من الوظائف الإضافية. بالإضافة إلى ذلك، لا يستخدم Word القالب Normal.dotm الموجود. أعد تشغيل Word باستخدام الأمر الفرعي /a.

الخطوة ١: بدء تشغيل Word باستخدام الأمر الفرعي /a

  1. قم بإنهاء برنامج Word.
  2. في نظام تشغيلك ابحث عن تشغيل. في مربع الحوار "تشغيل"، اكتب الأمر winword.exe /a.

الخطوة 2: فتح المستند

  1. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
  2. انقر فوق المستند التالف، ثم انقر فوق فتح.
في حالة استمرار السلوك غير المعتاد للمستند، انتقل إلى الطريقة الثالثة.

الطريقة الثالثة: تغيير برامج تشغيل الطابعة

الخطوة 1: جرِّب استخدام برنامج تشغيل طابعة مختلف

الخطوة أ: فتح "إضافة طابعة"
  1. في نظام تشغيلك ابحث عن الأجهزة والطابعات.
  2. انقر فوق إضافة طابعة.
الخطوة ب: إضافة طابعة جديدة
  1. في مربع الحوار إضافة طابعة، انقر فوق إضافة طابعة محلية.
  2. انقر فوق استخدام منفذ موجود، ثم انقر فوق التالي.
  3. في قائمة الشركة المصنّعة، انقر فوق Microsoft.
  4. انقر فوق Microsoft XPS Document Writer، ثم انقر فوق التالي.
  5. انقر فوق استخدام برنامج التشغيل المثبَّت حاليًا (مستحسن)، ثم انقر فوق التالي.
  6. انقر لتحديد خانة الاختيار التعيين كطابعة افتراضية، ثم انقر فوق التالي.
  7. انقر فوق إنهاء.

الخطوة 2: التحقق من أن تغيير برامج تشغيل الطابعات يؤدي إلى حل المشكلة

  1. قم ببدء تشغيل Word.
  2. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
  3. انقر فوق المستند التالف، ثم انقر فوق فتح.
في حالة استمرار السلوك غير المعتاد للمستند، انتقل إلى الطريقة الثالثة.

الخطوة 3: إعادة تثبيت برنامج تشغيل الطابعة الأصلي.

نظاما التشغيل Windows Vista وWindows 7
  1. في نظام تشغيلك ابحث عن الأجهزة والطابعات.
  2. انقر بزر الماوس الأيمن فوق الطابعة الافتراضية الأصلية، ثم انقر فوق حذف.
    إذن التحكم في حساب المستخدم إذا تمت مطالبتك بكلمة مرور المسؤول أو تأكيدها، فاكتب كلمة المرور أو انقر فوق متابعة.
  3. في حالة مطالبتك بإزالة كافة الملفات المرتبطة بالطابعة، انقر فوق نعم.
  4. انقر فوق إضافة طابعة، ثم اتبع الإرشادات الموجودة في معالج إضافة طابعة لإعادة تثبيت برنامج تشغيل الطابعة.

الخطوة 4: التحقق من أن تغيير برامج تشغيل الطابعات يؤدي إلى حل المشكلة

  1. قم ببدء تشغيل Word.
  2. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
  3. انقر فوق المستند التالف، ثم انقر فوق فتح.
في حالة استمرار السلوك غير المعتاد للمستند، انتقل إلى الطريقة الرابعة.

الطريقة الرابعة: إجبار Word على محاولة إصلاح ملف

الخطوة 1: إصلاح مستند

  1. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
  2. في مربع الحوار فتح، انقر لتمييز مستند Word.
  3. انقر فوق السهم الموجود على الزر فتح، ثم انقر فوق فتح وإصلاح.

الخطوة 2: التحقق من أن إصلاح المستند يؤدي إلى حل المشكلة

تحقق من أن السلوك الغريب لم يعد يحدث مرة أخرى. في حالة استمرار السلوك غير المعتاد للمستند، قم بإعادة تشغيل Windows، ثم انتقل إلى الطريقة السادسة.

الطريقة الخامسة: قم بتغيير تنسيق المستند ثم حول المستند مرة أخرى إلى تنسيق Word

الخطوة 1: فتح المستند

  1. قم ببدء تشغيل Word.
  2. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
  3. انقر فوق المستند التالف، ثم انقر فوق فتح.

الخطوة 2: حفظ المستند بتنسيق ملف مختلف

  1. في Word، انقر فوق ملف على الشريط، ثم انقر فوق حفظ باسم.
  2. في Word 2007، انقر فوق تنسيقات أخرى.
  3. من القائمة حفظ بنوع، انقر فوق (Rich Text Format (*.rtf.
  4. انقر فوق حفظ.
  5. في Word، انقر فوق ملف على الشريط، ثم انقر فوق إغلاق.

الخطوة 3: افتح المستند ثم حوّله مرة أخرى إلى تنسيق ملف Word

  1. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
  2. انقر فوق المستند التالف، ثم انقر فوق فتح.
  3. في Word، انقر فوق ملف على الشريط، ثم انقر فوق حفظ باسم.
  4. اختر مستند Word في نوع حفظ باسم.
  5. أعد تسمية ملف المستند، ثم انقر فوق حفظ.

الخطوة 4: التحقق من أن تحويل المستند يؤدي إلى حل المشكلة

تحقق من أن السلوك الغريب لم يعد يحدث مرة أخرى. أما في حالة استمرار السلوك، حاول حفظ الملف باستخدام تنسيق ملف آخر. كرر الخطوات من ١ إلى ٤، ثم حاول حفظ الملف بتنسيقات الملفات التالية، بالترتيب التالي:
  • صفحة ويب (.htm؛ .html)
  • أي تنسيق آخر لمعالجة الكلمات
  • (Plain Text (.txt
ملاحظة عند حفظ الملفات باستخدام التنسيق (Plain Text (.txt، قد تتمكن من حل مشكلة تلف المستند. وعلى الرغم من ذلك، يتم فقد كافة تنسيق المستند وتعليمات الماكرو البرمجية والرسومات. عند حفظ الملفات باستخدام التنسيق (Plain Text (.txt، قد تتمكن من حل مشكلة تلف المستند. ولذلك، استخدم التنسيق (Plain Text (.txt فقط إذا لم يؤدِ استخدام تنسيقات الملفات الأخرى إلى حل المشكلة.

في حالة استمرار السلوك غير المعتاد للمستند، انتقل إلى الطريقة السابعة.

الطريقة السادسة: نسخ كل شيء إلى مستند جديد باستثناء آخر علامة فقرة

الخطوة 1: إنشاء مستند جديد

  1. في Word، انقر فوق ملف على الشريط، ثم انقر فوق جديد.
  2. انقر فوق مستند فارغ، ثم انقر فوق إنشاء.

الخطوة 2: فتح المستند التالف

  1. قم ببدء تشغيل Word.
  2. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
  3. انقر فوق المستند التالف، ثم انقر فوق فتح.

الخطوة 3: نسخ محتويات المستند ثم لصقها في المستند الجديد

ملاحظة إذا كان المستند يتضمن فواصل مقطعية، فانسخ النص الموجود بين الفواصل المقطعية فقط. لا تقم بنسخ الفواصل المقطعية لأن هذا قد ينقل التلف إلى المستند الجديد. قم بتغيير طريقة عرض المستند إلى عرض المسودة عند النسخ واللصق بين المستندات لتجنب نقل الفواصل المقطعية. للتغيير إلى عرض المسودة، من علامة التبويب عرض، انقر فوق مسودة في المجموعة طرق عرض المستندات.
  1. في المستند التالف، اضغط المفتاحين CTRL+END ثم اضغط المفاتيح CTRL+SHIFT+HOME.
  2. في علامة التبويب الصفحة الرئيسية، انقر فوق نسخ في المجموعة الحافظة.
  3. في علامة التبويب عرض، انقر فوق تبديل النوافذ في المجموعة نافذة.
  4. انقر فوق المستند الجديد الذي قمت بإنشائه في الخطوة ١.
  5. في علامة التبويب الصفحة الرئيسية، انقر فوق لصق في المجموعة الحافظة.
في حالة استمرار السلوك غير المعتاد للمستند، انتقل إلى الطريقة الثامنة.

الطريقة السابعة: نسخ الأجزاء غير التالفة من المستند التالف إلى مستند جديد

الخطوة 1: إنشاء مستند جديد

  1. في Word، انقر فوق ملف على الشريط، ثم انقر فوق جديد.
  2. انقر فوق مستند فارغ، ثم انقر فوق إنشاء.

الخطوة 2: فتح المستند التالف

  1. قم ببدء تشغيل Word.
  2. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
  3. انقر فوق المستند التالف، ثم انقر فوق فتح.

الخطوة 3: نسخ أجزاء المستند غير التالفة ثم لصقها في المستند الجديد

ملاحظة إذا كان المستند يتضمن فواصل مقطعية، فانسخ النص الموجود بين الفواصل المقطعية فقط. لا تقم بنسخ الفواصل المقطعية لأن هذا قد ينقل التلف إلى المستند الجديد. قم بتغيير طريقة عرض المستند إلى عرض المسودة عند النسخ واللصق بين المستندات لتجنب نقل الفواصل المقطعية. للتغيير إلى عرض المسودة، من علامة التبويب عرض، انقر فوق مسودة في المجموعة طرق عرض المستندات.
  1. في المستند التالف، حدد موقع الجزء غير التالف من المستند ثم حدد جزءًا غير تالف من محتويات المستند.
  2. في علامة التبويب الصفحة الرئيسية، انقر فوق نسخ في المجموعة الحافظة.
  3. في علامة التبويب عرض، انقر فوق تبديل النوافذ في المجموعة نافذة.
  4. انقر فوق المستند الجديد الذي قمت بإنشائه في الخطوة ١.
  5. في علامة التبويب الصفحة الرئيسية، انقر فوق لصق في المجموعة الحافظة.
  6. كرر الخطوات من 3أ إلى 3هـ لكل جزء من الأجزاء غير التالفة في المستند. يجب إعادة إنشاء المقاطع التالفة من المستند الخاص بك.

الطريقة الثامنة: تبديل عرض المستند لإزالة المحتوى التالف

حالة ظهور المستند مقطوعًا (لم يتم عرض كافة الصفحات في المستند)، فربما يمكن تبديل عرض المستند وإزالة المحتوى التالف من المستند.
  1. حدد رقم الصفحة حيث يتسبب المحتوى التالف في إظهار المستند مقطوعًا.
    1. في Word، انقر فوق ملف على الشريط، ثم انقر فوق فتح.
    2. انقر فوق المستند التالف، ثم انقر فوق فتح.
    3. قم بالتمرير لعرض الصفحة الأخيرة التي يتم عرضها قبل أن يظهر المستند مقطوعًا. لاحظ المحتوى الذي يظهر على تلك الصفحة.
  2. قم بالتبديل بين العروض، ثم قم بإزالة المحتوى التالف.
    1. في علامة التبويب عرض في مجموعة طرق عرض المستندات انقر فوق تخطيط الويب أو عرض المسودة.
    2. قم بالتمرير لعرض المحتوى الذي تم عرضه قبل أن يظهر أن المستند مقطوع.
    3. حدد الفقرة أو الجدول أو الكائن التالي في الملف وقم بحذفه.
    4. في علامة التبويب عرض في مجموعة طرق عرض المستندات انقر فوق تخطيط الويب. إذا استمر ظهور المستند مقطوعًا، فاستمر في تبديل العروض، وحذف المحتوى حتى لا يظهر مقطوعًا بعد الآن في عرض تخطيط الطباعة.
    5. قم بحفظ المستند.

الخطوات التي يجب اتباعها لاستكشاف الأخطاء وإصلاحها في حالة عدم فتح المستند التالف

الطريقة الأولى: فتح المستند التالف باستخدام الوضع "مسودة" بدون تحديث الارتباطات

الخطوة 1: تكوين Word

  1. قم ببدء تشغيل Word.
  2. من علامة التبويب عرض، انقر فوق مسودة في المجموعة طرق عرض المستندات.
  3. في Word، انقر فوق قائمة ملف، ثم انقر فوق خيارات ثم خيارات متقدمة.
  4. في قسم إظهار محتوى المستند، انقر لتحديد استخدام الخط التمهيدي في طريقتي العرض مسودة ومخطط تفصيلي وإظهار العناصر النائبة للصور.
  5. في قسم "عام" انقر لمسح تحديث الارتباطات التلقائية عند الفتح ثم انقر فوق موافق ثم أغلق Word.

الخطوة 2: فتح المستند التالف

  1. قم ببدء تشغيل Word.
  2. في Word، انقر فوق قائمة ملف، ثم انقر فوق فتح.
  3. انقر فوق المستند التالف، ثم انقر فوق فتح.
إذا تمكنت من فتح المستند، فأغلق المستند ثم افتحه مرة أخرى باستخدام الطريقة السادسة، وقم بإصلاح المستند. بخلاف ذلك، انتقل إلى الطريقة الثانية.

الطريقة الثانية: إدراج المستند كملف جديد في مستند جديد

الخطوة 1: إنشاء مستند فارغ جديد

  1. في Word 2010، انقر فوق قائمة ملف، ثم انقر فوق جديد.
  2. انقر فوق مستند فارغ، ثم انقر فوق إنشاء.
ملاحظة قد تضطر إلى إعادة تطبيق بعض التنسيقات على آخر مقطع من المستند الجديد.

الخطوة 2: إدراج المستند التالف في المستند الجديد

  1. في علامة التبويب إدراج، انقر فوق إدراج كائن، ثم انقر فوق نص من ملف.
  2. في مربع الحوار إدراج ملف، قم بتحديد موقع المستند التالف، ثم انقر فوقه. ثم بعد ذلك، انقر فوق إدراج.
ملاحظة قد تضطر إلى إعادة تطبيق بعض التنسيقات على آخر مقطع من المستند الجديد.

الطريقة الثالثة: إنشاء ارتباط للمستند التالف

الخطوة 1: إنشاء مستند فارغ

  1. في Word، انقر فوق قائمة ملف، ثم انقر فوق جديد.
  2. انقر فوق مستند فارغ، ثم انقر فوق إنشاء.
  3. في المستند الجديد، اكتب هذا اختبار.
  4. في Word، انقر فوق قائمة ملف، ثم انقر فوق حفظ.
  5. اكتب ارتباط للإنقاذ، ثم انقر فوق حفظ.

الخطوة 2: إنشاء ارتباط

  1. حدد النص الذي قمت بكتابته في الخطوة 1ج.
  2. في علامة التبويب الصفحة الرئيسية، انقر فوق نسخ في المجموعة الحافظة.
  3. في Word، انقر فوق قائمة ملف، ثم انقر فوق جديد.
  4. انقر فوق مستند فارغ، ثم انقر فوق إنشاء.
  5. في علامة التبويب الصفحة الرئيسية، انقر فوق السهم الموجود على الزر لصق في المجموعة الحافظة، ثم انقر فوق لصق خاص.
  6. انقر فوق لصق الارتباط، وانقر فوق نص منسق (RTF).
  7. انقر فوق موافق.

الخطوة 3: تغيير الارتباط إلى المستند التالف

  1. انقر بزر الماوس الأيمن فوق النص المرتبط في المستند، ثم قم بالإشارة إلى كائن المستند المرتبط، ثم انقر فوق ارتباطات.
  2. في مربع الحوار ارتباطات، انقر فوق اسم الملف الخاص بالمستند المرتبط، ثم انقر فوق تغيير المصدر.
  3. في مربع الحوار تغيير المصدر، انقر فوق المستند الذي لا يمكنك فتحه، ثم انقر فوق فتح.
  4. انقر فوق موافق لإغلاق مربع الحوارارتباطات.

    ملاحظة تظهر المعلومات الموجودة في المستند التالف فقط في حالة وجود أية بيانات أو نصوص قابلة للاسترداد.
  5. انقر بزر الماوس الأيمن فوق النص المرتبط في المستند، ثم قم بالإشارة إلى كائن المستند المرتبط، ثم انقر فوق ارتباطات.
  6. في مربع الحوار ارتباطات، انقر فوق قطع الارتباط.
  7. عندما تظهر الرسالة التالية، انقر فوق نعم:
    هل تريد بالتأكيد قطع الارتباطات المحددة؟

الطريقة الرابعة: استخدام محول "استرداد النص من أي ملف"

ملاحظة توجد قيود في محول "استرداد النص من أي ملف". على سبيل المثال، يتم فقد تنسيق المستند. بالإضافة إلى ذلك، يتم فقد الرسومات والحقول والكائنات الرسومية وأي عناصر أخرى ليست نصًا. ولكن، يتم الاحتفاظ بنص الحقل والرؤوس والتذييلات والحواشي السفلية والتعليمات الختامية كنص بسيط.
  1. في Word، انقر فوق قائمة ملف، ثم انقر فوق فتح.
  2. في المربع أنواع الملفات، انقر فوق استرداد النص من أي ملف(*.*).
  3. انقر فوق المستند الذي تريد استرداد النص منه.
  4. انقر فوق فتح.
بعد استرداد المستند باستخدام محوِّل "استرداد النص من أي ملف"، يوجد نص لبعض البيانات الثنائية التي لم يتم تحويلها. يوجد هذا النص بشكلٍ أساسي في بداية المستند ونهايته. يجب حذف نص البيانات الثنائية هذا قبل حفظ الملف كمستند Word.

ملاحظة: إذا كنت تستخدم Word 2007 فلا يوجد زر ملف في واجهة المستخدم، فضلا اختر زر Office ثم اتبع التوجيهات عند الحاجة.
خصائص

رقم الموضوع: 918429 - آخر مراجعة: 15‏/12‏/2016 - المراجعة: 1

تعليقات