كيفية استخدام ماكرو لإضافة تسميات إلى نقاط البيانات في مخطط س ص مبعثر أو في مخطط فقاعي في Excel

ملخص

في Microsoft Excel، يوجد لا أمر مضمن تلقائياً إرفاق التسميات النصية نقاط البيانات في تخطيط س ص (مبعثر) أو فقاعي. ومع ذلك، يمكنك إنشاء Microsoft Visual Basic for Applications الماكرو الذي يقوم بذلك. تحتوي هذه المقالة على نموذج ماكرو يقوم بهذه المهمة على مخطط "س ص مبعثر". ومع ذلك، يمكن استخدام نفس التعليمات البرمجية لأي "مخطط فقاعي".

مزيد من المعلومات

توفر Microsoft أمثلة برمجية للتوضيح فقط، دون أي ضمان صريح أو ضمني. هذا يتضمن، على سبيل المثال لا الحصر، الضمانات الضمنية الخاصة بالتسويق أو الملاءمة لغرض معين. تفترض هذه المقالة أنك معتاد على لغة البرمجة التي يتم شرحها والأدوات المستخدمة لإنشاء الإجراءات وتصحيحها. يساعد مهندسو الدعم لدى Microsoft شرح وظيفة إجراء محدد. ومع ذلك، لن يقوموا بتعديل هذه الأمثلة لتقديم وظيفة إضافية أو إنشاء إجراءات تستوفي متطلبات محددة. نموذج التعليمة البرمجية في هذه المقالة في يفترض ترتيب البيانات والتسميات المرتبطة في ورقة العمل استناداً إلى التنسيق التالي:
  • يحتوي العمود الأول على تسميات البيانات.
  • العمود الثاني يحتوي على قيم س للمخطط س ص (مبعثر).
  • تحتوي أعمدة الثالث واللاحقة على قيم ص لتخطيط س ص (مبعثر).
ملاحظة: على الرغم من أن المثال المذكور يحتوي على عمود واحد من البيانات لقيم ص، يمكنك استخدام أكثر من سلسلة بيانات.

لاستخدام وحدات الماكرو في هذا المقال، إنشاء مخطط باستخدام البيانات التالية:
   A1: Labels       B1: X Values   C1: Y Values
A2: DataPoint1 B2: 12 C2: 5
A3: DataPoint2 B3: 9 C3: 7
A4: DataPoint3 B4: 5 C4: 3
A5: DataPoint4 B5: 4 C5: 8
A6: DataPoint5 B6: 1 C6: 4
ملاحظة: يجب أن يتضمن الجدول الأعمدة الفارغة، ولا يمكن فصل العمود الذي يحتوي على تسميات البيانات من العمود الذي يحتوي على قيم س. التسميات والقيم يجب أن يكون تخطيط تماما في تنسيق الموضحة في هذه المقالة. (الخلية العلوية اليمنى ليس لديه أن الخلية A1.)

لإرفاق التسميات النصية نقاط البيانات في مخطط س ص (مبعثر)، اتبع الخطوات التالية:
  1. في ورقة العمل التي تحتوي على بيانات نموذج، حدد نطاق الخلية B1:C6.
  2. في Microsoft Office Excel 2003 وفي الإصدارات السابقة من Excel، اتبع الخطوات التالية:
    1. انقر فوق تخطيط في القائمة إدراج .
    2. في مربع الحوار معالج التخطيط-الخطوة 1 من 4-نوع التخطيط ، انقر فوق علامة التبويب أنواع قياسية . ضمن نوع التخطيط، انقر فوق تخطيط س ص (مبعثر)، ومن ثم انقر فوق التالي.
    3. في مربع الحوار معالج التخطيطات-الخطوة 2 من 4-البيانات المصدر للتخطيط ، انقر فوق التبويب " نطاق البيانات ". ضمن سلسلة، انقر فوق أعمدةومن ثم انقر فوق التالي.
    4. في مربع الحوار معالج التخطيطات-الخطوة 3 من 4-خيارات التخطيط ، انقر فوق التالي.
    5. في مربع الحوار معالج التخطيطات-الخطوة 4 من 4-موقع التخطيط ، انقر فوق الخيار كورقة جديدة ، ومن ثم انقر فوق إنهاء.
    في Microsoft Office Excel 2007، اتبع الخطوات التالية:
    1. انقر فوق علامة التبويب إدراج ، انقر فوق
      التشتت في المجموعة مخططات ، وثم حدد نوع.
    2. ضمن علامة التبويب " تصميم "، انقر فوق نقل المخطط في مجموعة الموقع ، انقر فوق
      ورقة جديدة ، ثم انقر فوق موافق.
  3. اضغط ALT + F11 لبدء تشغيل محرر Visual Basic.
  4. من القائمة إدراج ، انقر فوق الوحدة.
  5. نوع نموذج التعليمات البرمجية التالية في ورقة وحدة نمطية:
    Sub AttachLabelsToPoints()
    'Dimension variables.
    Dim Counter As Integer, ChartName As String, xVals As String

    ' Disable screen updating while the subroutine is run.
    Application.ScreenUpdating = False

    'Store the formula for the first series in "xVals".
    xVals = ActiveChart.SeriesCollection(1).Formula

    'Extract the range for the data from xVals.
    xVals = Mid(xVals, InStr(InStr(xVals, ","), xVals, _
    Mid(Left(xVals, InStr(xVals, "!") - 1), 9)))
    xVals = Left(xVals, InStr(InStr(xVals, "!"), xVals, ",") - 1)
    Do While Left(xVals, 1) = ","
    xVals = Mid(xVals, 2)
    Loop

    'Attach a label to each data point in the chart.
    For Counter = 1 To Range(xVals).Cells.Count
    ActiveChart.SeriesCollection(1).Points(Counter).HasDataLabel = _
    True
    ActiveChart.SeriesCollection(1).Points(Counter).DataLabel.Text = _
    Range(xVals).Cells(Counter, 1).Offset(0, -1).Value
    Next Counter

    End Sub
  6. اضغط ALT + Q للعودة إلى Excel.
  7. قم بالتبديل إلى ورقة المخطط.
  8. في Excel 2003 وفي الإصدارات السابقة من Excel، أشر إلى ماكرو في قائمة " أدوات " ومن ثم انقر فوق وحدات الماكرو. انقر فوق أتتاتشلابيلستوبوينتس، ومن ثم انقر فوق تشغيل لتشغيل الماكرو.

    في Excel 2007، انقر فوق علامة التبويب المطور ، انقر فوق
    حدد ماكرو في مجموعة التعليمات البرمجية
    أتتاتشلابيلستوبوينتس، ثم انقر فوق تشغيل.
إرفاق الماكرو التسميات في الخلايا a2: a6 نقاط البيانات في المخطط.
خصائص

رقم الموضوع: 213750 - آخر مراجعة: 09‏/01‏/2017 - المراجعة: 1

تعليقات