معلومات حول قائمة "الإكمال التلقائي" Outlook

ملخص

يتضمن هذا المقال نظرة عامة حول قائمة "الإكمال التلقائي" من Microsoft Outlook (يعرف أيضا توقعات قائمة الإكمال التلقائي). بالإضافة إلى وصف الميزة، تحتوي هذه المقالة على مزيد من المعلومات والإرشادات خطوة بخطوة للمستخدمين المتقدمين لإدارة القائمة.

مزيد من المعلومات

يحتفظ outlook قائمة "الإكمال التلقائي". القائمة يتم استخدامها بواسطة ميزة تدقيق الأسماء التلقائي وميزة "الإكمال التلقائي". يتم إنشاء قائمة "الإكمال التلقائي"، المعروف أيضا الكنيات، تلقائياً عندما تقوم بإرسال رسائل بريد إلكتروني من Outlook. يحتوي على القائمة عناوين SMTP وإدخالات LegacyExchangeDN أسماء العرض للأشخاص الذين تم إرسال البريد مسبقاً.

ملاحظة: قائمة الإكمال التلقائي ل Outlook مخصص ل Outlook ولا تتم المشاركة عن طريق تطبيق ويب Outlook (OWA). يحتفظ OWA قائمة "الإكمال التلقائي" الخاص به.

توفر المقاطع التالية معلومات حول الميزة "الإكمال التلقائي".

تحديد عدد الإدخالات

يحدد outlook عدد الإدخالات التي يمكنك حفظها في قائمة "الإكمال التلقائي". بعد الوصول إلى هذا الحد، يستخدم Outlook خوارزمية داخلية لتحديد أسماء أفضل إزالته من القائمة. ويتم ذلك استناداً إلى استخدام وزن. لذلك، قد تجد بعض الأسماء بشكل غير متوقع إزالة من ذاكرة التخزين المؤقت للاسم المستعار الخاص بك. هناك نهجان العامة التي يمكنك استخدامها لتجنب هذا الموقف:
  1. يمكنك إزالة إدخالات قائمة "الإكمال التلقائي" التي لم تعد بحاجة استباقي. هذا هو الأسلوب المفضل. لمزيد من المعلومات حول كيفية القيام بذلك، راجع الجزء الموجود بعنوان "كيفية إزالة إدخالات قائمة" الإكمال التلقائي "واحدة في كل مرة".
  2. يمكنك زيادة الحد الأقصى للتخزين المؤقت للكنيات. لأنه لم يتم اختبارها هذا التكوين، أننا لا ننصح بهذا. إذا كان لديك الكنيات أكبر، قد تفقد عدد كبير من الإدخالات المخزنة مؤقتاً إذا أصبحت ذاكرة التخزين المؤقت للاسم المستعار الخاص بك غير قابل للاستخدام بسبب الفساد. لمزيد من المعلومات حول كيفية زيادة الحد، راجع الجزء الموجود بعنوان "كيفية تغيير الحد الأقصى لقائمة" الإكمال التلقائي "."
الحدود كما يلي:
  • Outlook 2016: 1000
  • Outlook 2013: 1000
  • Outlook 2010: 1000
  • برنامج outlook 2007: إدخالات 2000
  • برنامج outlook 2003: 1000

كيفية تمكين الميزة "الإكمال التلقائي"

تفاصيل هذا المقطع كيفية تمكين أو تعطيل ميزة "الإكمال التلقائي".
Outlook 2013 و outlook 2010 Outlook 2016
للوصول إلى إعدادات "الإكمال التلقائي"، اتبع الخطوات التالية:
  1. من القائمة ملف ، انقر فوق " خيارات".
  2. حدد علامة التبويب البريد .
  3. التمرير في منتصف الطريق تقريبا حتى تشاهد إرسال رسائل. تأكد من أن مربع قائمة الإكمال التلقائي استخدام اقتراح عند الكتابة في إلى ونسخة ومخفية في بنود محددة.

Outlook 2003 و Outlook 2007
للوصول إلى إعدادات "الإكمال التلقائي"، اتبع الخطوات التالية:
  1. انقر فوق أدوات، ومن ثم انقر فوق خيارات.
  2. انقر فوق الزر خيارات البريد الإلكتروني .
  3. انقر فوق الزر خيارات متقدمة للبريد الإلكتروني .
  4. تأكد من اقتراح أسماء أثناء إكمال إلى ونسخة ومخفية حقول خانة. (يتبع لقطة لهذه الخطوة.)The screen shot for this step.

كيفية استيراد ملفات.nk2 إلى Outlook 2013 و Outlook 2010 Outlook 2016

Microsoft Office Outlook 2007 والإصدارات السابقة تخزين قائمة "الإكمال التلقائي" في ملف اسم مستعار (.nk2) على القرص. Outlook 2013 و outlook 2010 Outlook 2016 بتخزين قائمة "الإكمال التلقائي" كرسالة مخفية في مخزن الرسائل الأساسية. Outlook 2013 و outlook 2010 Outlook 2016 تتيح لك استيراد ملفات.nk2 القديمة.

لمزيد من المعلومات حول كيفية استيراد ملفات.nk2 في عام 2010 Outlook، انتقل إلى موقع Microsoft التالي على الويب:
لمزيد من المعلومات حول كيفية استيراد ملفات.nk2 في Outlook 2013 و Outlook 2016، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
كيفية استيراد ملفات.nk2 إلى Outlook 2013 أو Outlook 2016 2806550

كيفية نسخ قائمة "الإكمال التلقائي"

تختلف الخطوات لتصدير واستيراد قائمة "الإكمال التلقائي"، اعتماداً على إصدار Outlook الذي تقوم باستخدامه.
Outlook 2013 و outlook 2010 Outlook 2016
لنسخ قائمة "الإكمال التلقائي" في Outlook 2010 و Outlook 2013 Outlook 2016، اتبع الخطوات التالية:

الخطوة 1

لتصدير الرسائل علبة البريد "الإكمال التلقائي"، اتبع الخطوات التالية:
  1. قم بإنهاء Outlook وقم بإغلاق Outlook Web Access أو تطبيق ويب Outlook (OWA) على كافة محطات العمل المتصلة بصندوق البريد الخاص بك.
  2. تنزيل وتثبيت MFCMAPI من http://mfcmapi.codeplex.com.
  3. قم بتشغيل mfcmapi.exe.
  4. في القائمة جلسة العمل ، انقر فوق تسجيل الدخول.
  5. إذا تم مطالبتك بملف تعريف، حدد اسم ملف التعريف الذي تريده ومن ثم انقر فوق موافق.
  6. في الجزء العلوي، حدد السطر الذي يتوافق مع علبة البريد الخاصة بك، وثم انقر فوقه نقراً مزدوجاً.
  7. في جزء التنقل على الجانب الأيسر، قم بتوسيع حاوي الجذرثم قم بتوسيع IPM_SUBTREEأو أعلى مخزن المعلومات .
  8. انقر فوق المجلد علبة الوارد ومن ثم انقر فوق فتح جدول المحتويات المقترنة. هذا الإجراء بفتح نافذة جديدة MFCMAPI الذي يحتوي على الخصائص المختلفة.
  9. تحت عمود " الموضوع "، انقر نقراً مزدوجاً فوق العنصر الذي يحتوي الموضوع IPM. Configuration.Autocomplete، ثم انقر فوق تصدير الرسائل. هذا الإجراء بفتح إطار الرسالة حفظ للملف .
  10. في القائمة المنسدلة، حدد ملف MSG (UNICODE)، ومن ثم انقر فوق موافق.
  11. حدد موقع مجلد الذي تريد حفظ الرسالة، ومن ثم انقر فوق حفظ. ملاحظة هذا الموقع.
الخطوة 2

لاستيراد رسائل علبة البريد "الإكمال التلقائي"، اتبع الخطوات التالية.
  1. قم بإنهاء Outlook وقم بإغلاق Outlook Web Access أو تطبيق ويب Outlook (OWA) على كافة محطات العمل المتصلة بصندوق البريد الخاص بك.
  2. تنزيل وتثبيت MFCMAPI من http://mfcmapi.codeplex.com
  3. قم بتشغيل mfcmapi.exe.
  4. في القائمة جلسة العمل ، انقر فوق تسجيل الدخول.
  5. إذا تم مطالبتك بملف تعريف، حدد اسم ملف التعريف الذي تريده ومن ثم انقر فوق موافق.
  6. في الجزء العلوي، حدد السطر الذي يتوافق مع علبة البريد الخاصة بك، وثم انقر فوقه نقراً مزدوجاً.
  7. في جزء التنقل على الجانب الأيسر، قم بتوسيع أصل-علبة البريد، ثم قم بتوسيع أعلى مخزن المعلومات أو IPM_SUBTREE.
  8. انقر فوق المجلد علبة الوارد ومن ثم انقر فوق فتح جدول المحتويات المقترنة. هذا الإجراء بفتح نافذة جديدة MFCMAPI الذي يحتوي على الخصائص المختلفة.
  9. لتجنب الإدخالات المكررة، يجب حذف رسالة "إكمال تلقائي" الموجودة.

    ملاحظة: قبل حذف IPM. Configuration.Autocomplete الرسالة، يجب تصدير الرسالة باتباع الخطوات الموجودة في القسم "كيفية تصدير التخزين المؤقت الإكمال التلقائي".

    لحذف رسالة "إكمال تلقائي" موجود، اتبع الخطوات التالية:

    1. في عمود " الموضوع "، حدد موقع العنصر الذي يحتوي الموضوع IPM. Configuration.Autocomplete.
    2. انقر نقراً مزدوجاً فوق العنصر ومن ثم انقر فوق حذف الرسالة. يؤدي هذا إلى فتح الإطار حذف عنصر .
    3. في القائمة المنسدلة، حدد حذف دائمة (يحذف لاستبقاء العنصر المحذوف دعم)، ومن ثم انقر فوق موافق.
  10. في قائمة المجلدات ، انقر إدراج، ومن ثم انقر فوق رسالة من.
  11. حدد موقع ملف.msg الذي قمت بإنشائه في الخطوة 11 من القسم "كيفية لتصدير إكمال قائمة" ومن ثم انقر فوق موافق.
  12. في إطار رسالة التحميل الذي يظهر، حدد تحميل الرسائل في المجلد الحالي في القائمة نمط التحميل ، وثم انقر فوق موافق.
تم استيراد معلومات "الإكمال التلقائي" من IPM. Configuration.Autocomplete_.msg< رمز ست عشري >، حيث يمثل العنصر النائب< رمز ست عشري > سلسلة طويلة من الأرقام والحروف.
Outlook 2003 و Outlook 2007
تختلف خطوات لنسخ قائمة "الإكمال التلقائي" في برنامج Outlook 2003 و Outlook 2007. وهذا لأن Outlook 2003 و Outlook 2007 بتخزين قائمة "الإكمال التلقائي" في ملف.nk2.

لنسخ قائمة "الإكمال التلقائي" في برنامج Outlook 2003، انتقل إلى موقع Microsoft التالي على الويب:
لنسخ قائمة "الإكمال التلقائي" في برنامج Outlook 2007، انتقل إلى موقع Microsoft التالي على الويب:

كيفية إزالة إدخالات قائمة "إكمال تلقائي" واحد في كل مرة

لإزالة الإدخالات من ذاكرة التخزين المؤقت للإكمال التلقائي إدخال واحد في مرة الواحدة، اتبع الخطوات التالية:
  1. افتح رسالة بريد إلكتروني جديدة.
  2. اكتب الأحرف القليلة الأولى من إدخال "الإكمال التلقائي" الذي تريد إزالته.
  3. عند ظهور الإدخال في القائمة اقتراح أسماء، حرك مؤشر الماوس فوق الاسم حتى يصبح تمييزه، ولكن لا تنقر فوق الاسم.
  4. عند رمز "X" بجوار الاسم المميز، انقر فوق X لإزالة الاسم من القائمة، أو اضغط المفتاح Delete على لوحة المفاتيح.

كيفية مسح القائمة "الإكمال التلقائي" بأكملها

يفسر هذا القسم كيفية حذف قائمة "الإكمال التلقائي".
Outlook 2013 و outlook 2010 Outlook 2016
استخدم إحدى الطريقتين التاليتين لحذف قائمة "الإكمال التلقائي" في Outlook 2010 و Outlook 2013 Outlook 2016.

الطريقة الأولى
  1. افتح Outlook.
  2. في علامة التبويب " ملف "، انقر فوق خيارات
  3. انقر فوق علامة التبويب بريد .
  4. ضمن إرسال الرسائل، انقر فوق قائمة "الإكمال التلقائي" فارغة.


  5. انقر فوق نعم.

Method 2

بدء تشغيل برنامج Outlook باستخدام رمز التبديل/CleanAutoCompleteCache. للقيام بذلك، اتبع الخطوات التالية:
  1. وانقر فوق ابدأ، ثم انقر فوق تشغيل.
  2. نوع Outlook.exe/CleanAutoCompleteCache.

    ملاحظة: إذا لم يتم تثبيت Outlook في الموقع الافتراضي، يجب أن يشير مسار Outlook.exe.
Outlook 2003 و Outlook 2007
لحذف قائمة "الإكمال التلقائي" في برنامج Outlook 2003 و Outlook 2007، يجب حذف الملف.nk2 يدوياً. لحذف ملف.nk2، اتبع الخطوات التالية:
  1. قم بإنهاء Outlook.
  2. انقر فوق ابدأ، وثم انقر فوق جهاز الكمبيوتر.
  3. انقر فوق تنظيم، ومن ثم انقر فوق خيارات المجلد والبحث.
  4. ضمن علامة التبويب عرض ، انقر فوق إظهار الملفات المخفية والمجلدات، ومحركات الأقراص.
  5. انقر فوق "موافق".
  6. انقر فوق ابدأ، انقر فوق كافة البرامج، انقر فوق البرامج الملحقة، وثم انقر فوق تشغيل.
  7. في مربع الحوار تشغيل ، اكتب الأمر التالي (بما في ذلك علامتي الاقتباس)، ومن ثم انقر فوق موافق:

    “C:\ Users\UserName\AppData\Roaming\Microsoft\Outlook”


    ملاحظة: اسم المستخدم في هذا المسار هو اسم المسجلة حاليا على مستخدم Windows.
  8. انقر بالزر الأيمن. ملف NK2 يحتوي على اسم ملف التعريف الذي تريد إعادة تعيين، ثم انقر فوق إعادة تسمية.
  9. إعادة تسمية الملف ب اسم ملف التعريف.bak، واضغط على Enter.
  10. يم Outlook.

مشكلات ذاكرة التخزين المؤقت "الإكمال التلقائي"

يصف هذا القسم المشكلات المعروفة التي تحدث مع ذاكرة التخزين المؤقت "الإكمال التلقائي". ذاكرة التخزين المؤقت "الإكمال التلقائي" أصبح تالفاً على مر الزمن، وقد لا يتم حفظ إدخالات جديدة. إذا حدث هذا، يمكنك محاولة إزالة الإدخالات الفردية من القائمة. للقيام بذلك، راجع الجزء الموجود بعنوان "كيفية إزالة إدخالات قائمة" الإكمال التلقائي "واحدة في كل مرة". إذا لم تحل المشكلة، يمكنك إعادة تعيين القائمة "الإكمال التلقائي" بأكملها. للقيام بذلك، راجع الجزء الموجود بعنوان "كيفية مسح قائمة" الإكمال التلقائي "الكامل".

كيفية تغيير الحد الأقصى لقائمة "الإكمال التلقائي"

لأنه لم يتم اختبارها هذا التكوين، أننا لا ننصح بهذا. إذا كان لديك قائمة "الإكمال التلقائي" أكبر، قد تفقد عدد كبير من الإدخالات المخزنة مؤقتاً إذا أصبحت ذاكرة التخزين المؤقت "الإكمال التلقائي" الخاص بك غير قابل للاستخدام بسبب الفساد. ونظرا لهذا التنازل، يمكنك استخدام بيانات التسجيل التالية لزيادة حد قائمة "الإكمال التلقائي" في Outlook.

هام: يحتوي هذا المقطع أو الأسلوب أو المهمة على الخطوات التي توضح كيفية تعديل التسجيل. ومع ذلك، قد تحدث مشكلات خطيرة إذا قمت بتعديل التسجيل بشكل غير صحيح. لذلك، تأكد من اتباع الخطوات التالية بعناية. للحماية الإضافية، قم بعمل نسخة احتياطية للسجل قبل تعديله. بعد ذلك، يمكنك استعادة السجل في حالة حدوث مشكلة. لمزيد من المعلومات حول كيفية عمل نسخة احتياطية من السجل واستعادته، انقر فوق رقم المقالة التالية لعرضها في "قاعدة معارف Microsoft":

322756 كيفية عمل نسخة احتياطية من السجل واستعادته في Windows
  1. قم بإنهاء Outlook.
  2. ابدأ تشغيل "محرر التسجيل".

    • في Windows 8.x، اضغط مفتاح، اكتب regedit الإطارات واضغط Enter.
    • في Windows 7 ونظام التشغيل Windows Vista، انقر فوق ابدأواكتب regedit في المربع بدء البحث واضغط على Enter.
  3. حدد موقع ثم حدد مفتاح التسجيل الفرعي التالي:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck

    ملاحظة: يمثل العنصر النائب x.0 في مفتاح التسجيل الفرعي هذا الإصدار الخاص بك من Microsoft Office. استخدم القيمة المناسبة من القائمة التالية.

    Outlook 2016 = 16.0
    Outlook 2013 = 15.0
    Outlook 2010 = 14.0
    Outlook 2007 = 12.0
    Outlook 2003 = 11.0
  4. من القائمة تحرير ، أشر إلى جديد، ومن ثم انقر فوق قيمة DWORD.
  5. اكتب ماكسنيكناميسومن ثم اضغط Enter.
  6. من القائمة تحرير ، انقر فوق تعديل.
  7. اكتب قيمة جديدة للحد، ومن ثم انقر فوق موافق.

    ملاحظات
    • تأكد من كتابة الرقم دنموذج أسمال. وهذا النموذج الصحيح لكتابة الرقم.
    • حاول زيادة الحد بنسبة هامشية لاختبار الحد الجديد. على سبيل المثال، لإنشاء بزيادة 20 في المائة في حدود عام Outlook 2013، حدد 1200 لقيمة ماكسنيكناميس.
  8. اخرج من "محرر السجل".
  9. قم ببدء تشغيل Outlook.
ملاحظة: تحدد قيمة التسجيل ماكسنيكناميس الحد غير الافتراضية فقط. لذلك، يمكنك أيضا استخدام هذه القيمة لتخفيض حد ذاكرة التخزين المؤقت للكنيات.

خصائص

رقم الموضوع: 2199226 - آخر مراجعة: 15‏/02‏/2017 - المراجعة: 1

Outlook 2016, Microsoft Outlook 2013, Microsoft Office Outlook 2003, Microsoft Office Outlook 2007, Microsoft Outlook 2010

تعليقات