عدم إمكانية اتصال تطبيقات عميل Outlook بالمجلدات العامة بعد تثبيت Exchange Server 2010 SP1

الأعراض

تواجه تطبيقات عميل Microsoft Outlook معينة مشاكل في الاتصال عند ظهور العديد من التهديدات لخدمة Microsoft Exchange RPC Client Access على مجلد عام في انتظار تلقي استجابات من خدمة Availability. على سبيل المثال، تحدث المشكلة عندما يظهر أكثر من ٥٠٠ تهديد في انتظار تلقي الاستجابات من مجلد عام.

ملاحظات

  • لا يوجد أي خيار لتعطيل خدمة Availability في خادم مثبت عليه Exchange Server 2010 Service Pack (SP1).
  • إذا قمت بإعادة تشغيل خدمة Exchange RPC Client Access على خادم المجلد العمومي بنظام Exchange Server 2010 SP1، فإن هذه المشكلة يتم حلها مؤقتًا.

السبب

تحدث هذه المشكلة نظرًا لوجود ميزة جديدة في Exchange Server 2010 SP1. تستخدم هذه الميزة الجديدة لخدمة Microsoft Exchange RPC Client Access كوكيل للإصدارات الأقدم من خدمة Availability (معلومات الإتاحة/الإشغال). ولذلك، فإذا كان لديك أحد المجلدات العامة على خادم Exchange Server 2010 SP1، فسيتم الوصول إلى طلبات معلومات الإتاحة/الإشغال بواسطة خدمة Microsoft Exchange RPC Client Access.

الحل

معلومات مفتاح السجل

هام يحتوي هذا القسم أو الطريقة أو المهمة على خطوات توضح كيفية تعديل السجل. وقد يحدث رغم ما سبق مشاكل خطيرة في حالة تعديل السجل بطريقة غير صحيحة. ولذلك، يجب التأكد من اتباع هذه الخطوات بعناية. قم بعمل نسخة احتياطية من السجل قبل تعديله كوسيلة من وسائل الحماية الإضافية. بعد ذلك، يمكنك استعادة السجل في حالة حدوث أية مشكلة. لمزيد من المعلومات حول كيفية عمل نسخة احتياطية من السجل واستعادته، انقر فوق رقم المقالة التالي لعرضها في "قاعدة معارف Microsoft":
322756 كيفية عمل نسخة احتياطية من السجل واستعادته في نظام التشغيل Windows
لحل هذه المشكلة، قم بتثبيت التحديث التالي على خادم Exchange Server 2010 SP1:
2497453 الإصلاح: قد يعمل التطبيق على إيقاف الاستجابة بعد إحباط طلبات HTTP عديدة إذا استخدمت فئة HttpWebRequest لإرسال طلبات في .NET Framework

ملاحظة
: لحل هذه المشكلة، قم بتثبيت مجموعة التحديثات التالية:
2579150 وصف مجموعة التحديثات 4 لبرنامج Exchange Server 2010 المزود بحزمة الخدمة Service Pack 1


للسماح لنا بتعطيل خدمة Availability بعد تثبيت هذا التحديث، انتقل إلى القسم "إصلاح المشكلة بالإنابة عني". إذا كنت تفضل تعطيل خدمة Availability بنفسك، فانتقل إلى القسم "إصلاح المشكلة بنفسي".

إصلاح المشكلة بالإنابة عني



لتعطيل خدمة Availability تلقائيًا، انقر فوق الزر أو الارتباط Fix it. ثم انقر فوق تشغيل في مربع الحوار تنزيل ملف، ثم اتبع الخطوات الموجودة في المعالج Fix it.




ملاحظات
  • قد يتوفر هذا المعالج باللغة الإنجليزية فقط. ومع ذلك، يعمل الإصلاح التلقائي أيضًا مع إصدارات Windows باللغات الأخرى.
  • إذا كنت لا تعمل على الكمبيوتر الذي توجد به المشكلة، يمكنك حفظ حل "Fix it" على محرك أقراص محمول أو قرص مضغوط ثم تشغيله على الكمبيوتر الذي توجد به المشكلة.

وبعد ذلك، انتقل إلى القسم "هل عمل ذلك على إصلاح المشكلة؟".



إصلاح المشكلة بنفسي

بعد قيامك بتثبيت التحديث، اتبع الخطوات التالية لتعطيل خدمة Availability: 
  1. انقر فوق ابدأ، وانقر فوق تشغيل، واكتب regedit في المربع فتح، ثم انقر فوق موافق.
  2. حدد موقع مفتاح التسجيل الفرعي التالي، ثم انقر فوقه:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\
  3. من القائمة تحرير، قم بالإشارة إلى جديد، ثم انقر فوق مفتاح.
  4. اكتب ParametersSystem، ثم اضغط على مفتاح "الإدخال".
  5. حدد موقع مفتاح التسجيل الفرعي التالي، ثم انقر فوقه:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem
  6. من القائمة تحرير، قم بالإشارة إلى جديد، ثم انقر فوق قيمة Dword.
  7. اكتب DisableAvailabilityServiceCalls، ثم اضغط على مفتاح "الإدخال".
  8. في جزء التفاصيل، انقر بزر الماوس الأيمن فوق DisableAvailabilityServiceCalls، ثم انقر فوق تعديل.
  9. في المربع بيانات القيمة ، اكتب ١، وانقر بعد ذلك فوق موافق.
  10. قم بإنهاء "محرر السجل".
ملاحظة إذا اخترت انتظار مجموعة التحديثات ٤ لـ Exchange Server 2010 SP1، حيث يعمل الأمر على عكس الوظيفة المتأثرة لنظام التشغيل Exchange Server 2010 RTM.


هل عمل ذلك على إصلاح المشكلة؟

  • تحقق مما إذا كان قد تم إصلاح المشكلة أم لا. في حالة إصلاح المشكلة، فلا يتطلب الأمر إكمال قراءة هذا القسم. أما في حالة عدم إصلاح المشكلة، يمكنك الاتصال بالدعم.
  • نحن نقدّر إرسالك لأية ملاحظات. لتقديم ملاحظات أو الإبلاغ عن المشاكل التي تحدث مع هذا الحل، الرجاء كتابة تعليق بالمدوّنة "إصلاح المشكلة بالإنابة عني" أو إرسال رسالة بريد إلكتروني إلينا.

تصريح

أقرت Microsoft أن هذه مشكلة تحدث في منتجات Microsoft المسردة في القسم "ينطبق على".

معلومات أخرى

لمزيدٍ من المعلومات حول خدمة Availability، قم بزيارة موقع Microsoft TechNet التالي على الويب:
خصائص

رقم الموضوع: 2535105 - آخر مراجعة: 20‏/01‏/2012 - المراجعة: 1

تعليقات