"Collector initiated" subscription fails on a Windows Server 2008 R2-based computer that uses a disjointed domain namespace

Symptoms

Consider the following scenario:
  • You have a Windows Server 2008 R2 Service Pack 1 (SP1)-based computer that uses a disjointed domain namespace in an Active Directory domain environment.
  • You set up Windows Remote Management (WinRM) to receive requests on this computer. To do this, you enable the WinRM firewall exception and use the following command to configure WinRM:
    winrm qc -c
  • You create a Collector initiated subscription in Event Viewer to collect events from other domain member computers.
In this scenario, the subscription fails. Additionally, if you check the Runtime Status of the subscription, you receive an error message that resembles the following:
[FQDN of the computer] - Error - Last retry time: MM/DD/YYYY TIME . Code (0x80338095): The connectivity test from the push subscription source to the client failed. This can happen if the client machine initiating the push subscription is unreachable from the server machine where the event source is located. Possible reasons include firewall or some other network boundary. Modify subscription to use Pull based subscription. Next retry time: MM/DD/YYYY TIME.
Note A computer that uses a disjointed namespace is a computer whose DNS domain name differs from the Active Directory DNS domain name.

Cause

This issue occurs because the fully qualified domain name (FQDN) differs from the disjoint DNS suffix. Therefore, the subscription fails.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows Server 2008 R2RTMGDR
    6.1.760
    1.22xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
For all supported x64-based versions of Windows Server 2008 R2
For all supported IA-64-based versions of Windows Server 2008 R2
For all supported IA-64-based versions of Windows Server 2008 R2

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about Event Subscriptions, go to the following Microsoft website:For more information about create a new subscription, go to the following Microsoft website:
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
980255 You cannot create a subscription by using the "Source computer initiated" type on a computer that is running Windows Server 2008 R2
For more information about disjointed domain namespace, click the following article number to view the article in the Microsoft Knowledge Base:
909264 Naming conventions in Active Directory for computers, domains, sites, and OUs
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Additional files for all supported x64-based versions of Windows Server 2008 R2
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
خصائص

رقم الموضوع: 2768529 - آخر مراجعة: 14‏/11‏/2012 - المراجعة: 1

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