كيفية إنشاء "مصنف ماكرو الشخصي" في Excel لنظام التشغيل Mac

ملخص

توضح هذه المقالة كيفية إنشاء "مصنف ماكرو الشخصي" للكتابة والتحرير Microsoft Visual Basic للتطبيقات (VBA) وحدات الماكرو يمكنك تسجيلها.

مزيد من المعلومات

كيفية إنشاء مصنف ماكرو الشخصي

أن أسهل طريقة لإنشاء "مصنف ماكرو الشخصي" تسجيل ماكرو "زائفة". للقيام بذلك، اتبع الخطوات التالية:

  1. بدء تشغيل Excel بحيث يتم فتح مصنف جديد. من القائمة أدوات ، أشر إلى ماكرو، ومن ثم انقر فوق تسجيل ماكرو جديد.
  2. في مربع الحوار تسجيل ماكرو ، انقر فوق مصنف الماكرو الشخصي في القائمة تخزين الماكرو .
  3. انقر فوق موافق. لا انقر فوق لإنشاء ماكرو "زائفة"، أو كتابة أي شيء.
  4. في شريط الأدوات الذي يظهر، انقر فوق الزر إيقاف التسجيل .
  5. في قائمة Excel ، انقر فوق " إنهاء". أو، لإصدارات Excel الأقدم من Excel X، انقر فوق " إنهاء " في القائمة " ملف ".
  6. انقر فوق حفظ عندما تتم مطالبتك بحفظ التغييرات.
عند بدء تشغيل Excel، يتم فتح "مصنف الماكرو الشخصي" هذا كمصنف مخفي. بشكل افتراضي، يتم تخزينه في المسار التالي استناداً إلى الإصدار الخاص بك من Excel.

Excel في Excel 98 وفي عام 2001
مجلد Microsoft Office: "مصنف ماكرو" Office: بدء التشغيل: Excel: الشخصية
في Excel X أو الإصدارات الأحدث
محرك الأقراص الثابتة:: تطبيقات Microsoft Office الإصدار: "مصنف ماكرو" Office: بدء التشغيل: Excel: الشخصية

كيفية استخدام مصنف ماكرو الشخصي

للكتابة أو تحرير التعليمات البرمجية ل VBA في "مصنف ماكرو الشخصي"، اتبع الخطوات التالية:

  1. من القائمة أدوات ، أشر إلى ماكرو، ومن ثم انقر فوق محرر Visual Basic.
  2. في إطار "مشروع VBA – مشروع"، انقر نقراً مزدوجاً فوق VBAProject (مصنف الماكرو الشخصي) لعرض المجلد داخل الوحدات النمطية .
  3. انقر نقراً مزدوجاً فوق المجلد الوحدات النمطية لعرض أية وحدات نمطية في هذا المشروع، وانقر نقراً مزدوجاً فوق وحدة نمطية لعرض التعليمات البرمجية أو ورقة التعليمات البرمجية فارغة.

    يمكنك استخدام صفحة التعليمات البرمجية هذه لكتابة وتحرير التعليمات البرمجية ل VBA.
خصائص

رقم الموضوع: 288117 - آخر مراجعة: 22‏/01‏/2017 - المراجعة: 2

Microsoft Excel 2004 for Mac, Microsoft Excel X لـ Mac, Microsoft Excel 2001 لـ Macintosh, Microsoft Excel 98 لـ Macintosh

تعليقات