كيفية تشغيل نموذج التعليمة البرمجية الخاصة ببرامج Office XP من مقالات قاعدة المعارف

للحصول على إصدار Microsoft Office 2000 من هذه المقالة، راجع
212536 .
للحصول على إصدار Microsoft Office 97 من هذه المقالة، راجع
173707 .
للحصول على Microsoft Office 2001 ل Mac نسخة من هذه المقالة، راجع
274703 .
للحصول على إصدار Microsoft Office 98 Macintosh Edition من هذه المقالة، راجع
181058 .

ملخص

يتضمن Microsoft Knowledge Base عددا من المقالات التي تتضمن نموذج التعليمات البرمجية ل Visual Basic للتطبيقات وحدات الماكرو. توضح العديد من وحدات الماكرو هذه المفاهيم الأساسية للبرمجة في Visual Basic لمختلف برامج Office XP. تحتوي هذه المقالة على إرشادات حول كيفية استخدام نموذج التعليمة البرمجية لإنشاء ماكرو جديد وكيفية تشغيل هذا الماكرو.

مزيد من المعلومات

توفر Microsoft أمثلة برمجية للتوضيح فقط، دون أي ضمان صريح أو ضمني. هذا يتضمن، على سبيل المثال لا الحصر، الضمانات الضمنية الخاصة بالتسويق أو الملاءمة لغرض معين. تفترض هذه المقالة أنك معتاد على لغة البرمجة التي يتم شرحها والأدوات المستخدمة لإنشاء الإجراءات وتصحيحها. يساعد مهندسو الدعم لدى Microsoft في شرح وظيفة إجراء محدد، لكنهم لن يقوموا بتعديل هذه الأمثلة لتقديم وظيفة إضافية أو إنشاء إجراءات تستوفي متطلبات محددة. لاستخدام نموذج التعليمة البرمجية من مقالة قاعدة المعارف، يجب إضافة ماكرو Visual Basic جديد (أو حدد ماكرو موجود). يمكن نسخ ولصق أو نوع النموذج التعليمات البرمجية في هذا الماكرو باستخدام أي من الطرق التالية.

لإنشاء ماكرو جديد

  1. فتح أو إنشاء قالب في برنامج Office الذي تستخدمه.
  2. من القائمة أدوات ، أشر إلى ماكرو، ومن ثم انقر فوق وحدات الماكرو.
  3. في القائمة وحدات الماكرو في ، حدد قالب Word أو المستند الذي تريد حفظ الماكرو.
  4. في مربع اسم الماكرو ، اكتب اسماً للماكرو.
  5. انقر فوق إنشاء لفتح "محرر Visual Basic".
  6. قم بأحد الإجراءات التالية:
    • اكتب التعليمات البرمجية للماكرو بين الخط Macroname() الفرعية وخط End Sub.
      Sub macroname()    Type your macro code here
      End Sub

      -أو-
    • نسخ ولصق نموذج التعليمات البرمجية لوحدات الماكرو الخاص بك باتباع الخطوات التالية:
      Sub macroname() 
      End Sub

      1. قم بالتبديل إلى البرنامج الذي تستخدمه لعرض مقالة قاعدة معارف Microsoft، مثل Microsoft Internet Explorer.
      2. لتحديد نموذج التعليمة البرمجية، اضغط على المفتاح CTRL ثم النقر المفرد التعليمات البرمجية.
      3. في القائمة تحرير ، انقر فوق نسخ.
      4. قم بالتبديل إلى محرر Visual Basic.
      5. في محرر Visual Basic، حدد نص التعليمات البرمجية الموجودة Macroname() الفرعية إلى End Sub الماكرو.
      6. في القائمة تحرير ، انقر فوق لصق.

        ملاحظة: عندما تقوم بلصق، يتم استبدال النص الموجود في التعليمات البرمجية بالتعليمات البرمجية التي قمت بنسخها من مقالة قاعدة المعارف.
  7. بعد كتابة أو لصق التعليمات البرمجية للماكرو الخاص بك، انقر فوق إغلاق ورجوع إلى Microsoft البرنامج في القائمة " ملف " حيث أن البرنامج هو برنامج Microsoft Office XP الذي تستخدمه.


ملاحظة: استخدم المفتاح TAB لوضع مسافة بادئة النص. تعليقات الأسطر التي تبدأ بعلامة اقتباس أحادية (') وغير مطلوبة لتشغيل الماكرو. ومع ذلك، قد تحتاج إلى كتابتها لجعلها أسهل للفهم الماكرو.

لإضافة نموذج التعليمة البرمجية إلى وحدة نمطية

لإضافة التعليمات البرمجية إلى وحدة نمطية، يجب أن تحتوي وحدة نمطية موجودة أو إنشاء وحدة نمطية جديدة. للقيام بذلك، اتبع الخطوات التالية:
  1. فتح أو إنشاء قالب في برنامج Office الذي تستخدمه.
  2. من القائمة أدوات ، أشر إلى ماكرو، ومن ثم انقر فوق محرر Visual Basic.
  3. في إطار المشروع من Visual Basic Editor (بشكل افتراضي هذا في الزاوية اليسرى العليا)، انقر فوق رمز المشروع بنفس اسم القالب أو المستند الخاص بك. إذا كنت لم تقم بحفظ القالب أو المستند الخاص بك، سيكون اسم المشروع مشابه ل Project(Document1) أو TemplateProject(Template1).

    ملاحظة لمستخدمي WORD: إذا كنت تريد تخزين الماكرو في القالب العمومي الافتراضي، Normal.dot, انقر نقراً مزدوجاً فوق مشروع العادي .
  4. إذا لم يتضمن المشروع الذي قمت بالنقر فوق مجلد يسمى الوحدات النمطية تحته، انقر فوق الوحدة النمطية في القائمة إدراج .
  5. انقر فوق أي مكان في إطار التعليمات البرمجية للوحدة النمطية التي تريد إنشاء. إطار التعليمات البرمجية عادة في الركن العلوي الأيسر من محرر Visual Basic.
  6. اكتب أو الصق التعليمة البرمجية العينة تماما كما يظهر في مقالة قاعدة المعارف، بما في ذلك البنود الفرعية Macroname() و End Sub.

    ملاحظة: لمزيد من المعلومات حول كتابة أو لصق التعليمات البرمجية للماكرو، الرجاء مراجعة القسم "لإنشاء ماكرو جديد" في هذه المقالة.
بعد كتابة أو لصق التعليمات البرمجية للماكرو الخاص بك، انقر فوق إغلاق ورجوع إلى Microsoft البرنامج في القائمة " ملف "

حيث أن البرنامج هو برنامج Microsoft Office XP الذي تستخدمه.

لتشغيل الماكرو

  1. من القائمة أدوات ، أشر إلى ماكرو، ومن ثم انقر فوق وحدات الماكرو.
  2. حدد اسم الماكرو في القائمة اسم الماكرو ، ومن ثم انقر فوق تشغيل.

المراجع

تعليمات Microsoft لكل برنامج من برامج Office يحتوي على مواضيع عديدة حول العمل مع وحدات الماكرو. تعليمات Visual Basic يحتوي على معلومات شاملة حول كتابة التعليمات البرمجية الخاصة بك.
خصائص

رقم الموضوع: 290140 - آخر مراجعة: 22‏/01‏/2017 - المراجعة: 1

تعليقات