ماذا تفعل إذا فيروس ماكرو Word الخاص بك لنظام التشغيل Mac

ملخص

توضح هذه المقالة ما فيروسات الماكرو وما يجب فعله إذا كنت تعتقد أن الكمبيوتر قد يكون لديك فيروس ماكرو Word وكيفية التأكد من أن المستندات لا يصاب بفيروس ماكرو.

مزيد من المعلومات

تم اكتشاف فيروس ماكرو الأول في صيف عام 1995. ومنذ ذلك الوقت، ظهرت فيروسات الماكرو الأخرى.

فيروس ماكرو هو برنامج خبيثة التي يتم كتابتها باستخدام لغة الماكرو برنامج مثل Word. الفيروس بنشر نفسه بين ملفات البيانات ويمكن أن تضر الملفات أو نظام التشغيل الخاص بك.

فيروسات ماكرو Word لا تنتقل بحرية عبر الإنترنت أو أية وسيلة أخرى؛ يمكن تحويلها فقط عندما يقوم مستخدم بفتح المستند أو القالب الذي يحتوي على فيروس ماكرو.

لا يمكن نقل فيروسات الماكرو عن طريق البريد الإلكتروني، إلا إذا تم تضمين مستند المتأثرة في رسالة البريد الإلكتروني وجهاز الاستقبال بفتح المستند.

أعراض فيروس ماكرو

وفيما يلي بعض أعراض فيروسات ماكرو Word التي تؤثر على Word و Word المستندات:
  • عند محاولة حفظ مستند Word فقط يتيح لك حفظ المستند كقالب.

    -أو-
  • يبدو الرمز الخاص بالملف كقالب بدلاً من مستند.

    -أو-
  • عند فتح مستند، يظهر مربع حوار يظهر الرقم 1.

    -أو-
  • لم تعد تظهر أوامر الماكرو وتخصيص في قائمة الأدوات.

    -أو-
  • وحدات ماكرو جديدة تظهر في قائمة وحدات الماكرو. قد تظهر وحدات الماكرو AutoOpen و FileSaveAs؛ إذا كان الماكرو مسبقاً بهذه الأسماء، يمكن تعديل محتوياتها بفيروس ماكرو.

    -أو-
  • تظهر الرسائل غير عادي أو غير متوقع عند فتح قالب أو مستند Word.
ملاحظات
  • عدم البحث عن فيروسات الماكرو Word أو إزالة أية فيروسات الماكرو من القوالب والمستندات الموجودة. فإنه فقط يحذرك إذا كان المستند الذي تفتحه يحتوي على وحدات ماكرو. ثم يمكنك فتح المستند باستخدام وحدات الماكرو النشط أو فتحه باستخدام وحدات الماكرو معطلة. لا يجب فتح مستند يحتوي على وحدات الماكرو النشط، إلا إذا كنت متأكداً أن يحتوي المستند على أية فيروسات ماكرو ضارة.
  • يجب تحديث برامج مكافحة الفيروسات الغير متكرر ليظل نافذا. اتصل بالمورد للحصول على معلومات التحديث.

تثبيت برنامج مكافحة الفيروسات

للحصول على حل طويل الأمد لفيروسات الماكرو، تثبيت برنامج مكافحة الفيروسات المصممة خصيصا للكشف عن فيروسات الماكرو. للحصول على معلومات إضافية حول بائعي برامج الحماية من الفيروسات، بما في ذلك برامج قادرة على اكتشاف ومنع فيروسات الماكرو، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

49500 قائمة بموردي برامج الحماية من الفيروسات

توفر Microsoft معلومات الاتصال خارجية لمساعدتك في الحصول على الدعم التقني. قد تتغير معلومات جهة الاتصال هذه دون إشعار. لا تضمن Microsoft دقة معلومات جهة الاتصال لهذه الجهات الأخرى.

ماذا أفعل إذا كنت تعتقد أن الكمبيوتر قد يكون لديك فيروس ماكرو

استخدم الطرق التالية بحلول مؤقتة فقط عندما كنت تعتقد أن الكمبيوتر قد يكون لديك فيروس ماكرو.

الطريقة الأولى: تعطيل وحدات الماكرو ونسخ النص إلى مستند جديد

إذا لم يتعرض أي من مؤشرات الخطأ الموضحة مسبقاً في هذه المقالة، ولكن لا تريد أن تتأثر بفيروس ماكرو، اضغط باستمرار على المفتاح SHIFT عند فتح ملف قد يكون مصاباً بفيروس ماكرو. الضغط على مفتاح العالي منع أية وحدات ماكرو تلقائي Word تشغيل; في حالة وجود فيروس ماكرو، فإنه لم يتم تحميل.

الطريقة الثانية: حذف الماكرو واسترداد المستند

تواجه الأعراض الموضحة مسبقاً في هذه المقالة، أو إذا كنت تشك في وجود فيروس ماكرو غير الموضحة في هذه المقالة، اتبع هذه الخطوات لحذف الماكرو مشكوك بها ولتصحيح المستند المتأثرة.

ملاحظة: هذا مجرد حل مؤقت؛ لأنه يتم إنشاء وحدات ماكرو جديدة، قد لا تعمل هذه الخطوات على وحدات ماكرو جديدة.

  1. في القائمة، انقر فوق الكلمة ثم انقر فوق إنهاء. نقل ملف عادي إلى سطح المكتب. للقيام بذلك:
    1. قم بإنهاء كافة برامج Microsoft.
    2. من القائمة البحث عن، انقر فوق حدد الانتقال الرئيسية .
    3. فتح مجلد مكتبة .
    4. فتح مجلد دعم التطبيقات .
    5. افتح مجلد Microsoft .
    6. افتح مجلد Office .
    7. فتح مجلد قوالب المستخدم .
    8. انقر نقراً مزدوجاً فوق ملف عادي. انقر فوق تحرير، ثم اختر نسخ "Normal.dotm".

  2. فتح Word. من القائمة ملف ، انقر فوق فتح.
  3. انتقل إلى المجلد الذي يحتوي على الملف المتأثر.
  4. انقر لتحديد الملف المتأثر. مباشرة تضغط على المفتاح SHIFT، ثم انقر فوق فتح. استمر في الضغط على المفتاح SHIFT حتى الملف المتأثرة مفتوح في Word.

    ملاحظة: الضغط على المفتاح SHIFT أثناء فتح ملف منع أية وحدات ماكرو تلقائي Word تشغيل.
  5. لحذف ماكرو مشكوك بها، اتبع الخطوات التالية:
    1. من القائمة أدوات ، أشر إلى ماكرو، ومن ثم انقر فوق وحدات الماكرو.
    2. في وحدات الماكرو في القائمة المنبثقة، حدد كافة القوالب النشطة والمستندات.
    3. حدد الماكرو مشكوك بها، ومن ثم انقر فوق حذف. انقر فوق نعم عند مطالبتك ما إذا كنت تريد حذف الماكرو.
    4. كرر الخطوة c لكافة وحدات الماكرو مشكوك بها.
    5. انقر فوق إلغاء الأمر لإغلاق مربع الحوار ماكرو .
  6. استرداد النص من مستند المصابة، اتبع الخطوات التالية:
    1. تحديد المستند بأكمله بضغط الأمر + A أو عن طريق النقر فوق تحديد الكل ضمن القائمة تحرير .
    2. حذف علامة الفقرة الأخيرة من المستند من التحديد بالضغط على SHIFT + السهم الأيسر.
    3. في القائمة تحرير ، انقر فوق نسخ.
    4. من القائمة ملف ، انقر فوق جديد. حدد القالب الذي تريد استخدامه ومن ثم انقر فوق موافق.
    5. في القائمة تحرير ، انقر فوق لصق.
    6. كرر الخطوة 7 للتأكد من أنه قد لا نسخ الماكرو الذي يحتوي على فيروس.
    7. احفظ المستند.
  7. كرر هذه الخطوات لأي مستند الشك قد تحتوي على فيروس ماكرو.
ملاحظة: إذا لم يعمل الأسلوب 2، استخدم الطريقة الثالثة.

الطريقة الثالثة: استخدم المنظم لتنظيف فيروس ماكرو مؤقتاً

استخدم المنظم لتنظيف فيروس ماكرو. ضع في اعتبارك أنه إذا قمت بفتح الملفات الأخرى بعد فتح الملف المصاب، غالباً كانت الملفات مصابة أيضا.

لإزالة الفيروس من القالب Normal، اتبع الخطوات التالية:
  1. قم بإغلاق كافة المستندات. في حالة فتح أحد مستندات مصابة، فإنه يمكن بسهولة إعادة تصيب القالب Normal.
  2. من القائمة أدوات ، انقر فوق قوالب ووظائف إضافية، وثم انقر فوق الزر المنظم .
  3. انقر فوق علامة التبويب عناصر مشروع ماكرو ، ثم إعادة تسمية أو حذف كافة وحدات الماكرو التالية:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • فيليكسيت
    • ملف جديد
    • FileOpen
    • حفظ ملف
    • FileSaveAs
    • وحدات الماكرو
    • ToolsMacro
  4. انقر فوق إغلاق.
  5. اضغط SHIFT باستمرار أثناء النقر فوق حفظ الكل في القائمة " ملف " لحفظ القالب.
لإزالة فيروس ماكرو من أحد مستندات مصابة:

في حالة إصابة ملف، استخدم نفس الأسلوب كما هو موضح في الخطوات من 1 إلى 5، ولكن إزالة وحدات الماكرو من كلا القالب Normal ومن المستندات المصابة (قالب) في المنظم. عند الانتهاء، اضغط باستمرار المفتاح SHIFT أثناء انقر فوق حفظ الكل في القائمة ملف ، ثم نقل إلى الملف التالي. ضع في الاعتبار أن كل مرة يتم فيها فتح ملف مصاب، أن تصيب القالب Normal، حيث يجب إزالة وحدات الماكرو من القالب Normal مرارا وتكرارا.

الأسلوب 4: إدراج الملف المصاب بالفيروس ضمن مستند جديد

هذا الأسلوب مفيد بشكل خاص مع فيروس ماكرو "الحد الأقصى" الذي يقوم بإزالة الماكرو و تخصيص من قائمة " أدوات ".

ملاحظة: في هذه الحالة، قد لا تعمل قوالب ووظائف إضافية في القائمة أدوات .

  1. في القائمة، انقر فوق الكلمة ثم انقر فوق إنهاء. نقل القالب Normal على سطح المكتب. للقيام بذلك:
    1. قم بإنهاء كافة برامج Microsoft.
    2. من القائمة البحث عن، انقر فوق حدد الانتقال الرئيسية .
    3. فتح مجلد مكتبة .
    4. فتح مجلد دعم التطبيقات .
    5. افتح مجلد Microsoft .
    6. افتح مجلد Office .
    7. فتح مجلد قوالب المستخدم .
    8. انقر نقراً مزدوجاً فوق ملف عادي. انقر فوق تحرير، ثم اختر نسخ "Normal.dotm".

  2. فتح Word ثم ثم تحقق من أن الماكرو وتخصيص تظهر في القائمة " أدوات ".
  3. فتح مستند جديد. من القائمة إدراج، انقر فوق " ملف".
  4. انتقل إلى المجلد الذي يحتوي على الملف المتأثر.
  5. انقر لتحديد الملف المتأثر.
  6. تضغط على المفتاح SHIFT، ثم انقر فوق فتح. متابعة اضغط باستمرار على المفتاح SHIFT حتى الملف المتأثرة مفتوح في Word.
    ملاحظة: الضغط على المفتاح SHIFT أثناء فتح ملف منع وحدات الماكرو التلقائية Word قيد التشغيل.
  7. للتحقق من وجود أية وحدات ماكرو في المستند الجديد (يجب أن يتم سرد أي)، وأشر إلى ماكرو في قائمة " أدوات " ثم انقر فوق وحدات الماكرو. في وحدات الماكرو في القائمة المنبثقة، انقر فوق كافة القوالب والمستندات النشطة. ضمن اسم الماكرو، يجب أن سرد أية وحدات ماكرو. انقر فوق إلغاء الأمر.
  8. حفظ الملف باسم ملف مختلف.
  9. حذف الملف المصاب بالفيروس.

الطريقة الخامسة: استخدام الحل البديل RTF

أ. احذف ملف عادي (قالب عمومي).

هذا مشكلة ماكرو يتم حفظ القالب Normal.

الخطوات التالية إلى إزالة القالب Normal. انتبه، ستتم إزالة أية مجموعة التنسيق الخاصة في القالب Normal، وسيتم إعادة تعيين القالب الإعدادات الافتراضية.
  1. قم بإنهاء كافة برامج Microsoft.
  2. من القائمة البحث عن، انقر فوق حدد الانتقال الرئيسية .
  3. فتح مجلد مكتبة .
  4. فتح مجلد دعم التطبيقات .
  5. افتح مجلد Microsoft .
  6. افتح مجلد Office .
  7. فتح مجلد قوالب المستخدم .
  8. حدد موقع الملف الذي يسمى عادي. انقر فوق الملف ، ثم انقر فوق نقل إلى سلة المهملات.

ب. قم بتعطيل وحدات الماكرو.

فتح ملفات الفيروسات ثم قم بتعطيل وحدات الماكرو لكل ملف عند تلقي تحذير الماكرو. إذا لم تحصل على تحذير، تحتاج إلى تشغيل تحذيرات الماكرو. للقيام بذلك، اتبع الخطوات التالية:
  1. في القائمة Word ، انقر فوق تفضيلات.
  2. في جزء التنقل، انقر فوق الأمان، وثم حدد خانة الاختيار التحذير قبل فتح ملف يحتوي على وحدات ماكرو .

ج. قم بإعادة حفظ الملفات الموجودة.

  1. انقر فوق حفظ باسم ضمن القائمة ملف .
  2. في القائمة تنسيق ، انقر فوق تنسيق Rich Text (RTF).
  3. انقر فوق حفظ.

بعد القيام بحفظ الملف كملف RTF، حفظ المستند بتنسيق Word (.doc) مرة أخرى بالكتابة فوق الملف الذي يحتوي على فيروس ماكرو أو حفظ المستند كملف جديد وقم بحذف الملف القديم الذي يحتوي على الفيروس. بعد حفظ الملف بتنسيق.doc جديدة، يمكنك حذف ملف RTF. ضع في اعتبارك أن بعض عناصر التنسيق قد لا يكون الاحتفاظ في الانتقال من تنسيق Word (.doc) إلى RTF.


خصائص

رقم الموضوع: 291824 - آخر مراجعة: 22‏/01‏/2017 - المراجعة: 1

Microsoft Word 2011 for Mac, Microsoft Word 2004 for Mac

تعليقات