كيفية استخدام دمج المراسلات لإنشاء قائمة تم فرزها حسب الفئة في Word

للحصول على إصدار Microsoft Word 2000 من هذه المقالة، راجع
211303 .
للحصول على إصدار Microsoft Word 98 من هذه المقالة، راجع
181731 .
للحصول على إصدار Microsoft Word 97 من هذه المقالة، راجع
181730 .
للحصول على إصدار Microsoft Word 95 من هذه المقالة، راجع
181729 .

ملخص

توضح هذه المقالة كيفية استخدام ميزة دمج المراسلات في Word لإنشاء قائمة بالبيانات التي تم فرزها ومفصوله بفئة. تحتوي هذه المقالة على إرشادات وعينه التي يمكنك استخدامها لإنشاء قائمة من هذا القبيل.

قم بإعداد ملف البيانات

فرز ملف البيانات، حيث أن كافة السجلات ذات نفس قيمة المفتاح حقل الفئة (الحقل التي تسندها الفرز) تظهر معا، كما هو موضح في نموذج ملف البيانات. يتم فرز قائمة النماذج التالية حسب الحقل CITY (المدينة يعد حقل مفتاح في هذا المثال).

إعداد المستند الأساسي

ملاحظة: "علامة فقرة" بين قوسين معقوفين العبارة تعيين علامة فقرة في المثال التالي. لكتابة علامة فقرة، اضغط ENTER.

لكي يعمل هذا الإجراء، يجب تحديد نوع المستند "الدليل" عند إعداد المستند الأساسي. لإعداد المستند الأساسي كدليل، اتبع الخطوات التالية:
  1. في مستند فارغ جديد، ابدأ عملية الدمج. للقيام بذلك، استخدم أحد الإجراءات التالية، بما يتناسب مع إصدار Word الذي تستخدمه:

    Microsoft Word 2002

    من القائمة أدوات ، انقر فوق رسائل ومراسلاتومن ثم انقر فوق معالج دمج المراسلات.



    Microsoft Office Word 2003

    من القائمة أدوات ، انقر فوق رسائل ومراسلاتومن ثم انقر فوق دمج المراسلات.



    Microsoft Office Word 2007 و Word Microsoft Office 2010

    ضمن علامة التبويب مراسلات ، انقر فوق بدء دمج المراسلات، ومن ثم انقر فوق معالج دمج المراسلات خطوة بخطوة.

  2. في جزء المهام دمج المراسلات ضمن تحديد نوع المستند، انقر فوق لتحديد الدليل.
  3. انقر فوق التالي: مستند البداية.
  4. ضمن تحديد مستند البداية، انقر لتحديد استخدام المستند الحالي.
  5. انقر فوق التالية: تحديد المستلمين.
  6. ضمن استخدام قائمة موجودة، انقر فوق استعراض.
  7. في مربع الحوار تحديد مصدر البيانات ، حدد نموذج الملف الذي تم إنشاؤه في
    تعيين إعداد ملف البيانات المقطع.
  8. إذا ظهر مربع الحوار تأكيد مصدر البيانات ، حدد نوع بيانات المناسب لنوع الملف الذي قمت بإنشائه في المقطع إعداد ملف البيانات . على سبيل المثال، إذا قمت بإنشاء الملف في Microsoft Excel، حدد ملفات Excel عبر ODBC (*.xls)أو أوراق عمل Excel MS عبر DDE (*.xls) .
  9. في مربع الحوار مستلمو دمج المراسلات ، انقر فوق "موافق".
  10. باستخدام المثال التالي كدليل، إدراج حقول لمقارنة حقل المفتاح في كل صف بحقل مفتاح في الصف السابق، ولإدراج سلسلة نصية واحدة إذا كانوا يختلفون وسلسلة أخرى من النص إذا كانت هي نفسها.
مثال

يستخدم هذا المثال عينة من البيانات
قم بإعداد ملف البيانات المقطع، ويستخدم { MERGEFIELD CITY} كحقل المفتاح.

ملاحظة: لإدراج أقواس الحقل، اضغط CTRL + F9. الحقول المحددة في إنتاج هذا المثال قائمة مفروزة كما يلي:
أتلانتا

جالوس 3000 دولار
ديلاني 50000 دولار
هينينجسين 10.000 ريال سعودي

هيوستن

جونسون 8000 دولار
كريم 9000 دولار
باك ر 0

إجبار كل فئة جديدة على صفحة جديدة

كما في المثال السابق، هو حقل المفتاح في هذا المثال { MERGEFIELD City }. عند تغيير قيمة مدينة إلى مدينة أخرى في ملف البيانات، تتم إضافة صفحة جديدة إلى النتائج المدمجة، ويتم متابعة الدمج في أعلى الصفحة التالية. لإدراج أقواس الحقل، اضغط CTRL + F9.
ملاحظة: لإدراج فاصل صفحات، أما الضغط على CTRL + ENTER أو انقر فوق " فاصل " في القائمة " إدراج " حدد فاصل الصفحاتوثم انقر فوق موافق.

الحقول المحددة في إنتاج هذا المثال قائمة على صفحات منفصلة كما يلي:
أتلانتا

جالوس 3000 دولار
ديلاني 50000 دولار
هينينجسين 10.000 ريال سعودي

----------------------------Page Break-----------------------------
هيوستن

جونسون 8000 دولار
كريم 9000 دولار
باك ر 0

تنسيق حقل المفتاح

هو حقل المفتاح في هذا المثال {MERGEFIELD CITY}. لتنسيق نتائج {MERGEFIELD CITY} كأحرف استهلالية كبيرة، يمكنك إدراج مفتاح تبديل التنسيق من
\ * العليا. لإدراج أقواس الحقل، اضغط CTRL + F9.
الحقول المحددة في إنتاج هذا المثال قائمة بالمدينة التي تظهر في أحرف كبيرة، كما يلي:
أتلانتا

جالوس 3000 دولار
ديلاني 50000 دولار
هينينجسين 10.000 ريال سعودي

هيوستن

جونسون 8000 دولار
كريم 9000 دولار
باك ر 0
ملاحظة: يمكنك تطبيق تنسيقات مختلفة لحقل المفتاح { MERGEFIELD City } عن طريق تحديد الحقل بأكمله (بما في ذلك الأقواس الحقل {})، والتنسيق الميداني للتفضيلات الخاصة بك. لتنسيق الحقل، انقر فوق " خط " في قائمة " تنسيق ".

تضمين نص إضافي

إذا أردت أن تظهر في مستند دمج نص إضافي، يجب عليك تضمين هذا النص داخل المجموعات من علامات الاقتباس في حقول IF. وبهذه الطريقة، يظهر النص فقط إذا كانت المعلومات الموجودة في مصدر البيانات مع الشروط التي تقوم بتعريفها في حقول IF (على سبيل المثال، عندما يختلف عن اسم المدينة في الصف الحالي من مصدر البيانات اسم المدينة في الصف السابق).

إذا قمت بوضع النص خارج حقول IF في المستند الأساسي، يظهر هذا النص في مستند دمج مرة واحدة لكل صف جديد في مصدر البيانات، وليس مرة واحدة لكل حقل مفتاح جديد. في المثال الذي قمت بإنشائه في المقطع إعداد ملف البيانات ، يظهر مرة واحدة لكل موظف، بدلاً من مرة واحدة لكل مدينة.

يقدم هذا المثال كل مدينة في قائمة بجملة تمهيدية قصيرة: إنتاج الحقول الواردة في هذا المثال قائمة بنص مقدمة لكل مدينة كما يلي:
هذه هي إجمالي المبيعات لاتلانتا:

جالوس 3000 دولار
ديلاني 50000 دولار
هينينجسين 10.000 ريال سعودي

هذه هي إجمالي المبيعات ل:

جونسون 8000 دولار
كريم 9000 دولار
باك ر 0

كيفية عمل هذه العملية

إدراج حقل IF الأولى في هذه الأمثلة اسم المدينة وعﻻمة فقرة للسجل الأول في دمج المراسلات. لكافة السجلات اللاحقة إدراج هذا الحقل IF أي شيء (""). يتعرف عليها السجل الأول الذي تم دمج المراسلات عن طريق مقارنة الحقل MERGESEQ (التي تقوم بإرجاع الرقم التسلسلي للسجل الحالي) إلى الرقم "1".

الثاني إذا كان الحقل بإدراج حرف إرجاع (وفاصل صفحة إذا تم فرض كل مدينة إلى صفحة جديدة)، اسم المدينة، أكثر ذهابا وإيابا مبلغ المبيعات (بهذا الترتيب)، واسم الموظف أو أحرف فقط إذا كان الحقل IF يحدد أن السجل الحالي يتضمن اسم مدينة التي تختلف عن السجل السابق. إذا كان Word يحدد أن السجل الحالي يتضمن اسم مدينة التي هي نفس السجل السابق، يدرج Word اسم الموظف التالي ومبلغ المبيعات.


يتعرف هذا الحقل إذا كان اسم المدينة الجديدة عن طريق مقارنة النص الإشارات المرجعية المحددة في الحقلين مجموعة. نص الإشارة المرجعية "Place1" دائماً يساوي حقل المدينة السجل الحالي، ويساوي نص الإشارة المرجعية "Place2" حقل المدينة السجل السابق.

المراجع

لمزيد من المعلومات حول دمج المراسلات، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

294688 كيفية تصميم وإعداد قائمة عناوين دمج المراسلات في Word 2002 وفي الإصدارات الأحدث من Word

290408 الأسئلة المتداولة حول دمج المراسلات في Word 2002

كيفية استخدام دمج المراسلات لإنشاء دليل في Word 2002 وفي الإصدارات الأحدث من Word 294693

كيفية استخدام دمج المراسلات لإنشاء نماذج رسائل في Word 2002 وفي الإصدارات الأحدث من Word 294683

خصائص

رقم الموضوع: 294686 - آخر مراجعة: 18‏/01‏/2017 - المراجعة: 1

تعليقات