فشل "معالج تكبير الحجم" بتكبير حجم البيانات في جداول كبيرة

متوسطة: يتطلب ماكرو الأساسية ترميز والمهارات إمكانية التشغيل المتداخل.

تنطبق هذه المقالة فقط على قاعدة بيانات Microsoft Access (.mdb).


هام: تتضمن هذه المقالة معلومات حول كيفية تعديل التسجيل. قبل تعديل السجل، تأكد من إجراء النسخ الاحتياطي والتأكد من فهمك لطريقة استعادته في حالة حدوث مشكلة. لمزيد من المعلومات حول كيفية عمل نسخة احتياطية واستعادة تحرير التسجيل، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
وصف 256986 تسجيل Microsoft Windows

الأعراض

عند محاولة تكبير حجم قاعدة بيانات Microsoft Access (.mdb) إلى Microsoft SQL Server، لا يقوم معالج تكبير الحجم تصدير البيانات لجداول كبيرة.

السبب

مهلة الاستعلام التمريري ODBC التي يستخدمها Microsoft Access لتصدير البيانات.

الحل

توضح هذه المقالة حلاً للمشكلة المقطع التالي ويتطلب تغيير التسجيل. إذا لم ترغب بإجراء التغييرات على التسجيل، هناك أيضا حلاً لهذه المشكلة، التي وصفها بعد القرار.

لحل هذه المشكلة، تعيين قيمة QueryTimeout في التسجيل إلى 0. يحتفظ هذا الاستعلام من انتهاء المهلة. لتعيين قيمة QueryTimeout إلى 0، اتبع الخطوات التالية:
  1. قم بإنهاء أية مثيلات Microsoft Access قيد التشغيل.
  2. وانقر فوق ابدأ، ثم انقر فوق تشغيل.
  3. في مربع الحوار تشغيل ، اكتب Regedit.exe، ومن ثم انقر فوق موافق. يؤدي هذا إلى تشغيل "محرر التسجيل".
  4. انقر فوق قيمة QueryTimeout تحت المفتاح الفرعي التالي في السجل:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\ODBC
  5. من القائمة تحرير ، انقر فوق تعديل.
  6. في مربع الحوار تحرير قيمة DWORD ، انقر فوق عشري ضمن قاعدة.
  7. أدخل 0 في المربع بيانات القيمة ومن ثم انقر فوق موافق.
  8. قم بإنهاء "محرر التسجيل".
  9. ابدأ تشغيل Microsoft Access وفتح قاعدة البيانات ثم حاول تكبير الحجم.

الحل البديل

للتغلب على هذه المشكلة، اتبع الخطوات التالية:
  1. تكبير حجم بنية الجدول فقط.
  2. استخدم خدمات تحويل البيانات (DTS) لاستيراد البيانات من جدول Access، ثم إلحاق إلى تكبير حجم بنية.
هذا سيسمح لك لتكبير بنية قاعدة البيانات وذلك إنشاء العلاقات المطلوبة ومشغلات/حديد الاختزال المباشر دون الحاجة لتغيير إعدادات التسجيل.

للحصول على معلومات إضافية حول كيفية استخدام DTS، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
285829 كيفية استخدام البيانات تحويل خدمات (DTS) لتصدير البيانات من قاعدة بيانات Microsoft Access إلى قاعدة بيانات ملقم SQL

الحالة

أقرت Microsoft أن هذه مشكلة في منتجات Microsoft المسردة في بداية هذه المقالة.

مزيد من المعلومات

عند ذلك يقوم حجم قاعدة بيانات Jet إلى Microsoft SQL Server، يستخدم "معالج تكبير الحجم" SQL ODBC الاستعلامات التمريرية تنفيذها عن طريق مشغل قاعدة بيانات Jet. تعين قيمة QueryTimeout في التسجيل ODBC المدة (بالثواني) قد تنفيذ استعلامات قبل انتهاء المهلة. بشكل افتراضي، يتم تعيين قيمة QueryTimeout إلى 60 ثانية. لذلك مهلة أي استعلام تمريري ODBC الذي يأخذ أكثر من 60 ثانية، ويتخطى "معالج تكبير الحجم" العملية.

خطوات إعادة إنشاء المشكلة في Access 2003

ملاحظة: الخطوات التالية محاكاة عملية التكبير سلوك نموذج قاعدة البيانات Northwind بتعيين QueryTimeout لثانية واحدة. يؤدي أي ODBC الاستعلامات التمريرية للمهلة بعد ثانية واحدة.
  1. قم بإنهاء أية مثيلات Microsoft Access قيد التشغيل.
  2. وانقر فوق ابدأ، ثم انقر فوق تشغيل.
  3. في مربع الحوار تشغيل ، اكتب Regedit.exe، ومن ثم انقر فوق موافق. يؤدي هذا إلى تشغيل "محرر التسجيل".
  4. انقر فوق قيمة QueryTimeout تحت المفتاح الفرعي التالي في السجل:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\ODBC
  5. من القائمة تحرير ، انقر فوق تعديل.
  6. في مربع الحوار تحرير قيمة DWORD ، انقر فوق عشري ضمن قاعدة.
  7. قم بإدخال 1 في المربع بيانات القيمة ومن ثم انقر فوق موافق.
  8. قم بإنهاء "محرر التسجيل".
  9. ابدأ تشغيل Microsoft Access.
  10. افتح نموذج قاعدة البيانات Northwind.mdb.
  11. من القائمة أدوات ، أشر إلى أدوات مساعدة لقاعدة البيانات، ومن ثم انقر فوق "معالج تكبير الحجم".
  12. انقر فوق إنشاء قاعدة بيانات جديدةومن ثم انقر فوق التالي.
  13. تحديد SQL Server الذي تريد تكبير الحجم إلى ومن ثم أدخل معلومات المصادقة الخاصة بك لتسجيل الدخول إلى ملقم SQL.
  14. أدخل اسماً لقاعدة بيانات SQL Server جديدة ومن ثم انقر فوق التالي.
  15. حدد كافة الجداول لتكبير الحجم ومن ثم انقر فوق التالي.
  16. الاحتفاظ بكافة الإعدادات الافتراضية في الصفحة التالية، ومن ثم انقر فوق التالي.
  17. حدد الخيار لإنشاء تطبيق عميل/ملقم Microsoft Access جديد.
  18. أدخل اسم الملف والمسار في المربع اسم ADP ، ومن ثم انقر فوق إنهاء.
  19. تقرير تكبير الحجم قد إظهار كافة الجداول تم تكبير حجمها بنجاح أو قد تشاهد الرسالة التالية أسفل بعض الجداول:
    تم تخطي الجدول.
  20. إغلاق "تقرير تكبير الحجم". وهذا يفتح تلقائياً في ملف مشروع Access الجديد (.adp) متصل بقاعدة بيانات SQL Server جديدة.
  21. افتح الجدول Order details.
لاحظ أن بنية الجدول تكبير الحجم، إلا أن الجدول لا يحتوي على بيانات.
خصائص

رقم الموضوع: 295231 - آخر مراجعة: 18‏/01‏/2017 - المراجعة: 1

تعليقات