كيفية كتابة الملفات الثنائية إلى المستعرض باستخدام ASP.NET و Visual C#.NET

للحصول على إصدار Microsoft Visual Basic.NET من هذه المقالة، راجع
307603 .

في هذه المهمة

ملخص

هذه المقالة خطوة بخطوة إنشاء صفحة مثال يوضح كيفية استرداد البيانات الثنائية من ملف ثم كيفية كتابة البيانات إلى المستعرض باستخدام ASP.NET و Visual C#. على الرغم من أن هذا العرض التوضيحي يستخدم ملف Adobe Acrobat (.pdf) (التي عادة ما تستخدم مطوري تطبيقات ويب)، يمكنك تطبيق هذا الإجراء لتنسيقات الملفات الثنائية الأخرى.

متطلبات

  • Microsoft.NET Framework
  • نظام التشغيل Microsoft Windows 2000 أو Windows XP
  • خادم معلومات إنترنت ل Microsoft (IIS)

إنشاء تطبيق ويب ASP.NET باستخدام Visual C #

يوضح هذا القسم كيفية إنشاء تطبيق ويب ASP.NET جديد باسم بيناريديمو:
  1. فتح Microsoft Visual Studio.NET
  2. من القائمة ملف ، أشر إلى جديد، ومن ثم انقر فوق المشروع.
  3. ضمن أنواع المشروع، انقر فوق مشاريع Visual C#. ضمن قوالب، انقر فوق تطبيق ويب ASP.NET.
  4. في مربع النص الاسم ، اكتب بيناريديمو. في مربع النص الموقع ، اكتب اسم الملقم. إذا كنت تستخدم الملقم المحلي، ترك الموقع ك http://localhost.

إضافة الملف إلى المشروع

لإعداد المشروع حيث يمكنك إضافة وتشغيل التعليمات البرمجية في المقطع إنشاء صفحة ASPX لمتابعة، يجب أولاً إضافة ملف Adobe Acrobat (.pdf) إلى المشروع الحالي الخاص بك. للقيام بذلك في Visual Studio.NET، اتبع الخطوات التالية:
  1. في "مستكشف الحلول"، انقر نقراً مزدوجاً فوق عقده المشروع وانقر فوق إضافةوثم انقر فوق إضافة عنصر موجود.
  2. استعرض للوصول إلى موقع ملف.pdf على النظام الخاص بك.
  3. انقر فوق لتمييز الملف ومن ثم انقر فوق فتح.
  4. في Visual Studio.NET "مستكشف الحلول"، انقر نقراً مزدوجاً فوق الملف، وانقر فوق إعادة تسمية. إعادة تسمية ملف.pdf حيث يطابق اسم الملف Acrobat.pdf الذي يتم استخدامه في التعليمات البرمجية التالية.
وبالإضافة إلى ذلك، تأكد من أن Adobe Acrobat Reader مثبتاً على جهاز الكمبيوتر العميل الذي يتم عرض صفحة.aspx حيث المستعرض بشكل صحيح قراءة وتقديم البيانات الثنائية. يمكنك تحميل برنامج Adobe Acrobat Reader من موقع Adobe على الويب التالية:

إنشاء صفحة ASPX

  1. إضافة صفحة.aspx جديدة باسم BinaryData.aspx للمشروع الحالي كما يلي:
    1. في "مستكشف الحلول"، زر الماوس الأيمن فوق عقده المشروع، انقر فوق إضافة، وثم انقر فوق إضافة نموذج ويب.
    2. اسم صفحة BinaryData.aspx، ومن ثم انقر فوق فتح.

      ملاحظة: تأكد من أنه تم إضافة الصفحة إلى المشروع في نفس المستوى مثل ملف.pdf الذي قمت بإضافته في المقطع السابق. وهذا مهم جداً لأن التعليمات البرمجية تستخدم المسار النسبي للرجوع إلى ملف.pdf في البداية.
  2. في المحرر، انقر نقراً مزدوجاً فوق BinaryData.aspx، وثم انقر فوق عرض التعليمات البرمجية.
  3. تمييز التعليمات البرمجية التالية وانقر نقراً مزدوجاً فوق الرمز ثم انقر فوق نسخ. في حدث Page_Load في التعليمات البرمجية-خلف الصفحة، انقر فوق لصق في القائمة تحرير للصق التعليمات البرمجية:
    private void Page_Load(object sender, System.EventArgs e){
    //Set the appropriate ContentType.
    Response.ContentType = "Application/pdf";
    //Get the physical path to the file.
    string FilePath = MapPath("acrobat.pdf");
    //Write the file directly to the HTTP content output stream.
    Response.WriteFile(FilePath);
    Response.End();
    }

  4. من القائمة ملف ، انقر فوق حفظ الكل.
  5. في بنية القائمة، انقر فوق إنشاء.
  6. لتشغيل التعليمات البرمجية، BinaryData.aspx في "مستكشف الحلول" انقر بالزر الأيمن، ثم انقر فوق عرض في مستعرض. إذا تم مطالبتك، انقر فوق فتح لفتح وعرض الملف في المستعرض.
ملاحظة: إذا كنت تريد استخدام التعليمات البرمجية السابقة لدعم أنواع الملفات الثنائية الأخرى، يجب تعديل القيمة في سلسلة نوع المحتوى حيث تحدد تنسيق الملف المناسب. عادة يتم تنسيق بناء جملة هذه السلسلة ك "نوع/النوع الفرعي،" حيث "النوع" فئة المحتوى العام وهو "نوع فرعي" نوع محتوى معين. للحصول على قائمة كاملة من أنواع المحتوى المعتمدة، راجع الوثائق الخاصة بمستعرض ويب أو مواصفات HTTP الحالي. توضح القائمة التالية بعض القيم المشتركة في نوع المحتوى :
  • "text/HTML"
  • "image/GIF"
  • "image/JPEG"
  • "text/plain"
  • "تطبيق/مايكروسوفت وورد" (لملفات Microsoft Word)
  • "تطبيق/س-إكسيل" (لملفات Microsoft Excel)

المراجع

لمزيد من المعلومات، راجع المواضيع التالية في وثائق.NET Framework برامج تطوير مجموعة (SDK):للحصول على معلومات إضافية حول كيفية تنفيذ هذه المهمة باستخدام Microsoft صفحات الملقم النشطة (ASP)، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
276488 كيفية استخدام كائن ADODB. كائن الدفق لإرسال الملفات الثنائية إلى المستعرض إلى آسيا والمحيط الهادئ
توفر Microsoft معلومات الاتصال خارجية لمساعدتك في الحصول على الدعم التقني. قد تتغير معلومات جهة الاتصال هذه دون إشعار. لا تضمن Microsoft دقة معلومات جهة الاتصال لهذه الجهات الأخرى.

منتجات الجهات الأخرى التي تمت مناقشتها في هذه المقالة تابعة لشركات مستقلة عن Microsoft. لا تقدم Microsoft أي ضمان، سواء ضمنياً أو صريحا، بخصوص أداء هذه المنتجات أو كفائتها.

خصائص

رقم الموضوع: 306654 - آخر مراجعة: 18‏/01‏/2017 - المراجعة: 2

تعليقات