كيفية تشغيل برنامج نصي لتسجيل دخول مرة واحدة عند جديد تسجيل دخول مستخدم في نظام التشغيل Windows Server 2003

للحصول على إصدار نظام التشغيل Microsoft Windows 2000 من هذه المقالة، راجع
284193 .

هام: تتضمن هذه المقالة معلومات حول كيفية تعديل التسجيل. قبل تعديل السجل، تأكد من إجراء النسخ الاحتياطي والتأكد من فهمك لطريقة استعادته في حالة حدوث مشكلة. لمزيد من المعلومات حول كيفية عمل نسخة احتياطية واستعادة تحرير التسجيل، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
وصف 256986 تسجيل Microsoft Windows

في هذه المهمة

ملخص

توضح هذه المقالة كيفية تكوين البرنامج النصي لتسجيل الدخول أو برنامج تشغيل مرة واحدة عند مستخدم بتسجيل الدخول إلى كمبيوتر لأول مرة. هذه الخطوات تنطبق فقط على المستخدمين الجدد الذين ابدأ بتسجيل الدخول إلى الكمبيوتر. إذا كان مستخدم بالفعل ملف تعريف مستخدم محلي أو تشكيل جانبي متجول، لا يتم تشغيل البرنامج النصي أو البرنامج.

تكوين برنامج نصي لتشغيله مرة واحدة عند تسجيل دخول مستخدم جديد

تحذير: إذا كنت تستخدم محرر التسجيل بشكل غير صحيح، قد يؤدي حدوث مشكلات خطيرة يلزم معها إعادة تثبيت نظام التشغيل الخاص بك. لا تضمن Microsoft حل المشكلات التي تنتج عن استخدام "محرر التسجيل" بطريقة غير صحيحة. استخدم "محرر التسجيل" على مسؤوليتك الشخصية.

عند تثبيت منتج يستند إلى Windows Server 2003، يتم إنشاء التشكيل الجانبي "الافتراضي للمستخدم". أول مرة يقوم مستخدم بتسجيل الدخول، يتم نسخ التشكيل الجانبي "المستخدم الافتراضي" إلى التشكيل الجانبي للمستخدم.

لتكوين برنامج نصي أو برنامج لتشغيلها عند تسجيل دخول مستخدم جديد، اتبع الخطوات التالية:
  1. وانقر فوق ابدأ، ثم انقر فوق تشغيل.
  2. في المربع فتح ، اكتب regedit.exe، ومن ثم انقر فوق موافق.
  3. حدد موقع المفتاح الفرعي التالي في السجل:

    HKEY_USERS
  4. من القائمة ملف ، انقر فوق تحميل الخلية.
  5. في مربع الحوار تحميل الخلية ، حدد موقع
    ملف \Default User\Ntuser.dat Profilepath، أين
    Profilepath هو موقع نظام ملف التشكيل الجانبي "الافتراضي للمستخدم". انقر فوق فتح.
  6. في مربع الحوار تحميل خلية اكتب اسماً للخلية، ومن ثم انقر فوق موافق.

    ملاحظة: Ntuser.dat الملف مخفي. إذا تعذر تحديد موقع أو تحميل ملف Ntuser.dat، يجب تغيير إعدادات العرض الخاصة بك في "مستكشف Windows". للقيام بذلك، اتبع الخطوات التالية:
    1. انقر فوق ابدأ، وثم انقر فوق مستكشف Windows.
    2. انقر فوق أدوات، وفوق خيارات المجلد.
    3. انقر فوق علامة التبويب عرض .
    4. انقر لإلغاء تحديد خانة الاختيار إخفاء ملحقات الملفات لأنواع الملفات المعروفة .
    5. حدد إظهار الملفات والمجلدات المخفية، ومن ثم انقر فوق موافق.
  7. حدد موقع المفتاح الفرعي التالي في السجل:
    HKEY_USERS\Test\Software\Microsoft\Windows\CurrentVersion\Runonce

    ملاحظة: عند اختبار هو الاسم الذي أعطيته لخلية Ntuser.dat في الخطوة 6.
  8. من القائمة تحرير ، أشر إلى جديد، ومن ثم انقر فوق قيمة سلسلة.
  9. في الجزء الأيسر، انقر نقراً مزدوجاً فوق القيمة الجديدة.
  10. في مربع الحوار تحرير سلسلة ، اكتب المسار الكامل واسم الملف للبرنامج النصي لتسجيل الدخول أو البرنامج، ومن ثم انقر فوق موافق.
  11. في الجزء الأيمن، انقر فوق خلية اختبار .
  12. من القائمة ملف ، انقر فوق إلغاء تحميل الخلية.
  13. انقر فوق نعم عند المطالبة بتأكيد أنك تريد إلغاء تحميل الخلية.
  14. قم بإنهاء "محرر التسجيل".
يتم تشغيل هذا البرنامج النصي لتسجيل الدخول أو البرنامج لمستخدم ليس لديه ملف تعريف مستخدم. لعرض ملفات تعريف المستخدمين على الكمبيوتر المحلي، اتبع الخطوات التالية:
  1. انقر فوق ابدأوأشر إلى لوحة التحكمثم انقر فوق النظام.
  2. انقر فوق علامة التبويب خيارات متقدمة .
  3. في ناحية التشكيلات الجانبية للمستخدم ، انقر فوق إعدادات.

    يتم سرد ملفات تعريف المستخدمين في مربع الحوار ملفات تعريف المستخدمين .

خصائص

رقم الموضوع: 325347 - آخر مراجعة: 15‏/01‏/2017 - المراجعة: 1

تعليقات