بعد تحديث إلى Dynamics 365 (كانون الأول/ديسمبر 2016)، يفشل حل الذي تم استيراده باستخدام إصدار سابق (على سبيل المثال في Dynamics CRM) أثناء إلغاء تثبيت/ترقية مع رسالة خطأ تشبه "مطلوب" الدور "بمعرف [RoleID] بالحلول [اسم الحل]."

ينطبق على: Dynamics CRM

العرض


قبل ترقية إلى تحديث ديسمبر 2016 Dynamics 365، يتم تثبيت محلول يحتوي على دور مخصص. بعد الترقية المنظمة، الحل لا يمكن إلغاء تثبيت/ترقية سبب تبعية بين الدور وحل آخر، حل النظام الأكثر شيوعاً. عدم عرض هذه المشكلة أو الناجمة عن المستخدم.

السبب


في Dynamics 365، يتم تمثيل "تدفق عملية الأعمال" (BPFs) بالدرجة الأولى الكيانات التي تلتزم بنموذج أمان Dynamics 365 تماما مثل أي كيان آخر. يتم إنشاء هذه الوحدات خلال كانون الأول/ديسمبر 2016 الترقية إلى Dynamics 365. لضمان أن يتوفر لكافة الأدوار القائمة الوصول المناسب إلى BPFs، يتم تلقائياً تعيين الامتيازات BPF للأدوار الموجودة أثناء الترقية. في بعض الحالات، هذه التعيينات الامتياز يمكن أن ينتج تبعيات غير صحيحة بين الحلول.

الحل


  1. في Dynamics 365، انتقل إلى إعدادات > الأمان > "أدوار الأمان". حدد دور الأمان الذي يظهر في الخطأ ثم فتح علامة التبويب "تدفق العملية التجارية".
  2. تحيط علما بالامتيازات التي تم تعيينها BPFs. لقطة مفيد، حيث أنه تمثيل مرئي.
  3. قم بإلغاء تحديد كافة الامتيازات ثم قم بحفظ التغييرات. هذا وينبغي إزالة التبعيات مشكوك فيه.
    ملاحظة: قد لا تكون قادراً على تحرير الامتيازات إذا كان جزءا من الحل الدور وتم وضع علامة غير قابل للتخصيص. إذا كان الحل غير مدار، فيمكنك تحديث الخاصية دور المدارة والمتابعة 'تخصيص'. في حالة حل مدار الرجاء الاتصال بدعم Microsoft لجعل الدور القابلة للتخصيص.
  4. إعادة تعيين الامتيازات التي تم تعيينها مسبقاً، ثم حفظ وإغلاق مربع الحوار. هذا يؤكد أن يتم الاحتفاظ بإمكانية الوصول المطلوبة لأدوار مختلفة.

قد يكون هناك تبعيات بين الأدوار وحلول متعددة. في هذه الحالة، تنفيذ الخطوات السابقة لكل من الأدوار التي يتم الإبلاغ عنها بالمشاكل.