ظهور رسالة خطأ عند محاولة تثبيت حزمة الخدمة Windows XP service Pack 2 أو حزمة الخدمة Windows Server 2003 service Pack 1: "تم رفض الوصول"

تم إعداد هذه المقالة لمستخدمي أجهزة الكمبيوتر المتقدمين. إذا لم تكن راضيا على اكتشاف المشاكل وإصلاحها، قد تحتاج إلى طلب مساعدة أحد الأشخاص أو الاتصال بالدعم. لمزيد من المعلومات حول كيفية الاتصال بالدعم، قم بزيارة موقع Microsoft التالي على الويب:
http://support.microsoft.com/contactus/

الأعراض

عند محاولة تثبيت حزمة الخدمة Windows Server 2003 service Pack 1 (SP1) أو Windows XP Service Pack 2 (SP2)، قد تواجه إحدى المشكلات التالية:
  • لا يمكنك تثبيت حزمة الخدمات.
  • تتلقى رسالة الخطأ التالية:
    فشل إعداد "حزمة الخدمة". تم رفض الوصول
  • يحتوي الملف Svcpack.log على رسالة الخطأ التالية:
    فشل DoRegistryUpdates

السبب

قد تحدث هذه المشكلات إذا أذونات لمفتاح تسجيل واحد أو أكثر مقيدة بطريقة تمنع إجراء تحديث لمفاتيح التسجيل هذه. قد يتسبب فشل تحديث أحد مفاتيح تسجيل في فشل برنامج الإعداد. للتحقق من فشل تحديث التسجيل، راجع قسم "مزيد من المعلومات".

الحل البديل

المستخدمين المتقدمين

هذه الطرق مخصصة لمستخدمي أجهزة الكمبيوتر المتقدمين. إذا لم تكن راضيا عن حلول متقدمة، قد تحتاج إلى طلب مساعدة أحد الأشخاص أو الاتصال بالدعم. لمزيد من المعلومات حول كيفية الاتصال بالدعم، قم بزيارة موقع Microsoft التالي على الويب:
http://support.microsoft.com/contactus/

هام: يحتوي هذا المقطع أو الأسلوب أو المهمة على الخطوات التي توضح كيفية تعديل التسجيل. ومع ذلك، قد تحدث مشكلات خطيرة إذا قمت بتعديل التسجيل بشكل غير صحيح. لذلك، تأكد من اتباع الخطوات التالية بعناية. للحماية الإضافية، قم بعمل نسخة احتياطية للسجل قبل تعديله. بعد ذلك، يمكنك استعادة السجل في حالة حدوث مشكلة. لمزيد من المعلومات حول كيفية عمل نسخة احتياطية من السجل واستعادته، انقر فوق رقم المقالة التالية لعرضها في "قاعدة معارف Microsoft":
322756 كيفية عمل نسخة احتياطية من السجل واستعادته في نظام التشغيل Windows


الطريقة الأولى: تحديد موقع مفتاح التسجيل وإعادة تعيين أذونات التسجيل

بعد اتباع هذه الخطوات، قم بإعادة تثبيت حزمة الخدمة. قد تضطر لاتباع هذه الخطوات عدة مرات لحل هذه المشكلة.

ملاحظة يجب أن تكون عضوا في مجموعة الأمان Administrators لإكمال هذه الخطوات.

الخطوة 1: تحديد موقع مفتاح التسجيل المحدد

لتحديد موقع مفتاح التسجيل الصحيح لتغيير الأذونات وتمكين Windows XP SP2 أو Windows Server 2003 SP1 لتثبيت بنجاح، اتبع الخطوات التالية:
  1. تضمين معلومات التسجيل في الملف Setupapi.log بتمكين خاصية التسجيل المطول. لمزيد من المعلومات حول كيفية تمكين خاصية التسجيل المطول، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

    906485 كيفية تمكين خاصية التسجيل المطول على جهاز كمبيوتر يستند إلى نظام التشغيل Windows XP

    ملاحظة: بشكل افتراضي، لا يتم تسجيل مفاتيح التسجيل في الملف Setupapi.log.

    بعد تمكين خاصية التسجيل المطول، قم بتثبيت Windows XP SP2 أو Windows Server 2003 SP1 مرة أخرى للحصول على مفتاح التسجيل.
  2. افتح الملف Setupapi.log. بشكل افتراضي، يوجد هذا الملف في المجلد C:\Windows. لفتح الملف Setupapi.log، انقر فوق ابدأ، ثم انقر فوق تشغيل، اكتب %windir%\setupapi.log، وثم انقر فوق موافق.
  3. اضغط CTRL + END للتمرير إلى نهاية الملف Setupapi.log.
  4. في القائمة تحرير ، انقر فوق بحث.
  5. في المربع البحث عن ، اكتب خطأ 5: تم رفض الوصول ضمن اتجاه، انقر فوق أعلى، ومن ثم انقر فوق بحث عن التالي.

    الإدخال الموجود في الملف Setupapi.log تشبه المثال التالي:
    مفتاح التسجيل سيؤدي حذف # 007 HKCR\vnd.ms.radio

    #E033 خطأ 5: تم رفض الوصول.
    ملاحظة: يشير السطر قبل إدخال "تم رفض الوصول" إلى مفتاح التسجيل المحدد. في هذه الحالة، يمثل HKCR خلية التسجيل الذي يسمى "HKEY_CLASSES_ROOT." "vnd.ms.radio" إلى مفتاح فرعي موجود ضمن خلية التسجيل هذه.

الخطوة 2: إعادة تعيين أذونات التسجيل

بمجرد العثور على المفتاح الفرعي للتسجيل الذي يحتوي على الأذونات غير الصحيحة، تحديث أذونات المفتاح الفرعي هذا.

لتحديث أذونات المفتاح الفرعي للتسجيل، اتبع الخطوات التالية:
  1. انقر فوق ابدأ، ثم انقر فوق تشغيل، اكتب regedit، وثم انقر فوق "موافق" لبدء تشغيل "محرر التسجيل".
  2. تحديد موقع والأيمن المفتاح الفرعي للتسجيل الذي قمت بتدوينه في الخطوة 2 د، ثم انقر فوق أذونات.
  3. تحت أسماء المجموعات أو المستخدمين، انقر فوق المسؤولين.
  4. تحت أذونات ل Administrators، تأكد من تحديد خانة الاختيار السماح للإدخالات التالية:
    • التحكم الكامل
    • القراءة
  5. انقر فوق تطبيق، ومن ثم انقر فوق موافق.
  6. من القائمة ملف ، انقر فوق إنهاء لإنهاء "محرر التسجيل".
يجب حل مشكلة أذونات للمفتاح الفرعي للتسجيل الآن، وحزمة الخدمة Windows XP SP2 أو Windows Server 2003 SP1 يجب تثبيتها بنجاح. إذا واجهتك مشكلات أخرى عند محاولة تثبيت حزمة الخدمة Windows XP SP2 أو Windows Server 2003 SP1، كرر هذه الخطوات عند الضرورة.

الطريقة الثانية: إعادة تعيين نظام التشغيل الخاص بك مرة أخرى إلى الإعدادات الافتراضية

لإعادة تعيين نظام التشغيل لديك إلى إعدادات الأمان الافتراضية التثبيت الأصلي، اتبع الخطوات التالية:
  1. انقر فوق ابدأ، ثم انقر فوق تشغيل، واكتب cmd ثم اضغط ENTER.
  2. نوع secedit/تكوين/cfg %windir%\repair\secsetup.inf/db secsetup.sdb/مطول، ثم اضغط ENTER.
تظهر رسالة "إكمال المهمة"، ورسالة تحذير شيء لا يمكن تحقيقه. يمكن تجاهل هذه الرسالة بأمان. لمزيد من المعلومات حول هذه الرسالة عرض الملف %windir%\Security\Logs\Scesrv.log.


لمزيد من المعلومات حول كيفية إعادة تعيين إعدادات الأمان إلى الإعدادات الافتراضية، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

كيفية إعادة تعيين إعدادات الأمان إلى الإعدادات الافتراضية 313222

مزيد من المعلومات

للتحقق من فشل تحديث التسجيل، اتبع الخطوات التالية:
  1. افتح الملف Svcpack.log. بشكل افتراضي، يوجد هذا الملف في المجلد C:\Windows. لفتح الملف Svcpack.log، انقر فوق ابدأ، ثم انقر فوق تشغيل، اكتب %windir%\svcpack.log، وثم انقر فوق موافق.
  2. في القائمة تحرير ، انقر فوق بحث.
  3. في المربع البحث عن ، اكتب فشل DoRegistryUpdates، ومن ثم انقر فوق بحث عن التالي.
  4. إذا تم العثور على رسالة خطأ فشل DoRegistryUpdates ، توجد مشكلة تمنع إجراء التحديث للتسجيل. سيتم رسالة خطأ مشابهة لما يلي:
    xxxx.xxx: فشل DoInstallation:DoRegistryUpdates.

    xxxx.xxx: تم رفض الوصول.

    xxxx.xxx: عرض رسالة للمستخدم: تم رفض الوصول.
    ملاحظة: xxxx.xxx ويمثل الطابع الزمني لكل إدخال.

مشكلات وحلول مشابهة

إذا كنت تزال تواجه المشكلة في هذه المقالة، قد يكون لديك مشكلة مشابهة ولكنها مختلفة. لمزيد من المعلومات حول مشكلة مشابهة ودقة، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

828213 خطأ "تم رفض الوصول" عند محاولة تثبيت حزمة الخدمة Windows XP service Pack 1

إذا لم تساعدك هذه المقالات على حل المشكلة أو في حالة ظهور أعراض تختلف عن الأعراض الموضحة في هذه المقالة، ابحث في "قاعدة معارف Microsoft" للحصول على مزيد من المعلومات. للبحث في قاعدة المعارف ل Microsoft، قم بزيارة موقع Microsoft التالي على الويب:ثم اكتب نص رسالة الخطأ التي تظهر. أو، اكتب وصفاً للمشكلة في حقل بحث الدعم (KB).
خصائص

رقم الموضوع: 873148 - آخر مراجعة: 15‏/01‏/2017 - المراجعة: 2

تعليقات