وصف أداة "محلل مراسل المنفذ" (محلل PR)

ملخص

توضح هذه المقالة استخدام أداة "محلل مراسل المنفذ" (محلل العلاقات العامة). توضح هذه المقالة الموضوعات التالية المتعلقة بأداة محلل العلاقات العامة:
  • معلومات أساسية
  • GUI Windows Microsoft مراجعة سجلات
  • تعريف البيانات مريبة أو البيانات التي تهمك
  • تحليل السجلات وتوليد البيانات

مقدمة

توضح هذه المقالة استخدام أداة "محلل مراسل المنفذ" (محلل العلاقات العامة). محلل العلاقات العامة هو أداة يوزع السجلات التي تنشئ الخدمة "مراسل المنفذ". أداة محلل لمشروع يحتوي على العديد من الميزات المتقدمة التي يمكن أن تساعدك في تحليل ملفات سجل خدمة "مراسل المنفذ". يمكنك استخدام محلل بالعلاقات العامة مع الأداة "مراسل المنفذ" في بعض وحدات السيناريو، بما في ذلك سيناريوهات متعلقة بالأمان واستكشاف الأخطاء وإصلاحها. تركز هذه المقالة على كيفية استخدام أداة محلل العلاقات العامة في السيناريوهات المتعلقة بالأمان.

للحصول على الأداة محلل العلاقات العامة، قم بزيارة موقع Microsoft التالي على الويب:

مزيد من المعلومات

معلومات أساسية

عندما يصبح عرضه جهاز كمبيوتر يستند إلى Windows Microsoft، يستخدم مهاجم عادة موارد كمبيوتر يستند إلى Windows إلى إلحاق مزيد من الأضرار أو لمهاجمة أجهزة الكمبيوتر الأخرى. يتضمن هذا النوع من الهجمات عادة أنشطة مثل بدء عملية واحدة أو أكثر، أو باستخدام منافذ TCP و UDP، أو كليهما. ما لم يكن مهاجم إخفاء هذا النشاط من كمبيوتر يستند إلى Windows نفسه، يمكنك التقاط والتعرف على هذا النشاط. ولذلك، بحثاً عن إشارات من هذا النوع من النشاط يساعد تحديد ما إذا كان نظام الضعيفة.

الأداة "مراسل المنفذ" هو برنامج تشغيل كإحدى خدمات على جهاز كمبيوتر يقوم بتشغيل Microsoft Windows Server 2003 أو نظام التشغيل Microsoft Windows XP أو نظام التشغيل Microsoft Windows 2000. تسجل خدمة "مراسل منفذ" نشاط منفذ TCP و UDP. على أجهزة الكمبيوتر المستندة إلى Windows Server 2003 ونظام التشغيل Windows xp، يمكنك تسجيل خدمة "مراسل منفذ" المعلومات التالية:
  • المنافذ المستخدمة
  • العمليات التي تستخدم المنفذ
  • ما إذا كانت عملية خدمة
  • الوحدات النمطية (.dll،.drv، وهكذا) الذي يقوم بتحميل عملية
  • حسابات المستخدمين بدء عملية
البيانات التي يتم التقاطها بواسطة خدمة "مراسل المنفذ" قد تساعدك في تحديد ما إذا كان كمبيوتر عرضه. نفس البيانات مفيداً أيضا لاستكشاف الأخطاء وإصلاحها لفهم استخدام منفذ جهاز كمبيوتر والتدوين سلوك الكمبيوتر.

محلل العلاقات العامة هو أداة يوزع السجلات التي تنشئ الخدمة "مراسل المنفذ". للحصول على معلومات إضافية حول خدمة "مراسل المنفذ"، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

وصف الأداة "مراسل المنفذ" وتوفر 837243

توفر الأداة محلل العلاقات العامة الوظائف الأساسية الثلاث التالية:
  • أداة محلل العلاقات العامة لها Windows واجهة المستخدم الرسومية (GUI) يسهل عليك مراجعة السجلات. باستخدام واجهة المستخدم الرسومية، يمكنك فرز وتصفية البيانات في عدد من الطرق.
  • تساعد هذه الأداة محلل العلاقات العامة التعرف وتصفية البيانات التي تهمك. توفر الأداة الوظائف التالية:
    • تعريف العمليات التي كنت ترغب في تشغيلها على جهاز كمبيوتر
    • يحاول تحديد متى يتم تشغيل عملية التي تستخدم اسم العملية الشرعية من المجلد غير صحيح على جهاز كمبيوتر
    • تعريف الوحدات النمطية، مثل.dll و.drv، التي تم تحميلها على الكمبيوتر
    • يساعد على تحديد الوقت عند عناوين بروتوكول إنترنت (IP) وأسماء المجال المؤهل بالكامل (Fqdn)، أو أسماء أجهزة الكمبيوتر التي تهمك تتصل بالكمبيوتر
    • تعرف المنافذ التي يتم استخدامها على جهاز كمبيوتر
    • يساعد على تحديد عندما تكون نشطة على كمبيوتر حسابات المستخدمين
  • توفر الأداة محلل العلاقات العامة بعض بيانات تحليل السجل أيضا. يمكن أن تساعدك هذه البيانات على فهم استخدام الكمبيوتر. وتتضمن هذه البيانات ما يلي:
    • قائمة مرتبة باستخدام منفذ بروتوكول التحكم بالإرسال (TCP) المحلية
    • قائمة مرتبة باستخدام العملية المحلية
    • قائمة مرتبة باستخدام عنوان IP البعيد
    • قائمة مرتبة باستخدام سياق المستخدم
    • تعداد Svchost.exe خدمة
    • استخدام منفذ بساعة اليوم
    • استخدام Microsoft Internet Explorer من قبل المستخدم

GUI Windows لمراجعة السجلات

تنشئ أداة "مراسل منفذ" ملفات السجلات الثلاثة التالية عند تشغيل الأداة:
  • PR-PORTS-timestamp.log
  • PR-PIDS-timestamp.log
  • PR-INITIAL-timestamp.log
يستخدم اسم كل ملف سجل التاريخ والوقت بتنسيق 24 ساعة الذي يستند إلى وقت إنشاء الملف. يتم تنسيق طابع التاريخ والوقت ييرمونثدايهورمينوتسيكوند. على سبيل المثال، تم إنشاء الملفات الثلاثة التالية في 24 كانون الثاني/يناير 2004، في الساعة 08:49:30:
  • PR-PORTS-04-01-24-8-49-30.log
  • PR-PIDS-04-01-24-8-49-30.log
  • PR-INITIAL-04-01-24-8-49-30.log
عند فتح ملف سجل باستخدام أداة محلل العلاقات العامة، GUI Windows أداة محلل العلاقات العامة توفر المعلومات التالية:
  • يشير شريط عنوان النموذج الرئيسي إلى فتح اسم الملف لملف السجل الذي يتم حاليا.
  • يتم عرض الطوابع الزمنية السجلات الأولى والأخيرة في ملف السجل.
  • يتم سرد عدد السجلات التي يتم عرضها حاليا.
  • يتم عرض إدخالات السجل في شبكة في النموذج الرئيسي.
ملاحظة: في الشبكة في النموذج الرئيسي، قد لا ترى الأعمدة المرتبطة بمعالجة تفاصيل حالة تشغيل الأداة محلل العلاقات العامة من كمبيوتر لا يدعم تعيين منفذ للعملية. على سبيل المثال، معرف المنتجو الوحدة النمطية الحساب هي الأعمدة المرتبطة بمعالجة التفاصيل. لا يعتمد Windows 2000 تعيين منفذ بالعملية. لذلك، على جهاز كمبيوتر يستند إلى نظام التشغيل Windows 2000، لا يمكنك رؤية هذه الأعمدة.

GUI Windows أداة محلل العلاقات العامة يوفر الميزات التالية:
  • تظهر تفاصيل إدخال سجل في شبكة. إذا انقر نقراً مزدوجاً فوق صف في الشبكة في النموذج الرئيسي أو زر الماوس الأيمن فوق صف، وثم انقر فوق خصائص، يتم عرض تفاصيل إدخال السجل. تتوفر هذه الميزة فقط عند فحص ملفات السجل على جهاز كمبيوتر في نظام التشغيل الذي يدعم تعيين منفذ للعملية. اعتبارا من أيلول/سبتمبر 2004، و Windows Server 2003 و Windows XP يعتمد هذه الميزة.
  • يمكنك فرز البيانات في الشبكة على النموذج الرئيسي في ترتيب تصاعدي أو تنازلي حسب أي عمود. عند النقر فوق رأس عمود، الأداة فرز البيانات في الشبكة على النموذج الرئيسي في ترتيب تصاعدي حسب هذا العمود. عند النقر فوق رأس العمود مرة أخرى، الأداة بفرز البيانات في ترتيب تنازلي. يظهر سهم في رأس عمود عند فرز البيانات حسب هذا العمود. يشير السهم إلى ترتيب الفرز. إذا كنت تريد استعادة الشبكة إلى ترتيب الفرز الأصلي الخاص به، انقر فوق إعادة تعيين الشبكة للفرز الافتراضي في القائمة تحرير .
  • يمكنك استخدام أي من الأساليب التالية لتصفية البيانات في الشبكة في النموذج الرئيسي:
    • في القائمة تحرير ، أشر إلى عوامل تصفية، ومن ثم انقر فوق تصفية البيانات. يظهر مربع الحوار تصفية شبكة البيانات . يمكنك تحديد عمود كتصفية البيانات وتوفير معيار عامل تصفية. بعد تحديد وتطبيق المعايير، تظهر البيانات التي تمت تصفيتها في شبكة البيانات.
    • زر الماوس الأيمن فوق خلية قيمته هي معايير عامل التصفية في الشبكة في النموذج الرئيسي وأشر إلى عامل التصفيةثم انقر فوق عامل التصفية المناسب، استناداً إلى ما إذا كنت تريد تصفية الصفوف دون هذه القيمة أو كافة الصفوف بهذه القيمة.
  • يمكنك نسخ محتويات خلية أو نسخ محتويات كافة الخلايا في صف واحد. لنسخ محتويات خلية، انقر نقراً مزدوجاً فوق خلية، ثم انقر فوق نسخ. لنسخ محتويات كافة الخلايا في صف، انقر نقراً مزدوجاً فوق رأس الصف، ثم انقر فوق نسخ.
  • يمكنك حل عناوين IP البعيدة التي تظهر في العمود IP البعيد إلى أسمائها المقابلة. يتم عرض قائمة بكافة عناوين IP وأسماء المقترنة في الشبكة بعد انتهاء أداة محلل العلاقات العامة العملية. لا تتضمن هذه القائمة التكرارات. يمكنك استخدام أي من الطرق التالية لحل عناوين IP البعيدة:
    • من القائمة أدوات ، انقر فوق حل كافة IPs البعيد لحل عناوين IP البعيدة.
    • انقر نقراً مزدوجاً فوق خلية، وثم انقر فوق حل عنوان IP البعيد لحل عنوان IP المحدد.
    اعتماداً على عدد عناوين IP حلها، قد تستغرق هذه العملية عدة دقائق للاكتمال. يتم استخدام DNS ذاكرة التخزين المؤقت على العميل لتجنب إرسال الاستعلامات بالشبكة التي تمت الإجابة.

    ملاحظة: سرعة ونجاح هذه العملية يعتمد على البنية الأساسية تحليل الاسم على شبكة الاتصال. سرعة ونجاح هذه العملية يعتمد أيضا على ما إذا كانت تتوفر سجلات البحث العكسي لكل عنوان IP.
  • يمكنك نقل فحص جهاز كمبيوتر بعيد باستخدام الأداة المساعدة لسطر الأوامر Portqry.exe. Portqry.exe هي اتصال فعالة سطر أوامر اختبار الأداة التي يمكن أن تولد معلومات مفيدة حول منافذ TCP و UDP.

    توفر الأداة محلل PR واجهة مستخدم لاستخدام الأداة المساعدة Portqry.exe. يمكن أن تساعدك هذه الميزة في تحديد نوع الخدمات التي توفر الكمبيوتر البعيد والكمبيوتر البعيد. منفذ تفحص كمبيوتر بعيد وانقر نقراً مزدوجاً فوق خلية ثم انقر فوق عنوان IP البعيد من الأداة PortQry. للحصول على معلومات إضافية حول الأداة المساعدة Portqry.exe سطر الأوامر، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

    وصف الأداة المساعدة Portqry.exe سطر الأوامر 310099

    ملاحظة: عندما يتم تثبيت الأداة محلل العلاقات العامة، يتم نسخ الملف Portqry.exe في نفس المجلد الذي تم تخزين الملف Prparser.exe.

تعريف البيانات مريبة أو البيانات التي تهمك

يمكنك استخدام الأداة محلل العلاقات العامة لتعقب العديد من نقاط البيانات، بما في ذلك الوحدات النمطية وعناوين IP والمنافذ، المستخدمين وأسماء المضيفين. باستخدام أداة محلل العلاقات العامة، يمكنك تحديد مطابقة أية إدخالات السجل في ملف سجل "مراسل المنفذ" أي معيار تم تكوين أداة محلل العلاقات العامة للبحث. يمكنك تكوين هذه المعايير في واجهة المستخدم الرسومية للأداة محلل العلاقات العامة وقم بتحديثها لتشمل الصفات المميزة للظروف الجديدة التي تقوم باختيارها.

لعرض أو إضافة أو حذف المعايير، انقر فوق إعدادات المعايير القائمة تحرير .

فيما يلي بعض المعايير الستة التي يمكن تعيينها في أداة محلل العلاقات العامة لتعريف البيانات مريبة أو البيانات التي تهمك.

تعرف وحدات تعقب

تتبع الوحدات النمطية المعروفة يتيح لك تحديد الملفات القابلة للتنفيذ التي تستخدم أسماء الملفات الثنائية الشرعية وتشغيل أو يتم تحميلها من مجلد غير صحيح. على سبيل المثال، اسم شعبي للبرامج الضارة هو Svchost.exe. يتم تشغيل Svchost.exe الشرعية من المجلد %windir%\System32. عندما يسمى Svchost.exe البرامج الضارة ونسخها إلى المجلد % windir %، فيكون صعباً أن هذا الملف الثنائي قيد التشغيل من المجلد غير صحيح. Svchost.exe قيد التشغيل من مجلد خلاف المجلد System32، قد يكون الكمبيوتر عرضه للهجمات. أداة محلل PR يعرف هذا النوع من المشاكل.

لاحظ أنه، بشكل عام، تشغيل بعض الوحدات النمطية من موقع واحد أو أكثر. يجب مراجعة أية تحذيرات محلل العلاقات العامة لتحديد ما إذا كان التحذير إيجابية كاذبة أو ما إذا كان شيء غير منتظمة قد وجد. إذا كنت ترغب في فحص ملفات السجل "مراسل المنفذ" من أجهزة كمبيوتر مختلفة، قد تضطر لتجاوز إعدادات المجلد على الكمبيوتر المحلي لأجهزة الكمبيوتر قد بني مجلدات مختلفة. على سبيل المثال، % windir % و % systemroot % نقطة إلى مواقع مختلفة على أجهزة كمبيوتر مختلفة. في هذه الحالة قد تعريف الأداة محلل العلاقات العامة العديد من الملفات قيد التشغيل في المجلد غير صحيح لأن الأداة محلل العلاقات العامة حل هذه المتغيرات باستخدام بنية المجلد في الكمبيوتر المحلي حيث يتم تشغيل الأداة محلل العلاقات العامة. وللتعويض عن هذا النوع من الفرق بين أجهزة الكمبيوتر، يمكن تجاوز هذا السلوك وتعيين أداة محلل العلاقات العامة لحل هذه المتغيرات البيئية. للقيام بذلك، اتبع الخطوات التالية:
  1. في القائمة تحرير ، انقر فوق إعدادات المعايير.
  2. ضمن علامة التبويب الوحدات النمطية المعروفة ، انقر فوق تكوين.
  3. انقر فوق تجاوز إعدادات دليل النظام المحلي.
يتيح هذا إمكانية تجاوز طريقة أن الأداة محلل العلاقات العامة بحل متغيرات البيئة.

الوحدات النمطية

أداة محلل العلاقات العامة بشكل سريع تحديد ما إذا كانت الوحدات النمطية التي تهمك تم العثور عليها في ملفات السجل "مراسل المنفذ". لإضافة الوحدات النمطية إلى قائمة الوحدات النمطية التي تهمك، اتبع الخطوات التالية:
  1. في القائمة تحرير ، انقر فوق إعدادات المعايير.
  2. انقر فوق علامة التبويب الوحدات النمطية .
  3. انقر فوق إضافة.
  4. اكتب اسم الوحدة النمطية مهتما، وثم انقر فوق "موافق" لإضافة الوحدة إلى قائمة الوحدات النمطية "البحث عن" .
وبالمثل، يمكنك حذف الوحدات النمطية التي تم إضافتها إلى قائمة الوحدات النمطية "البحث عن" .

عند عثور الأداة محلل العلاقات العامة على وحدة نمطية في ملف سجل التي تهمك، يعرض الإدخال باللون الأحمر في الشبكة في النموذج الرئيسي. على سبيل المثال، أداة Netcat.exe أداة أن المسؤولين قد أو قد لا تريد للمستخدمين للاستخدام على شبكة الاتصال الخاصة بهم. يمكن تعريف في سجلات "مراسل المنفذ" في حالة تشغيل الأداة Netcat.exe باستخدام الاسم الأصلي.

انقر نقراً مزدوجاً فوق خط الذي تم تحديده لعرض التفاصيل. يفتح مربع حوار محلل مراسل منفذ-تفاصيل إدخال السجل ويوفر تفاصيل حول العملية حول المنافذ التي يتم استخدامها وحول الوحدات النمطية التي تم تحميلها. كما توفر محلل العلاقات العامة بتحذير. في مربع الحوار محلل مراسل منفذ-تفاصيل إدخال السجل ، إذا انقر فوق اسم العملية، أداة محلل العلاقات العامة يوفر خيارات للبحث عن عملية مشبوهة أو "مثيرة للاهتمام".

ملاحظة: لا يمكنك مشاهدة تفاصيل إدخال السجل على جهاز كمبيوتر يستند إلى نظام التشغيل Windows 2000.

عناوين IP

التعرف على عناوين IP التي تهمك في ملفات السجل "مراسل منفذ" أداة محلل العلاقات العامة. لتحديد عناوين IP، اتبع الخطوات التالية:
  1. في القائمة تحرير ، انقر فوق إعدادات المعايير.
  2. انقر فوق علامة التبويب عناوين IP .
  3. انقر فوق إضافة.
  4. اكتب عنوان IP مهتما، وثم انقر فوق موافق لإضافة عنوان IP إلى قائمة عناوين IP "البحث عن" .
وبالمثل، يمكنك أيضا حذف عناوين IP التي تم إضافتها إلى قائمة عناوين IP "البحث عن" .

بعد إضافة عنوان IP في معايير عناوين IP وقم بتطبيق المعايير، يتم عرض عنوان IP المعين في الشبكة في النموذج الرئيسي.

المنافذ

مسؤولي الشبكة استخدام سجلات جدار الحماية لتحديد البرامج قيد التشغيل على شبكاتهم ونقاط النهاية التي يتم استخدامها عند الاتصال بالبرامج. أداة محلل العلاقات العامة يساعد تحديد أي المنافذ المستخدمة بواسطة برنامج ويمكنك التعرف بسرعة على المنافذ التي كنت ترغب في. العديد من الفيروسات والديدان، البرامج الضارة والأدوات التي يتم استخدامها من قبل المستخدمين الضارين استخدام المنافذ نفس كل مرة يتم تشغيلها. تحديد أداة محلل العلاقات العامة أي المنافذ المسردة في قائمة معايير المنافذ.

لتعديل هذه القائمة، اتبع الخطوات التالية:
  1. في القائمة تحرير ، انقر فوق إعدادات المعايير.
  2. انقر فوق علامة التبويب منافذ .
  3. انقر فوق إضافة.
  4. اكتب اسم المنفذ والبروتوكول الذي كنت ترغب في ومن ثم انقر فوق "موافق" لإضافة معلومات المنفذ إلى قائمة المنافذ "البحث عن" .
وبالمثل، يمكنك حذف المنافذ التي يتم إضافتها إلى قائمة المنافذ "البحث عن" .

لاحظ أن البرامج القانونية قد تستخدم نفس المنافذ التي تستخدمها البرامج الضارة. يجب أن تتحقق كل تحذير الذي أنشأته الأداة محلل العلاقات العامة لتحديد ما إذا كان يتم إنشاء التحذير بسبب عملية غير عادية.

حسابات المستخدمين

تتيح لك تحديد حسابات المستخدمين التي تهمك في ملفات السجل "مراسل منفذ" أداة محلل العلاقات العامة. لتحديد حسابات المستخدم، اتبع الخطوات التالية:
  1. في القائمة تحرير ، انقر فوق إعدادات المعايير.
  2. انقر فوق حسابات المستخدمين .
  3. انقر فوق إضافة.
  4. اكتب حساب المستخدم الذي ترغب في، ثم انقر فوق "موافق" لإضافة حساب مستخدم إلى قائمة حسابات المستخدمين "البحث عن" .
وبالمثل، يمكنك حذف حسابات المستخدمين التي يتم إضافتها إلى قائمة حسابات المستخدمين "البحث عن" .

بعد إضافة مستخدم في معايير حسابات المستخدم، يتم عرض حساب المستخدم المحدد في الشبكة في النموذج الرئيسي.

اسم المضيف

الأداة محلل العلاقات العامة بمحاولة حل عناوين IP البعيدة التي تم العثور عليها في السجلات بأسماء المضيفين. نجاح القرار يعتمد على عوامل مثل إعدادات TCP/IP بشكل صحيح تكوين إعدادات DNS، بنية تحتية دقة اسم التشغيلية وعناوين IP لتعيينات اسم. لتقليل عدد الاستعلامات التي يتم إرسالها إلى الشبكة، يحتوي ذاكرة التخزين مؤقت لاسم الأداة محلل العلاقات العامة ويستخدم أيضا تخزين اسم العميل. لتحديد أسماء هذه، اتبع الخطوات التالية:
  1. في القائمة تحرير ، انقر فوق إعدادات المعايير.
  2. انقر فوق علامة التبويب أسماء المضيفين .
  3. انقر فوق إضافة.
  4. اكتب اسم المضيف مهتما، وثم انقر فوق "موافق" لإضافة اسم المضيف إلى قائمة أسماء المضيفين "البحث عن" .
أداة محلل العلاقات العامة بنجاح حل عناوين IP إلى أسماء المضيف، يعرف أسماء الأجهزة المضيفة التي تطابق الأسماء الموجودة في قائمة معايير أسماء المضيفين الأداة وثم يعرض أسماء المضيفين.

تطبيق المعايير

إذا أردت تحديد معايير لملف السجل الذي يتم فتحه، يمكنك استخدام
خيار تطبيق المعايير القائمة أدوات . أداة محلل العلاقات العامة بتوزيع ملف السجل للبحث عن إدخالات مطابقة للمعايير. إذا تم العثور على تطابق، أداة محلل PR يعرض الحقل المطابق. لا يتم سرد تفاصيل، مثل الوحدات النمطية المحملة، في الشبكة في النموذج الرئيسي. تتوفر هذه التفاصيل فقط عند عرض تفاصيل سجل.

عند عثور الأداة محلل العلاقات العامة على تحميل الوحدة نمطية التي تهمك أو أنه تم تحميل الوحدة نمطية التي تستخدم اسم شرعية من المجلد غير صحيح، لا الأداة بعرض هذه المعلومات في شبكة النموذج الرئيسي. وهذا لأن الأداة محلل العلاقات العامة عرض الحقول. تحديد كافة الصفوف التي تحتوي على البيانات التي تتطابق مع المعايير، حتى في تفاصيل إدخال، يجب تصفية البيانات. للقيام بذلك، أشر إلى عوامل تصفية في القائمة تحرير ، ومن ثم انقر فوق إظهار صفوف من البيانات "مثيرة للاهتمام". هذه الميزة تسمح لك بتحديد ما إذا كانت أية إدخالات سجل تطابق المعايير التي قمت بتعيينها. القائمة الناتجة قد تكون فارغة تحتوي على كافة الصفوف حيث البيانات مطابقة للمعايير، بما في ذلك تفاصيل مثل الوحدات النمطية. لا يتوفر الخيار إظهار صفوف من البيانات "مهم" حتى يتم تطبيق معيار للبيانات. بعد النقر فوق تطبيق المعايير على القائمة " أدوات "، يتوفر الخيار إظهار صفوف من البيانات "مثيرة للاهتمام" .

تحليل السجلات وتوليد البيانات

يمكن لأداة محلل لمشروع إنشاء سجل تحليل البيانات التي يمكن أن تكون مفيدة لمسؤولي الكمبيوتر ومسؤولي شبكات الاتصال. يتم إنشاء سبع مجموعات من البيانات من سجلات "مراسل منفذ" لأجهزة الكمبيوتر المستندة إلى Windows Server 2003 أو نظام التشغيل Windows xp. نظراً لعدم القيام بأداة "مراسل منفذ" تعيين المنفذ إلى عملية على أجهزة الكمبيوتر المستندة إلى نظام التشغيل Windows 2000، لا يمكن إنشاء بعض هذه الإحصائيات من السجلات من أجهزة الكمبيوتر هذه. لتحليل السجلات وإنشاء إخراج، انقر فوق سجل تحليل البيانات القائمة أدوات .

فيما يلي سبع مجموعات من البيانات التي تم إنشاؤها بواسطة الأداة محلل العلاقات العامة:

استخدام منفذ TCP المحلي

يتضمن هذا مجموعة البيانات عدد المرات التي تم تسجيل كل منفذ TCP بالأداة "مراسل المنفذ". هذا النوع من البيانات يمكن أن يكون مفيداً عندما تريد تحديد أي منفذ سيتم فتح بين الشبكات الفرعية أو في الخارج للإنترنت. تمنحك هذه البيانات فكرة عن كم المنافذ التي يستخدمها كل جهاز كمبيوتر. تحتوي البيانات على قيمة النسبة المئوية من الإجمالي مقابل كل إدخال. يتم حساب هذه القيمة بقسمة عدد مرات استخدام كل منفذ من العدد الإجمالي من المرات يتم استخدام كافة المنافذ.

استخدام العملية

يمكنك استخدام هذه البيانات لتحليل عملية استخدام أجهزة الكمبيوتر. على سبيل المثال، البرامج التي يستخدمها الكمبيوتر، كم تسجيل الأداة "مراسل المنفذ" والبرامج المستخدمة بشكل عام على الأكثر. تحتوي البيانات على قيمة النسبة المئوية الإجمالية لكل إدخال. يتم حساب هذه القيمة بقسمة عدد مرات تسجيل كل عملية بإجمالي عدد مرات تسجيل كافة العمليات. هذه البيانات غير متوفرة لأجهزة الكمبيوتر المستندة إلى نظام التشغيل Windows 2000.

تعداد Svchost.exe

تحديد أداة محلل العلاقات العامة كافة الخدمات التي يتم استضافتها بواسطة العملية Svchost.exe. هذه المعلومات مطلوبة لتحديد البرامج قيد التشغيل على كمبيوتر.

استخدام عنوان IP البعيد

إظهار عناوين IP مجموعة البيانات هذه وقد تظهر أسماء المضيفين الاتصال الكمبيوتر ب. القائمة المرتبة حيث يمكنك أن ترى أجهزة الكمبيوتر التي تتصل غالباً.

الماوس الأيمن فوق الشبكة وقم بتحديد خيار لحل عناوين IP إلى أسماء المضيف المطابق. الأداة محلل العلاقات العامة بمحاولة حل الأسماء باستخدام الشبكة وإعدادات DNS على الكمبيوتر حيث يتم تشغيل الأداة محلل العلاقات العامة.

استخدام سياق المستخدم

مجموعة البيانات هذه لإظهار قائمة مرتبة من حسابات المستخدمين التي تم استخدامها في ملف سجل "مراسل المنفذ". يمكنك استخدام هذا لتحديد حسابات المستخدم التي تم استخدامها في كمبيوتر. هذه البيانات غير متوفرة لأجهزة الكمبيوتر المستندة إلى نظام التشغيل Windows 2000.

استخدام منفذ بالساعة

مجموعة البيانات هذه تفصيلاً لاستخدام منفذ في الساعة مع مرور الوقت التي جمعت بيانات ملف السجل "مراسل المنفذ". يمكنك استخدام هذه البيانات لمعرفة أوقات الذروة لكمبيوتر وفهم ما إذا كان يتم استخدام المنافذ في أوقات غير متوقعة.

ملاحظة: بشكل افتراضي، "مراسل المنفذ" بتجميع البيانات لمدة 24 ساعة.

استخدام Iexplore.exe

تعداد مجموعة البيانات هذه النقاط النهائية التي زارت Microsoft Internet Explorer. يتم تصنيف هذه البيانات على أساس مستخدم بحيث أنه يمكن لمحة عن استخدام Internet Explorer لكل مستخدم. يمكنك استخدام هذه البيانات لتحديد التي قامت بزيارة مواقع المستخدمين أو التي جدران الحماية الكمبيوتر المستخدم للوصول إلى إنترنت.

يمكنك انقر نقراً مزدوجاً فوق النموذج لعرض المعلومات ذات الصلة. يمكن حل كل عنوان IP المسرد لاسم مضيف. لذلك، يمكن تحديد الاسم المقابل لكل موقع أو جدار حماية.

يمكنك أيضا استخدام الأداة المساعدة Portqry.exe الاستعلام المنافذ الموجودة على أجهزة الكمبيوتر التي تم تعريفها في هذه القائمة. لحفظ بيانات تحليل السجل إلى ملف نصي، انقر فوق حفظفي مربع الحوار بيانات تحليل السجل للسجل .
خصائص

رقم الموضوع: 884289 - آخر مراجعة: 15‏/01‏/2017 - المراجعة: 1

تعليقات