كيفية تنفيذ دمج المراسلات في Works 9

ملخص

توضح هذه المقالة كيفية تنفيذ دمج المراسلات في Microsoft Works 9. بالإضافة إلى ذلك، توضح هذه المقالة كيفية تنفيذ دمج المراسلات باستخدام أحد المصادر التالية:
  • ملف قاعدة البيانات Works أو جدول البيانات Works.
  • كتاب "دفتر العناوين" في نظام التشغيل Microsoft Windows XP أو جهات اتصال Windows في نظام التشغيل Windows Vista.
لإجراء دمج البريد، اتبع الخطوات التالية:
  1. إنشاء مصدر بيانات لدمج المراسلات.
  2. تنفيذ عملية دمج المراسلات.
  3. تصفية المستند المدمج.
  4. إكمال عملية دمج المراسلات.

مقدمة

تحتوي هذه المقالة على إرشادات خطوة بخطوة لتنفيذ دمج المراسلات في Works 9.

مزيد من المعلومات

إنشاء مصدر بيانات لدمج المراسلات

مصدر بيانات هو ملف يحتوي على حقول مثل أسماء وعناوين ومعلومات أخرى قد ترغب في دمجها في مستند آخر. يمكنك إنشاء مصدر بيانات لدمج المراسلات باستخدام جدول البيانات Works أو قاعدة البيانات Works. بالإضافة إلى ذلك، يعمل 9 دمج سجلات من المصادر التالية:
  • كتاب "دفتر العناوين" في نظام التشغيل Windows XP أو جهات اتصال Windows في نظام التشغيل Windows Vista.
  • Microsoft Excel (*.xls).
  • العديد من تنسيقات النص.
توضح هذه المقالة كيفية تنفيذ دمج المراسلات من قاعدة البيانات Works من "جدول الأعمال"، "دفتر العناوين"، أو من دفتر جهات اتصال Windows.

إنشاء مصدر بيانات في جدول البيانات Works 9

  1. فتح جدول بيانات فارغ وجديد في "جدول الأعمال".
  2. إضافة السجلات التي تريد دمجها "جدول الأعمال". وضع أسماء الحقول في الصف الأول.
  3. من القائمة ملف ، انقر فوق حفظ، وقم بحفظ الملف كملف جدول البيانات Works (*.xlr).

إنشاء مصدر بيانات في قاعدة البيانات Works 9

  1. فتح قاعدة بيانات فارغة وجديدة في قاعدة البيانات Works 9.
  2. قم بإنشاء العدد الصحيح وتنسيق حقول السجلات الخاصة بك. تأكد من أن يعطي أسماء وصفية لكل حقل.
  3. من القائمة ملف ، انقر فوق حفظ، وقم بحفظ الملف كملف قاعدة البيانات Works (*.wdb).

دمج المراسلات 9 عمل قاعدة بيانات أو ملف جدول بيانات 9 Works

  1. بدء تشغيل مشغل المهام Works و قوالبانقر فوق ثم انقر فوق رسائل & تسميات.
  2. انقر فوق مستندات دمج المراسلات. سيتم الآن بدء معالج النصوص Works.
  3. في مربع الحوار فتح مصدر البيانات ، انقر فوق دمج المعلومات من نوع آخر للملف.
  4. في مربع الحوار فتح مصدر البيانات ، ضمن أنواع الملفات، حدد نوع مصدر البيانات الذي تريده.
  5. حدد قاعدة بيانات 9 Works أو ملف جدول بيانات 9 Works التي تريدها، ومن ثم انقر فوق فتح.
  6. إذا كنت تستخدم جدول 9 Works، سيطلب ما إذا كان الصف الأول من الورقة تحتوي على أسماء الحقول. انقر فوق نعم أو لا حسب الاقتضاء. إذا كنت لا تستخدم جدول 9 Works، انتقل إلى الخطوة 7. يظهر مربع الحوار إدراج الحقول .

    ملاحظة: عند هذه النقطة، هو إرفاق ملف قاعدة بيانات 9 Works أو ملف جدول بيانات 9 Works إلى المستند الأساسي لدمج المراسلات.
  7. اكتب محتويات المستند الرئيسي لدمج المراسلات، حسب الاقتضاء. على سبيل المثال، اكتب رسالة نموذجية.
  8. في المستند الرئيسي، وضع المؤشر حيث تريد أن تظهر حقول مدمجة.
  9. في مربع الحوار إدراج الحقول ، حدد الحقل الذي تريده، ومن ثم انقر فوق إدراج.
  10. متابعة لتحديد الحقول التي تريد إدراج، ثم انقر فوق إدراج حتى تحصل على كافة الحقول التي تريدها.

    ملاحظة: عند إدراج الحقول، اكتب علامات الترقيم والمسافات بين الحقول، واضغط على ENTER للانتقال إلى سطر جديد. تنسيق التخطيط بالطريقة التي تريد أن تظهر.
  11. بعد إدراج وتنسيق الحقول، انقر فوق عرض النتائج في مربع الحوار إدراج الحقول لعرض الحقول. يمكنك استخدام مربع الحوار عرض النتائج لعرض كل سجل في ملف قاعدة بيانات 9 Works التي تريدها.

دمج المراسلات من دفتر العناوين

ملاحظة: تفترض هذه الخطوات أن قمت مسبقاً بإضافة سجلات دفتر العناوين أو دفتر جهات اتصال Windows.
  1. بدء تشغيل مشغل المهام Works و قوالبانقر فوق ثم انقر فوق رسائل & تسميات.
  2. انقر فوق مستندات دمج المراسلات. سيتم الآن بدء معالج النصوص Works.
  3. في مربع الحوار فتح مصدر البيانات ، انقر فوق دمج من "دفتر العناوين". يظهر مربع الحوار إدراج الحقول .

    ملاحظة: عند هذه النقطة، ملف قاعدة البيانات Works أو ملف جدول البيانات Works إرفاق المستند الرئيسي لدمج المراسلات.
  4. اكتب محتويات المستند الرئيسي لدمج المراسلات، حسب الاقتضاء. على سبيل المثال، اكتب رسالة نموذجية.
  5. في المستند الرئيسي، وضع المؤشر حيث تريد أن تظهر حقول مدمجة. في مربع الحوار إدراج الحقول ، حدد الحقل الذي تريده، ومن ثم انقر فوق إدراج.
  6. متابعة لتحديد الحقول التي تريد إدراج، ثم انقر فوق إدراج حتى تحصل على كافة الحقول التي تريدها.

    ملاحظة: عند إدراج الحقول، اكتب المسافات بين الحقول وعلامات الترقيم، واضغط على ENTER للانتقال إلى سطر جديد. تنسيق التخطيط بالطريقة التي تريد أن تظهر.
  7. بعد إدراج وتنسيق الحقول التي تريدها، انقر فوق عرض النتائج في مربع الحوار إدراج الحقول لعرض الحقول. يمكنك استخدام مربع الحوار عرض النتائج لعرض كل سجل في ملف قاعدة بيانات 9 Works التي تريدها.

تصفية مستند المدمج

إذا لم يتضمن العرض عرض نتائج السجلات التي قمت بتحديدها في ملف جدول البيانات Works أو في ملف "قاعدة البيانات تعمل" بشكل صحيح، يمكنك تصفية السجلات في مستند مدمج. للقيام بذلك، اتبع الخطوات التالية:
  1. في المستند المدمج، من القائمة أدوات ، أشر إلى دمج المراسلات، ومن ثم انقر فوق تصفية وفرز.
  2. إذا لم يكن محدداً بالفعل، انقر فوق علامة التبويب عامل التصفية .
  3. في القائمة الحقل ، انقر فوق الحقل الذي تريد استخدامه لتصفية.
  4. في المربع المقارنة ، حدد عبارة المقارنة التي تريدها.
  5. في المربع مقارنة ب ، حدد النص الذي تريد مقارنة محتويات الحقل الأول.
  6. لإضافة عوامل تصفية إضافية، كرر الخطوات من 4 إلى 6.
  7. حدد خانة الاختيار و تتطلب أن الأسماء والعناوين في المستند المدمج تفي بجميع معايير عوامل تصفية مجموعة. حدد أو لتضمين الأسماء والعناوين التي تفي بأحد معايير عوامل تصفية مجموعة.
  8. انقر فوق موافق. يظهر مربع الحوار عرض النتائج . يمكنك مراجعة نسخ فردية للحرف في المستند المدمج لمشاهدة نتائج عامل التصفية.
  9. انقر فوق إغلاق (س) لإغلاق مربع الحوار عرض النتائج .
ملاحظات
  • لإزالة عامل تصفية، انقر فوق إلغاء تطبيق عامل التصفية في التبويب عامل التصفية .
  • إذا قمت بإنشاء مستند مدمج باستخدام تحديد الأسماء، لا يمكنك تصفية باستخدام الأسماء التي قمت بتحديدها فقط.
  • إذا كان مصدر البيانات هو "عمل قاعدة بيانات"، يمكنك استخدام عامل التصفية فقط لدمج السجلات المحددة. للقيام بذلك، انقر فوق استخدام السجلات المحددة في علامة التبويب عامل التصفية .
  • يمكنك القيام ببعض تصفية متقدمة وفرز ملف البيانات قبل إكمال عملية دمج المراسلات لتلقي النتائج التي تريدها فعلا. للحصول على تعليمات تنفيذ تصفية وفرز متقدم، انقر فوق علامات التبويب عامل تصفية أو فرز تعليمات (?) ، وثم انقر فوق الناحية حيث تريد الحصول على تعليمات إضافية.

إكمال عملية دمج المراسلات

  1. من القائمة ملف ، انقر فوق طباعة.
  2. إذا قمت بعرض النتائج في عملية دمج المراسلات وملاحظة لا يتم منع الأسطر الفارغة، انقر لتحديد خانة الاختيار عدم طباعة الأسطر تتضمن حقول فارغة .
  3. لإخراج المستند المدمج، استخدم إحدى الطرق التالية:
    • إذا كنت تريد طباعة المستند المدمج مباشرة، انقر فوق "موافق" لإكمال دمج البريد وطباعة المغلفات على الطابعة. إذا قمت بتحديد هذا الخيار، قد لا يتم تطبيق باقي الخطوات في هذا المقال.
    • لحفظ عملية دمج المراسلات إلى مستند جديد بحيث يمكنك طباعة لاحقاً، انقر لتحديد خانة الاختيار إرسال نتائج دمج إلى مستند جديد ، ومن ثم انقر فوق موافق.
  4. سيتم الآن فتح مستند جديد يحتوي على قائمة العناوين المدمجة. لحفظ هذا الملف للطباعة لاحقاً، انقر فوق حفظ القائمة ملف .
  5. في مربع الحوار حفظ باسم ، اكتب الاسم الذي تريد استخدامه للمستند الجديد في المربع اسم الملف . على سبيل المثال، اكتب مغلفات الخاصة بي.
  6. انقر فوق حفظ. سينشئ معالج النصوص Works مستند جديد (*.wps) الذي يحتوي على كافة صفحات المستندات المدمجة. على سبيل المثال، كافة المغلفات التي تريد البريد. يمكنك طباعة المستند لاحقاً لإكمال الإرسال.

المراجع

لمزيد من المعلومات حول كيفية تنفيذ دمج المراسلات في Works 7.0 أو في Works 8.0، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

كيفية تنفيذ دمج المراسلات في Works 7.0 وفي Works 8.0 832797

خصائص

رقم الموضوع: 940002 - آخر مراجعة: 13‏/01‏/2017 - المراجعة: 2

تعليقات