حدوث مشاكل متعددة على جهاز كمبيوتر يستند إلى نظام التشغيل Windows Server 2003 يقوم بتشغيل "خدمة النسخ الاحتياطي لوحدة التخزين"

الأعراض

في جهاز كمبيوتر يستند إلى نظام التشغيل Windows Server 2003، يقوم الجهاز على تشغيل "خدمة النسخ الاحتياطي لوحدة التخزين" قد تواجه أحد الأعراض التالية:
  • عندما تقوم بإجراء عملية نسخ احتياطي باستخدام الأداة NTBackup، فإنه يتم تسجيل الحدث التالي في "سجل التطبيقات":


    ملاحظة إذا قمت بعرض ملف سجل النسخ الاحتياطي، يتم عرض المعلومات التالية:
    تم إرجاع خطأ أثناء إنشاء نسخة الظل الاحتياطي لوحدة التخزين:0xffffffff
  • في حالة الوصول إلى خصائص إحدى وحدات التخزين وقمت بعد ذلك بالنقر فوق ملفات الظل الاحتياطي، فإنك تتلقى إحدى رسائل الخطأ التالية:
    خطأ 0x8004230F: حدث خطأ غير متوقع بموفر ملف الظل الاحتياطي أثناء محاولة إجراء العملية المحددة.
    خطأ 0x80004002: لا يتم دعم هذا النوع من الواجهات.
  • تم تسجيل أحد الأحداث التالية في سجل "التطبيقات":

السبب

تحدث هذه المشكلة لأن ملفات النظام VSS غير مسجلة.

الحل

ملاحظة هذه المقالة غير معدَّة للاستخدام مع أنظمة التشغيل Windows Vista أو Windows Server 2008 أو أنظمة التشغيل الأحدث. بدايةً من نظامي التشغيل Windows Vista وWindows Server 2008، أصبح مكوِّن أنظمة التشغيل Windows يستند إلى البيان. إذا كنت تحاول تسجيل مكونات محددة يدويًا، مثل تلك الموضحة في القسم "حل"، في أنظمة التشغيل المذكورة في هذه الملاحظة، فقد يؤدي ذلك إلى حدوث نتائج غير متوقعة تتطلب منك إعادة تثبيت Windows لحلها.


لنقوم بإصلاح هذه المشكلة لك، انتقل إلى القسم "إصلاح المشكلة بالإنابة عني". إذا كنت تفضل إصلاحها بنفسك، فانتقل إلى القسم "إصلاح هذه المشكلة بنفسي".

إصلاح المشكلة بالإنابة عني



لحل هذه المشكلة تلقائيًا، انقر فوق الزر أو الارتباط Fix it. في مربع الحوار تنزيل الملف، انقر فوق تشغيل، ثم اتبع الخطوات الموجودة في معالج "الإصلاح".




ملاحظات
  • قد يتوفر هذا المعالج باللغة الإنجليزية فقط. ومع ذلك، يعمل الإصلاح التلقائي أيضًا مع إصدارات اللغات الأخرى من Windows.
  • إذا كنت لا تعمل على الكمبيوتر الذي توجد به المشكلة، يمكنك حفظ حل "Fix it" على محرك أقراص محمول أو قرص مضغوط ثم تشغيله على الكمبيوتر الذي توجد به المشكلة.

وبعد ذلك، انتقل إلى القسم "هل عمل ذلك على إصلاح المشكلة؟".



إصلاح هذه المشكلة بنفسي



لحل هذه المشكلة، اتبع الخطوات التالية:
  1. انقر فوق ابدأ، ثم انقر فوق تشغيل، ثم اكتب cmd، ثم انقر فوق موافق.
  2. اكتب الأوامر التالية في موجه أوامر. اضغط على مفتاح "الإدخال" بعد كتابة كل أمر.
    • cd /d %windir%\system32
    • Net stop vss
    • Net stop swprv
    • regsvr32 ole32.dll
    • regsvr32 oleaut32.dll
    • regsvr32 vss_ps.dll
    • vssvc /register
    • regsvr32 /i swprv.dll
    • regsvr32 /i eventcls.dll
    • regsvr32 es.dll
    • regsvr32 stdprov.dll
    • regsvr32 vssui.dll
    • regsvr32 msxml.dll
    • regsvr32 msxml3.dll
    • regsvr32 msxml4.dll
    ملاحظة قد لا يتم تشغيل الأمر الأخير بنجاح.
  3. قم بإجراء عملية نسخ احتياطي للتحقق من أنه قد تم حل المشكلة.

هل عمل ذلك على إصلاح المشكلة؟

  • تحقق مما إذا كان قد تم إصلاح المشكلة أم لا. في حالة إصلاح المشكلة، لا يتطلب الأمر إكمال قراءة هذا القسم. أما في حالة عدم إصلاح المشكلة، يمكنك الاتصال بالدعم.
  • نحن نقدّر إرسالك لأية ملاحظات. لتقديم ملاحظات أو الإبلاغ عن أية مشاكل تتعلق بهذا الحل، الرجاء كتابة تعليق بالمدوّنة "إصلاح المشكلة بالإنابة عني" أو إرسال رسالة بريد إلكتروني إلينا.

معلومات أخرى

خطوات إعادة إنشاء هذه المشكلة

  1. اكتب الأمر التالي في موجه أوامر. اضغط على مفتاح "الإدخال" بعد كتابة الأمر.
    regsvr32 /u swprv.dll
  2. حاول تنفيذ عملية النسخ احتياطي.
خصائص

رقم الموضوع: 940032 - آخر مراجعة: 20‏/12‏/2011 - المراجعة: 1

تعليقات