معلومات حول كيفية العمل مع ملفات تنسيق Open XML في Microsoft Office 2004 ل Mac

مقدمة

هام: وصلت إلى نهاية دورة حياة دعم office 2004 ل Mac، ولم تعد تتلقى الدعم المساعد أو تحديثات من Microsoft. نوصي الترقية إلى Office 2011 لنظام التشغيل Mac لإصدار معتمد من Office. لمزيد من المعلومات حول نهاية دعم خاصة ب Office 2004 ل Mac، راجع موقع دورة حياة دعم Microsoft .


إذا قمت بتثبيت Microsoft Office 2004 لتحديث Mac 11.5.0 و Microsoft Office فتح محول تنسيق ملفات XML ل Mac، يمكنك استخدام تطبيقات Office 2004 لفتح الملفات وحفظها تنسيقات Open XML التي تم تقديمها في نظام 2007 Microsoft Office لنظام التشغيل Windows وفي Microsoft Office 2008 لأنظمة تشغيل mac.


ملاحظة: للتحقق من استيفاء هذه المتطلبات الدنيا على نظام التشغيل Mac، انقر فوق حول هذا Mac
قائمة Apple .

يجب عليك تنزيل حزم اثنين التالية على جهاز ماك.
  • لتنزيل Microsoft Office 2004 لنظام التشغيل Mac 11.5.0 تحديث، قم بزيارة موقع ويب مركز تنزيل Microsoft التالية:متطلبات النظام: أبل Mac OS X 10.2.8 (Jaguar) أو إصدار أحدث من نظام التشغيل Mac OS
  • لتنزيل "محول تنسيق ملفات XML المفتوحة" لحزمة التحديث Mac، قم بزيارة موقع ويب مركز تنزيل Microsoft التالية:هام: لفتح المستندات التي تم تحويلها، يجب أن يكون لديك Office 2004 11.4.0 أو الإصدارات الأحدث أو Office الإصدار X 10.1.9 أو الإصدارات الأحدث مثبتاً على جهاز الكمبيوتر الخاص بك. ومع ذلك، نوصي بتثبيت تحديث Office 2004 11.5.1 أو تحديث لاحق خاصة ب Office 2004 ل mac.

    متطلبات النظام: إصدار Mac OS X 10.4.9 (Tiger) أو إصدار أحدث من نظام التشغيل Mac OS

مزيد من المعلومات

تنسيقات الملفات المدعمة

يمكن فتح أنواع الملفات التالية تنسيق Open XML وحفظها في Office 2004 ل Mac عند تثبيت Office 2004 ل Mac 11.5.0 "و" محول تنسيق ملفات XML المفتوحة من لجنة الهدنة العسكرية:
  • مستند 2008 Word (.docx)
  • مستند Word 2008 ماكرو (.docm)
  • 2008 المصنف (.xlsx)
  • مصنف ثنائي 2008 Excel (.xlsb)
  • تمكين ماكرو Excel 2008 المصنف (.xlsm)
  • قالب 2008 Excel (.xltx)
  • قالب Excel 2008 ماكرو (.xltm)
  • Excel 2008 الإضافية (.xlam)
  • 2008 عرضاً (.pptx)
  • عرض تقديمي ل PowerPoint 2008 ماكرو (pptm.)
  • PowerPoint 2008 قالب (.potx)
  • قالب PowerPoint 2008 ماكرو (.potm)
  • عرض 2008 PowerPoint (.ppsx)
  • عرض PowerPoint 2008 ماكرو (.ppsm)

ملفات دعم المحول

عند تثبيت Office 2004 ل Mac 11.5.0 "و" محول تنسيق ملفات XML المفتوحة من لجنة الهدنة العسكرية، يتعرف Office 2004 ل Mac محول ملفات الدعم في مجلد مكتبة/الدعم/Microsoft/مكتب "محول يدعم" تطبيق. ملفات دعم المحول التالية مطلوبة:
  • MFConverter.bundle
  • MicrosoftChartPlugin.framework
  • MicrosoftComponentPlugin.framework
  • MicrosoftOffice.framework
  • MicrosoftOLE.framework
  • MicrosoftOLEAutomation.framework
  • MicrosoftOleo.framework
  • MSXML.framework
  • OfficeArt.framework
  • XML المفتوح ل Charts.app
  • XML المفتوح ل Excel.app
  • XML المفتوح ل Excel.framework
  • XML المفتوح ل Word.app
  • XML المفتوح ل Word.framework
  • pptfc.app
  • SmartArt.framework
يستخدم Microsoft Office 2008 لنظام التشغيل Mac أيضا ملفات دعم المحول. ولذلك، يجب عليك عدم إزالة هذه الملفات من الكمبيوتر الخاص بك إذا قررت إزالة Office 2004 أو محول XML المفتوحة.

تتوفر تحديثات لملفات دعم المحول من التحديث التلقائي ل Microsoft. للتحقق من وجود تحديثات لملفات دعم المحول فتح التطبيق فتح تحويل XML. ثم انقر فوق التحقق من وجود تحديثات في القائمة تعليمات .

هام: لا يمكنك استخدام إصدارات بيتا من "محول XML المفتوحة" مع Office 2004 11.5.0 أو الإصدارات الأحدث من Office 2004. إذا كان لديك إصدار بيتا من محول مثبت على جهاز الكمبيوتر الخاص بك، تحميل وتثبيت الإصدار 1.0 أو إصدار أحدث من "محول XML المفتوحة". للقيام بذلك، قم بزيارة موقع Microsoft التالي على الويب:

الخطوط

إذا تم تثبيت Microsoft Office 2004 ل Mac على جهاز الكمبيوتر، يتم تثبيت الخطوط التالية إلى مجلد/Library/Fonts/Microsoft أو إلى المجلد/Library/Fonts/Microsoft/User/اسم المستخدمعند تثبيت "محول تنسيق ملفات XML المفتوحة" لنظام التشغيل Mac:
  • كامبريا
  • Calibri
  • كونسولاس
  • Constantia
  • كوربل
  • كندرا
هذه الخطوط تحسين توافق المستند والدقة المستند عند فتح المستندات التي تم إنشاؤها في نظام 2007 Microsoft Office ل Windows و Microsoft Office 2008 لأنظمة تشغيل mac.

المشكلات المعروفة للعمل مع ملفات تنسيق Open XML في Word 2004

قد تصادف المشاكل التالية عند استخدام Word 2004 للعمل مع مستند Word "تنسيق XML المفتوح ل":
  • لا يتم حفظ كائنات Word 2007 المعادلة.
  • تخطيطات جديدة من المستند والتنسيق المتوفرة في Word 2008 لنظام التشغيل Mac أو Word 2007 ل Windows لا تعرض بشكل صحيح في الملفات المحولة.
  • يتم اقتطاع كائنات HTML، مثل مربعات القائمة ومربعات النص في الملفات التي تم تحويلها.
  • لا يمكن تحويل 2008 Word Templates (.dotx) والخاص Word 2008 Templates (.dotm).
  • لا يمكن تحويل المستندات المحمية بواسطة كلمة مرور أو بإدارة حقوق المعلومات (IRM).
  • قد يتم تحويل صور نقطية للتعداد النقطي القياسية.
  • يتم تحويلها إلى نص حقول المراجع واستشهاد ولن يتم تحديثها تلقائياً في الملفات المحولة.
  • تعقب التغييرات قد لا يتم الاحتفاظ ألوان علامات المراجعة.
  • يتم تحويل المحتوى الذي تم نقله مع "تعقب التغييرات" قيد التشغيل إلى عمليات الإدراج والحذف.
  • يتم تحويل الصور الملونة إعادة إلى اللون الأصلي.
  • يتم تحويل أنماط الخطوط الصورة إلى نمط خط الرسم الأصلي.
  • يتم تحويل التعليقات التوضيحية بالحبر الرقمي للصور.
  • يتم تحويل رسومات SmartArt ومخططات الصور.
  • لا يتم حفظ العلامات المائية التي تتضمن خطوط هيراغانا.
  • استبدال الخطوط عند تغيير نص أفقي يستخدم الخط Meiryo إلى نص عمودي في ملف المحول.
  • تظهر التحذيرات والأخطاء المتعلقة بتحويل XML المفتوحة دائماً باللغة الإنكليزية.
  • لا يمكن فتح أو تحرير الكائنات التي تم إنشاؤها باستخدام محرر المعادلات في الملفات التي تم تحويلها.
  • عدم الاحتفاظ بالمستندات المفتوحة من تنسيق XML التي تم حفظها في Word 2004 أنماط "التنسيق السريع" عند فتحها في Word 2007.
  • لا يمكنك حفظ مستندات تنسيق Open XML متعددة في نفس الوقت في Word 2004.
  • لا يتم عرض محتوى المستند بشكل صحيح لأن هذا المحتوى قد يتضمن مخطط غير متوافق. يتم حفظ المستندات المفتوحة من تنسيق XML التي تم حفظها في Word 2004 في "وضع التوافق". لذلك، المحتوى الذي تم إنشاؤه في Word 2007 ل Windows أو Word 2008 لنظام التشغيل Mac قد لا تظهر أو تتصرف كما هو متوقع عند فتح المستند في تلك التطبيقات. لاستعادة المحتوى، قم بفتح المستند في Word 2008، انقر نقراً مزدوجاً فوق التخطيط لتحريره. ثم، عندما تتم مطالبتك، مخطط العقار. بعد التحويل، التبديل إلى Word ثم ثم حفظ المستند.
  • إذا قمت بتحرير في Word 2004 "رسم smartart"، قد تتغير خلفية لبعض "رسومات smartart" إلى اللون الأسود.
  • يتم تحويل رسومات SmartArt المضمنة بشكل غير متوقع إلى صور عند استخدام Word 2004 لحفظ مستند "تنسيق XML المفتوح".
  • لا يمكن تحرير المضمنة العروض التقديمية ل PowerPoint 2007، مخططات Excel 2007 أوراق، ومخططات Excel 2008 والأوراق في وثائق تنسيق Open XML في Word 2004.
  • الخيار لإرسال البريد على
    القائمة " ملف " في Word 2004 بإرسال المستندات بتنسيق مستند Word (.doc). يحدث هذا حتى إذا كان الملف الذي تقوم بإرساله في "تنسيق XML المفتوح".
  • عند فتح مستند في "تنسيق XML مفتوح"، لا يوفر مؤشر التقدم في Word 2004 قياسا دقيقا للتقدم.
  • إذا قمت بحفظ مستند تنسيق Open XML يحتوي على ماكرو في تنسيق Word 2008 الخاص المستند (.docm)، تتلقى رسالة خطأ "لم يتم العثور على ملف". على الرغم من ذلك، يمكن تجاهل هذه الرسالة بأمان.
  • يرجى مراعاة السيناريو التالي:
    1. فتح مستند Microsoft Office Word يستخدم ملحق اسم الملف.docm.
    2. لا يحتوي مستند Office Word هذا الماكرو أو التعليمات البرمجية ل Visual Basic.
    3. فتح محرر Visual Basic باستخدام القائمة الفرعية "ماكرو" في قائمة " أدوات ".
    في هذا السيناريو، سيتم فتح محرر Visual Basic دون مشروع متوفرة لمستند Office Word.

    لحل هذه المشكلة، حفظ المستند بتنسيق Word Document (.docx) وإغلاق وإعادة فتح المستند وقم بفتح Visual Basic Editor.I
  • يرجى مراعاة السيناريو التالي:
    1. مستخدمي Mac OS X 10.5 (Leopard) فتح مستند "تنسيق XML فتح".
    2. هذا المستند مخزن في مجلد شبكة.
    3. المستخدمين الاتصال إلى وحدة تخزين شبكة الاتصال باستخدام بروتوكول SMB
    في هذا السيناريو، يتم فتح المستند للقراءة فقط في Word 2004.

المشكلات المعروفة للعمل مع ملفات تنسيق Open XML في Excel 2004

قد تصادف المشاكل التالية عند استخدام Excel 2004 للعمل مع مصنف Excel في "تنسيق XML المفتوح":
  • لا يمكن تحويل المصنفات المحمية بواسطة كلمة مرور أو بإدارة حقوق المعلومات (IRM).
  • لا يتم حفظ أية بيانات تتجاوز 256 عمود أو صف 65,526. أي صيغة تشير البيانات في هذه المنطقة ترجع قيمة الخطأ "#REF!".
  • لا يتم حفظ عدة قواعد التنسيق الشرطي في خلية. يتوقف Excel التقييم بعد أول شرط يتم تقييمه وعرض.
  • لا يتم الاحتفاظ بالوظائف الجديدة في Excel 2008. هذه الدالات بإرجاع #NAME؟ قيمة الخطأ بدلاً من النتائج المحسوبة.
  • لا يتم حفظ الصيغ التي لها أكثر من 29 وسيطة المعرفة من قبل المستخدم. يتم تحويل هذه الصيغ إلى قيمة الخطأ "#VALUE!".
  • لا يتم الاحتفاظ بعناصر تحكم ActiveX غير المهيأة.
  • لا يتم حفظ الصيغ التي تحتوي على مراجع لجداول في مصنفات أخرى. يتم تحويل هذه المراجع إلى قيمة الخطأ "#REF!".
  • لا يتم حفظ الصيغ التي تحتوي على أكثر من 30 وسيطة في خلية. يتم تحويل هذه الصيغ إلى قيمة الخطأ "#VALUE!".
  • لا يتم حفظ أنواع التنسيقات الشرطية في نطاقات غير متجاورة.
  • لا يمكن تحويل تقارير PivotTable التي تحتوي على أكثر من 8 آلاف العناصر.
  • لا يتم حفظ الصيغ التي تتجاوز حد طول الداخلي (1800 حرفاً). يتم تحويل هذه الصيغ إلى قيمة الخطأ "#VALUE!".
  • لا يتم حفظ الصيغ التي تتجاوز حدود مستوى التداخل من سبعة مستويات. يتم تحويل هذه الصيغ إلى قيمة الخطأ "#VALUE!".
  • يتم تحويل تواريخ بتنسيق تقويم غير معتمد بشكل غير متوقع إلى تنسيق التقويم الميلادي.
  • لا يتم حفظ تنسيقات الخلايا الفريدة التي تتجاوز الحد الداخلي (أحرف 4,050).
  • لا يتم حفظ التنسيق الشرطي لخيار تنسيق الصف بأكمله .
  • لا يتم حفظ تاريخ التحقق من صحة الصيغ التي تحتوي على أكثر من 255 حرفاً.
  • تعرض الخلايا بتنسيقات شرطية أكثر من ثلاثة الشروط الثلاثة الأولى فقط.
  • لا يتم حفظ Excel 2008 التأثيرات المطبقة على الكائنات.
  • لا يتم حفظ تنسيقات الخطوط الفريدة التي تتجاوز حدود داخلية.
  • لا يتم حفظ الصيغ التي تحتوي على أكثر من 40 معامل. يتم تحويل هذه الصيغ إلى قيمة الخطأ "#VALUE!".
  • لا يتم الاحتفاظ بعوامل تصفية البيانات التالية:
    • مخصص
    • يستند إلى رمز
    • على أساس اللون
    • مجموعة التاريخ
    • أحدث 10
    • لون الخط
    • البيانات المستندة إلى شريط
  • لا يتم حفظ معايير الفرز اثنين أو أكثر.
  • لا يتم حفظ إعدادات Windows الخاصة للنشر على ويب التلقائية.
  • لا يتم حفظ عامل تصفية واحد أو أكثر على فرز.
  • يتم تحويل رسومات SmartArt إلى الصور.
  • لا يمكن فتح مستندات Word 2008 المرتبطة أو المضمنة ومصنفات Excel 2008 والعروض التقديمية PowerPoint 2008 أو تحريرها من الملفات المحولة.
  • لا يمكنك حفظ مصنفات تنسيق Open XML متعددة في نفس الوقت في Excel 2004.

المشكلات المعروفة للعمل مع ملفات تنسيق Open XML في PowerPoint 2004

قد تصادف المشاكل التالية عند استخدام PowerPoint 2004 للعمل مع عرض تقديمي ل PowerPoint في "تنسيق XML المفتوح":
  • لا يمكن تحويل العروض التقديمية المحمية بكلمة مرور أو بواسطة "إدارة حقوق المعلومات".
  • يتم تحويل التسطير المزدوج إلى تسطير مفرد.
  • لا يتم حفظ إعدادات تباعد الأحرف المخصصة.
  • لا يتم حفظ إعدادات التجانب في العروض التقديمية المحول إذا تم استخدام صورة متجانبة كخلفية لشريحة.
  • عروض PowerPoint التقديمية التي تحتوي على الكائنات التي لها تأثيرات ثلاثية الأبعاد قد يستغرق وقتاً طويلاً لتحويل.
  • التواريخ اليابانية مكدس غير العرض بشكل صحيح في تحويل الملفات.
  • يتم تحويل رسومات SmartArt إلى الصور.
  • يتم تحويل القوائم النقطية أكثر من خمسة مستويات للصور.
  • المحتوى الذي يتم تحويلها إلى صور تحتوي على خطوط بديلة إذا لم يكن لدى الكمبيوتر الخطوط من تثبيت العرض التقديمي الأصلي.
  • يتم تحويل الظلال الخفيفة إلى ظلال.
  • الشرائح الجديدة التي تمت إضافتها إلى ملف المحول يكون تخطيط فارغ بدلاً من تخطيط قائمة ذات تعداد نقطي.
  • لا يمكنك حفظ العروض التقديمية تنسيق Open XML متعددة في نفس الوقت في PowerPoint 2004.
  • لا يمكن فتح مستندات Word 2008 المضمنة ومصنفات Excel 2008 والعروض التقديمية PowerPoint 2008 أو تحريرها من الملفات المحولة.
  • عند تحويل PowerPoint 2008 الخاص قوالب (.potm) وقوالب 2008 (.potx)، يتم فتح مربع الحوار حفظ باسمعند حفظ ملف. ومع ذلك، يمكنك النقر فوق
    الخيار حفظ باسم في القائمة " ملف " لفتح
    شاشة حفظ باسم .
  • قد لا تظهر المخططات التي تم إنشاؤها في PowerPoint 2007 ل Windows أو PowerPoint 2008 لنظام التشغيل Mac أو قد لا تتصرف كما هو متوقع إذا حفظ عرض تقديمي في PowerPoint 2004 وقم بفتح المستند في برنامج PowerPoint 2007 أو PowerPoint 2008. لاستعادة فتح المحتوى، المستند في PowerPoint 2008، انقر نقراً مزدوجاً فوق التخطيط لتحريره وعندما تتم مطالبتك باختيار تحويل التخطيط. بعد التحويل، قم بالتبديل إلى PowerPoint ثم ثم حفظ المستند.
  • سوف تظهر المخططات التي تم إنشاؤها في PowerPoint 2007 ل Windows أو في PowerPoint 2008 لنظام التشغيل Mac كصور عند عرضها في PowerPoint 2004.
  • لا يمكن حفظ العروض التقديمية تمكين وحدات الماكرو في تنسيق ملف تم تمكين وحدات الماكرو في PowerPoint 2004. بالإضافة إلى ذلك، تحدث هذه المشكلة حتى إذا قمت بإزالة كافة وحدات الماكرو في العرض التقديمي.
  • قد تضيف PowerPoint 2004 ملحقات أسماء ملفات متعددة إلى اسم الملف. على سبيل المثال، قد يشبه اسم الملف "myfile. pptx.pptm." تحدث هذه المشكلة عند فتح عرض تقديمي يستخدم تنسيق تمكين وحدات الماكرو، إضافة ماكرو إلى العرض التقديمي، ثم حفظ العرض التقديمي بتنسيق تمكين وحدات الماكرو. لحل هذه المشكلة، عليك حذف ملحق اسم ملف تم تمكين وحدات الماكرو من اسم الملف في مربع الحوار حفظ باسم قبل حفظ الملف.
  • PowerPoint 2004 توقف عن الاستجابة عندما يتم تحويل عرض تقديمي "تنسيق XML مفتوح"، يجب إعادة تشغيل جهاز الكمبيوتر الخاص بك أو استخدام أداة "مراقبة النشاط" في المجلد/Applications/Utilities لإغلاق عملية Pptfc.app قبل أن تتمكن من فتح أو حفظ العروض التقديمية فتح تنسيق XML مرة أخرى.

مزيد من المعلومات

مواضيع ذات صلة لآخر التحديثات التي يمكنك تثبيتها

انقر فوق الارتباطات التالية للبحث عن المزيد من الخيارات إذا تعذر هذه المقالة في حل المشكلة:
منتجات الجهات الأخرى المذكورة في هذه المقالة تابعة لشركات مستقلة عن Microsoft. لا تقدم Microsoft أي ضمان، سواء ضمنياً أو صريحا، بخصوص أداء هذه المنتجات أو كفاءتها.
خصائص

رقم الموضوع: 953823 - آخر مراجعة: 14‏/01‏/2017 - المراجعة: 1

تعليقات