فقدان البيانات عند 0 بايت ترجع الدالة "تلقي" Winsock في حالة تشغيل تطبيقات الخادم والعميل على نفس الكمبيوتر الذي يقوم بتشغيل Windows Server 2003

الأعراض

يرجى مراعاة السيناريو التالي:
  • إجراء اتصال Winsock على جهاز كمبيوتر يقوم بتشغيل Windows Server 2003. تشغيل تطبيقات الخادم والعميل على هذا الكمبيوتر.
  • استدعاء دالة تلقي لتلقي البيانات.
في هذا السيناريو، تلقي تقوم الدالة بإرجاع 0 بايت عشوائياً. هذه القيمة التي تم إرجاعها من 0 بايت تتسبب في فقد البيانات. ومع ذلك، إذا قمت فورا باستدعاء الدالة تلقي مرة أخرى، يتم تلقي البيانات المتوقعة بنجاح.

السبب

برنامج تشغيل البروتوكول TCP/IP (Tcpip.sys) في تشغيل إجراء حدث قطع اتصال عشوائياً بينما طلب تلقي برنامج التشغيل. لذلك، تمت مقاطعة عملية نقل البيانات، وحدوث المشكلة المذكورة في قسم "الأعراض".

الحل

معلومات الإصلاح العاجل

يتوفر إصلاح عاجل معتمد من Microsoft. ومع ذلك، هذا الإصلاح العاجل الغرض منه هو حل المشكلة الموضحة في هذه المقالة فقط. قم بتطبيق هذا الإصلاح العاجل فقط على الأنظمة التي تواجه المشكلة الموضحة في هذه المقالة. قد يتم إجراء اختبارات إضافية على هذا الإصلاح العاجل. ولذلك، إذا لم يكن تأثير المشكلة كبيرا، نوصي بالانتظار حتى الإصدار التالي من تحديث البرنامج الذي يحتوي على هذا الإصلاح العاجل.

إذا كان يتوفر الإصلاح العاجل للتنزيل، يوجد مقطع "توفر تنزيل الإصلاح عاجل" أعلى مقالة قاعدة المعارف. في حالة عدم ظهور هذا القسم، اتصل بخدمة العملاء ل Microsoft والدعم للحصول على الإصلاح العاجل.

ملاحظة: في حالة حدوث مشكلات إضافية أو يجب إجراء استكشاف للأخطاء وحلها، قد يلزم إنشاء طلب خدمة منفصل. سيتم تطبيق تكاليف الدعم المعتادة على أسئلة الدعم الإضافية والمشكلات التي لا يعمل على حلها هذا الإصلاح العاجل بالتحديد. للحصول على قائمة أرقام هواتف خدمة العملاء ل Microsoft والدعم أو لإنشاء طلب خدمة منفصل، قم بزيارة موقع Microsoft التالي على الويب:ملاحظة: يعرض النموذج "توفر تنزيل الإصلاح العاجل" اللغات التي يتوفر الإصلاح الجديد. في حالة عدم ظهور اللغة الخاصة بك، يكون بسبب عدم توفر إصلاح عاجل لتلك اللغة.

المتطلبات الأساسية

لتطبيق هذا الإصلاح العاجل، يجب تشغيل الكمبيوتر في Windows Server 2003 Service Pack 2 (SP2).

متطلبات إعادة التشغيل

يجب إعادة تشغيل جهاز الكمبيوتر بعد تطبيق هذا الإصلاح العاجل.

معلومات استبدال الإصلاح العاجل


لا يحل هذا الإصلاح العاجل محل أية إصلاحات عاجلة تم إصدارها مسبقاً أخرى.

معلومات الملف

يحتوي إصدار اللغة الإنجليزية من هذا الإصلاح العاجل على سمات الملف (أو سمات الملف الأحدث) المسرودة في الجدول التالي. يتم سرد التواريخ والأوقات الخاصة بهذه الملفات بالتوقيت العالمي المتفق عليه (UTC). عند عرض معلومات الملف، يتم تحويلها إلى التوقيت المحلي. لمعرفة الفرق بين التوقيت العالمي المتفق عليه والتوقيت المحلي، استخدم علامة التبويب المنطقة الزمنية في عنصر التاريخ والوقت في "لوحة التحكم".
بالنسبة لكافة الإصدارات المستندة إلى x86 من نظام التشغيل Windows Server 2003 SP2 المعتمدة
اسم الملفإصدار الملفحجم الملفالتاريخالوقتالنظام الأساسي
Tcpip.sys5.2.3790.4531391,16816-Jun-200911:52x86
بالنسبة لكافة الإصدارات المستندة إلى إيتانيوم من Windows Server 2003 SP2 المعتمدة
اسم الملفإصدار الملفحجم الملفالتاريخالوقتالنظام الأساسي
Tcpip.sys5.2.3790.45311,311,23216-Jun-200913:13IA-64
لكافة الإصدارات المستندة إلى x64 من Windows Server 2003 حزمة الخدمة SP 2 و Windows XP SP2
اسم الملفإصدار الملفحجم الملفالتاريخالوقتالنظام الأساسي
Tcpip.sys5.2.3790.4531785,40816-Jun-200913:13x64

الحل البديل

للتغلب على هذه المشكلة، أعد محاولة الدالة تلقي من نفس مأخذ التوصيل إذا تم إرجاع 0 بايت من الدالة تلقي .

الحالة

أقرت Microsoft أن هذه مشكلة في منتجات Microsoft المسردة في قسم "ينطبق على".

مزيد من المعلومات

لمزيد من المعلومات حول دالة تلقي ، قم بزيارة موقع Microsoft التالي على الويب:لمزيد من المعلومات، انقر فوق رقم المقالة التالية لعرضها في "قاعدة معارف Microsoft":

824684 وصف للمصطلحات القياسية المستخدمة في وصف تحديثات برامج Microsoft


خصائص

رقم الموضوع: 971383 - آخر مراجعة: 13‏/01‏/2017 - المراجعة: 1

تعليقات