وحدة تحكم مجال المستندة إلى Windows Server 2003 قد بشكل غير صحيح إرجاع رمز الحالة "NO_SUCH_USER (0xc0000064)" في الاستجابة لطلبات تسجيل الدخول عند إيقاف أو إعادة تشغيل وحدة تحكم المجال

الأعراض

بشكل غير صحيح قد Windows Server 2003-وحدات التحكم بالمجال من إرجاع رمز حالة رمز الحالة "NO_SUCH_USER (0xc0000064)" في الاستجابة لطلبات تسجيل الدخول بعد إرجاع رمز الحالة "STATUS_INVALID_SERVER_STATE (0xc00000dc)" أو الرمز "STATUS_NO_MEMORY (0xc0000017)". يحدث هذا السلوك عندما يتم إيقاف تشغيل أو إعادة تشغيل وحدة التحكم بالمجال.

قد يتم إرجاع رمز الحالة إلى أحد أجهزة الكمبيوتر التالي:
  • كمبيوتر عضو المجال الذي تم إنشاء طلب تسجيل الدخول
  • خادم التطبيق
  • وحدة تحكم مجال إعادة توجيه طلب تسجيل الدخول إلى وحدة التحكم بالمجال باستخدام مصادقة المرور
رمز الحالة غير صحيح قد يؤدي التطبيق الذي تم إنشاء طلب تسجيل الدخول إلى فشل أو لمدة.

ملاحظة: قد تحدث هذه المشكلة حتى إذا قمت بتطبيق الإصلاح العاجل 942636.
942636 وحدات تحكم المجال المستندة إلى Windows Server 2003 قد بشكل غير صحيح إرجاع رمز الحالة "NO_SUCH_USER (0xc0000064)" في الاستجابة لطلبات تسجيل الدخول

السبب

تحدث هذه المشكلة لأن خدمة Net Logon بإدارة الحالة التي تم إرجاعها بشكل غير صحيح.

الحل

لحل هذه المشكلة، يجب تطبيق هذا الإصلاح العاجل على وحدات التحكم بالمجال المستندة إلى Windows Server 2003. بعد تطبيق هذا الإصلاح العاجل، وحدات التحكم بالمجال بإرجاع رمز الحالة "STATUS_NO_MEMORY (0xc0000017)" أثناء عملية إيقاف التشغيل. عندما يتلقى العميل هذا رمز الحالة، يحاول العميل للاتصال بوحدة تحكم مجال أخرى.

ملاحظة: راجع Windows يجب أن يكون أعضاء مجال Server 2003 الإصلاح العاجل جانب العميل 942636 تطبيقها، بشكل غير صحيح قد وحدات تحكم المجال المستندة إلى Windows Server 2003 942636 كيلو بايت من إرجاع رمز حالة رمز الحالة "NO_SUCH_USER (0xc0000064)" في الاستجابة لطلبات تسجيل الدخول.

معلومات الإصلاح العاجل

يتوفر إصلاح عاجل معتمد من Microsoft. ومع ذلك، هذا الإصلاح العاجل الغرض منه هو حل المشكلة الموضحة في هذه المقالة فقط. قم بتطبيق هذا الإصلاح العاجل فقط على الأنظمة التي تواجه المشكلة الموضحة في هذه المقالة. قد يتم إجراء اختبارات إضافية على هذا الإصلاح العاجل. ولذلك، إذا لم يكن تأثير المشكلة كبيرا، نوصي بالانتظار حتى الإصدار التالي من تحديث البرنامج الذي يحتوي على هذا الإصلاح العاجل.

إذا كان يتوفر الإصلاح العاجل للتنزيل، يوجد مقطع "توفر تنزيل الإصلاح عاجل" أعلى مقالة قاعدة المعارف. في حالة عدم ظهور هذا القسم، اتصل بخدمة العملاء ل Microsoft والدعم للحصول على الإصلاح العاجل.

ملاحظة: في حالة حدوث مشكلات إضافية أو يجب إجراء استكشاف للأخطاء وحلها، قد يلزم إنشاء طلب خدمة منفصل. سيتم تطبيق تكاليف الدعم المعتادة على أسئلة الدعم الإضافية والمشكلات التي لا يعمل على حلها هذا الإصلاح العاجل بالتحديد. للحصول على قائمة أرقام هواتف خدمة العملاء ل Microsoft والدعم أو لإنشاء طلب خدمة منفصل، قم بزيارة موقع Microsoft التالي على الويب:ملاحظة: يعرض النموذج "توفر تنزيل الإصلاح العاجل" اللغات التي يتوفر الإصلاح الجديد. في حالة عدم ظهور اللغة الخاصة بك، يكون بسبب عدم توفر إصلاح عاجل لتلك اللغة.

المتطلبات الأساسية

لتطبيق هذا الإصلاح العاجل، يجب تشغيل الكمبيوتر في Windows Server 2003 Service Pack 2 (SP2).

متطلبات إعادة التشغيل

يجب إعادة تشغيل جهاز الكمبيوتر بعد تطبيق هذا الإصلاح العاجل.

معلومات استبدال الإصلاح العاجل

لا يحل هذا الإصلاح العاجل أي إصلاح عاجل آخر.

معلومات الملف

يحتوي إصدار اللغة الإنجليزية من هذا الإصلاح العاجل على سمات الملف (أو سمات الملف الأحدث) المسرودة في الجدول التالي. يتم سرد التواريخ والأوقات الخاصة بهذه الملفات بالتوقيت العالمي المتفق عليه (UTC). عند عرض معلومات الملف، يتم تحويلها إلى التوقيت المحلي. لمعرفة الفرق بين التوقيت العالمي المتفق عليه والتوقيت المحلي، استخدم علامة التبويب المنطقة الزمنية في عنصر التاريخ والوقت في "لوحة التحكم".
بالنسبة لكافة الإصدارات المستندة إلى x86 من نظام التشغيل Windows Server 2003 SP2 المعتمدة
اسم الملفإصدار الملفحجم الملفالتاريخالوقتالنظام الأساسيمتطلب حزمة الخدمة
Ksecdd.sys5.2.3790.4616135,16806-Nov-200911:04x86SP2
Msv1_0.dll5.2.3790.4616146,94411-Nov-200910:08x86SP2
Schannel.dll5.2.3790.4530151,04016-Jun-200907:21x86SP2
بالنسبة لكافة الإصدارات المستندة إلى x64 من نظام التشغيل Windows Server 2003 SP2 المعتمدة
اسم الملفإصدار الملفحجم الملفالتاريخالوقتالنظام الأساسيمتطلب حزمة الخدمةفرع الخدمة
Ksecdd.sys5.2.3790.4616190,97612-Nov-200900:25x64SP2غير قابل للتطبيق
Msv1_0.dll5.2.3790.4616265,21612-Nov-200900:25x64SP2غير قابل للتطبيق
Schannel.dll5.2.3790.4530259,07212-Nov-200900:26x64SP2غير قابل للتطبيق
Wmsv1_0.dll5.2.3790.4616146,94412-Nov-200900:26x86SP2ياه
Wschannel.dll5.2.3790.4530151,04012-Nov-200900:26x86SP2ياه
بالنسبة لكافة الإصدارات المستندة إلى إيتانيوم من Windows Server 2003 SP2 المعتمدة
اسم الملفإصدار الملفحجم الملفالتاريخالوقتالنظام الأساسيمتطلب حزمة الخدمةفرع الخدمة
Ksecdd.sys5.2.3790.4616322,04812-Nov-200900:20IA-64SP2غير قابل للتطبيق
Msv1_0.dll5.2.3790.4616396,80012-Nov-200900:20IA-64SP2غير قابل للتطبيق
Schannel.dll5.2.3790.4530474,62412-Nov-200900:20IA-64SP2غير قابل للتطبيق
Wmsv1_0.dll5.2.3790.4616146,94412-Nov-200900:21x86SP2ياه
Wschannel.dll5.2.3790.4530151,04012-Nov-200900:21x86SP2ياه

الحل البديل

للتغلب على هذه المشكلة، إيقاف خدمة Net Logon قبل إيقاف تشغيل وحدة تحكم المجال يدوياً.

الحالة

أقرت Microsoft أن هذه مشكلة في منتجات Microsoft المسردة في قسم "ينطبق على".

مزيد من المعلومات

كيف تؤثر هذه المشكلة على التطبيقات

عند تلقي رمز الحالة رمز الحالة "NO_SUCH_USER" مجال أجهزة الكمبيوتر الأعضاء ووحدات التحكم بالمجال تأسيس قناة أمان جديدة إلى وحدة تحكم مجال أخرى قيد التشغيل بشكل صحيح. لذلك، قد طلبات تسجيل الدخول التي يتم إرسالها من قبل المستخدمين أو من قبل التطبيقات مهلة. التطبيق الذي تم إنشاء طلبات تسجيل الدخول قد تنقضي مهلة ربما تفشل إلا إذا كان التطبيق منطق تجاوز الفشل أو إعادة محاولة منطق.

يمكن تمكين المصادقة في أمان إنترنت وملقم تسريع (ISA) لتصفية حركة مرور شبكة الاتصال. أو قد تكون قد قمت بتمكين المصادقة في "خدمات معلومات الإنترنت" لمصادقة الوصول إلى موقع ويب. عندما يتم إيقاف تشغيل وحدة تحكم مجال، قد رفض المستخدمين الوصول إلى الملقم الوكيل أو إلى موقع ويب.

بالإضافة إلى ذلك، منع هذه المشكلة Microsoft BizTalk Server من العمل بشكل صحيح. إيقاف الخدمات BizTalk بشكل غير متوقع كل مرة يتم إعادة تشغيل وحدة تحكم مجال. يجب عليك إعادة تشغيل خدمات BizTalk يدوياً.


في هذا السيناريو، يتم تسجيل الأخطاء التالية في سجل التطبيق على الخادم الذي يستضيف خادم BizTalk:

معرف الحدث 6913

نوع الحدث: خطأ

مصدر الحدث: BizTalk Server 2006

فئة الحدث: BizTalk Server 2006

معرف الحدث: 6913

المستخدم: n/A

الكمبيوتر: < اسم الكمبيوتر >
الوصف: فشل محاولة الاتصال < اسم ملقم SQL > قاعدة بيانات SQL Server على ملقم < اسم الخادم > بالخطأ: "فشل تسجيل الدخول للمستخدم' (خالية) '. السبب: غير المقترنة مع اتصال SQL Server موثوق. ".
معرف الحدث 5410

نوع الحدث: خطأ

مصدر الحدث: BizTalk Server 2006

معرف الحدث: 5410

المستخدم: n/A

الكمبيوتر: < اسم الكمبيوتر >
الوصف: حدث خطأ تتطلب الخدمة BizTalk لإنهاء. الأسباب الأكثر شيوعاً هي التالية:

1) نفاد الذاكرة خطأ غير متوقع. أو

2) عدم قدرة على الاتصال أو فقدان الاتصال إلى إحدى قواعد البيانات BizTalk. سيتم إيقاف الخدمة وإعادة التشغيل التلقائي في دقيقة واحدة. إذا بقيت مشكوك قاعدة البيانات غير متوفرة، سيتم تكرار هذه الدورة.



رسالة الخطأ: فشل تسجيل الدخول للمستخدم '(خالية)'. السبب: غير المقترنة باتصال SQL Server موثوق به.

المصدر الخطأ: BizTalk

اسم المضيف: < اسم الخادم >
اسم خدمة Windows: < اسم الخدمة >
لتجنب حدوث هذا السيناريو، يمكنك استخدام برنامج نصي في إدارة التحكم بالخدمة لبدء تشغيل خدمات BizTalk إذا إيقاف الخدمات.

معلومات تصحيح الأخطاء

إذا قمت بتمكين تسجيل خدمة Net Logon، يتم تسجيل رمز الحالة لطلب تسجيل الدخول في الملف التالي:
%systemroot%\Debug\Netlogon.log
قد يتم تسجيل رمز الخطأ 0xC0000064 في ملف Netlogon.log على أجهزة الكمبيوتر التالي:
  • الكمبيوتر الذي تم إنشاء طلب تسجيل الدخول
  • وحدة تحكم المجال التي استجابت لطلب تسجيل الدخول
  • خادم التطبيق أو وحدة تحكم المجال الذي يقوم بإعادة توجيه الطلب إلى وحدة التحكم بالمجال
ملاحظة: الرمز رمز الحالة "NO_SUCH_USER (0xC0000064)" رمز إرجاع صالحة في حالة عدم وجود حساب المستخدم المصادقة. قد يحدث هذا الموقف إذا تحقق أحد الشروط التالية:
  • حساب مستخدم نسخ متماثل لها إلى مصادقة المجال.
  • تم حذف حساب المستخدم من خدمة دليل "Active Directory".
  • يتم تنسيق حساب المستخدم في طلب المصادقة بشكل غير صحيح عن طريق المستخدم أو التطبيق.
عندما يستجيب وحدة تحكم مجال إلى طلب تسجيل دخول التي تم تلقيها باستخدام مصادقة المرور، ملف Netlogon.log على وحدة تحكم مجال بتسجيل معلومات مشابهة لما يلي:
MM/DD HH:MM:SS [LOGON] CORP-DOMAIN: SamLogon: Transitive Network logon of <Domain name> \<User account> from CALLER (via <DC or member server>) Entered MM/DD HH:MM:SS [LOGON] CORP-DOMAIN: SamLogon: Transitive Network logon of <Domain name> \<User account> from CALLER (via <DC or member server>) Returns 0xC0000064  
عندما يستجيب وحدة التحكم بالمجال لطلب تسجيل دخول التي تم تلقيها مباشرة من كمبيوتر عضو في مجال في نفس المجال، ملف Netlogon.log على وحدة تحكم مجال بتسجيل معلومات مشابهة لما يلي:
MM/DD HH:MM:SS [LOGON] Samlogon: Network logon of <Domain name>\<User account> from CALLER Entered MM/DD HH:MM:SS [CRITICAL] NlPrintRpcDebug: Couldn't get EEInfo for I_NetLogonSamLogonEx: 1761 (may be legitimate for 0xc0000064) 
MM/DD HH:MM:SS [LOGON] Samlogon: Network logon of <Domain name>\<User account> from CALLER Returns 0xC0000064

لمزيد من المعلومات، انقر فوق رقم المقالة التالية لعرضها في "قاعدة معارف Microsoft":

تسجيل لخدمة Net Logon التصحيح تمكين 109626

لمزيد من المعلومات، انقر فوق رقم المقالة التالية لعرضها في "قاعدة معارف Microsoft":

824684 وصف للمصطلحات القياسية المستخدمة في وصف تحديثات برامج Microsoft


خصائص

رقم الموضوع: 973667 - آخر مراجعة: 13‏/01‏/2017 - المراجعة: 1

تعليقات