أنت غير متصل حاليًا، وفي انتظار الإنترنت الخاص بك ليقوم بإعادة الاتصال

لا يتم اعتماد كائنات بيانات التعاون (CDO) 1.2.1 مع Outlook 2010 والإصدارات الأحدث

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية2028411
الموجز

على الرغم من أنه يمكن استخدام مكتبة الكائنات كائنات بيانات التعاون (CDO) 1.2.1 مع Microsoft Outlook 2010 و Microsoft Outlook 2013، نحن لا ننصح أو دعم ذلك في أي شكل من الأشكال.

هام: يتم تطبيق هذا المقال إلى استخدام CDO 1.2.1 العميل مع Outlook 2010 والإصدارات الأحدث. ينطبق هذا باستخدام CDO 1.2.1 الذي يقوم بتثبيت النظام الفرعي MAPI والتي تم تصميمها للاستخدام على كمبيوتر دون Outlook.

معلومات أخرى

كائنات بيانات التعاون (CDO) 1.2.1 هو مكتبة عميل أن يوفر برنامج تضمين رفيع عبر وظيفة Extended MAPI. هذه المكتبة يستخدم عادة لإضافة البريد الإلكتروني المراسلة وظيفة لبرامج مخصصة. تسمح هذه المكتبة تلك البرامج أداء مهام مثل إرسال البريد الإلكتروني من خلال MAPI والعمل بالتقويمات والوصول إلى البيانات المختلفة في Microsoft Outlook أو في Microsoft Exchange.

بدءاً من Outlook 2007، CDO 1.2.1 لم يتم تضمينها مع Microsoft Outlook. ولكن CDO 1.2.1 فقط كتحميل لبرنامج Outlook 2007:

http://www.microsoft.com/downloads/details.aspx?FamilyID=2714320d-c997-4de1-986f-24f081725d36&DisplayLang=en

يمكن تثبيت هذا التحميل فقط على كمبيوتر يحتوي على تثبيت Outlook 2007. إذا لم يتم تثبيت Outlook، تتلقى رسالة الخطأ التالية عند تشغيل الملف ExchangeCdo.msi:

لا يمكن تثبيت كائنات بيانات التعاون 1.2.1 ما لم يتم أيضا تثبيت Microsoft Office Outlook 2007.

على الرغم من أنه لم يتم تثبيت الإصدار القابل للتنزيل من CDO عندما يتم تثبيت Outlook 2010 أو Outlook 2013، يمكن تثبيت CDO أولاً مع برنامج Outlook 2007 قبل الترقية إلى Outlook. في هذا السيناريو، لا يزال استخدام البرامج مكتبة CDO للتكامل مع Outlook 2010 وإصدار Outlook 2013 MAPI.

ومع ذلك، نوصي بتثبيت CDO أولاً قبل ترقية من Outlook 2007 Outlook إلى Outlook 2010 والإصدارات الأحدث.

Microsoft Outlook 2010 والإصدارات الأحدث تتضمن العديد من التغييرات المعمارية على النظام الفرعي MAPI العميل. أهمية خاصة وحدات سيناريو حيث تم تكوين Outlook لاستخدام عدة حسابات Exchange. أيضا، CDO 1.2.1 مكتبة عميل 32-بت ولن تعمل مع الإصدارات 64 بت من Outlook. ونظرا لكل هذه العوامل، CDO 1.2.1 غير معتمد للاستخدام مع Outlook 2013 أو Outlook 2010، ولا نوصي باستخدامها مع Outlook 2010 والإصدارات الأحدث.

يجب إعادة تصميم البرامج التي تستخدم CDO لاستخدام الأخرى "واجهات برمجة التطبيقات" (APIs) بدلاً من CDO. بدءاً من Outlook 2007، نموذج كائن Outlook تم زيادة كبيرة لتوفير وظيفة كانت متوفرة مسبقاً فقط باستخدام CDO 1.2.1. نموذج كائن Outlook 2010 و Outlook 2013 يتضمن بعض الميزات الجديدة التوسع في هذا أكثر. على سبيل المثال، يحتوي نموذج كائن Outlook وظائف جديدة العمل بشكل صحيح مع عدة حسابات Exchange. نموذج كائن Outlook يعمل أيضا على إصدارات كل من 32 بت و 64 بت من Outlook. يجب على المطورين استخدام Outlook 2010 ونموذج كائن لاحق بدلاً من CDO 1.2.1. أيضا، يمكن للمطورين لا يزال استخدام Extended MAPI (الذي يتطلب c + + غير مدار) في بعض وحدات السيناريو يلزم فيها CDO. ومع ذلك، إذا كان من الممكن، بشكل عام نوصي أنه يمكن استخدام نموذج كائن Outlook بدلاً من Extended MAPI.

يساعد دعم منتجات Microsoft العملاء المطور ترحيل برامج مخصصة من استخدام CDO 1.2.1 باستخدام واجهات برمجة التطبيقات الأخرى. ومع ذلك، لن يوفر Microsoft دعم لوحدات السيناريو التي يتم استخدام CDO 1.2.1 مع Outlook 2013 أو Outlook 2010.

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 2028411 - آخر مراجعة: 04/02/2013 21:57:00 - المراجعة: 4.0

  • kbmt KB2028411 KbMtar
تعليقات
tml>html>