كيفية إنشاء مربع تحرير وسرد Word يحتوي على أكثر من 25 عنصرا من قاعدة بيانات Microsoft Access

هام: تمت ترجمة هذه المقالة باستخدام برامج مايكروسوفت للترجمة الآلية ومن المحتمل ان يتم تحريرها او تدقيقها بعد ذلك من خلال تكنولوجيا منصة مجموعات الترجمة(CTF) او من خلال مترجم بشري. تقدم لك شركة مايكروسوفت هذه المقالات المترجمة بشكل آلي او بالترجمة البشرية او بعد تحريرها وتدقيقها من قبل مجموعات الترجمة حتى تمكنكم من الوصول إلى جميع المقالات الموجودة في قواعد المعرفة لديها بلغات مختلفة. إلا أن المقالات المترجمة قد تحتوي على أخطاء في المفردات او بناء الجمل او النحو. وعليه، فإن شركة مايكروسوفت ليست مسؤولة عن اية أخطاء او عدم دقة في الترجمة او أية أضرار قد تحدث نتيجة أخطاء في ترجمة محتويات النص او استخدامه من قبل العملاء.

اضغط هنا لرابط المقالة باللغة الانجليزية253542
للحصول على إصدار Microsoft Word 97 من هذه المقالة، راجع 253552.
الموجز
توضح هذه المقالة كيفية إنشاء واستخدام مربع تحرير وسرد في نموذج مستخدم كماكرو إدخال لحقل نموذج نص لإظهار معلومات من قاعدة بيانات Microsoft Access. يمكن استخدام هذا الماكرو كحل مؤقت للقيد البند 25 في حقول النماذج المنسدلة.

لمزيد من المعلومات حول كيفية القيام بذلك إذا كنت لا تستخدم قاعدة بيانات Microsoft Access، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
198561 كيفية إنشاء مربع التحرير وسرد الذي يحتوي على عناصر أكثر من 25
306258 كيفية إنشاء مربع التحرير وسرد الذي يحتوي على أكثر من 25 عنصرا في Word 2002
معلومات أخرى
تقدم Microsoft أمثلة برمجية للتوضيح فقط، دون أي ضمان صريح أو ضمني. هذا يتضمن، لكن لا يقتصر على، الضمانات الضمنية الخاصة بالتسويق أو الملاءمة لغرض معين. تفترض هذه المقالة أنك معتاد على لغة البرمجة التي يتم شرحها والأدوات المستخدمة لإنشاء الإجراءات وتصحيحها. يساعد مهندسو الدعم لدى Microsoft في شرح وظيفة إجراء محدد، لكنهم لن يقوموا بتعديل هذه الأمثلة لتقديم وظيفة إضافية أو إنشاء إجراءات تستوفي متطلبات محددة.
لمزيد من المعلومات، انقر فوق رقم المقالة التالي لعرضها في "قاعدة معارف Microsoft":
212536 كيفية تشغيل نموذج التعليمات البرمجية من مقالات قاعدة المعارف في Office 2000
في القالب الخاص بك، اتبع الخطوات التالية.

ملاحظة: لإغلاق إطار (على سبيل المثال، إطار التعليمات برمجية أو نافذة الخصائص )، انقر فوق X الموجودة في الزاوية اليسرى العليا من الإطار.

إنشاء مربع تحرير وسرد في نموذج مستخدم

  1. في Microsoft Office Word 2003 وفي الإصدارات السابقة، أشر إلى ماكرو في قائمة " أدوات " ومن ثم انقر فوق محرر Visual Basic.

    في الإصدار Word 2007، انقر فوق علامة التبويب المطور ، ومن ثم انقر فوق محرر Visual Basic
  2. في إطار المشروع ، حدد تيمبلاتيبروجيكت الخاصة بك.

    ملاحظة: إذا لم يظهر إطار Project ، انقر فوق مستكشف المشاريع في القائمة عرض .
  3. في القائمة إدراج ، انقر فوق نموذج مستخدم. يجب أن يظهر نموذج مستخدم جديد و عناصر تحكم مربع الأدوات . انقر بالزر الأيمن داخل نموذج مستخدمومن ثم انقر فوق عرض التعليمات البرمجية القائمة المختصرة. أضف التعليمات البرمجية التالية إلى حدث تهيئة :
    Option Explicit'Define VariablesPrivate Sub UserForm_Initialize()Dim dbDatabase As DatabaseDim rsNorthwind As RecordsetDim i As IntegerDim aResults()' This code activates the Database connection. Change ' the path to reflect your database.Set dbDatabase = OpenDatabase("C:\My Documents\NorthWind.mdb")' This code opens the Customers table.  Change the Table ' to reflect the desired table.Set rsNorthwind = dbDatabase.OpenRecordset("Customers", dbOpenSnapshot) i = 0    With rsNorthwind   ' This code populates the combo box with the values    ' in the CompanyName field.         Do Until .EOF         ComboBox1.AddItem (i)         ComboBox1.Column(0, i) = .Fields("CompanyName")         .MoveNext         i = i + 1      Loop   End WithEnd Sub					
  4. من القائمة أدوات ، انقر فوق " مراجع".
  5. انقر فوق Microsoft DAO 3.6 كائن مكتبة.
  6. انقر فوق موافق لإغلاق مربع حوار المراجع .
  7. قم بإغلاق إطار التعليمات البرمجية.
  8. انقر نقراً مزدوجاً فوق نموذج مستخدمومن ثم انقر فوق خصائص القائمة المختصرة. ضمن علامة التبويب Alphabetic ، إعادة تسمية (اسم) إلى فرمكومبوومن ثم إعادة تسمية توضيحية إلى Microsoft Word. إغلاق إطار خصائص نموذج مستخدم .
  9. من علامة التبويب عناصر التحكم من مربع الأدوات، حدد مربع تحرير وسرد ووضعه على نموذج مستخدم الخاص بك. زر الماوس الأيمن فوق عنصر تحكم مربع تحرير وسرد ومن ثم انقر فوق عرض التعليمات البرمجية القائمة المختصرة. تغيير رمز مربع تحرير وسرد إلى:
    Private Sub ComboBox1_Change()   ActiveDocument.FormFields("Text1").Result = ComboBox1.ValueEnd Sub
    ملاحظة: النص 1 هو اسم الإشارة المرجعية حقل النموذج النص التي تقوم بإدراجها في القالب الخاص بك في إجراء الخطوة 2 من "إنشاء حقل نموذج نصي" من هذه المقالة.
  10. قم بإغلاق إطار التعليمات البرمجية.
  11. ضمن علامة التبويب عناصر التحكم في مربع الأدوات، حدد CommandButton وضعه على نموذج المستخدم الخاص بك كزر إغلاق . انقر نقراً مزدوجاً فوق CommandButtonومن ثم انقر فوق عرض التعليمات البرمجية القائمة المختصرة. تغيير رمز CommandButton إلى:
    Private Sub Cmdclose_Click()   EndEnd Sub					
  12. قم بإغلاق إطار التعليمات البرمجية.
  13. انقر نقراً مزدوجاً فوق CommandButtonومن ثم انقر فوق خصائص القائمة المختصرة. ضمن علامة التبويب Alphabetic ، إعادة تسمية (اسم) إلى Cmdcloseومن ثم إعادة تسمية توضيحية إغلاق. إغلاق إطار خصائص CommandButton .
تم الآن الانتهاء من مربع تحرير وسرد في نموذج مستخدم. انتقل إلى الإجراء "إنشاء ماكرو الإدخال".

إنشاء ماكرو الإدخال

  1. في إطار المشروع، حدد تيمبلاتيبروجيكت الخاصة بك.
  2. من القائمة إدراج ، انقر فوق الوحدة النمطية. تظهر ورقة التعليمات برمجية في وحدة نمطية فارغة.
  3. اكتب التعليمات البرمجية التالية:
    Sub gocombobox()   frmcombo.ShowEnd Sub					
اكتمل الآن إدخال الماكرو. من القائمة ملف ، انقر فوق إغلاق ورجوع إلى Microsoft Word.

إنشاء حقل نموذج نصي

  1. في القالب الخاص بك، من القائمة عرض ، أشر إلى أشرطة الأدوات، ومن ثم انقر فوق نماذج.
  2. ضع نقطة الإدراج حيث تريد نتيجة القائمة المنسدلة إدراج. في شريط أدوات النماذج ، انقر فوق حقل نموذج نصي (الزر الأول على الجانب الأيمن). يتم إدراج حقل نموذج نصي إلى القالب التظليل الرمادي.

    ملاحظة: إذا كنت ترى الحقل { FORMTEXT} ، اضغط ALT + F9 لإيقاف تشغيل رموز الحقول.
  3. انقر نقراً مزدوجاً فوق حقل نموذج نصيومن ثم انقر فوق خصائص القائمة المختصرة.
  4. في مربع الحوار خيارات حقل نموذج نصي ضمن المقطع تشغيل الماكرو ، حدد الماكرو gocombobox من الإدخال: يسمى مربع التحرير والسرد.

    ملاحظة: تأكد من أن اسم الإشارة المرجعية حقل نموذج نصي الخاص بك هو نفسه الذي حددته في الخطوة رقم 9 للإجراء "إنشاء نموذج مستخدم السرد مربع" مسبقاً في هذه المقالة.
  5. في شريط أدوات النماذج ، انقر فوق حماية نموذج.
  6. احفظ وأغلق القالب الخاص بك.
لاستخدام القالب في Word 2003 وفي الإصدارات السابقة، انقر فوق جديد في القائمة ملف . حدد القالب ومن ثم انقر فوق موافق.

لاستخدام القالب في Word 2007، انقر فوق زر Microsoft Office، انقر فوق جديد، حدد القالب، وثم انقر فوق إنشاء.

يظهر مستند جديد استناداً إلى القالب الخاص بك. يظهر نموذج مستخدم يحتوي مربع تحرير وسرد مع العناصر عند استخدام المفتاح TAB للانتقال إلى حقل نموذج نصي.
رموز vba vbe المستخدم النموذج wd2002 wd2003 wd2007

تحذير: تمت ترجمة هذه المقالة تلقائيًا

Ιδιότητες

Αναγνωριστικό άρθρου: 253542 - Τελευταία αναθεώρηση: 10/04/2015 14:05:00 - Αναθεώρηση: 5.0

Microsoft Office Word 2007, Microsoft Word 2002 Standard Edition, Microsoft Word 2000 Standard Edition

  • kbhowto kbprogramming kbmt KB253542 KbMtar
Σχόλια