استكشاف أخطاء تثبيت عامل System Center Operations Manager وإصلاحها

الأعراض
يمكن نشر عامل System Center Operations Manager(SCOM) على أجهزة الكمبيوتر التي تعمل بنظام Windows إما عبر "الدفع البعيد" من خادم إدارة أو يمكن تثبيته يدويًا على كمبيوتر مستهدف باستخدام MomAgent.msi.إذا لم يتم تثبيت العامل بنجاح، فهناك عدد من خطوات استكشاف الأخطاء وإصلاحها التي يمكن استخدامها وفقًا لموقع حدوث الخطأ وكيفية نشر العامل.
الحل

تحقق من تلبية الكمبيوتر المستهدف للتكوين المدعوم
الخطوة الأولى في استكشاف أخطاء تثبيت عامل Operations Manager وإصلاحها على كمبيوتر يعمل بنظام Windows هي التحقق من تلبية العامل المحتمل لتكوين الأجهزة والبرامج المدعوم. تسرد المقالات التالية متطلبات عامل Operations Manager 2007 و2012:

تكوينات Operations Manager 2007 R2 المدعومة

تكوينات Operations Manager 2012 المدعومة

إذا كان النظام المستهدف هو كمبيوتر يعمل بنظام التشغيل Unix/Linux، فتأكد من دعم التوزيع والإصدار. يرجى ملاحظة أن دعم بعض إصدارات Operations Manager 2007 يستلزم التحديثات التراكمية التي تلي الإصدار R2. تحتوي المقالة التالية على الإصدارات المدعومة من Unix/Linux:

حزم إدارة مراقبة System Center Operations Manager 2007 R2 Cross Platform

إصدارات أنظمة تشغيل Unix وLinux المدعومة للعمل مع System Center Operations Manager 2012

استكشاف أخطاء نشر العامل وإصلاحها عبر معالج الاستكشاف في وحدة التحكم في Operations Manager
في حالة نشر العامل عن طريق الاستكشاف من وحدة التحكم في Operations Manager، سيتم تثبيت العامل من خادم الإدارة أو خادم البوابة المحدد في معالج الاستكشاف لإدارة العامل، وليس من الخادم الذي كانت وحدة التحكم في العمليات متصلة به عند فتحها. ولذلك، يجب إجراء أي اختبار من خادم الإدارة أو البوابة المحددة عند تشغيل المعالج أو يجب تحديد خادم إدارة/بوابة مختلفة خلال المعالج لمعرفة ما إذا كان نفس الخطأ يحدث أم لا.

  • المشكلة:
    لا يعرض المعالج قائمة بالعوامل المحتملة للتثبيت.

    السبب:
    يجب أن تحصل بيانات الاعتماد المحددة في المعالج خلال الاستكشاف الأولي على الإذن للبحث في Active Directory عن عوامل Operations Manager المحتملة. إذا كان هذا الحساب غير قادر على الاتصال بـ Active Directory، فسيتعرض "معالج الاستكشاف" للفشل.

    فيما يلي الأخطاء المعتادة التي تظهر:
    • رمز الخطأ: 800706BA
      وصف الخطأ: خادم RPC غير متوفر
    • رمز الخطأ: 80070079
      فشل خادم MOM في إجراء عملية محددة على الكمبيوتر "الاسم". انتهاء صلاحية مهلة الإشارة.
    • رمز الخطأ: 80070643
      فشل تثبيت Agent Management Operation Agent للكمبيوتر البعيد "الاسم"

    الحلول الممكنة:
    • خلال الاستكشاف، حدد حسابًا يحتوي على أذونات مسؤول المجال ويعد عضوًا في مجموعة مسؤولي Operations Manager.
    • في حالة انتهاء مهلة استعلام LDAP، أو عدم تمكنه من حل العوامل المحتملة في Active Directory، يمكن إجراء الاستكشاف عبر Operations Manager Command Shell. راجع القسم التالي"استكشاف أخطاء نشر العامل وإصلاحها عبر Operations Manager Command Shell"للحصول على معلومات إضافية.

  • المشكلة:
    الكمبيوتر المستهدف المعني غير موجود في قائمة العوامل المحتملة بعد تشغيل الاستكشاف الأولي.

    السبب:
    • الكمبيوتر محدد بالفعل في قاعدة البيانات كجزء من مجموعة الإدارة.
    • الكمبيوتر مدرج ضمن "الإجراءات المعلّقة" في وحدة التحكم في العمليات.

    الحلول الممكنة:
    • إذا كان الكمبيوتر المستهدف مدرجًا في العقدة "الإجراءات المعلّقة" ضمن المساحة "الإدارة" في وحدة التحكم في العمليات، فيتعين إما الموافقة على الإجراء الحالي أو رفضه قبل إمكانية تنفيذ إجراء جديد. إذا كانت إعدادات التثبيت الحالية كافية، فعليك اعتماد التثبيت المعلّق من وحدة التحكم. إذا كانت الإعدادات الحالية غير صحيحة، فعليك رفض الإجراء المعلّق، ثم تشغيل معالج الاستكشاف مرة أخرى.

  • المشكلة:
    يصادف معالج الاستكشاف أحد الأخطاء التالية عند محاولة تثبيت العامل:
    • العملية: تثبيت العامل
      رمز الخطأ: 800706D9
    • وصف الخطأ: خطأ غير معروف 0xC000296E
    • وصف الخطأ: خطأ غير معروف 0xC0002976
    • رمز الخطأ: 80070643
      وصف الخطأ: حدث خطأ فادح أثناء التثبيت.


    السبب:
    • يحتاج الحساب المحدد مسبقًا لتنفيذ تثبيت العامل في معالج الاستكشاف إلى امتلاك أذونات للاتصال عن بعد بالكمبيوتر المستهدف وتثبيت خدمة Windows. ويتطلب ذلك أذونات المسؤول المحلي بسبب المطلب الخاص بالكتابة إلى السجل.
    • قد تمنع قيود نهج المجموعة الموجودة على حساب كمبيوتر خادم الإدارة أو الحساب المستخدم لدفع العامل، من التثبيت الناجح. قد تمنع كائنات نهج المجموعة الموجودة في Active Directory والتي تمنع حساب كمبيوتر خادم الإدارة أو حساب المستخدم الذي يستخدمه معالج الاستكشاف للوصول البعيد إلى مجلد Windows أو السجل أو WMI أو المجلدات المشتركة الإدارية على الكمبيوتر المستهدف، من النشر الناجح لعامل Operations Manager.
    • يحظر "جدر حماية Windows" المنافذ بين خادم الإدارة والكمبيوتر المستهدف.
    • الخدمات المطلوبة على الكمبيوتر المستهدف لا تعمل.


    الحلول الممكنة:
    • إذا لم تكن بيانات الاعتماد المحددة في المعالج تمتلك أذونات المسؤولين المحليين، فأضف الحساب إلى مجموعة أمان المسؤولين المحليين على الكمبيوتر المستهدف أو استخدم حسابًا عضوًا بالفعل في هذه المجموعة.
    • قم بحظر توريث نهج المجموعة على الكمبيوتر المستهدف أو حساب المستخدم الذي ينفّذ التثبيت.

    • في حالة فشل تثبيت عامل عند استخدام حساب مجال لدفع العامل من خادم إدارة، قد يساعد استخدام أدوات Windows الإدارية في تحديد المشاكل المحتملة. قم بتسجيل الدخول إلى خادم الإدارة من خلال بيانات الاعتماد المعنية وحاول القيام بالمهام التالية. إذا لم يملك الحساب الإذن لتسجيل الدخول إلى خادم الإدارة، فيمكن تشغيل الأدوات من خلال بيانات الاعتماد ليتم اختبارها من موجه الأوامر.
      • "RUNAS /user: compmgmt.msc". من عنصر قائمة "الإجراء"، حدد "الاتصال بكمبيوتر آخر". استعرض أو اكتب اسم الكمبيوتر البعيد. حاول فتح عارض الأحداث واستعراض أي من سجلات الأحداث.
      • "RUNAS /user:services.msc". من عنصر قائمة "الإجراء"، حدد "الاتصال بكمبيوتر آخر". استعرض أو اكتب اسم الكمبيوتر البعيد. حاول بدء "تخزين مؤقت للطباعة" أو إيقافه، أو أي خدمة أخرى في الكمبيوتر المستهدف.
      • "RUNAS /user: regedt32.exe". من عنصر القائمة "ملف"، حدد "الاتصال بسجل الشبكة". استعرض أو اكتب اسم الكمبيوتر البعيد. حاول فتح "HKey_Local_Machine" على الجهاز البعيد.
      • "RUNAS /user:Explorer.exe". اكتب ما يلي في شريط العناوين: \\admin$

        في حالة فشل أي من المهام التالية، حاول استخدام حساب مختلف معروف بامتلاكه لأذونات مسؤول المجال أو المسؤول المحلي (على الكمبيوتر المستهدف). يمكنك أيضًا تجربة نفس المهام من خادم عضو أو محطة عمل لمعرفة ما إذا كانت المهام تفشل من أجهزة متعددة.
        قد يمنع الفشل في الاتصال بمشاركة admin$ خادم الإدارة من نسخ ملفات الإعداد إلى الكمبيوتر المستهدف. قد يؤدي الفشل في الاتصال بسجل Windows على الكمبيوتر المستهدف إلى عدم تثبيت "خدمة الحماية" بصورة صحيحة. يؤدي الفشل في الاتصال بمدير التحكم بالخدمة إلى منع الإعداد من بدء الخدمة.
    • يتعين فتح المنافذ التالية بين خادم الإدارة والكمبيوتر المستهدف:
      • معين نقطة نهاية RPC، رقم المنفذ: 135، البروتوكول: TCP/UDP
      • *المنافذ من 1024 إلى 5000 (نظام التشغيل 2000/2003) منافذ "عالية" RPC/DCOM، البروتوكول: TCP/UDP
      • *المنافذ من 49152 إلى 65535 (نظام التشغيل 2008) منافذ "عالية" RPC/DCOM، البروتوكول: TCP/UDP
      • خدمة أسماء NetBIOS، رقم المنفذ: 137، البروتوكول: TCP/UDP
      • خدمة جلسات عمل NetBIOS، رقم المنفذ: 139، البروتوكول: TCP/UDP
      • SMB عبر IP، رقم المنفذ: 445، البروتوكول: TCP
      • MOM Channel، رقم المنفذ: 5723، البروتوكول: TCP/UDP
    • يجب تمكين الخدمات التالية وتشغيلها على الكمبيوتر المستهدف:
      • Netlogon
      • التسجيل البعيد
      • Windows Installer
      • التحديثات التلقائية

توفر المقالات التالية بعض الخلفيات الجيدة حول نشر عامل Operations manager باستخدام الاستكشاف من خادم الإدارة:

كيفية نشر عامل Operations Manager 2007 باستخدام معالج إعداد العامل
كيف "يعمل اكتشاف الكمبيوتر" في OpsMgr 2007؟
استكشاف أخطاء الدفع واكتشاف العامل وإصلاحها في OpsMgr 2007
جدول استكشاف أخطاء نشر العامل المستند إلى وحدة التحكم وإصلاحها
إدارة الاكتشاف والعوامل في SCOM 2012

استكشاف أخطاء نشر العامل وإصلاحها عبر Operations Manager Command Shell
في بعض الحالات، قد تنتهي مهلة الاكتشاف التلقائي للعوامل المحتملة بسبب بيئات Active Directory المعقدة أو الكبيرة جدًا. قد تتطلب مواقف أخرى تشغيل الاكتشاف التلقائي باستخدام استعلام LDAP المحدود أكثر من المتوفر في واجهة المستخدم. وفي هذه الحالات، يكون الاكتشاف التلقائي لأجهزة الكمبيوتر والتثبيت البعيد لعامل Operations Manager ممكنًا عبر Operations Manager command shell. يتيح نشر المدونة التالي بناء الجملة المطلوب للقيام بذلك:

اكتشاف أجهزة كمبيوتر Windows بواسطة Powershell

استكشاف أخطاء نشر العامل وإصلاحها عبر تسجيل Windows Installer المطوّل
في حالة فشل تثبيت العامل على كمبيوتر بعيد خلال التثبيت، قد يتم إنشاء سجل Windows Installer المطوّل على خادم الإدارة في الموقع الافتراضي التالي:

C:\Program Files\System Center Operations Manager \AgentManagement\AgentLogs

عندما يكون إما 2007 أو 2012

يمكن استخدام السجل لتحديد ما إذا كان هناك خطأ محدد تتم مصادفته، وقد يكون مفيدًا لمزيد من الاستكشاف لأخطاء تثبيت عامل Operations Manager على الكمبيوتر المستهدف وإصلاحها.

ابحث عن الإدخال الأول من خلال السلسلة "Return Value 3" في السجل. ستوضح الأسطر القليلة السابقة عادة الخطأ الذي واجه Windows Installer. وسيكون التنسيق عادة بالصيغة "الوظيفة / وصف الخطأ / رمز إرجاع الخطأ"، ويمكنه الإشارة إلى مشاكل في الأذونات أو ملفات مفقودة أو إعدادات أخرى يجب تغييرها. أمثلة:

  • رسالة خطأ:
    فشل ConvertStringSecurityDescriptorToSecurityDescriptor: 87

    السبب المحتمل:
    لا يمتلك حساب التثبيت أذونات للوصول إلى سجل الأمان على الكمبيوتر المستهدف

  • رسالة خطأ:
    ModifyEventLogAccessForNetworkService(): يتعذر منح حق الوصول للقراءة إلى SecurityLog: 0x00000057

    السبب المحتمل:
    لا يمتلك حساب التثبيت أذونات للوصول إلى سجل الأمان على الكمبيوتر المستهدف

  • رسالة خطأ:
    يتعذر فتح ملف قاعدة البيانات. خطأ النظام -2147024629

    السبب المحتمل:
    لا يمتلك حساب التثبيت أذونات للوصول إلى مجلد TEMP الخاص بالنظام

هناك العديد من الأخطاء المحتملة التي يمكن تسجيلها هنا. يمكن إجراء المزيد من البحث عن الأخطاء الفردية الأخرى على TechNet أو قاعدة المعارف على الإنترنت.

استكشاف أخطاء التثبيت اليدوي لعامل Operations Manager وإصلاحها
في الحالات التي يتعذر خلالها نشر عامل Operations Manager على كمبيوتر بعيد عبر معالج الاكتشاف، يحتاج العامل للتثبيت يدويًا. يمكن إجراء ذلك عن طريق سطر الأوامر باستخدام الملف MomAgent.msi. توضح المراجع التالية المبدلات المتنوعة وخيارات التكوين المتاحة لتنفيذ تثبيت يدوي:

كيفية نشر عامل Operations Manager 2007 باستخدام MOMAgent.msi من سطر الأوامر
أوامر وحالات استخدام Windows Agent Install MSI
معالجة عمليات تثبيت العامل اليدوية في Operations Manager 2007

كيفية نشر عامل Operations Manager 2012 باستخدام سطر الأوامر

معالجة عمليات تثبيت العامل اليدوية في Operations Manager 2012

أمثلة حول استخدام الأمر MOMAgent لإدارة العوامل في Operations Manager 2012

في حالة نشر العامل عبر التثبيت اليدوي، تحتاج التحديثات التراكمية أو تحديثات حزم الخدمة المستقبلية إلى النشر اليدوي أيضًا. لن يتم تعيين أجهزة الكمبيوتر التي تم تثبيتها يدويًا بواسطة خدمة System Center Configuration Management كأجهزة قابلة للإدارة عن بعد، ولن يتم عرض خيار ترقيتها في وحدة التحكم في العمليات.

الاعتبارات الرئيسية الأخرى التي تتم مراعاتها أثناء التثبيت اليدوي للعوامل:

  • في حالة إجراء التثبيت عن طريق مستخدم محلي أو مجال، يجب أن يكون الحساب عضوًا ضمن مجموعة أمان المسؤولين المحليين في Vista أو أنظمة التشغيل الأحدث. في أنظمة التشغيل التي تسبق Vista، يمتلك المستخدمون الذين كانوا أعضاءً في مجموعة الأمان "المستخدمين الفائقين" الأذونات المطلوبة لتثبيت الخدمات.
  • في حالة نشر العامل عبر "مدير التكوين"، يجب تشغيل حساب خدمة "عامل مدير التكوين" إما كـ Localsystem (وهو الافتراضي) أو ضمن سياق المسؤول المحلي.

يمكن التعرف على الأخطاء التي تمنع تثبيت العوامل يدويًا في سجلات إعداد Windows Installer. يمكن استخدام الأمر التالي لتمكين تسجيل Windows Installer المطوّل لتثبيت عامل Operations Manager:
msiexec.exe /i "MOMAgent.msi" /l*v "C:\Agent\MOMAgent_install.log"

كحل بديل، توضح المقالة التالية كيفية تمكين تسجيل Windows Installer المطوّل بشكل عام على كمبيوتر يعمل بنظام Windows:
كيفية تمكين تسجيل Windows Installer

يمكن استخدام السجل لتحديد ما إذا كان هناك خطأ محدد تتم مصادفته، وقد يكون مفيدًا لمزيد من الاستكشاف لأخطاء تثبيت عامل Operations Manager على الكمبيوتر المستهدف وإصلاحها.

ابحث عن الإدخال الأول من خلال السلسلة "Return Value 3" في السجل. ستوضح الأسطر القليلة السابقة عادة الخطأ الذي واجه Windows Installer. وسيكون التنسيق عادة بالصيغة "الوظيفة / وصف الخطأ / رمز إرجاع الخطأ"، ويمكنه الإشارة إلى مشاكل في الأذونات أو ملفات مفقودة أو إعدادات أخرى يجب تغييرها.

أمثلة:

  • رسالة خطأ:
    فشل ConvertStringSecurityDescriptorToSecurityDescriptor: 87

    السبب المحتمل:
    لا يمتلك حساب التثبيت أذونات للوصول إلى سجل الأمان على الكمبيوتر المستهدف

  • رسالة خطأ:
    ModifyEventLogAccessForNetworkService(): يتعذر منح حق الوصول للقراءة إلى SecurityLog: 0x00000057

    السبب المحتمل:
    لا يمتلك حساب التثبيت أذونات للوصول إلى سجل الأمان على الكمبيوتر المستهدف

  • رسالة خطأ:
    يتعذر فتح ملف قاعدة البيانات. خطأ النظام -2147024629

    السبب المحتمل:
    لا يمتلك حساب التثبيت أذونات للوصول إلى مجلد TEMP الخاص بالنظام

هناك العديد من الأخطاء المحتملة التي يمكن تسجيلها هنا. يمكن إجراء المزيد من البحث عن الأخطاء الفردية الأخرى علىTechNet أو قاعدة المعارف على الإنترنت.

معلومات أخرى
تسري هذه المقالة على جميع إصدارات System Center Operations Manager 2007 (OpsMgr 2007) وجميع إصدارات System Center 2012 Operations Manager (OpsMgr 2012).
ملاحظة هذه عبارة عن مقالة "للنشر العاجل" تم إنشاؤها مباشرةً من قِبل منظمة الدعم الخاصة بـ Microsoft. وتم توفير المعلومات الواردة بها كاستجابةً للمشكلات البارزة. وكنتيجة للاستعجال في إتاحة هذه المقالة، فقد تحتوى المواد الواردة بها على بعض الأخطاء المطبعية وقد يتم مراجعتها في أي وقت بدون إشعار بذلك. راجع شروط الاستخدام لمعرفة الاعتبارات الأخرى.
خصائص

رقم الموضوع: 2566152 - آخر مراجعة: 10/06/2015 16:53:00 - المراجعة: 2.0

Microsoft System Center Operations Manager 2007, Microsoft System Center Operations Manager 2007 R2, Microsoft System Center Operations Manager 2007 Service Pack 1, Microsoft System Center 2012 Operations Manager, Microsoft System Center 2012 Operations Manager Service Pack 1

  • kbtshoot KB2566152
تعليقات