الوصول إلى إغلاق بشكل غير متوقع بعد تصدير كائن Microsoft Graph برمجياً

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية287022
تمت أرشفة هذه المقالة. وتظهر "كما هي" ولن يتم تحديثها بعد الآن.
متقدمة: يتطلب ترميز الخبير إمكانية التشغيل المتداخل و مهارات متعددة المستخدمين.

ينطبق هذا المقال إلى قاعدة بيانات Microsoft Access (.mdb) مشروع Microsoft Access (.adp).

الأعراض
بعد محاولة تصدير كائن Microsoft Graph برمجياً تتلقى رسالة الخطأ التالية:
فشلت العملية على كائن المخطط.

لم يتم تسجيل ملقم OLE.

لتسجيل ملقم OLE إعادة تثبيته.
عند النقر فوق موافق، تظهر رسالة الخطأ التالية ثم ثم يقوم Microsoft Access بإيقاف تشغيل:
Microsoft Access واجه مشكلة ويجب إغلاقه. نأسف للإزعاج.
الحل
هناك اثنين الحلول المحتملة لهذه المشكلة.

تعيين الخاصية "إجراء" إلى acOLEClose بعد التصدير الكائن

لأن كائن Microsoft Graph موجود في إطار كائن OLE ، يمكنك تعيين الخاصية "إجراء" إطار الكائن إلى acOLEClose. هذا يفرض ملقم OLE لإغلاق ، والذي يمنع حدوث الخطأ. ومع ذلك، على الرغم من أن هذا يمنع إيقاف التشغيل في الأسفل من حدوث كائن Microsoft Graph لن يمكن الوصول إليها حتى أغلق الأخرى ثم أعد فتح النموذج. لتعيين الخاصية "إجراء" إطار الكائن إلى acOLEClose اتبع الخطوات التالية:
  1. افتح قاعدة البيانات الذي تريد تصدير كائن Microsoft Graph.
  2. افتح النموذج الذي يحتوي على كائن Microsoft Graph في طريقة العرض "تصميم".
  3. إدراج رمز مشابهة لما يلي الحدث Click لزر أمر:
    Private Sub Command1_Click()Dim grpApp As Graph.ChartSet grpApp = Me.Graph1.ObjectgrpApp.Export "C:\Graph1.jpg", "JPEG"Me.Graph1.Locked = FalseMe.Graph1.Enabled = TrueSet grpApp = NothingMe.Graph1.Action = acOLECloseEnd Sub 					
  4. من القائمة ملف، انقر فوق إغلاق ورجوع إلى Microsoft Access.
  5. من القائمة ملف، انقر فوق حفظ ثم قم بحفظ النموذج.
  6. من القائمة عرض، انقر فوق عرض النموذج. لاحظ أنه يتم فتح النموذج عرض كائن Microsoft Graph.
  7. انقر فوق زر الأمر لتصدير كائن Microsoft Graph إلى ملف C:\Graph1.jpg.
  8. من القائمة عرض، انقر فوق "طريقة العرض" تصميم ". لاحظ أن يفتح النموذج في طريقة العرض "تصميم" بدون أية أخطاء.

إنشاء كائن PivotChart بدلاً من استخدام Microsoft Graph

عند استخدام طريقة عرض PivotChart للنماذج في Microsoft Access يمكنك تصدير المخطط برمجياً إلى ملف رسومات تجنب المشكلة. إنشاء PivotChart برمجياً تصدير إلى ملف رسومات اتبع الخطوات التالية:
  1. افتح نموذج قاعدة البيانات Northwind.mdb.
  2. من القائمة إدراج ، انقر فوق "نموذج".
  3. في مربع الحوار نموذج جديد ، انقر فوق نموذج تلقائي: عمودي ، انقر فوق السهم في المربع اختيار الجدول أو الاستعلام موضع بيانات الكائن انقر فوق الاستعلام المبيعات حسب الفئة في القائمة ثم انقر فوق موافق.
  4. من القائمة عرض، انقر فوق "طريقة العرض" تصميم ".
  5. من القائمة عرض، انقر فوق خصائص.
  6. من القائمة تحرير ، انقر فوق تحديد نموذج.
  7. في صفحة الخصائص للنموذج انقر فوق علامة التبويب تنسيق ثم قم بتغيير خاصية "طريقة_العرض_الافتراضية إلى PivotChart.
  8. من القائمة عرض، انقر فوق طريقة عرض PivotChart.
  9. اسحب الحقل CategoryName من قائمة الحقول إلى ناحية الإفلات إفلات حقول الفئات هنا.
  10. اسحب الحقل ProductSales من قائمة الحقول إلى ناحية الإفلات إفلات حقول البيانات هنا. لاحظ أن يظهر مخطط الذي يظهر في المجموع ProductSales حسب الفئة.
  11. من القائمة ملف، انقر فوق إغلاق. عندما تتم مطالبتك بحفظ انقر فوق نعم ، ثم احفظ النموذج frmPivotChart.
  12. من القائمة إدراج ، انقر فوق "نموذج".
  13. انقر فوق طريقة العرض "تصميم" ومن ثم انقر فوق "موافق" دون تحديد جدول أو استعلام.
  14. اسحب النموذج frmPivotChart من إطار قاعدة البيانات إلى نموذج جديد لإنشاء نموذج فرعي.
  15. من القائمة عرض، انقر فوق خصائص.
  16. انقر فوق كائن النموذج الفرعي.
  17. في صفحة الخصائص، انقر فوق علامة التبويب غير ذلك ثم قم بتعيين خاصية الاسم إلى frmPivotChart.
  18. إضافة زر أمر إلى النموذج الرئيسي وتعيين خاصية الاسم الخاص به إلى Command1.
  19. في القائمة عرض، انقر فوق الرمز لعرض الوحدة النمطية للنموذج.
  20. إضافة التالية Visual Basic for Applications برمجية إلى حدث النقر لزر الأمر:
    Private Sub Command1_Click()    Dim frm As Access.Form    Set frm = Me.frmPivotChart.Form    frm.ChartSpace.ExportPicture "C:\PivotChart1.jpg", "JPEG"End Sub					
  21. من القائمة ملف، انقر فوق إغلاق ورجوع إلى Microsoft Access.
  22. من القائمة ملف، انقر فوق حفظ ثم قم بحفظ النموذج كـ frmMain.
  23. من القائمة عرض، انقر فوق عرض النموذج. لاحظ أنه يتم عرض النموذج الفرعي في طريقة عرض PivotChart.
  24. انقر فوق زر الأمر لتصدير PivotChart إلى ملف C:\PivotChart1.jpg.
  25. من القائمة عرض، انقر فوق "طريقة العرض" تصميم ".
لاحظ أن يفتح النموذج في طريقة العرض "تصميم" بدون أية أخطاء.
تصريح
أقرت Microsoft أن هذه مشكلة في منتجات Microsoft المسردة في قسم "تنطبق على".
معلومات أخرى

خطوات إعادة إنشاء السلوك

تحذير: إذا اتبع الخطوات الموجودة في هذا المثال, يمكنك تعديل نموذج قاعدة البيانات Northwind.mdb. قد ترغب في نسخة احتياطية من ملف Northwind.mdb ثم اتبع الخطوات التالية على نسخة من قاعدة البيانات.

  1. افتح نموذج قاعدة البيانات Northwind.mdb.
  2. من القائمة إدراج ، انقر فوق "نموذج".
  3. في مربع الحوار نموذج جديد انقر فوق معالج التخطيطات انقر فوق السهم في المربع اختيار الجدول أو الاستعلام موضع بيانات الكائن ، وانقر فوق الاستعلام المبيعات حسب الفئة في القائمة ثم انقر فوق موافق.
  4. إضافة حقول CategoryName و ProductSales إلى المربع الحقول لمخطط ثم انقر فوق إنهاء. لاحظ أن يفتح نموذج جديد مع كائن Microsoft Graph عليه.
  5. من القائمة عرض، انقر فوق "طريقة العرض" تصميم ".
  6. من القائمة عرض، انقر فوق خصائص.
  7. حدد الكائن MSGraph لعرض خصائصها.
  8. على علامة التبويب غير ذلك بتعيين خاصية الاسم إلى Graph1.
  9. إضافة زر أمر إلى النموذج وتعيين خاصية الاسم الخاص به إلى Command1.
  10. في القائمة عرض، انقر فوق الرمز.
  11. من القائمة أدوات ، انقر "مراجع".
  12. في مربع الحوار مراجع انقر لتحديد خانة الاختيار إلى جانب مكتبة كائنات Microsoft Graph 10.0. إذا لم تكن ترى هذه المكتبة، انقر فوق الزر استعراض الاستعراض بحثاً عن ملف Office\Office10\Graph.exe Files\Microsoft C:\Program ثم انقر فوق فتح.
  13. انقر فوق موافق لإغلاق مربع الحوار مراجع.
  14. إضافة التالية Visual Basic for Applications برمجية إلى الوحدة النمطية للنموذج:
    Private Sub Command1_Click()    Dim grpApp As Graph.Chart    Set grpApp = Me.Graph1.Object    grpApp.Export "C:\Graph1.jpg", "JPEG"    Set grpApp = NothingEnd Sub					
  15. من القائمة ملف، انقر فوق إغلاق ورجوع إلى Microsoft Access.
  16. من القائمة ملف، انقر فوق حفظ ثم احفظ النموذج Form1.
  17. من القائمة عرض، انقر فوق عرض النموذج. لاحظ أنه يتم فتح النموذج عرض كائن MSGraph.
  18. انقر فوق زر الأمر لتصدير كائن Microsoft Graph إلى ملف C:\Graph1.jpg.
  19. من القائمة عرض، انقر فوق "طريقة العرض" تصميم ". لاحظ ظهور رسالة الخطأ التالية:
    فشلت العملية على كائن المخطط.

    لم يتم تسجيل ملقم OLE.

    لتسجيل ملقم OLE إعادة تثبيته.
  20. انقر فوق موافق.
لاحظ أن تتلقى رسالة الخطأ التالية ثم يقوم Access بإيقاف تشغيل:
Microsoft Access واجه مشكلة ويجب إغلاقه. نأسف للإزعاج.
pra

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 287022 - آخر مراجعة: 02/04/2014 21:44:13 - المراجعة: 3.0

Microsoft Access 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbprb kbnofix KB287022 KbMtar
تعليقات