كيفية إنشاء "مصنف الماكرو الشخصي" في Excel لـ Mac

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية288117
تمت أرشفة هذه المقالة. وتظهر "كما هي" ولن يتم تحديثها بعد الآن.
الموجز
توضح هذه المقالة كيفية إنشاء "مصنف الماكرو الشخصي" الكتابة والتحرير Microsoft Visual Basic لوحدات الماكرو Applications (VBA) التي لا يمكنك تسجيل.
معلومات أخرى

كيفية إنشاء مصنف ماكرو الشخصي

إن أسهل طريقة لإنشاء "مصنف الماكرو الشخصي" لتسجيل ماكرو "زائف". للقيام بذلك، اتبع الخطوات التالية:
  1. بدء تشغيل Excel بحيث يتم فتح مصنف جديد. من القائمة أدوات، أشر إلى ماكرو ، ثم انقر فوق تسجيل ماكرو جديد.
  2. في مربع الحوار "تسجيل ماكرو" ، انقر فوق "مصنف الماكرو الشخصي" في القائمة تخزين الماكرو.
  3. انقر فوق موافق. لأنك تقوم بإنشاء ماكرو "زائف" لا تقم انقر فوق أو كتابة شيء.
  4. في شريط الأدوات الذي يظهر, انقر فوق الزر إيقاف التسجيل.
  5. من القائمة Excel ، انقر فوق "إنهاء". أو للحصول على إصدارات Excel السابقة من Excel X انقر فوق "إنهاء" من القائمة ملف.
  6. انقر فوق حفظ عندما تتم مطالبتك بحفظ التغييرات.
عند بدء تشغيل Excel يفتح هذا "مصنف الماكرو الشخصي" مصنف مخفي. بشكل افتراضي، يتم تخزينه في المسار التالي استناداً إلى إصدار Excel.

في Excel 98 و في Excel 2001
Microsoft Office folder: مصنف الماكرو Office: بدء التشغيل: Excel: شخصي
في Excel X أو الإصدارات الأحدث
Hard disk drive: version التطبيقات: Microsoft Office:Office:Startup:Excel:Personal "مصنف الماكرو"

كيفية استخدام مصنف ماكرو الشخصي

الكتابة أو تحرير التعليمات البرمجية لـ VBA في "مصنف الماكرو الشخصي" ، اتبع الخطوات التالية:
  1. من القائمة أدوات، أشر إلى ماكرو ، ثم انقر فوق محرر Visual Basic.
  2. في الإطار "مشروع VBA - المشروع" ، انقر نقراً مزدوجاً فوق VBAProject (مصنف الماكرو الشخصي) لعرض مجلد الوحدات النمطية ضمن.
  3. انقر نقراً مزدوجاً فوق المجلد الوحدات النمطية لعرض أية وحدات نمطية في هذا المشروع ثم انقر نقراً مزدوجاً فوق الوحدة نمطية لعرض التعليمات البرمجية أو ورقة فارغة التعليمات البرمجية الخاصة به.

    يمكنك استخدام صفحة التعليمات البرمجية هذه كتابة وتحرير التعليمات البرمجية لـ VBA.
أتمتة XL2004 XL2001 XL98 MAC MacXLX برنامج VBA البرمجية بدء سجل ماكرو شخصي الأتمتة التحرير

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 288117 - آخر مراجعة: 12/06/2015 00:24:05 - المراجعة: 3.4

Microsoft Excel 2004 for Mac, Microsoft Excel X لـ Mac, Microsoft Excel 2001 لـ Macintosh, Microsoft Excel 98 لـ Macintosh

  • kbnosurvey kbarchive kbmt kbdtacode kbhowto KB288117 KbMtar
تعليقات