تقوم حذر تزامن الدليل يتوقف Azure Active Directory أو أنه لم تسجيل المزامنة في أكثر من يوم واحد

هام: تمت ترجمة هذه المقالة باستخدام برامج مايكروسوفت للترجمة الآلية ومن المحتمل ان يتم تحريرها او تدقيقها بعد ذلك من خلال تكنولوجيا منصة مجموعات الترجمة(CTF) او من خلال مترجم بشري. تقدم لك شركة مايكروسوفت هذه المقالات المترجمة بشكل آلي او بالترجمة البشرية او بعد تحريرها وتدقيقها من قبل مجموعات الترجمة حتى تمكنكم من الوصول إلى جميع المقالات الموجودة في قواعد المعرفة لديها بلغات مختلفة. إلا أن المقالات المترجمة قد تحتوي على أخطاء في المفردات او بناء الجمل او النحو. وعليه، فإن شركة مايكروسوفت ليست مسؤولة عن اية أخطاء او عدم دقة في الترجمة او أية أضرار قد تحدث نتيجة أخطاء في ترجمة محتويات النص او استخدامه من قبل العملاء.

اضغط هنا لرابط المقالة باللغة الانجليزية2882421
المشكلة
تواجه أحد الأعراض التالية:
  • أداة مزامنة Active Directory Microsoft Azure إيقاف المزامنة.
  • يمكنك تلقي رسائل البريد الإلكتروني التي تفيد بأنه لم يسجل Azure Active Directory (Azure AD) بمحاولة مزامنة في الساعات ال 24 الأخيرة.
  • في أداة MIISClient.exe، ظهور رسالة "توقف ملقم أسفل" أو "متوقف-ملحق-DLL-استثناء".
  • أنت غير قادر على بدء تشغيل واحد أو أكثر من خدمات مزامنة الدليل.
  • مستكشف أخطاء "مزامنة دليل" يشير إلى وجود مشاكل تمنع بدء تشغيل خدمات مزامنة دليل واحد أو أكثر.
ملاحظة: افتراضياً، يعمل تزامن الدليل كل ثلاث ساعات.
السبب
قد تحدث هذه المشكلة إذا كان واحد أو أكثر من الشروط التالية صحيحاً:
  • لدى الحساب العمل أو المدرسة التي استخدمت لإعداد المزامنة الدليل في معالج تكوين إحدى المشاكل التالية:
    • تم حذف الحساب.
    • تم تعطيل الحساب.
    • انتهت مدة صلاحية كلمة مرور الحساب.
  • له حساب تسجيل الدخول لخدمة مزامنة دليل أو أكثر من المشاكل التالية:
    • تم حذف الحساب.
    • تم تعطيل الحساب.
    • انتهت مدة صلاحية كلمة مرور الحساب.
    ملاحظة: يتم تلقائياً تكوين حساب تسجيل الدخول لخدمة المزامنة الدليل ولا يمكن تعديلها.
  • تم تغيير حساب المسؤول الذي يستخدم لمزامنة الدليل.
  • وجود مشكلات في اتصال الشبكة.
  • تم إيقاف خدمات مزامنة الدليل.
الحل
ملاحظة: إذا قمت بتشغيل مستكشف أخطاء المزامنة الدليل وأشار إلى أن هناك مشكلة مع حساب تسجيل الدخول لإحدى الخدمات، انتقل إلى "الطريقة الثانية".

الطريقة الأولى: تشغيل مستكشف أخطاء "مزامنة الدليل"

يمكنك حل هذه المشكلة عن طريق تشغيل مستكشف أخطاء المزامنة الدليل على الخادم الذي تم تثبيت الجهاز Azure تزامن خدمة active Directory. يمكن أن يكون جهاز Azure تزامن خدمة active Directory مما يلي:
  • الاتصال azure Active Directory
  • أداة مزامنة Active Directory azure

الطريقة الثانية: التحقق يدوياً بدء تشغيل الخدمة وأن حساب مسؤول تسجيل الدخول

  1. انقر فوق ابدأ، ثم انقر فوق تشغيل، نوع Services.msc، ثم انقر فوق موافق.
  2. تحديد موقع خدمة أجهزة Azure تزامن خدمة active Directory، وثم تحقق من ما إذا كان يتم تشغيل الخدمة. إذا لم يتم بدء تشغيل الخدمة، انقر بالزر الأيمن، وانقر فوقابدأ.
    • إذا كنت تستخدم "أداة مزامنة Active Directory أزور"، ابحث عن خدمة مزامنة Active Directory Azure.
    • إذا كنت تستخدم "اتصال الدليل النشط أزور"، ابحث عن تزامن إعلان Azure Microsoft.
  3. تأكد من أن حساب المسؤول الذي يتم استخدامه لتزامن الدليل لا يزال قائما وأنه أتاح لتسجيل الدخول. إذا لم يكن الحساب لا يزال موجوداً، إعادة تعيين كلمة المرور ومن ثم تحقق من إمكانية تسجيل دخولك. إذا تم مطالبتك، يمكنك تغيير كلمة المرور.

    إذا كنت لا تعرف حساب المسؤول العمومي الذي يستخدم لتكوين تزامن الدليل، اتبع الخطوات التالية على الخادم الذي قمت بتثبيت الجهاز مزامنة الدليل:
    1. الانتقال إلى %ProgramFiles%\Microsoft أزور AD Sync\UIShell\، ثم قم بتشغيل Miisclient.exe.

      ملاحظة: إذا كنت تستخدم الاتصال الدليل النشط Azure أو خدمة المزامنة Azure Active Directory، انقر فوق ابدأ، ثم ابحث عن وفتح خدمة المزامنة.
    2. انقر فوق الروابط، وانقر نقراً مزدوجاً فوق الموصل Azure Active Directory.
    3. انقر فوق اتصال.
    4. دون قيمة اسم المستخدم . هذا هو حساب المسؤول العمومي الذي يستخدم لتكوين تزامن الدليل.
  4. على ملقم المزامنة الدليل، تشغيل معالج تكوين الجهاز Azure تزامن خدمة active Directory واكتب كلمة المرور لحساب المسؤول الذي يستخدم لمزامنة الدليل وثم اتبع الخطوات المتبقية في المعالج.
  5. عند مطالبتك، حدد فرض المزامنة الدليل خانة الاختيار.

الطريقة الثالثة: حل المشكلة مع حساب تسجيل الدخول لخدمة المزامنة الدليل

  1. انقر فوق ابدأ، ثم انقر فوق تشغيل، نوع Services.msc، ثم انقر فوق موافق.
  2. تحديد موقع خدمة أجهزة Azure تزامن خدمة active Directory:
    • إذا كنت تستخدم "أداة مزامنة Active Directory أزور"، ابحث عن خدمة مزامنة Active Directory Azure.
    • إذا كنت تستخدم "اتصال الدليل النشط أزور"، ابحث عن تزامن إعلان Azure Microsoft.
    انقر نقراً مزدوجاً فوق الخدمة ومن ثم انقر فوقخصائص. في التبويب تسجيل الدخول ، لاحظ اسم الحساب المذكور.

    ملاحظة: إعادة تكوين أي خدمات مزامنة دليل تسجيل الدخول كحساب نظام محلي غير معتمد وقد ينتج عن المشاكل.
  3. على وحدة تحكم بمجال أو جهاز كمبيوتر يحتوي على "أدوات إدارة" تثبيت، فتح مستخدمي Active Directory وأجهزة الكمبيوتر (Dsa.msc)، زر الماوس الأيمن فوق اسم المجال ومن ثم حددالبحث. اكتب اسم الحساب الذي قمت بتدوينه في الخطوة 2، ومن ثم انقر فوق البحث الآن.
    • في حالة العثور على الحساب، انتقل إلى الخطوة 4.
    • إذا تعذر العثور الحساب، قد يكون تم حذفه. لمزيد من المعلومات حول كيفية استعادة هذا الحساب، راجعدليل خطوة بخطوة سلة المحذوفات active Directory. لا يمكنك استعادة الحساب، سيكون لديك لتثبيت وإعادة عميل المزامنة الدليل.
  4. انقر نقراً مزدوجاً فوق الحساب ومن ثم انقر فوق خصائص. ضمن علامة التبويب حساب ، ضمن خيارات الحساب،اتبع الخطوات التالية:
    1. تأكد من تحديد خانة الاختيار عدم انتهاء صلاحية كلمة المرور .
    2. تأكد منالحساب معطل تم مسح خانة الاختيار. ثم، قم بأحد الإجراءات التالية:
      • إذا تم تحديد خانة الاختيار الحساب معطل ، إلغاء تحديدها لتمكين الحساب. ثم أعد تشغيل خدمة أجهزة Azure تزامن خدمة active Directory. للقيام بذلك، انقر فوق ابدأ، ثم انقر فوق تشغيل، نوع Services.msc، ثم انقر فوق موافق. تحديد موقع الخدمة وانقر بالزر الأيمن ثم انقر فوقإعادة التشغيل.
        • إذا كنت تستخدم "أداة مزامنة Active Directory أزور"، ابحث عن خدمة مزامنة Active Directory Azure.
        • إذا كنت تستخدم "اتصال الدليل النشط أزور"، ابحث عن تزامن إعلان Azure Microsoft.
      • إذا تم مسح خانة الاختيار الحساب معطلمسبقاً، انتقل إلى الخطوة 5.
  5. إذا تم مسح بوكسيس الاختيار الحساب معطلمسبقاً، فمن الممكن أنه تم تغيير كلمة المرور للحساب يدوياً. لتعيين كلمة مرور جديدة وفتح مستخدمي Active Directory وأجهزة الكمبيوتر، حدد وانقر بالزر الأيمن الحساب وثم انقر فوقإعادة تعيين كلمة المرورلإعادة تعيين كلمة المرور. لاحظ كلمة المرور التي قمت بتعيينها لأنه يجب عليك استخدامه في الخطوة التالية.
  6. تعيين كلمة المرور على حساب تسجيل الدخول لخدمات مزامنة الدليل. للقيام بذلك، اتبع الخطوات التالية:
    1. انقر فوق ابدأ، ثم انقر فوق تشغيل، ثم اكتب Services.mscوثم انقر فوق موافق.
    2. تعيين كلمة مرور للخدمات التالية، اعتماداً على العميل الذي تستخدمه. للقيام بذلك، انقر نقراً مزدوجاً فوق الخدمة المناسبة وانقر فوقخصائص، انقر فوق علامة التبويب تسجيل الدخول ، وثم اكتب كلمة المرور.
      عميل "تزامن خدمة active Directory" azureالاتصال azure Active Directory
      • إدارة الهويات forefront خدمة المزامنة
      • SQL الخادم (موسونليني) (أن وجدت)
      • خدمة مزامنة Active Directory azure
      • تزامن إعلان azure
    3. بدء تشغيل خدمة أو الخدمات التي قمت بتعيين كلمة المرور الجديدة.
    4. الانتظار ثلاث ساعات لمزامنة الدليل تحدث، ثم قم بتشغيل مستكشف أخطاء المزامنة الدليل.

الطريقة الرابعة: تثبيت أحدث إصدار من Microsoft عبر الإنترنت خدمات تسجيل الدخول "مساعد"

إذا كنت ترى خطأ معرف الحدث التالية في سجل التطبيق في "عارض الأحداث"، قد يكون لديك إصدار أقدم أو تثبيت تالف Microsoft عبر الإنترنت خدمات تسجيل الدخول المساعد:
معرف الحدث: 109
اسم السجل: التطبيق
المستوى: خطأ
المصدر: تزامن الدليل
الوصف:
حدث فشل أثناء استيراد إدخالات من Active Directory ل Windows Azure. استثناء:
Microsoft.Online.Coexistence.Security.DynamicPInvokeException: فشل الحصول على عنوان
للأسلوب: CreateIdentityHandle2 من مكتبة: C:\Program الملفات المشتركة مايكروسوفت
العمل على الإنترنت Services\msoidcli.dll. رمز GetLastError: 127
لحل هذه المشكلة، تثبيت أحدث إصدار من Microsoft عبر الإنترنت خدمات تسجيل الدخول "مساعد". لمزيد من المعلومات حول كيفية القيام بذلك، راجع قسم "الحل" لمقالة "قاعدة معارف Microsoft" التالية:
3037953 "فشل الحصول على عنوان للأسلوب: CreateIdentityHandle2" الخطأ عند تشغيل معالج تكوين أداة مزامنة الدليل النشط Azure
معلومات أخرى
لا تزال تحتاج إلى مساعدة؟ انتقل إلى جماعة office 365 موقع ويب أو منتديات azure Active Directory على الويب.

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 2882421 - آخر مراجعة: 04/01/2016 21:52:00 - المراجعة: 5.0

Microsoft Azure Active Directory, Microsoft Office 365, Microsoft Intune, CRM Online via Office 365 E Plans, Microsoft Azure Recovery Services, Office 365 Identity Management

  • o365 o365a o365e o365m o365022013 kbmt KB2882421 KbMtar
تعليقات