كيفية تشغيل نموذج التعليمة البرمجية للحصول على برامج Office XP من مقالات قاعدة المعارف

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية290140
تمت أرشفة هذه المقالة. وتظهر "كما هي" ولن يتم تحديثها بعد الآن.
للحصول على إصدار Microsoft Office 2000 من هذه المقالة، راجع 212536.
للحصول على Microsoft Office 97 راجع 173707 نسخة من هذه المقالة.
للحصول على يوم Office Microsoft الإصدار Mac من هذا المقال ، راجع 274703.
للحصول على إصدار الإصدار Microsoft Office 98 بماكنتوش من هذه المقالة، راجع 181058.
الموجز
"قاعدة المعارف لـ Microsoft" على عدد من المقالات التي تتضمن التعليمات البرمجية لـ Visual Basic لوحدات الماكرو التطبيقات. توضح العديد من وحدات الماكرو هذه المفاهيم الأساسية البرمجة في Visual Basic للحصول على برامج Office XP المتنوعة. تحتوي هذه المقالة على إرشادات حول كيفية استخدام نموذج التعليمة البرمجية لإنشاء ماكرو جديد وكيفية تشغيل هذا الماكرو.
معلومات أخرى
تقدم Microsoft الأمثلة البرمجية فقط دون أي ضمان التعبير عن أو ضمنية. هذا يتضمن ولكن لم يقتصر على الضمانات الضمنية الخاصة بالتجارة أو الملاءمة لغرض معين. تفترض هذه المقالة تكون مألوفة مع لغة البرمجة التي يتم شرحها مع الأدوات التي يتم استخدامها لإنشاء لتصحيح الإجراءات. يمكن لمهندسي الدعم لدى Microsoft شرح وظيفة إجراء محدد ولكن لن يقوموا بتعديل هذه الأمثلة لتقديم وظيفة إضافية أو إنشاء إجراءات تستوفي متطلبات محددة. لاستخدام نموذج التعليمة البرمجية من مقالة قاعدة معارف يجب عليك إضافة ماكرو Visual Basic جديد (أو حدد ماكرو موجود). يمكنك ثم نسخ ولصق أو نوع النموذج رمز إلى هذا الماكرو باستخدام أي من الطرق التالية.

لإنشاء ماكرو جديد

  1. فتح أو إنشاء قالب في برنامج Office الذي تستخدمه.
  2. من القائمة أدوات، أشر إلى ماكرو ، ثم انقر فوق وحدات الماكرو.
  3. في القائمة وحدات الماكرو في ، حدد في Word القالب أو المستند حيث تريد حفظ الماكرو.
  4. في المربع اسم الماكرو ، اكتب اسماً للماكرو.
  5. انقر فوق إنشاء لفتح محرر Visual Basic.
  6. قم بأحد الإجراءات التالية:
    • اكتب التعليمات البرمجية للماكرو بين خطي Macroname() Sub وخطي End Sub.
      Sub macroname()    Type your macro code hereEnd Sub							
      -or-
    • نسخ ولصق نموذج التعليمة البرمجية على الماكرو باتباع الخطوات التالية:
      Sub macroname() End Sub						
      1. التبديل إلى البرنامج الذي تستخدمه لعرض مقالة "قاعدة المعارف لـ Microsoft" ، مثل Microsoft Internet Explorer.
      2. لتحديد نموذج التعليمة البرمجية احتجاز المفتاح CTRL ثم النقر المفرد التعليمات البرمجية.
      3. من القائمة تحرير ، انقر فوق نسخ.
      4. قم بالتبديل إلى محرر Visual Basic.
      5. حدد في محرر Visual Basic نص التعليمات البرمجية الموجودة في Macroname() Sub إلى End Sub الماكرو.
      6. من القائمة تحرير ، انقر فوق لصق.

        ملاحظة: عندما تقوم بلصق يتم استبدال نص التعليمات البرمجية موجود مع التعليمات البرمجية التي قمت بنسخها من قاعدة المعارف.
  7. بعد كتابة أو لصق التعليمات البرمجية لوحدات الماكرو الخاص بك انقر فوق إغلاق ورجوع إلى Microsoft program في القائمة ملف حيث كان program برنامج Microsoft Office XP الذي تستخدمه.


ملاحظة: استخدم المفتاح TAB لوضع مسافة بادئة قبل النص. تعليقات الأسطر التي تبدأ بعلامة اقتباس أحادية (') ومن غير مطلوبة لتشغيل الماكرو. ومع ذلك، قد تحتاج إلى كتابتها لجعل من السهل فهم الماكرو.

لإضافة نموذج لتعليمة برمجية إلى وحدة نمطية

لإضافة تعليمة برمجية إلى وحدة نمطية يجب إما جعل وحدة نمطية موجودة أو إنشاء وحدة نمطية جديدة. للقيام بذلك، اتبع الخطوات التالية:
  1. فتح أو إنشاء قالب في برنامج Office الذي تستخدمه.
  2. من القائمة أدوات، أشر إلى ماكرو ، ثم انقر فوق محرر Visual Basic.
  3. في إطار المشروع من محرر Visual Basic (افتراضياً وهو في الركن الأيمن العلوي) ، انقر فوق رمز المشروع مع نفس الاسم مثل القالب أو المستند. إذا لم تقم بعد بحفظ القالب أو المستند الخاص بك, سيتم مشابهة Project(Document1) أو TemplateProject(Template1) اسم المشروع.

    ملاحظة FOR الكلمة المستخدمين: إذا كنت تريد تخزين الماكرو في الافتراضي العمومي القالب Normal.dot, انقر نقراً مزدوجاً فوق مشروع عادي.
  4. إذا لم يحتوي المشروع الذي قمت بالنقر فوق على مجلد يسمى الوحدات النمطية تحته ، انقر فوق وحدة نمطية في القائمة إدراج.
  5. انقر فوق أي مكان في إطار التعليمات البرمجية الخاصة الوحدة النمطية التي تريد إنشاء. عادة ما يكون إطار التعليمات البرمجية في الزاوية اليسرى العليا من "محرر Visual Basic.
  6. اكتب أو الصق نموذج التعليمة البرمجية تماماً كما يظهر في مقالة "قاعدة المعارف" بما في ذلك الخطوط Macroname() Sub و End Sub.

    ملاحظة: للحصول على المزيد من المعلومات حول كتابة أو لصق التعليمات البرمجية للماكرو الرجاء مراجعة القسم "إلى إنشاء ماكرو جديد" في هذه المقالة.
بعد كتابة أو لصق التعليمات البرمجية لوحدات الماكرو الخاص بك انقر فوق إغلاق ورجوع إلى Microsoft program في القائمة ملف

حيث أن program هو برنامج Microsoft Office XP الذي تستخدمه.

إلى تشغيل الماكرو

  1. من القائمة أدوات، أشر إلى ماكرو ، ثم انقر فوق وحدات الماكرو.
  2. حدد اسم الماكرو في القائمة اسم الماكرو ، ثم انقر فوق تشغيل.
مراجع
يحتوي Microsoft حول كل برنامج من برامج Office على العديد من المواضيع حول العمل مع وحدات الماكرو. تعليمات Visual Basic يحتوي على معلومات شاملة حول كتابة التعليمات البرمجية الخاصة بك.
vbe vba OfficeKBHowTo inf الأساسية المرئية XP OFFXP إيقاف

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 290140 - آخر مراجعة: 12/06/2015 00:45:01 - المراجعة: 3.5

Microsoft Excel 2002 Standard Edition, Microsoft Outlook 2002 Standard Edition, Microsoft PowerPoint 2002 Standard Edition, Microsoft Word 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbfaq kbhowto kbmacro kbprogramming KB290140 KbMtar
تعليقات