أنت غير متصل حاليًا، وفي انتظار الإنترنت الخاص بك ليقوم بإعادة الاتصال

إن المستعرض الذي تستخدمه غير معتمد

إنك تحتاج إلى تحديث المستعرض لاستخدام الموقع.

التحديث إلى أحدث إصدار من Internet Explorer

كيفية كتابة الملفات الثنائية إلى المستعرض استخدام ASP.NET و Visual C#.NET

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية306654
الموجز
هذه المقالة خطوة بخطوة حول إنشاء صفحة نموذج التي يوضح كيفية استرداد البيانات الثنائية من ملف "ثم" كيفية كتابة البيانات خارج إلى المستعرض استخدام ASP.NET و Visual C#. على الرغم من ذلك يستخدم العرض التوضيحي Adobe Acrobat (.pdf) الملفات (أي تطبيق ويب للمطورين عادة استخدام)، يمكنك تطبيق هذا الإجراء على الملفات الثنائية الأخرى تنسيقات.

back to the top

متطلبات

  • Microsoft.NET Framework
  • نظام التشغيل Microsoft Windows 2000 أو Windows XP
  • ملقم معلومات إنترنت ل Microsoft (IIS)
back to the top

إنشاء صفحة ASP.تطبيق ويب NET استخدام Visual C#

يوضح هذا القسم كيفية إنشاء صفحة ASP.NET على ويب تطبيق المسمى بيناريديمو:
  1. افتح Microsoft Visual Studio.NET
  2. من القائمة ملف ، أشر إلى جديد، ومن ثم انقر فوق المشروع.
  3. ضمن أنواع Project, انقر فوق مشاريع Visual C#. ضمن قوالب، انقر فوق ASP.تطبيق ويب NET.
  4. في مربع النص الاسم ، اكتب بيناريديمو. في مربع النص الموقع , اكتب اسم الملقم. إذا كنت تستخدم المحلي ملقم، اترك الموقع ك http://localhost.
back to the top

إضافة ملف PDF إلى المشروع

لإعداد المشروع الخاص بك حيث يمكنك إضافة وتشغيل التعليمات البرمجية علامة إنشاء صفحة ASPX المقطع المتابعة، يجب أولاً إضافة ملف Adobe Acrobat (.pdf) إلى الحالي المشروع. للقيام بذلك في Visual Studio.NET، اتبع الخطوات التالية:
  1. في "مستكشف الحلول"، زر الماوس الأيمن فوق العقدة المشروع وانقر فوق إضافة، ومن ثم انقر فوق إضافة عنصر موجود.
  2. استعرض للوصول إلى موقع ملف.pdf على الخاص بك نظام.
  3. انقر لتمييز الملف ومن ثم انقر فوق فتح.
  4. في Visual Studio.NET مستكشف الحلول، انقر نقراً مزدوجاً فوق ملف، ومن ثم انقر فوق إعادة تسمية. إعادة تسمية ملف.pdf بحيث يطابق اسم الملف Acrobat.pdf الذي يتم استخدامه في التعليمات البرمجية التالي.
بالإضافة إلى ذلك، تأكد من تثبيت برنامج Adobe Acrobat Reader على الكمبيوتر العميل الذي يتم عرض الصفحة.aspx حيث يمكنك المستعرض بشكل صحيح قراءة وعرض البيانات الثنائية. يمكنك تحميل Adobe Acrobat قارئ من موقع Adobe على الويب التالي: back to the top

إنشاء صفحة ASPX

  1. إضافة صفحة.aspx جديدة تسمى "BinaryData.aspx" إلى الحالي المشروع كما يلي:
    1. في "مستكشف الحلول"، زر الماوس الأيمن فوق العقدة المشروع انقر فوق إضافة، ومن ثم انقر فوق إضافة نموذج ويب.
    2. اسم صفحة BinaryData.aspx، ومن ثم انقر فوق فتح.

      ملاحظة: تأكد من أن تتم إضافة الصفحة الخاصة بك للمشروع في الوقت نفسه مستوى كملف.pdf الذي قمت بإضافته في المقطع السابق. هذا جداً هام لأنه يستخدم التعليمة البرمجية مسار نسبي إلى مرجع مبدئياً ملف.pdf.
  2. في "محرر"، انقر نقراً مزدوجاً فوق BinaryData.aspxومن ثم انقر فوق عرض التعليمات البرمجية.
  3. تمييز التعليمة البرمجية التالية، انقر نقراً مزدوجاً فوق الرمز، و ثم انقر فوق نسخ. في الحدث Page_Load في صفحة التعليمات البرمجية خلف، انقر فوق لصق في القائمة تحرير للصق التعليمات البرمجية:
    private void Page_Load(object sender, System.EventArgs e)	{             //Set the appropriate ContentType.	    Response.ContentType = "Application/pdf";             //Get the physical path to the file.	    string FilePath = MapPath("acrobat.pdf");             //Write the file directly to the HTTP content output stream.	    Response.WriteFile(FilePath);            Response.End();	}					
  4. من القائمة ملف ، انقر فوق حفظ الكل.
  5. في القائمة إنشاء , انقر فوق إنشاء.
  6. لتشغيل التعليمات البرمجية، زر الماوس الأيمن فوق BinaryData.aspx في "مستكشف الحلول"، ومن ثم انقر فوق طريقة العرض في مستعرض. إذا تم مطالبتك، انقر فوق فتح لفتح وعرض الملف في المستعرض.
ملاحظة: إذا كنت تريد استخدام التعليمات البرمجية السابقة لدعم البيانات الثنائية الأخرى أنواع الملفات، يجب تعديل القيمة في سلسلة نوع المحتوى حيث تحدد تنسيق الملف المناسب. علامة بناء جملة هذه السلسلة عادة منسقا كنوع "نوع/فرعي،" حيث يكون "النوع" فئة المحتوى العام و "نوع فرعي" هو نوع محتوى محدد. لإحدى القائمة المعتمدة من أنواع المحتويات الكاملة، راجع الوثائق المرفقة مع مستعرض ويب أو مواصفات HTTP الحالي. توضح القائمة التالية بعض القيم المشتركة من نوع المحتوى :
  • "text/HTML"
  • "صورة/GIF"
  • "صورة/JPEG"
  • "نص/عادي"
  • "تطبيق/ورد" (لملفات Microsoft Word)
  • "تطبيق/س-إكسيل" (ل Microsoft Excel ملفات)
back to the top
مراجع
للحصول على مزيد من المعلومات، راجع المواضيع التالية في .وثائق NET إطار برنامج تطوير Kit (SDK): للحصول على معلومات إضافية حول كيفية تنفيذ هذه المهمة باستخدام Microsoft صفحات الملقم النشطة (ASP)، انقر فوق رقم المقالة أدناه إلى عرض المقالة في "قاعدة المعارف ل Microsoft":
276488 كيفية استخدام كائن ADODB.كائن الدفق لإرسال الملفات الثنائية إلى المستعرض عن طريق ASP
توفر Microsoft معلومات جهات خارجية لمساعدتك في العثور على الدعم الفني. قد تتغير معلومات الاتصال هذه بدون إشعار. ولا تضمن Microsoft دقة هذه جهة خارجية معلومات.

منتجات الجهات التي التي تمت مناقشتها في هذه المقالة تابعة لشركات مستقلة عن Microsoft. تقدم Microsoft أي ضمان ضمنية أو خلاف ذلك، فيما يتعلق الأداء أو الاعتمادية من هذه المنتجات.

back to the top

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 306654 - آخر مراجعة: 06/12/2012 06:46:00 - المراجعة: 1.0

  • Microsoft ASP.NET 1.1
  • Microsoft ASP.NET 1.0
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C# .NET 2002 Standard Edition
  • kbhowtomaster kbmt KB306654 KbMtar
تعليقات
0&did=1&t=">p;did=1&t=">id=1&t=">