كيفية حل مشكلات المرجع في قاعدة بيانات Access

انتهاء دعم Office 2003

لقد أنهت شركة Microsoft دعم Office 2003 في 8 أبريل، 2014. وقد أثر هذا التغيير على تحديثات البرامج لديك وخيارات الأمان الخاصة بك. تعرف على ما يعنيه ذلك فيما يتعلق بك وكيفية الحفاظ على حمايتك.

هام: تمت ترجمة هذه المقالة باستخدام برامج مايكروسوفت للترجمة الآلية ومن المحتمل ان يتم تحريرها او تدقيقها بعد ذلك من خلال تكنولوجيا منصة مجموعات الترجمة(CTF) او من خلال مترجم بشري. تقدم لك شركة مايكروسوفت هذه المقالات المترجمة بشكل آلي او بالترجمة البشرية او بعد تحريرها وتدقيقها من قبل مجموعات الترجمة حتى تمكنكم من الوصول إلى جميع المقالات الموجودة في قواعد المعرفة لديها بلغات مختلفة. إلا أن المقالات المترجمة قد تحتوي على أخطاء في المفردات او بناء الجمل او النحو. وعليه، فإن شركة مايكروسوفت ليست مسؤولة عن اية أخطاء او عدم دقة في الترجمة او أية أضرار قد تحدث نتيجة أخطاء في ترجمة محتويات النص او استخدامه من قبل العملاء.

اضغط هنا لرابط المقالة باللغة الانجليزية310803
الموجز
توضح هذه المقالة مشكلات تتعلق باستخدام المراجع في قاعدة بيانات Access.

فهم أخطاء المرجع يتطلب فهما لكيفية الإشارة إلى مكتبات في قاعدة بيانات Access والمطلوب تثبيت قاعدة بيانات على جهاز كمبيوتر هدف دون كسر هذه المراجع. هذه المقالة ملخص للمواضيع التالية:
  • عرض مراجع قاعدة بيانات Access
  • حل Microsoft Visual Basic for أبليكاتيونسريفيرينسيس في Access
  • فهم رسائل خطأ مرجع
  • حل مشكلات مرجع على ديفيلوبمينتكومبوتير
  • توزيع ملفات قاعدة البيانات
  • تحديث قائمة المراجع
  • توزيع ملفات قاعدة البيانات التي تحتوي على أكتيفيكسكونترولس
  • معاودة تسجيل ملف
معلومات أخرى

عرض مراجع قاعدة بيانات Access

لعرض مراجع قاعدة البيانات الحالي:
  1. فتح قاعدة البيانات.
  2. . Visual Basic لبدء تشغيل محرر ALT + F11اضغط
  3. من القائمة أدوات ، انقر فوق " مراجع".

حل مراجع Visual Basic في Access

يقوم access بتحميل ملف ذات صلة (على سبيل المثال، مكتبة الأنواع أو مكتبة كائنات أو مكتبة عنصر تحكم) لكل مرجع، ووفقا للمعلومات التي يتم عرضها في المربع المراجع . إذا تعذر العثور الملف في Access، Access بتشغيل الإجراءات التالية إلى الملف:
  1. يقوم access بفحص لمعرفة ما إذا كان تحميل إيسكورينتلي الملف المشار إليه في الذاكرة.
  2. إذا لم يتم تحميل الملف في الذاكرة، يحاول Access فيريفيثات وجود مفتاح التسجيل RefLibPaths . إذا كان المفتاح موجوداً، يبحث Access عن ناميدفالوي له نفس الاسم كالمرجع. إذا كان هناك تطابق، أكسيسلوادس المرجع من المسار الذي يشير إلى القيمة المسماة.
  3. ثم يبحث access عن الملف المشار إليه في مواقع thefollowing، بهذا الترتيب:
    1. مجلد التطبيق (موقع الملف Msaccess.exe).
    2. المجلد الحالي التي تراها في حالة النقر فوق فتح في القائمة ملف .
    3. المجلد Winnt أو Windows التي تقوم بتشغيل ملفات نظام التشغيل.
    4. مجلد النظام ضمن مجلد Windows أو Winnt.
    5. المجلدات في متغير بيئة PATH التي يمكن الوصول إليها مباشرة من قبل نظام التشغيل.
  4. إذا لم يجد الوصول إلى الملف اروروككورس مرجع.

فهم رسائل خطأ مرجع

هناك العديد من رسائل الخطأ التي تتعلق بملف مفقود أو ملف يحتوي على إصدار مختلف عن الإصدار المستخدم في قاعدة البيانات. في معظم الحالات، يمكنك البحث في قاعدة المعارف ل Microsoft مقالة حول رسالة الخطأ المحددة، ويمكنك ثم حل الخطأ باتباع الخطوات المذكورة في هذه المادة. في بعض الحالات، ملف تبعية غير صحيح يتطابق مع الملف الأساسي.

تصف القائمة التالية بعض مرجع رسائل الخطأ التي قد تظهر. ومع ذلك، لاحظ أن القائمة لا تتضمن كافة رسائل خطأ مرجع المحتملة.
  • أسلوب " MethodName كائناسم الكائن فشل "

    عادة، يمكنك مايريسيفي هذا رسالة الخطأ إذا كان هناك مشكلة باستخدام typelibrary برمجة، على سبيل المثال، ملف غير صالح كائن الوصول إلى بيانات (DAO) library(DLL) الارتباط الحيوي. يمكنك البحث Microsoft Knowledge Base المادتان ثاتديسكريبي الأشكال المختلفة لرسالة الخطأ هذه.
  • "الدالة غير متوفرة فياستخدام تعبير "

    قد تتلقى رسالة ثيسيرور إذا كان هناك مشكلة في مكتبة أنواع برمجة، أو إذا كان عدم استدعاء thecode على وجه التحديد إلى المكتبة الصحيحة والملف ليستيدات أولوية أدنى في قائمة المراجع من ملف الذي يحتوي على اسم ساميفونكشن--على سبيل المثال، إذا تم استخدام التعليمات البرمجية DAO مع مكتبة Object(ADO) البيانات ActiveX مدرجاً في أولوية أعلى من مكتبة DAO. قد السوريسيفي رسالة الخطأ هذه إذا كان نموذج أو تقرير يحتوي على عنصر تحكم ActiveX.
  • "لا يمكن العثور على مشروع أو مكتبة"

    قد ريسيفيثيس رسالة خطأ إذا تعذر تحديد موقع الوصول إلى ملف في قائمة المراجع. يتم وضع الملف أوفتينثي علامة مفقود في مربع حوار المراجع . في بعض الأحيان لم يكن موجوداً كومبوتيربوت التنمية ليس على الكمبيوتر الهدف. للحصول على معلومات إضافية حول هذا الخطأ، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
    208218 ACC2000: فصل دالات VBA في قاعدة البيانات مع مراجع مفقودة
  • "لم يتم تعريف المتغير" أو "نوتديفينيد نوع معرف من قبل المستخدم"

    قد تظهر إحدى رسائل الخطأ هذه إذا كنت تستخدم معالج الأمان على مستوى تيسير لتأمين قاعدة تشير مكتبات otherthan المكتبات التي يتم تضمينها بشكل افتراضي. على سبيل المثال، توليبراريس المراجع الموجودة في قاعدة البيانات غير الآمنة غير تلقائياً كريتدين قاعدة بيانات آمنة وجديدة.
  • "خطأ وقت التشغيل 5،" "استدعاء إجراء غير صالح أو وسيطة" "المكتبة التي تحتوي على هذا الرمز لا يشار إليه _ الحالي" أو "المكتبة التي تحتوي على هذا الرمز لا يشار إليه بمشروع ثيكورينت، حيث يتم تعريف الرمز"

    قد تتلقى إحدى رسائل الخطأ منهذه إذا كان هناك مرجع إلى قاعدة بيانات مكتبة النوع، وهران مكتبة الكائنات التي تم وضع علامة مفقود. للحصول على معلومات إضافية، انقر فوق رقم المقالة التالي لعرضها في "قاعدة معارف Microsoft":
    231413 ACC2000: رسائل خطأ تشير إلى مرجع مفقود
  • مكون ActiveX "لا يمكن إنشاء كائن"

    رسالة ثيسيرور لا يعني بالضرورة أن ينطوي على عنصر تحكم ActiveX. على سبيل المثال، أحد الأسباب المحتملة هو DAO، عنصر تحكم ActiveX، لا يمكن إنشاء كائن لأنه لا يمكن بدء تشغيل ملقم الأتمتة DAO. وكثيراً ما هو السبب أن DLLs التي توفر الوظائف المشار إليها للبرنامج غير مسجلة أو المسجلة بشكل غير صحيح.للحصول على معلومات إضافية حول هذا الخطأ، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
    244264 INFO: استكشاف أخطاء وإصلاحها خطأ 429 عند أتمتة تطبيقات Office
    على الرغم من أن هذه المقالة مكتوبة من وجهة نظر VisualBasic، يغطي العديد من الأسباب لهذا الخطأ.

حل مشكلات مرجع على كمبيوتر التطوير

إنشاء قاعدة بيانات فارغة وجديدة ومن ثم استيراد الكائنات من ملف قاعدة بيانات آخر إنشاء مرجع المشاكل إذا كانت التعليمات البرمجية أو عناصر تحكم ActiveX التي تعتمد على الإشارات غير المتضمنة في قاعدة بيانات بشكل افتراضي. تكون المراجع الافتراضي لقاعدة بيانات Access 2000:
  • Visual Basic for Applications
  • مكتبة كائنات Microsoft Access 9.0
  • التنفيذ التلقائي OLE
  • مكتبة Microsoft كائنات بيانات ActiveX (ADO) 2.1
إذا كان المصدر قاعدة بيانات Access 2000 أخرى، تحقق من مطابقة المراجع. إذا كان المصدر في إصدار سابق من Access، DAO 3.5 أو إصدار سابق على الأرجح في استخدامها؛ ومع ذلك، لا يوفر Access 2000 DAO 3.5 بشكل افتراضي. حاول إزالة المرجع إلى ADO 2.1 المكتبة (إذا كان موجوداً) وإضافة المرجع إلى مكتبة كائنات DAO 3.6.

إذا قمت بتحويل قاعدة بيانات من إصدار سابق من Access، وقاعدة بيانات تحتوي على مرجع إلى ملف Utility.mda، في معظم الحالات يمكنك إزالة هذا المرجع لأن الوظائف التي تستدعي هذا المرجع ضمن مراجع "الافتراضية" في Access 2000. إذا كانت هناك إشارات إلى إصدارات سابقة من DAO، يمكنك أيضا إزالة هذه المراجع لأن DAO 3.6 معالجة هذه المهام.

لإضافة مرجع إلى مكتبة:
  1. فتح قاعدة البيانات.
  2. . Visual Basic لبدء تشغيل محرر ALT + F11اضغط
  3. من القائمة أدوات ، انقر فوق " مراجع".
  4. تحت المراجع المتوفرة، انقر لتحديد خانة الاختيار الموجودة بجانب اسم المكتبة ومن ثم انقر فوق موافق.
لإزالة مرجع إلى مكتبة:
  1. فتح قاعدة البيانات.
  2. . Visual Basic لبدء تشغيل محرر ALT + F11اضغط
  3. من القائمة أدوات ، انقر فوق " مراجع".
  4. تحت المراجع المتوفرة، انقر لإلغاء تحديد خانة الاختيار الموجودة بجانب اسم المكتبة ومن ثم انقر فوق موافق.

توزيع ملفات قاعدة البيانات

هناك طريقتان توزيع ملف قاعدة البيانات الأساسية. يمكنك نسخ الملف من كمبيوتر التطوير إلى الكمبيوتر الهدف، أو يمكنك استخدام حزمة ومعالج النشر لإنشاء حزمة إعداد.

إذا قمت بنسخ الملف من كمبيوتر التطوير إلى الكمبيوتر الهدف، يتم نسخ ملف قاعدة البيانات. يدوياً يجب التأكد من أن كافة الملفات المدرجة في قائمة المراجع متوفرة، على مستوى الإصدار الصحيح وفي نفس الموقع النسبي على الكمبيوتر الهدف كما على كمبيوتر التطوير.

إذا كنت تستخدم حزمة ومعالج النشر لإنشاء حزمة إعداد، راجع مقالة قاعدة المعارف بمثابة قائمة مرجعية لتطوير التطبيقات في وقت التشغيل في Access. للحصول على معلومات إضافية حول قائمة الاختيار، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
247530 MOD2000: كيفية تجنب الأخطاء الشائعة عند إنشاء تطبيقات وقت التشغيل القابلة للتوزيع
عند تطوير التطبيقات في وقت التشغيل في Access، يجب أن تدرك أن بعض ملفات نظام التشغيل يجب أن يتم توزيعه مع التطبيق وقت التشغيل. يتم إجراء التعبئة هذه الملفات تلقائياً بمكونات Microsoft Office 2000 Developer حزمة ومعالج النشر. في بعض الأحيان تعتمد إصدارات الملفات التي تم تضمينها في التطبيقات الأخرى التي تم تثبيتها على الكمبيوتر والتي قد قام بتعديل ملفات نظام التشغيل.

اتباع إرشادات معينة عادة ما يؤكد أن إصدارات الملفات التي تستخدمها سوف لا تتعارض مع الملفات الموجودة على الكمبيوتر الهدف عند تثبيت تطبيق وقت التشغيل. وفيما يلي المبادئ التوجيهية:
  1. تطوير قاعدة بيانات Access على أي كمبيوتر.
  2. إنشاء بيئة كمبيوتر حيث يكون القرص الثابت على بينريفورماتيد والمثبت عليه فقط الإصدار الأقدم من operatingsystem القابلة للتطبيق من Office ومن Office 2000 المطور. تشغيل "معالج نشر باكاجيند" على هذا الكمبيوتر لإنشاء إصدار وقت التشغيل ثيبليكاتيون. وهذا يضمن مستويات مراجعة الملفات ستعمل onany لأجهزة الكمبيوتر المستهدفة.
  3. إنشاء بيئة كمبيوتر حيث يكون القرص الثابت على بينريفورماتيد والمثبت عليه نظام التشغيل. اختبار التشغيل-تيميبليكيشن في هذه البيئة.
    • إذا لم يتم تشغيل التطبيق بنجاح، تعلم أن هناك مشكلة في التطبيق نفسه. تحتاج إلى تحديد وتصحيح المشكلة قبل توزيع التطبيق.
    • إذا كان التطبيق يعمل بنجاح على كمبيوتر اختبار ولكن لا يعمل على الكمبيوتر الهدف، تعلمون أن هناك شيء خاطئ وليس في التطبيق على الكمبيوتر الهدف. تحتاج إلى تحديد وتصحيح السبب المحتمل على الكمبيوتر الهدف، ربما بسبب عدم توافق أو ملف تالف.

تحديث قائمة المراجع

تتضمن مشكلة مرجع عنصر تحكم ActiveX، يمكنك أحياناً حل المشكلة عن طريق تحديث قائمة المراجع. لتحديث قائمة المراجع:
  1. في محرر Visual Basic، انقر فوق مراجع في قائمة " أدوات ".
  2. في مربع الحوار " مراجع "، انقر فوق لتحديد مرجع غير الريديسيليكتيد، لاحظ أحد أي تحديد، وثم انقر فوق موافق.
  3. من القائمة أدوات ، انقر فوق المراجع .
  4. انقر لإلغاء تحديد المرجع، وثينكليك "موافق".

توزيع ملفات قاعدة البيانات التي تحتوي على عناصر تحكم ActiveX

يوجد نوعان من تراخيص لعناصر تحكم ActiveX: ترخيص وقت التصميم وترخيص وقت التشغيل.
  • يسمح ترخيص وقت التصميم بإدراج عناصر تحكم ليسينسيداكتيفيكس من Office 2000 المطور في النماذج والتقارير في أكسيسداتاباسي.
  • ترخيص وقت التشغيل يسمح لك باستخدام كونترولسين ActiveX قاعدة بيانات Access على جهاز كمبيوتر لا يحتوي على Office 2000 ديفيلوبيرينستاليد، ولكن لا يسمح ترخيص وقت التشغيل يمكنك إدراج عناصر تحكم ليسينسيداكتيفيكس الجديدة. لتثبيت ترخيص وقت التشغيل، توزيع أكتيفيكسكونترولس باستخدام حزمة ومعالج النشر، يكتب ليسينسيفور عناصر التحكم في التسجيل للكمبيوتر الهدف.
علامة مفقود ، قد تشاهد عند فتح وحدة نمطية في طريقة عرض التصميم ومن ثم انقر فوق " مراجع " في قائمة " أدوات "، يشير إلى أن الإشارة إلى عنصر تحكم مربع "حوار مشترك" على الكمبيوتر الهدف لا يتطابق مع المصدر في ملف قاعدة البيانات من كمبيوتر التطوير.

في حالة توزيع ملف قاعدة بيانات بدون تثبيت عنصر التحكم "مربع حوار عام" قابلة للتوزيع أو المرجع لعنصر التحكم قد يكون إشارة على أنه مفقودأو قد تتلقى رسالة إعلام بخطأ أن "لم يكن لديك الترخيص المطلوب لاستخدام عنصر تحكم ActiveX هذا" إذا كان عنصر التحكم غير قابلة مثبت مسبقاً على الكمبيوتر الهدف.

حتى عندما ملف قاعدة البيانات جزء من التطبيقات في وقت التشغيل، قد تتلقى رسالة الإعلام بالخطأ أن "لم يكن لديك الترخيص المطلوب لاستخدام عنصر تحكم ActiveX هذا" إذا كان عنصر التحكم غير قابلة مثبت بالفعل على الكمبيوتر الهدف من إصدار أحدث من عنصر التحكم التي يتم توفيرها من قبل التطبيق وقت التشغيل الخاص بك. قد تحدث هذه المشكلة لأن برنامج "الإعداد" عدم الكتابة فوق الإصدارات الأحدث من الملف باستخدام إصدار أقدم من نفس الملف.

معاودة تسجيل ملف

من الممكن لملف الذي سيتم في قائمة المراجع دون أن تكون مسجلة بشكل صحيح في التسجيل. إذا كنت تشك في أن هذا قد يكون صحيحاً، اتبع هذه الخطوات لإعادة تسجيل الملف:
  1. في Microsoft Windows NT 4.0، انقر فوق ابدأ، أشر إلى بحث، ثم انقر فوق الملفات أو المجلدات، أو في Windows2000، انقر فوق ابدأ، أشر إلى بحث، وثم انقر فوق "عن ملفات" أندفولديرس.
  2. اكتب في المربع الاسم ، أو في مربع البحث عن الملفات وفولديرسناميد ، regsvr32.exe.
  3. في المربع بحث في ، انقر فوق جذر قرص ثيهارد (عادة ما يكون c:).
  4. انقر لتحديد خانة الاختيار تضمين المجلدات الفرعية إذا لم يكن محدداً بالفعل، ومن ثم انقر فوق البحث الآن أو البحث الآن.
  5. بعد العثور على الملف، انقر فوق ابدأ، ثم انقر فوق تشغيل، وحذف أي شيء موجود في المربع فتح .
  6. اسحب الملف Regsvr32.exe من جزء نتائج البحث إلى المربع فتح .
  7. كرر الخطوات من 2 إلى 6، في هذا الوقت في البحث عناسم الملف.dll، أيناسم الملف هو اسم الملف الذي تريد توريريجيستير.
  8. بعد اسم الملفالرقم العالمي ملف.dll المربع فتح الملف Regsvr32.exe، انقر فوق "موافق".
  9. في Access، إجراء اختبار لمعرفة ما إذا كان ستيليكسيستس المشكلة.
إذا لم تكن الملفات Regsvr32.exe على الكمبيوتر الخاص بك، تحقق من أجهزة الكمبيوتر الأخرى للملف. إذا لم يكن الملف متوفراً، يمكنك الحصول على الملف من موقع Microsoft على ويب. للحصول على معلومات إضافية، انقر فوق رقم المقالة التالي لعرضها في "قاعدة معارف Microsoft":
161983 لجنة التنسيق الإدارية: Regsvr32a.exe المتوفرة في مركز التحميل
ملاحظة: تذكر أن تقوم بترجمة كافة الوحدات النمطية بعد ضبط المراجع. لترجمة كافة الوحدات النمطية، الوحدة النمطية لا تزال فتح، انقر فوق ترجمة قاعدة البيانات القائمة تصحيح . في حالة عدم ترجمة الوحدات النمطية, قد يكون هناك مراجع إضافية لم يتم حلها.

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 310803 - آخر مراجعة: 06/11/2016 02:46:00 - المراجعة: 7.0

Microsoft Access 2000 Standard Edition, Microsoft Access 2002 Standard Edition, Microsoft Office Access 2003, Microsoft Office Access 2007, Microsoft Access 2010, Microsoft Access 2013, Access 2016

  • kbhowto kbenv kbinfo kbinterop kbprogramming kbmt KB310803 KbMtar
تعليقات