كيفية دمج البيانات من مستندين XML استخدام System.Xml باستخدام Visual C#.net

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية311530
تمت أرشفة هذه المقالة. وتظهر "كما هي" ولن يتم تحديثها بعد الآن.
الموجز
يوضح هذا المقال خطوة بخطوة حول كيفية استخدام كائن DataSet إلى دمج مستندين XML. الكائن المركزية لدعم غير متصل، توزيع DataSet سيناريوهات البيانات مع ADO.NET. DataSet هو تمثيل المقيم في الذاكرة البيانات الذي يوفر نموذج برمجة ثابتاً، العلائقية بغض النظر عن مصدر البيانات. يمثل DataSet مجموعة كاملة من البيانات، بما في ذلك الجداول المرتبطة وقيود والعلاقات بين الجداول.

back to the top

متطلبات

توضح القائمة التالية الأجهزة الموصى بها، والبرامج والبنية الأساسية للشبكة وحزم الخدمات التي تحتاجها:
  • نظام التشغيل Microsoft Windows XP أو نظام التشغيل Windows 2000 أو Windows NT 4.0 Service Pack 6a (SP6a)
  • Microsoft Visual Studio.net
تفترض هذه المقالة أنك معتاد مع المواضيع التالية:
  • بناء جملة visual C#.net
  • لغة التوصيف الموسعة (XML)
back to the top

إنشاء ملف Books1.xml

  1. من القائمة ابدأ ، انقر فوق تشغيل، نوع Notepad.exe، ثم انقر فوق موافق.
  2. تمييز التعليمة البرمجية التالية، زر الماوس الأيمن فوق الرمز، وثم انقر فوق نسخ. في "المفكرة"، من القائمة تحرير ، انقر فوق لصق.
    <?xml version="1.0"?><catalog>   <book id="bk101">      <author>Gambardella, Matthew</author>      <title>XML Developer's Guide</title>      <genre>Computer</genre>      <price>44.95</price>   </book>   <book id="bk102">      <author>Jeanette, Dasha</author>      <title>Quack the Duck</title>      <genre>Fantasy</genre>      <price>5.95</price>   </book></catalog>					
  3. من القائمة ملف ، انقر فوق حفظ.
  4. في مربع الحوار حفظ باسم ، في مربع القائمة المنسدلة حفظ كنوع ، انقر فوق كافة الملفات. في مربع النص اسم الملف ، اكتب Books1.xml، ثم انقر فوق حفظ.
back to the top

إنشاء ملف Books2.xml

  1. في "المفكرة"، إنشاء ملف نصي جديد يسمى Books2.xml.
  2. نسخ ولصق XML التالي في Books2.xml:
    <?xml version="1.0"?><catalog><book id="bk106">      <author>Randall, Cynthia</author>      <title>Lover Birds</title>      <genre>Romance</genre>      <price>4.95</price>   </book>   <book id="bk107">      <author>Vinzovskaia, Irina</author>      <title>Piano Fort A</title>      <genre>Romance</genre>      <price>4.95</price>   </book></catalog>					
  3. من القائمة ملف ، انقر فوق حفظ.
  4. في مربع الحوار حفظ باسم ، في مربع القائمة المنسدلة حفظ كنوع ، انقر فوق كافة الملفات. في مربع النص اسم الملف ، اكتب Books2.xml، ثم انقر فوق حفظ.
back to the top

خطوات لإنشاء Visual C#.net التطبيق

  1. تشغيل Visual Studio.net، ثم قم بإنشاء مشروع Visual C# "تطبيقات وحدة تحكم" جديد.
  2. إضافة التعليمة البرمجية التالية إلى الجزء العلوي من إطار التعليمات البرمجية:
    using System;using System.Xml;using System.IO;using System.Data ;					
  3. نسخ ولصق التعليمة البرمجية التالية في ساكنة باطلة الرئيسي (سلسلة وسائط []):
    try	{		XmlTextReader xmlreader1 = new XmlTextReader("C:\\Books1.xml");		XmlTextReader xmlreader2 = new XmlTextReader("C:\\Books2.xml");		DataSet ds = new DataSet();		ds.ReadXml(xmlreader1);		DataSet ds2 = new DataSet();		ds2.ReadXml(xmlreader2);		ds.Merge(ds2);		ds.WriteXml("C:\\Books.xml");		Console.WriteLine("Completed merging XML documents");	}	catch (System.Exception ex)	{		Console.Write(ex.Message);	}Console.Read();						
  4. إنشاء وتشغيل التطبيق. لاحظ ظهور الرسالة "إكمال دمج مستندات XML" في إطار وحدة التحكم.
  5. إغلاق إطار وحدة التحكم. لاحظ أنه يتم إنشاء ملف Books.xml في المسار الذي تحدده.
  6. افتح Books.xml. لاحظ أنه يتم إلحاق البيانات من Books2.xml حتى النهاية ل Books1.xml.
back to the top

سيناريوهات مستند XML

دمج مستندات XML التي لها نفس بنية

يوضح نموذج Visual C#.net السابقة إخراج مستندات XML مع نفس بنية.

back to the top

دمج مستندات XML التي لديها هياكل مختلفة

  1. افتح Books2.xml، ويستبدل XML XML التالي:
    <?xml version="1.0" ?><SampleData><Customer>          <CustomerName>Bob Frapples</CustomerName>          <PricePerUnit>5.95</PricePerUnit>          <ClosingDate>2001-12-16</ClosingDate></Customer><Customer>          <CustomerName>Bob Frapples</CustomerName>          <PricePerUnit>5.95</PricePerUnit>          <ClosingDate>2001-12-16</ClosingDate></Customer></SampleData>					
  2. حفظ Books2.xml.
  3. تشغيل مشروع Visual C#.net مرة أخرى. لاحظ أنه يتم إلحاق العقد من المستند الثاني (Books2.xml) إلى مستند XML الأول (Books1.xml).
back to the top

دمج مستندات XML مع بنية مشابه حيث المستند الثاني يحتوي على عناصر إضافية

  1. افتح Books2.xml، ويستبدل XML XML التالي:
    <?xml version="1.0"?><catalog><book id="bk106">      <author>Randall, Cynthia</author>      <title>Lover Birds</title>      <genre>Romance</genre>      <price>4.95</price>      <publish_date>2000-09-02</publish_date>      <description>When Carla meets Paul at an ornithology       conference, tempers fly as feathers get ruffled.</description>   </book>   <book id="bk107">      <author>Vinzovskaia, Irina</author>      <title>Piano Fort A</title>      <genre>Romance</genre>      <price>4.95</price>      <publish_date>2000-11-02</publish_date>      <description>Two young pianists strike a chord when they fight a       pitched battle to stop the gnomes at a key base.</description>   </book></catalog>					
  2. حفظ Books2.xml.
  3. تشغيل مشروع Visual C#.net مرة أخرى. لاحظ أنه يتم إلحاق العقد من المستند الثاني إلى مستند XML الأول.
back to the top

دمج مستندات XML مع بنية مشابه حيث المستند الثاني يحتوي على سمات

  1. افتح Books2.xml، ويستبدل XML XML التالي:
    <?xml version="1.0"?><catalog><book id="bk106" genre="Romance">      <author>Randall, Cynthia</author>      <title>Lover Birds</title>      <price>4.95</price>   </book>   <book id="bk107" genre="Romance">      <author>Vinzovskaia, Irina</author>      <title>Piano Fort A</title>      <price>4.95</price>   </book>   <book id="bk108" genre="Horror">      <author>de Dogg, Jazz</author>      <title>Night of the Flea</title>      <price>4.95</price>   </book>   </catalog>					
  2. حفظ Books2.xml.
  3. تشغيل مشروع Visual C#.net مرة أخرى. لاحظ أنه يتم إلحاق العقد من المستند الثاني إلى مستند XML الأول، والبنية تماما كمستند XML الأول.
back to the top

دمج مستندات XML مع بنية مشابه حيث المستند الأول يحتوي على سمات

  1. تعديل التعليمات البرمجية Visual C# كما يلي، حيث يتم إلحاق Books1.xml Books2.xml:
    try	{		XmlTextReader xmlreader1 = new XmlTextReader("C:\\Books2.xml");		XmlTextReader xmlreader2 = new XmlTextReader("C:\\Books1.xml");		DataSet ds = new DataSet();		ds.ReadXml(xmlreader1);		DataSet ds2 = new DataSet();		ds2.ReadXml(xmlreader2);		ds.Merge(ds2);		ds.WriteXml("C:\\Books.xml");		Console.WriteLine("Completed merging XML documents");	}	catch (System.Exception ex)	{		Console.Write(ex.Message);	}Console.Read();						
  2. تشغيل مشروع Visual C#.net مرة أخرى. لاحظ أن مستند XML الناتجة بإلحاق العقد من Books1.xml إلى Books2.xml. بالإضافة إلى ذلك، لاحظ أن كافة العقد دفتر تحتوي على سمة "النوع".

    ولذلك، اعتماداً على بنية مستند XML الأول، يتم تعديل مستند XML الثاني حيث يكون أكثر إفادة XML الناتجة.
back to the top
مراجع
للحصول على معلومات إضافية، انقر فوق رقم المقالة التالي لعرض المقالة في قاعدة معارف Microsoft:
286817 كيف يتم دمج البيانات في مستندات XML اثنين ببرمجة طراز كائن المستند (DOM)
back to the top

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 311530 - آخر مراجعة: 12/07/2015 08:06:24 - المراجعة: 1.0

Microsoft Visual C# .NET 2002 Standard Edition, Microsoft Visual C# .NET 2003 Standard Edition, Microsoft .NET Framework 1.0, Microsoft .NET Framework 1.1

  • kbnosurvey kbarchive kbhowtomaster kbio kbsystemdata kbmt KB311530 KbMtar
تعليقات