WD2000: مستند يحتوي على أحد كائنات مضمنة يستمر المطالبة حفظ زوجية بعد تعيين حفظ خاصية

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

325619
تمت أرشفة هذه المقالة. وتظهر "كما هي" ولن يتم تحديثها بعد الآن.
الأعراض
إذا تم تعيين الخاصية محفوظ على كائن مستند إلى True في Microsoft Word ، يمكنك منع Word من مطالبتك بحفظ المستند عند إغلاق المستند. يحدث هذا حتى إذا قمت بتعديل المستند. ومع ذلك، إذا كان المستند يحتوي على كائنات مضمنة (كائنات OLE القياسي أو عناصر تحكم ActiveX) ، يظهر مربع الحوار حفظ حتى إذا قمت بتعيين الخاصية محفوظ إلى True.
السبب
يحدث هذا السلوك عند تعديل كائن مضمن ولكن لا تقم بحفظ الكائن المضمن. لا يتم حفظ البيانات الدائمة الكائن إلى المستند. لا تتم إعادة تعيين هذه العلامة "سيئ" إلى خطأ عندما تستخدم الخاصية Document.Saved من Word.
الحل
يتوفر إصلاح عاجل معتمد من Microsoft. ولكن الغرض منه هو حل المشكلة الموضحة في هذه المقالة. تطبيق هذا الإصلاح العاجل فقط على الأنظمة التي تواجه هذه المشكلة بالتحديد.

في حالة تحميل الإصلاح العاجل يوجد قسم "توفر تنزيل الإصلاح عاجل" أعلى مقالة قاعدة المعارف رقم هذا. إذا لم يظهر هذا المقطع إرسال طلب إلى Microsoft خدمة العملاء والدعم للحصول على الإصلاح العاجل.

ملاحظة تحدث مشكلات إضافية أو في أي حالة الحاجة إلى استكشاف الأخطاء وإصلاحها قد يلزم الأمر إنشاء طلب خدمة منفصل. سيتم تطبيق تكاليف الدعم المعتادة على أسئلة الدعم الإضافية والمشكلات التي لا يعمل على حلها هذا الإصلاح العاجل بالتحديد. للحصول قائمة كاملة بأرقام هواتف Microsoft خدمة العملاء والدعم الخاصة بشركة أو لإنشاء طلب خدمة منفصل قم بزيارة موقع Microsoft التالي على الويب: ملاحظة يعرض نموذج "توفر تنزيل الإصلاح العاجل" اللغات التي يتوفر الإصلاح الجديد. إذا لم تشاهد اللغة الخاصة بك، يكون ذلك بسبب لا يتوفر إصلاح عاجل لتلك اللغة.بعد تثبيت الإصلاح العاجل سيكون إصدار اللغة الإنجليزية من هذا الإصلاح سمات الملف (أو الأحدث) المسرودة في الجدول التالي. يتم سرد التواريخ والأوقات الخاصة بهذه الملفات بالتوقيت العالمي coordinated (UTC). عندما تقوم بعرض معلومات الملف، يتم تحويلها إلى التوقيت المحلي. لمعرفة الفرق بين التوقيت العالمي (UTC) والتوقيت المحلي، استخدم علامة التبويب المنطقة الزمنية في أداة التاريخ والوقت في "لوحة التحكم".
   Date         Time   Size       File name   ------------------------------------------------    23-Nov-2002  14:50      1,804  Hotfix.txt    07-Nov-2002  19:20      2,962  Readme.txt    07-Nov-2002  19:05  3,667,096  Winword.msp    07-Nov-2002  19:41  4,684,436  Winword_admin.msp 				
يجب أن يكون للنسخة الإنجليزية من هذا الإصلاح سمات الملفات التالية أو أحدث:
   Date         Time   Version     Size       File name   ------------------------------------------------------   02-Nov-2002  07:15  9.0.0.7031  8,826,932  Winword.exe				

ملاحظة: يجب إجراء التغييرات التسجيل التالية إلى تمكين هذه الوظيفة. لإجراء التغييرات على التسجيل اتبع الخطوات التالية:
  1. ابدأ تشغيل "محرر التسجيل".
  2. حدد موقع ثم انقر فوق المفتاح التالي في التسجيل:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options
  3. من القائمة تحرير ، انقر فوق إضافة القيمة ثم قم بإضافة قيمة التسجيل التالية:
    اسم القيمة: EnableSubDocPutSaved
    نوع البيانات: DWORD
    قيمة البيانات: 0x00000001 (تمكين) أو 0x00000000 (تعطيل)
  4. قم بإنهاء "محرر التسجيل".
تحذير: حالة استخدام "محرر التسجيل" بطريقة غير صحيحة، قد يؤدي حدوث مشكلات خطيرة يلزم إعادة تثبيت نظام التشغيل. ولا تضمن Microsoft حل المشكلات التي تنتج عن استخدام "محرر التسجيل" بطريقة غير صحيحة. استخدم "محرر التسجيل" على مسؤوليتك الخاصة.

تصريح
أقرت Microsoft أن هذه مشكلة في منتجات Microsoft المسردة في بداية هذه المقالة.
معلومات أخرى

خطوات إعادة إنشاء في سلوك

  1. بدء تشغيل Microsoft Word.
  2. اكتب سطر من النص ثم اضغط المفتاح ENTER مرتين.
  3. من القائمة إدراج ، انقر فوق كائن.
  4. في علامة التبويب "جديد" ، انقر فوق ورقة عمل Microsoft Excel من قائمة أنواع الكائنات.
  5. انقر فوق "موافق" إدراج الكائن.
  6. اكتب قيمة في الخلية A1 من ورقة العمل المضمنة ثم انقر فوق خارج ورقة العمل لإلغاء تنشيط Excel.
  7. اضغط ALT + F11 للوصول Visual Basic for Applications (VBA) المحرر.
  8. من القائمة إدراج ، انقر فوق الوحدة النمطية إدراج وحدة نمطية جديدة.
  9. قم بلصق التعليمة البرمجية التالية في الوحدة النمطية جديد:
    Sub SetSaved()  Application.ActiveDocument.Saved = TrueEnd Sub					
  10. إغلاق محرر VBA.
  11. من القائمة ملف، انقر فوق حفظ.
  12. قم بحفظ الملف كملف C:\Test.doc.
  13. من القائمة ملف، انقر فوق إغلاق لإغلاق المستند.
  14. من القائمة ملف، انقر فوق فتح لإعادة فتح المستند.
  15. انقر نقراً مزدوجاً فوق ورقة العمل ثم قم بوضع قيمة في الخلية B1.
  16. انقر خارج ورقة العمل لإلغاء تنشيطه.
  17. من القائمة أدوات، انقر فوق ماكرو ثم انقر فوق وحدات الماكرو....
  18. انقر لتحديد SetSaved ثم انقر فوق "تشغيل" لتشغيل الماكرو.
  19. من القائمة ملف، انقر فوق إغلاق لإغلاق المستند.

    لاحظ أن تتم مطالبتك بحفظ المستند.

تحذير: تمت ترجمة هذا المقال تلقائياً

خصائص

رقم الموضوع: 325619 - آخر مراجعة: 02/07/2014 22:40:13 - المراجعة: 3.2

  • Microsoft Word 2000 Standard Edition
  • kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB325619 KbMtar
تعليقات