أنت غير متصل حاليًا، وفي انتظار الإنترنت الخاص بك ليقوم بإعادة الاتصال

كيفية تنفيذ الأحداث الإنشاء في Visual C# .NET أو Visual C# 2005

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية810230
تمت أرشفة هذه المقالة. وتظهر "كما هي" ولن يتم تحديثها بعد الآن.
هام: تحتوي هذه المقالة على معلومات حول تعديل التسجيل. قبل تعديل السجل، تأكد من عمل نسخة احتياطية والتأكد من فهمك لطريقة استعادته في حالة حدوث مشكلة. للحصول على معلومات حول كيفية عمل نسخة احتياطية من السجل واستعادته وتحريره انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف لـ Microsoft:
256986وصف تسجيل Microsoft Windows
الموجز
توضح هذه المقالة خطوة بخطوة حول كيفية تنفيذ الأحداث الإنشاء في Visual C# .NET أو Visual C# 2005.

عند استخدام أحداث بناء يمكنك تحديد إجراء الذي يحدث في وقت معين أثناء عملية الإنشاء. على سبيل المثال، يمكنك تحديد حدث post-build لتسجيل ملف باستخدام regsvr32.exe. يمكن أيضاً عرض كما إجراء تغيير على تجميع الذي تم إنشاؤه في GAC (التخزين المؤقت للتجميع العمومي) باستخدام الأداة Gacutil.exe.

في Visual C# .NET أو Visual C# 2005 هناك أية أساليب المباشرة لتحديد pre-build وأحداث post-build.


استخدام لمشروع Makefile C++ Visual إلى تنفيذ إنشاء أحداث

يتم إنشاء أحداث ميزة مضمنة المشاريع Microsoft Visual C++ .NET. يمكن تطبيق هذه الأحداث في مشروع Visual C# .NET أو Visual C# 2005 بواسطة بما في ذلك مشروع Makefile .NET Visual C++ في الحل. لتطبيق الأحداث pre-build يجب إجراء التابعة المشروع Makefile .NET Visual C++ على مشروع Visual C# .NET أو Visual C# 2005. لتطبيق الأحداث post-build يجب إجراء التابعة مشروع Visual C# .NET أو Visual C# 2005 على المشروع Makefile .NET Visual C++.

للقيام بذلك، اتبع الخطوات التالية:
  1. فتح الحل Visual C# .NET أو Visual C# 2005 الموجود.
  2. من القائمة ملف، أشر إلى إضافة Project ، ثم انقر فوق مشروع جديد.
  3. ضمن أنواع Project ، انقر فوق مشاريع Visual C++ ثم ضمن قوالب ، انقر فوق مشروع MakeFile.
    ملاحظة في Visual Studio 2005 ، يجب تغيير "مشاريع Visual C++" إلى "Visual C++."
  4. اكتب اسماً الحل حدد موقعاً الحل ثم انقر فوق موافق.
  5. في معالج التطبيق Makefile انقر فوق إنهاء.
  6. من القائمة المشروع Makefile Project انقر فوق خصائص.
  7. في المربع اكتب تكوين حدد المساعدة ثم انقر فوق موافق.
  8. من القائمة المشروع انقر فوق Dependencies… Project. لتنفيذ الأحداث pre-build اتبع الخطوات التالية:
    1. في تبويب الاعتمادية حدد مشروع Visual C# .NET المناسبة من قائمة المشاريع ثم ضمن Depends على ، انقر فوق المشروع Makefile Visual C++.
    2. انقر فوق موافق لتطبيق التغيير. يجعل هذا من إنشاء مشروع Visual C# .NET أو Visual C# 2005 الأخير.
    3. انقر بزر الماوس الأيمن فوق المشروع Makefile Visual C++ في "مستكشف الحلول" ومن ثم انقر فوق خصائص.
    4. انقر فوق إنشاء أحداث ثم قم بتحديد الأمر pre-build الحدث.
      على سبيل المثال، لنسخ الملف قبل إنشاء حدد ما يلي:
      copy c:\AddinReg.reg $(OutDir)
  9. لتنفيذ الإعداد post-build اتبع الخطوات التالية:
    1. انقر فوق المشروع Makefile Visual C++ في قائمة المشاريع ثم قم بتحديد مشروع Visual C# .NET أو Visual C# 2005 المناسب تحت Depends.
    2. انقر فوق موافق لتطبيق التغيير. يجعل هذا من إنشاء مشروع Visual C++ الأخير.
    3. انقر بزر الماوس الأيمن فوق المشروع Makefile Visual C++ في "مستكشف الحلول" ، انقر فوق خصائص ثم انقر فوق إنشاء أحداث لتحديد الأمر post-build الحدث.

استخدم PrePostBuildRules الوظيفة الإضافية إلى تنفيذ إنشاء أحداث

  1. هذه الوظيفة الإضافية يوفر pre-build وقواعد post-build في مستويات الحل والمشروع.
    لتحميل الوظيفة الإضافية راجع موقع Microsoft التالي على الويب:

    http://download.microsoft.com/download/VisualStudioNET/Samples/7.0/NT5XP/EN-US/BuildRules.exe

    تحذير: حالة استخدام "محرر التسجيل" بطريقة غير صحيحة، قد يؤدي حدوث مشكلات خطيرة يلزم إعادة تثبيت نظام التشغيل. ولا تضمن Microsoft حل المشكلات التي تنتج عن استخدام "محرر التسجيل" بطريقة غير صحيحة. استخدم "محرر التسجيل" على مسؤوليتك الخاصة.
    لاستخدام هذه الوظيفة الإضافية، اتبع الخطوات التالية:
    1. تحميل ملف الحل مع مصدر هذا كما ثم إنشاء الحل.
    2. في القائمة أدوات ، انقر فوق إدارة الوظائف الإضافية. إذا كان "إدارة" الوظائف الإضافية مفتوحاً، قم بإغلاقه ثم ثم افتحه مرة أخرى.

      ملاحظة إذا ظهر في جديدة الوظيفة الإضافية إضافة - في إدارة قائمة الوظائف الإضافية "، تم بنجاح تسجيل الوظيفة الإضافية.
    3. إذا الوظيفة الإضافية لم يظهر في إضافة - في إدارة ، اتبع الخطوات التالية إلى تسجيله يدوياً:
      1. حدد موقع الملف AddinReg.reg في المجلد BuildRules.
      2. انقر بزر الماوس الأيمن فوق AddinReg.reg ومن ثم انقر فوق دمج. انقر فوق نعم عند مطالبتك بإضافة الإدخالات إلى السجل.
      3. يمكن مشاهدة الإدخالات الجديدة التي تم إجراؤها على التسجيل في الموقع التالي:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\VisualStudio\7.0\AddIns
    4. بدء تشغيل مثيل جديد من Visual Studio .NET أو Visual Studio 2005.
    5. من القائمة أدوات، انقر فوق الإضافية الجديدة.
    6. يظهر مربع حوار يسمح لك حدد الحل أو المشروع ثم إضافة قواعد إليه.
    7. عند إضافة قاعدة يمكنك تحديد اسم echo كاسم برنامج عرض النص غير المنسق في إطار الإخراج.
مراجع
للحصول على مزيد من المعلومات، راجع موقع Microsoft التالي على الويب:

نماذج التنفيذ التلقائي لبرنامج Visual Studio .NET
http://www.microsoft.com/downloads/details.aspx?familyid=3ff9c915-30e5-430e-95b3-621dccd25150&displaylang=en

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 810230 - آخر مراجعة: 12/08/2015 01:40:14 - المراجعة: 3.3

Microsoft Visual C# .NET 2002 Standard Edition, Microsoft Visual C# .NET 2003 Standard Edition, Microsoft Visual C++ .NET 2002 Standard Edition, Microsoft Visual C++ .NET 2003 Standard Edition, Microsoft Visual C# 2005 Express Edition

  • kbnosurvey kbarchive kbmt kbdownload kbhowtomaster kbcompiler kbhowto KB810230 KbMtar
تعليقات