أنت غير متصل حاليًا، وفي انتظار الإنترنت الخاص بك ليقوم بإعادة الاتصال

كيفية تغيير طريقة العرض الافتراضية نموذج InfoPath برمجياً

انتهاء دعم Office 2003

لقد أنهت شركة Microsoft دعم Office 2003 في 8 أبريل، 2014. وقد أثر هذا التغيير على تحديثات البرامج لديك وخيارات الأمان الخاصة بك. تعرف على ما يعنيه ذلك فيما يتعلق بك وكيفية الحفاظ على حمايتك.

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

826997
الموجز
نماذج Microsoft Office InfoPath يعتمد طرق عرض متعددة. هي طريقة عرض افتراضية. عند فتح نموذج في 2010 InfoPath Microsoft أو Microsoft Office InfoPath 2007 Microsoft Office InfoPath 2003 فتح النموذج في طريقة العرض الافتراضية. تحتوي هذه المقالة على مثال عن كيفية تغيير طريقة العرض الافتراضية نموذج InfoPath برمجياً.

إنشاء نموذج جديد

  1. بدء تشغيل InfoPath.
    • لـ InfoPath مصمم 2010:
      1. انقر فوق جديد ، انقر فوق نموذج فارغ ثم انقر فوق تصميم النموذج.
    • InfoPath 2007:
      1. انقر فوق تصميم "قالب نموذج" من القائمة ملف.
      2. انقر فوق فارغ في جزء المهام تصميم "قالب نموذج" ثم انقر فوق موافق.
    • لـ InfoPath 2003:
      1. انقر فوق تصميم نموذج القائمة ملف.
      2. انقر فوق نموذج فارغ جديد في جزء المهام تصميم نموذج.

إنشاء عرض 1

لـ InfoPath 2010:
  1. في النموذج فارغة بكتابة يعتبر هذا عرض 1 للعنوان الرئيسي واكتب ثم تفحص لعرض عرض 2 عند فتح النموذج أسفل السطر المنقط.
  2. انقر فوق ضع المؤشر في بداية السطر الثاني.
  3. انقر نقراً مزدوجاً فوق خانة اختيار في عناصر التحكم.
  4. انقر فوق الرمز حفظ.
InfoPath 2003 و InfoPath 2007:
  1. في النموذج فارغة اكتب هذا هو 1 عرض السطر الأول, ثم اكتب التحقق لعرض عرض 2 عند فتح قالب النموذج على السطر الثاني.
  2. انقر فوق ضع المؤشر في بداية السطر الثاني.
  3. على القائمة المنسدلة أجزاء المهام انقر فوق عناصر التحكم.
  4. في جزء المهام عناصر التحكم، انقر فوق خانة اختيار.
  5. انقر فوق الرمز حفظ.

إنشاء عرض 2

لـ InfoPath 2010:
  1. انقر فوق علامة التبويب تصميم الصفحة إشعار يعتبر 1 عرض طريقة العرض الافتراضية للنموذج.
  2. في المقطع طرق العرض، انقر فوق طريقة عرض جديدة.
  3. اكتب اسم عرض 2 ومن ثم انقر فوق موافق.
  4. للحصول على العنوان، اكتب هذا هو عرض 2.
InfoPath 2003 و InfoPath 2007:
  1. على القائمة المنسدلة أجزاء المهام انقر فوق طرق عرض.

    طريقة العرض 1 هي طريقة العرض الافتراضية للنموذج.
  2. في المقطع الإجراءات من جزء المهام "، انقر فوق إضافة طريقة" عرض جديدة ".
  3. اكتب اسم عرض 2 ومن ثم انقر فوق موافق.
  4. في النموذج فارغة بكتابة يعتبر هذا عرض 2.

إضافة برنامج نصي

InfoPath 2007

عليك تعيين لغة البرمجة التي تريد استخدامها في InfoPath 2010 و2007. بالنسبة لبرنامج InfoPath 2003، تخطي هذا الإجراء ثم قم باستخدام الإجراء إضافة البرنامج النصي.

ملاحظة يستخدم هذا المثال في C# لغة البرمجة. يمكنك استخدام Visual Basic أو خيارات أخرى متوفرة.
تعيين لغة البرمجة
لـ InfoPath 2010:

قبل تشغيل هذا البرنامج النصي نموذج في InfoPath 2010 ، يجب تغيير لغة البرمجة إلى C#. للقيام بذلك، اتبع الخطوات التالية.

تحذير الأمر "إزالة التعليمات البرمجية" المشار إليه في الخطوات التالية بإزالة كافة التعليمات البرمجية الموجودة من النموذج الحالي. لذلك، لا تستخدم هذا الخيار ما لم تكن متأكداً من أنك تريد تنفيذ هذا الإجراء.
  1. انقر فوق علامة تبويب المطور.
  2. في المقطع تعليمات برمجية "، انقر فوق اللغة ثم انقر فوق تحديد البرمجة. إذا تم تعطيل مربع لغة التعليمات البرمجية لقالب النموذج انقر فوق إزالة التعليمات البرمجية إلى إزالة كافة التعليمات البرمجية الموجودة في النموذج. إذا توفرت خانة لغة التعليمات البرمجية لقالب نموذج ، انتقل إلى الخطوة التالية.
  3. في القائمة لغة التعليمات البرمجية لقالب نموذج ، انقر لتحديد C# ثم انقر فوق موافق.
InfoPath 2007:

قبل تشغيل هذا البرنامج النصي نموذج في InfoPath 2007 ، يجب تغيير لغة البرمجة إلى C#. للقيام بذلك، اتبع الخطوات التالية:

تحذير الأمر "إزالة التعليمات البرمجية" المشار إليه في الخطوات التالية بإزالة كافة التعليمات البرمجية الموجودة من النموذج الحالي. لذلك، لا تستخدم هذا الخيار ما لم تكن متأكداً من أنك تريد تنفيذ هذا الإجراء.
  1. من القائمة أدوات، انقر فوق خيارات النموذج.
  2. في القائمة فئة ، انقر فوق البرمجة. إذا تم تعطيل مربع لغة التعليمات البرمجية لقالب النموذج انقر فوق إزالة التعليمات البرمجية إلى إزالة كافة التعليمات البرمجية الموجودة في النموذج. إذا توفرت خانة لغة التعليمات البرمجية لقالب نموذج ، انتقل إلى الخطوة التالية.
  3. في القائمة لغة التعليمات البرمجية لقالب نموذج ، انقر فوق C# ثم انقر فوق موافق.
قم بإضافة البرنامج النصي
لـ InfoPath 2010:

قم بإضافة البرنامج النصي إلى تحميل الأحداث. للقيام بذلك، اتبع الخطوات التالية:
  1. ضمن علامة التبويب "المطور" ، انقر فوق تحميل حدث. يبدأ Microsoft Visual Studio أدوات للتطبيقات.
  2. إضافة مثال التعليمة البرمجية التالية في المواقع المشار إليها.
    {            //Create an XPathNavigator object for the main DOM            XPathNavigator xnDocument = this.MainDataSource.CreateNavigator();            //Create an XPathNavigator object for field1 - the check box for switching the View            XPathNavigator xnDefaultView = xnDocument.SelectSingleNode("/my:myFields/my:field1", this.NamespaceManager);                  //Make sure that the XPathNavigator object is not null or an empty string            if ((xnDefaultView != null) && (xnDefaultView.Value != ""))            {                //Switch to the appropriate View                switch (xnDefaultView.Value)                {                    case "false":                        e.SetDefaultView("View 1");                        break;                    case "true":                        e.SetDefaultView("View 2");                        break;                }        }}
  3. حفظ التغييرات ثم قم بإغلاق أدوات Visual Studio للتطبيقات.
  4. حفظ قالب النموذج الخاص بك SwitchDefaultView.xsn ثم قم بإغلاق قالب النموذج.
للحصول على InfoPath 2007

قم بإضافة البرنامج النصي إلى "حدث تحميل". للقيام بذلك، اتبع الخطوات التالية:
  1. من القائمة أدوات، أشر إلى البرمجة ثم انقر فوق تحميل الأحداث. يبدأ Microsoft Visual Studio أدوات للتطبيقات.
  2. إضافة رمز المثال التالي إلى الحدث Age_OnValidate.
    {            //Create an XPathNavigator object for the main DOM            XPathNavigator xnDocument = this.MainDataSource.CreateNavigator();            //Create an XPathNavigator object for field1 - the check box for switching the View            XPathNavigator xnDefaultView = xnDocument.SelectSingleNode("/my:myFields/my:field1", this.NamespaceManager);                  //Make sure that the XPathNavigator object is not null or an empty string            if ((xnDefaultView != null) && (xnDefaultView.Value != ""))            {                //Switch to the appropriate View                switch (xnDefaultView.Value)                {                    case "false":                        e.SetDefaultView("View 1");                        break;                    case "true":                        e.SetDefaultView("View 2");                        break;                }
  3. حفظ التغييرات ثم قم بإغلاق أدوات Visual Studio للتطبيقات.
  4. حفظ قالب النموذج الخاص بك SwitchDefaultView.xsn ثم قم بإغلاق قالب النموذج.

InfoPath 2003

لإضافة البرنامج النصي في InfoPath 2003، اتبع الخطوات التالية:
  1. من القائمة أدوات، أشر إلى البرنامج النصي ومن ثم انقر فوق Microsoft Script Editor.
  2. قم بإضافة التعليمات البرمجية التالية إلى إطار التعليمات البرمجية: دالة
    function XDocument::OnLoad(eventObj){	//Pick the default view based on the value of element DefaultView	var objDefaultView = XDocument.DOM.selectSingleNode("//my:field1");	if ((objDefaultView != null) && (objDefaultView.text != ""))   	{		switch (objDefaultView.text)      		{         		case "false":				    XDocument.ViewInfos("View 1").IsDefault = true;            			break;         		case "true":            			XDocument.ViewInfos("View 2").IsDefault = true;            			break;      		}   	}}
  3. حفظ البرنامج النصي ثم قم بإغلاق Microsoft Script Editor.
  4. حفظ قالب النموذج الخاص بك SwitchDefaultView.xsn ثم قم بإغلاق قالب النموذج.

اختبار برنامج نصي

للحصول على InfoPath 2010
  1. افتح ملء Microsoft Office InfoPath.
  2. انقر فوق نموذج بحث استعراض SwitchDefaultView.xsn حدده ثم انقر فوق فتح.

    يتم فتح النموذج في طريقة العرض 1 (طريقة العرض الافتراضية الأولي).
  3. انقر لتحديد خانة الاختيار عرض 2.
  4. احفظ النموذج SwitchDefaultViewForm.xml ثم قم بإغلاق النموذج.
  5. ضمن علامة التبويب "ملف" ، انقر فوق إغلاق ثم انقر فوق فتح.
  6. حدد موقع SwitchDefaultViewForm.xml ثم انقر فوق فتح.
يتم فتح النموذج في طريقة عرض 2.

InfoPath 2003 و InfoPath 2007:
  1. من القائمة ملف، انقر فوق تعبئة نموذج.

    ملاحظة تأكد من تعبئة النموذج في هذه الخطوة بدلاً من معاينة النموذج. معاينة لا يعكس أي تغيير البرمجي طريقة العرض الافتراضية في الحدث OnLoad. يُظهر وضع معاينة طريقة العرض المحددة حالياً في مصمم InfoPath دوماً.
  2. في InfoPath 2007، انقر فوق SwitchDefaultView ضمن فتح نموذج.

    في InfoPath 2003، انقر فوق SwitchDefaultView في جزء المهام.

    يتم فتح النموذج في طريقة العرض 1 (طريقة العرض الافتراضية الأولي).
  3. انقر لتحديد خانة الاختيار عرض 2.
  4. احفظ النموذج SwitchDefaultViewForm.xml ثم قم بإغلاق النموذج.
  5. من القائمة ملف، انقر فوق فتح.
  6. حدد موقع SwitchDefaultViewForm.xml ثم انقر فوق فتح.
يتم فتح النموذج في طريقة عرض 2.
ip2007 ip2010 ip2003 VBA C# أو

تحذير: تمت ترجمة هذا المقال تلقائياً

خصائص

رقم الموضوع: 826997 - آخر مراجعة: 05/14/2010 21:47:08 - المراجعة: 4.0

  • Microsoft Office InfoPath 2007
  • Microsoft Office InfoPath 2003
  • Microsoft Office InfoPath 2003, Service Pack 1 (SP1)
  • Microsoft Infopath 2010
  • kbmt kbhowto KB826997 KbMtar
تعليقات
>