كيفية تصحيح أخطاء برنامج نصي نموذج InfoPath

انتهاء دعم Office 2003

لقد أنهت شركة Microsoft دعم Office 2003 في 8 أبريل، 2014. وقد أثر هذا التغيير على تحديثات البرامج لديك وخيارات الأمان الخاصة بك. تعرف على ما يعنيه ذلك فيما يتعلق بك وكيفية الحفاظ على حمايتك.

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية827002
الموجز
توضح هذه المقالة كيفية إيقاف تنفيذ التعليمات البرمجية في نموذج InfoPath. تحتاج إلى القيام بذلك بحيث يمكن تصحيح أخطاء برنامج نصي نموذج InfoPath.
معلومات أخرى
لتصحيح نصي نموذج InfoPath، يجب أولاً إرفاق مصحح البرنامج النصي Microsoft إلى نموذج InfoPath. عند debugs "مصحح البرنامج النصي" برنامج نصي نموذج InfoPath, لم يتم التعرف على نقاط التوقف. لذلك، لا يوقف بتنفيذ التعليمات البرمجية في نقاط التوقف. بدلاً من نقاط التوقف ، يجب استخدام جملة Microsoft JScript مصحح الأخطاء (أو بيان Microsoft Visual Basic Scripting [VBScript] STOP) لإيقاف تنفيذ التعليمات البرمجية لأغراض التصحيح.

للحصول على معلومات إضافية حول كيفية إيقاف تنفيذ التعليمات البرمجية لتصحيح الأخطاء مع JScript و مع VBScript وكذلك حول كيفية تغيير لغة البرنامج النصي في نموذج InfoPath إلى VBScript أو JScript انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف لـ Microsoft:
828853كيفية تغيير لغة البرنامج النصي في نموذج InfoPath

خطوة بخطوة

InfoPath Office 2007

في InfoPath 2007، يجب عليك أولاً تعيين لغة البرمجة التي تريد استخدامها. وبعد ذلك، يجب إضافة البرنامج النصي.

ملاحظة يتم تضمين الأمثلة البرمجية JScript و VBScript في هذه المقالة.
تعيين لغة البرمجة
قبل تشغيل هذا البرنامج النصي نموذج في InfoPath 2007 يجب تغيير لغة البرمجة VBScript أو بلغة Jscript. للقيام بذلك، اتبع الخطوات التالية:

تحذير يزيل الأمر "إزالة التعليمات البرمجية" الواردة في الخطوات التالية كافة التعليمات البرمجية الموجودة من النموذج الحالي. لذلك، لا تستخدم هذا الخيار إلا إذا كنت تريد تنفيذ هذا الإجراء بالتأكيد.
  1. من القائمة أدوات، انقر فوق "خيارات النموذج".
  2. في القائمة فئة ، انقر فوق البرمجة. إذا تم تعطيل مربع لغة التعليمات البرمجية لقالب نموذج ، انقر فوق إزالة التعليمات البرمجية إلى إزالة كافة التعليمات البرمجية الموجودة في النموذج. في حالة توفر المربع لغة التعليمات البرمجية قالب النموذج، انتقل إلى الخطوة 3.
  3. في المربع لغة التعليمات البرمجية لقالب نموذج ، انقر فوق VBScript أو بلغة Jscript ثم انقر فوق موافق.
قم بإضافة البرنامج النصي
  1. من القائمة أدوات، أشر إلى البرمجة ثم انقر فوق عند حدث التحميل. بدء تشغيل Microsoft أدوات Visual Studio للتطبيقات.
  2. استبدال الدالة OnLoad باستخدام التعليمات البرمجية التالية JScript أو VBScript رمز كما هو مناسب:

    JScript
    	function XDocument::OnLoad(eventObj)	{		debugger;		XDocument.UI.Alert("This is a test.");	}
    VBScript
    	Sub XDocument_OnLoad(eventObj)		Stop		XDocument.UI.Alert "This is a test."	End Sub
  3. حفظ التغييرات ثم قم بإغلاق أدوات Visual Studio للتطبيقات.
  4. على شريط الأدوات قياسي ، انقر فوق معاينة.
  5. يظهر مربع الحوار التصحيح Just-In-Time. حدد جديد مثيل من Microsoft Script Editor في القائمة مصححات المحتملة ثم انقر فوق نعم.

    تظهر البرنامج النصي في محرر البرامج النصية ويتوقف بتنفيذ البرامج النصية.

    ملاحظة إذا ظهر Script Editor ولكن لا تظهر التعليمة البرمجية الخاصة بك قد يلزم الأمر تثبيت ميزة "تصحيح ويب" محرر البرامج النصية. للحصول على تفاصيل، راجع قسم "تثبيت البرامج تصحيح ويب".
  6. اضغط F10 للتنقل خلال سطر المتبقية من التعليمات البرمجية في البرنامج النصي.

InfoPath 2003

  1. بدء تشغيل Infopath 2003.
  2. من القائمة ملف، انقر فوق تصميم نموذج.
  3. في جزء مهام نموذج التصميم, انقر فوق نموذج فارغ جديد.
  4. لإضافة البرنامج النصي التالي إلى النموذج الخاص بك اتبع الخطوات التالية:
    1. من القائمة أدوات، أشر إلى البرامج ، ثم حدد عند حدث التحميل.

      يظهر Microsoft Script Editor.
    2. استبدال الدالة OnLoad التعليمة البرمجية التالية:

      JScript
      	function XDocument::OnLoad(eventObj)	{		debugger;		XDocument.UI.Alert("This is a test.");	}
      VBScript
      	Sub XDocument_OnLoad(eventObj)		Stop		XDocument.UI.Alert "This is a test."	End Sub
    3. حفظ البرنامج النصي ثم قم بإغلاق Script Editor.
  5. من القائمة ملف، أشر إلى نموذج معاينة ثم انقر فوق افتراضي.
  6. يظهر مربع الحوار التصحيح Just-In-Time. حدد جديد مثيل من Microsoft Script Editor في القائمة مصححات المحتملة ثم انقر فوق نعم.

    يظهر مربع الحوار الخطوة إلى استدعاء إجراء بعيد. انقر فوق موافق.

    تظهر البرنامج النصي في محرر البرامج النصية ويتوقف بتنفيذ البرامج النصية.

    ملاحظة إذا ظهر Script Editor ولكن لا تظهر التعليمة البرمجية الخاصة بك ثم قد يلزم تثبيت ميزة "تصحيح ويب" محرر البرامج النصية. للحصول على التفاصيل، راجع المقطع التالي "تثبيت البرامج تصحيح ويب".
  7. اضغط F10 للتنقل خلال سطر المتبقية من التعليمات البرمجية في البرنامج النصي.

تثبيت تصحيح البرامج النصية ويب

عندما يحاول تصحيح البرنامج النصي الخاص إذا فتح محرر البرامج النصية ولكن التعليمات البرمجية لا تظهر في الإطار "تعليمات برمجية" ، انقر فوق القائمة "تصحيح ، ثم انقر فوق تثبيت تصحيح ويب". إذا تم وضع علامة ميزة "تصحيح ويب" التثبيت عند أثناء إعداد Office ، تتلقى رسالة الخطأ التالية:
تثبيت الميزة "تصحيح ويب سوف تتطلب منك إعادة تشغيل Microsoft Script Editor. لم يتم تثبيت هذه الميزة حالياً. هل تريد تثبيته الآن؟
انقر فوق نعم لتثبيت تصحيح ويب. بعد التثبيت، يجب إغلاق وضع معاينة ومن ثم يجب عليك بدء تشغيل وضع "معاينة" مرة أخرى لتصحيح البرنامج النصي.

إذا تم وضع الميزة "تصحيح ويبلم يتم تثبيت أثناء إعداد Office ، تتلقى رسالة الخطأ التالية:
تثبيت الميزة "تصحيح ويب سوف تتطلب منك إعادة تشغيل Microsoft Script Editor. لا تتوفر هذه الميزة. لجعل هذه الميزة متوفرة الرجاء تشغيل الإعداد مرة أخرى وحدد "إضافة أو إزالة ميزات" ثم قم بتغيير الميزة إلى "تشغيل من جهاز الكمبيوتر" أو "تشغيل من القرص المضغوط/الشبكة".
انقر فوق موافق ثم قم بإنهاء محرر البرامج النصية.

لتثبيت ميزة "تصحيح ويب مع إعداد Office اتبع الخطوات التالية:

InfoPath 2007

  1. في "لوحة التحكم" ، قم بفتح العنصر "إضافة أو إزالة البرامج".
  2. حدد Microsoft Office في قائمة البرامج المثبتة ثم انقر فوق تغيير.

    بدء تشغيل برنامج إعداد Office.
  3. حدد "إضافة أو إزالة ميزات" في قائمة خيارات وضع الصيانة ثم انقر فوق التالي.
  4. قم بتوسيع عقدة أدوات Office.
  5. قم بتوسيع عقدة تحرير مصدر HTML.
  6. قم بتوسيع عقدة برمجة ويب النصية.
  7. انقر فوق تصحيح ويب ثم انقر فوق تشغيل من "جهاز الكمبيوتر".
  8. انقر فوق متابعة.
  9. بعد تحديث "التكوين" ، انقر فوق إغلاق.

InfoPath 2003

  1. في "لوحة التحكم" ، حدد "إضافة أو إزالة البرامج".
  2. حدد Microsoft Office في قائمة البرامج المثبتة ثم انقر فوق تغيير.

    يبدأ "برنامج إعداد Office".
  3. حدد "إضافة أو إزالة ميزات" في قائمة خيارات وضع الصيانة ثم انقر فوق التالي.
  4. حدد اختيار التخصيص المتقدم للتطبيقات ثم انقر فوق التالي.
  5. انقر نقراً مزدوجاً فوق عقدة أدوات Office.
  6. انقر نقراً مزدوجاً فوق عقدة "تحرير مصدر HTML.
  7. انقر نقراً مزدوجاً فوق عقدة برمجة ويب النصية.
  8. تحديد القائمة المنسدلة تصحيح ويب ثم انقر فوق تشغيل من "جهاز الكمبيوتر".
  9. انقر فوق تحديث.
ip2007

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 827002 - آخر مراجعة: 05/01/2007 17:56:24 - المراجعة: 2.1

Microsoft Office InfoPath 2007, Microsoft Office InfoPath 2003, Microsoft Office InfoPath 2003, Service Pack 1 (SP1)

  • kbmt kbscript kbdebug kbappdev kbhowto kbcode KB827002 KbMtar
تعليقات