كيفية: تغيير لغة البرنامج النصي لـ نموذج InfoPath الخاص بك

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية828853
تمت أرشفة هذه المقالة. وتظهر "كما هي" ولن يتم تحديثها بعد الآن.
الموجز
توضح هذه المقالة كيفية تغيير لغة البرنامج النصي في قالب نموذج InfoPath.

إذا تم مسبقاً بدء Microsoft Script Editor لقالب نموذج ، يمكن فقط تغيير لغة البرنامج النصي بواسطة إزالة البرنامج النصي الموجود الأولى من قالب النموذج. توضح هذه المقالة أيضًا كيفية يمكنك إزالة البرنامج النصي من القالب الخاص بك بحيث يمكنك تغيير لغة البرنامج النصي.
معلومات أخرى

تغيير لغة البرنامج النصي لقالب النموذج الخاص بك

  1. فتح القالب الخاص بك في وضع التصميم في InfoPath.
  2. من القائمة أدوات، انقر فوق "خيارات النموذج".

    يظهر مربع الحوار خيارات النموذج.
  3. انقر فوق علامة التبويب خيارات متقدمة.
  4. حدد اللغة المفضلة في القائمة المنسدلة لغة البرنامج النصي النموذج ثم انقر فوق موافق.
  5. من القائمة أدوات، أشر إلى البرنامج النصي ومن ثم انقر فوق Microsoft Script Editor.

    يظهر Microsoft Script Editor.

إزالة البرنامج النصي من قالب النموذج الخاص بك

هام الخطوات التالية قم بإزالة أي برنامج نصي الموجود من قالب النموذج الخاص بك. لتغيير لغة البرمجة النصية بنجاح بعد أن يبدأ محرر البرامج النصية لقالب النموذج الخاص بك يجب أن تقوم بإكمال الخطوات التالية.
  1. عمل نسخة احتياطية عن قالب نموذج InfoPath (ملف .xsn).
  2. فتح القالب الخاص بك في وضع التصميم في InfoPath.
  3. من القائمة ملف، انقر فوق استخراج ملفات النموذج.

    يظهر مربع الحوار الاستعراض بحثاً عن مجلد.
  4. حدد المجلد الذي تريد استخراج ملفات النموذج ثم انقر فوق موافق.
  5. إغلاق قالب النموذج الخاص بك.
  6. لتعديل Manifest.xsf اتبع الخطوات التالية:
    1. بدء تشغيل محرر نص مثل المفكرة أو بدء تشغيل محرر XML مثل Visual Studio .NET. افتح Manifest.xsf الموجود في المجلد الذي قمت باستخراج ملفات النموذج.
    2. حدد موقع ثم قم بحذف المقطع التالي:
      <xsf:file name="script.js">        <xsf:fileProperties>            <xsf:property name="scriptType" type="string" value="userEvents"></xsf:property>        </xsf:fileProperties>    </xsf:file>
    3. تحديد موقع العقدة xsf:solutionProperties ثم قم بحذف السمة scriptLanguage.

      على سبيل المثال، إذا كان يستخدم نموذج InfoPath الخاص بك حالياً JScript من أجل لغة البرنامج النصي, عقدة xsf:solutionProperties سيقرأ كما يلي:
      <xsf:solutionProperties scriptLanguage="jscript" fullyEditableNamespace="http://schemas.microsoft.com/office/infopath/2003/myXSD/2003-09-10T17:55:25" lastOpenView="view1.xsl"></xsf:solutionProperties>

      بعد حذف سمة scriptLanguage عقدة xsf:solutionProperties سيقرأ كالتالي::
      <xsf:solutionProperties fullyEditableNamespace="http://schemas.microsoft.com/office/infopath/2003/myXSD/2003-09-10T17:55:25" lastOpenView="view1.xsl"></xsf:solutionProperties>
    4. حدد موقع ثم قم بحذف المقطع التالي:
      <xsf:scripts language="jscript">     <xsf:script src="script.js"></xsf:script></xsf:scripts>
    5. حفظ التغييرات إلى Manifest.xsf وإغلاق محرر البرامج النصية.
  7. في "مستكشف Microsoft Windows،" انقر بزر الماوس الأيمن فوق Manifest.xsf ومن ثم انقر فوق تصميم.

    يتم فتح القالب الخاص بك في وضع التصميم في InfoPath.
  8. من القائمة ملف، انقر فوق حفظ.
  9. لتعيين لغة البرنامج النصي الخاص بك المفضل اتبع الخطوات الموجودة في القسم "تغيير Script اللغة الخاصة Your قالب نموذج".
مراجع
للحصول على معلومات إضافية حول تصحيح البرنامج النصي في قالب نموذج InfoPath انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف لـ Microsoft:
827002HOW TO: تصحيح برنامج نصي للحصول على نموذج Microsoft Office InfoPath 2003

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 828853 - آخر مراجعة: 12/08/2015 04:45:30 - المراجعة: 1.3

Microsoft Office InfoPath 2003

  • kbnosurvey kbarchive kbmt kbhowto KB828853 KbMtar
تعليقات