كيفية وضع صورة على زر في InfoPath 2003 أو في InfoPath 2007

انتهاء دعم Office 2003

لقد أنهت شركة Microsoft دعم Office 2003 في 8 أبريل، 2014. وقد أثر هذا التغيير على تحديثات البرامج لديك وخيارات الأمان الخاصة بك. تعرف على ما يعنيه ذلك فيما يتعلق بك وكيفية الحفاظ على حمايتك.

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية832511
تمت أرشفة هذه المقالة. وتظهر "كما هي" ولن يتم تحديثها بعد الآن.
الموجز
يمكنك وضع صورة من ملف .gif من واجهة عنصر تحكم زر في Microsoft Office InfoPath 2007 أو في Microsoft Office InfoPath 2003. يمكنك القيام بذلك عن طريق تحديد سمات الزر في الملف View.xsl من النموذج. يجب تعديل نمط عنصر الإدخال في الملف View.xsl للنموذج.
معلومات أخرى
تصف الخطوات التالية كيفية إنشاء نموذج يضع ملف .gif على زر. تتطلب الخطوات التالية استخدام ملف .gif. تثبيت نموذجي من Microsoft Office لدى مجلد ملفات .gif يمكنك تحديد من لمساعدة في تطوير المثال الخاص بك. افتراضياً، يقع مجلد ملفات .gif في Office\ClipArt\PUB60Cor Files\Microsoft C:\Program.
  1. بدء تشغيل InfoPath. إنشاء نموذج فارغ.
  2. في جزء المهام مهام التصميم انقر فوق الارتباط عناصر التحكم. انقر فوق عنصر تحكم زر.

    يظهر عنصر تحكم زر على نموذج فارغ.
  3. انقر بزر الماوس الأيمن فوق زر في النموذج لها ثم انقر فوق خصائص الزر. في مربع الحوار خصائص الزر انقر فوق علامة التبويب "الحجم" تغيير الارتفاع إلى 100 بكسل. تغيير العرض إلى 100 بكسل. انقر فوق موافق.
  4. في InfoPath 2007، انقر فوق "ملفات الموارد" في قائمة "أدوات". في مربع الحوار ملفات الموارد، انقر فوق إضافة. نقل إلى المجلد الذي يحتوي على ملفات .gif ومن ثم انقر نقراً مزدوجاً فوق الملف .gif الذي تريده. انقر فوق موافق لإغلاق مربع الحوار ملفات الموارد.

    في InfoPath 2003، انقر فوق إدارة الموارد في القائمة أدوات. في مربع الحوار "إدارة الموارد" ، انقر فوق إضافة. نقل إلى المجلد الذي يحتوي على ملفات .gif ومن ثم انقر نقراً مزدوجاً فوق الملف .gif الذي تريده. انقر فوق موافق لإغلاق مربع الحوار "إدارة الموارد".

    ملاحظة الملف المستخدم في هذا المثال هو AG00174_.gif.
  5. من القائمة ملف، انقر فوق حفظ.
  6. في المربع اسم الملف ، اكتب Button1 لتغيير اسم النموذج. حفظ النموذج إلى مجلد من اختيارك. انقر فوق "حفظ" لإغلاق مربع الحوار حفظ باسم.

    ملاحظة لم يتم إغلاق النموذج الذي تقوم بتصميمه.
  7. في InfoPath 2007، انقر فوق حفظ كملفات مصدر من القائمة ملف.

    في InfoPath 2003، انقر فوق استخراج ملفات نموذج القائمة ملف.
  8. في مربع الحوار الاستعراض بحثاً عن مجلد الانتقال إلى المجلد الذي قمت بحفظ النموذج Button1. انقر فوق المجلد ثم انقر فوق موافق لإغلاق مربع الحوار الاستعراض بحثاً عن مجلد. من القائمة ملف، انقر فوق إغلاق لإغلاق النموذج.
  9. في Microsoft Windows Explorer، انتقل إلى المجلد الذي يحتوي على النموذج والملفات التي تم استخراجها من الملف Button1.xsn.

    ملاحظة يحتوي المجلد على ملف Button1.xsn الأصلي الملفات المستخرجة التالية:
    • Manifest.xsf
    • Sampledata.xml
    • Template.xml
    • Myschema.xsd
    • View1.xsl
  10. فتح ملف View1.xsl في "المفكرة". للقيام بذلك، اتبع الخطوات التالية:
    1. انقر بزر الماوس الأيمن فوق الملف View1.xsl.
    2. انقر فوق فتح باستخدام.
    3. انقر فوق "المفكرة" من الخيارات المتوفرة.
  11. في ملف View1.xsl الآن مفتوح في "المفكرة" ، حدد موقع السطر التالي من التعليمات البرمجية:
    <input class="langFont" title="" style="WIDTH: 86px; HEIGHT: 85px" type="button" value="Button" xd:xctname="Button"      xd:CtrlId="CTRL1_5" tabIndex="0"/>
    From the following style attribute, copy the part that is in quotation marks:
    style="BORDER: none; BACKGROUND-IMAGE: url(yourImageHere.gif); BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat;"
    Note What you copy will look similar to the following code:
    BORDER: none; BACKGROUND-IMAGE: urlYourImageHere.gif; BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat;
    Insert what you just copied into the existing style attribute so that the completed line will now look similar to the following code:
    <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(yourImageHere.gif);      BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat; WIDTH: 86px; HEIGHT: 85px" type="button"      value="Button" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
  12. تغيير قيمة URL النمط من url(yourimageHere.gif) إلى url(AG00174_.gif).

    ملاحظة يمكنك أيضاً استخدام الاسم لملف .gif الذي اخترته مسبقًا.

    The code that appears will look similar to the following code:
    <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(AG00174_.gif);      BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat; WIDTH: 86px; HEIGHT: 85px" type="button"      value="Button" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
  13. حفظ ملف View1.xsl تم. قم بإغلاق "المفكرة".
  14. نقل إلى مجلد يحتوي على الملفات المستخرجة من Button1.xsn.

    ملاحظة هذا هو المجلد مع ملف View1.xsl تم.
  15. انقر نقراً مزدوجاً فوق Manifest.xsf لفتح النموذج في InfoPath.

    ملاحظة يظهر زر الأصلي صورة .gif في الزاوية العلوية اليمنى بالكلمة زر في وسط الزر.
  16. قم بإغلاق InfoPath.
  17. في المفكرة، إعادة فتح الملف View1.xsl. لتعديل "< الإدخال... / >" المقطع "، اتبع الخطوات التالية:
    1. تغيير حجم زر إلى 100 بكسل × 100 بكسل.

      يمكنك القيام بذلك عن طريق تغيير سمة عرض الزر وقم بتغيير سمة ارتفاع الزر.
    2. حذف الكلمة زر لإزالة الكلمة زر من وجه الزر.

      يمكنك القيام بذلك عن طريق تغيير السمة VALUE الزر.
    3. توسيط الصورة .gif على الزر.

      يمكنك القيام بذلك عن طريق تغيير السمة موضع الخلفية من الزر.

      <input.../> تغييرها element will look similar to the following code:
      <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(AG00174_.gif);      BACKGROUND-POSITION: center; BACKGROUND-REPEAT: no-repeat; WIDTH: 100px; HEIGHT: 100px" type="button"      value="" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
    4. حفظ ملف View1.xsl تم. قم بإغلاق "المفكرة".
  18. استبدال الإصدار السابق من الملف Manifest.xsf باستخدام إصدار أحدث من الملف Manifest.xsf.

    ملاحظة إذا نقرت نقراً مزدوجاً فوق الملف Manifest.xsf فتح النموذج في InfoPath. التغييرات غير موجودة في النموذج. يحدث هذا السلوك لأن الإصدار السابق من الملف Manifest.xsf في ذاكرة التخزين المؤقت. يجب استبدال الإصدار السابق من الملف Manifest.xsf مع الإصدار الحالي من الملف Manifest.xsf. للقيام بذلك، استخدم إحدى الطرق التالية:
    • الطريقة 1: تشغيل Windows سطر الأوامر، اكتب الأمر التالي ثم اضغط مفتاح الإدخال ENTER:
      InfoPath.exe /cache clearall
    • الطريقة 2:
      1. فتح ملف Manifest.xsf في "المفكرة".
      2. من القائمة ملف، انقر فوق حفظ باسم.

        يطالب مربع الحوار حفظ باسم ما إذا كنت تريد استبدال الملف الموجود مع نفس اسم الملف.
      3. انقر فوق نعم
    يحتوي إصدار أحدث من الملف Manifest.xsf طابع زمني أحدث. لذلك، عند النقر نقراً مزدوجاً فوق إصدار أحدث من الملف Manifest.xsf يتم تجاهل ملف ذاكرة التخزين المؤقت. يتم استبدال ملف ذاكرة التخزين المؤقت باستخدام إصدار أحدث من الملف Manifest.xsf. بعد إكمال الطريقة الأولى أو الطريقة الثانية انقر نقراً مزدوجاً فوق إصدار أحدث من الملف Manifest.xsf. يمكنك أن ترى الزر جديد.
ip2007

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 832511 - آخر مراجعة: 12/08/2015 05:28:24 - المراجعة: 2.2

Microsoft Office InfoPath 2007, Microsoft Office InfoPath 2003, Microsoft Office InfoPath 2003, Service Pack 1 (SP1)

  • kbnosurvey kbarchive kbmt kbhowtomaster KB832511 KbMtar
تعليقات