كيفية فتح المستندات باستخدام ميزة "فتح وإصلاح" في Word

هام: تمت ترجمة هذه المقالة باستخدام برامج مايكروسوفت للترجمة الآلية ومن المحتمل ان يتم تحريرها او تدقيقها بعد ذلك من خلال تكنولوجيا منصة مجموعات الترجمة(CTF) او من خلال مترجم بشري. تقدم لك شركة مايكروسوفت هذه المقالات المترجمة بشكل آلي او بالترجمة البشرية او بعد تحريرها وتدقيقها من قبل مجموعات الترجمة حتى تمكنكم من الوصول إلى جميع المقالات الموجودة في قواعد المعرفة لديها بلغات مختلفة. إلا أن المقالات المترجمة قد تحتوي على أخطاء في المفردات او بناء الجمل او النحو. وعليه، فإن شركة مايكروسوفت ليست مسؤولة عن اية أخطاء او عدم دقة في الترجمة او أية أضرار قد تحدث نتيجة أخطاء في ترجمة محتويات النص او استخدامه من قبل العملاء.

اضغط هنا لرابط المقالة باللغة الانجليزية893672
مقدمة
توضح هذه المقالة كيفية فتح المستندات باستخدام ميزة " فتح وإصلاح " في Microsoft Office Word 2002 أو الإصدارات الأحدث.
معلومات أخرى
يستخدم Microsoft Word تلقائياً ميزة " فتح وإصلاح " إذا كان Word الكشف عن مشكلة في مستند عند فتحه. ومع ذلك، يمكنك إجبار Word على استخدام ميزة " فتح وإصلاح " عند فتح أي مستند. قد يكون هذا مفيداً بشكل خاص عندما ترغب في حفظ المستند بتنسيق ملف مختلف. إذا قمت بحفظ مستند بتنسيق ملف مختلف، قد لا تتمكن من فتح المستند المحفوظ. لمزيد من المعلومات حول كيفية استكشاف أخطاء المستندات التالفة في Word، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":
826864 كيفية استكشاف أخطاء وإصلاحها تلف مستندات Word (لبرنامج Word 2002 و 2003)
918429 كيفية استكشاف أخطاء المستندات التالفة في Word 2007 و Word 2010


لفتح مستند باستخدام ميزة " فتح وإصلاح " في Word، استخدم إحدى الطرق التالية.

الطريقة الأولى: لفتح مستند محدد

لفتح مستند معين باستخدام ميزة " فتح وإصلاح " في Word، اتبع الخطوات التالية:
  1. بدء تشغيل Word.
  2. من القائمة ملف ، انقر فوق فتح.

    ملاحظة: في Word 2007 أو Word 2010، انقر فوق زر Microsoft Office، ومن ثم انقر فوق فتح.
  3. في مربع الحوار فتح ، انقر لتحديد الملف الذي تريد فتحه.
  4. انقر فوق السهم إلى الأسفل على الزر فتح ، وانقر فوق فتح وإصلاح.

الطريقة الثانية: لفتح كافة المستندات

تقدم Microsoft أمثلة برمجية للتوضيح فقط، دون أي ضمان صريح أو ضمني. هذا يتضمن، لكن لا يقتصر على، الضمانات الضمنية الخاصة بالتسويق أو الملاءمة لغرض معين. تفترض هذه المقالة أنك معتاد على لغة البرمجة التي يتم شرحها والأدوات المستخدمة لإنشاء الإجراءات وتصحيحها. يساعد مهندسو الدعم لدى Microsoft في شرح وظيفة إجراء محدد، لكنهم لن يقوموا بتعديل هذه الأمثلة لتقديم وظيفة إضافية أو إنشاء إجراءات تستوفي متطلبات محددة. لفتح كافة المستندات باستخدام ميزة " فتح وإصلاح " في Word، استبدال الماكرو FileOpen المضمنة في Word باستخدام Microsoft Visual Basic for Applications (VBA) الماكرو. للقيام بذلك، اتبع الخطوات التالية:
  1. بدء تشغيل Word وقم بفتح مستند فارغ جديد.
  2. في الإصدار Word 2007، انقر فوق وحدات الماكرو من علامة التبويب المطور . في Word 2003، أشر إلى ماكرو في قائمة " أدوات "، ومن ثم انقر فوق وحدات الماكرو.
  3. انقر فوق السهم إلى الأسفل في المربع وحدات الماكرو في ، ومن ثم انقر فوق أوامر Word.
  4. في القائمة اسم الماكرو ، انقر فوق FileOpen.
  5. انقر فوق السهم إلى الأسفل في المربع وحدات الماكرو في ، ومن ثم انقر فوق Normal.dot (قالب عمومي).

    ملاحظة: في Word 2007 و Word 2010، انقر فوقالقالب Normal.dotm (قالب عمومي).
  6. انقر فوق إنشاء.
  7. يظهر FileOpen الماكرو المضمن كما في المثال التالي:
    Sub FileOpen()'' FileOpen Macro' Opens an existing document or template'    Dialogs(wdDialogFileOpen).ShowEnd Sub
  8. استبدال الماكرو المضمن FileOpen بالمثال الماكرو التالي:
    Option Explicit' WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS EXAMPLE IS' AT YOUR OWN RISK. Microsoft provides this macro code "as is" without warranty of' any kind, either expressed or implied, including but not limited to the implied ' warranties of merchantability and/or fitness for a particular purpose.Sub FileOpen()'' FileOpen Macro' Opens an existing document or template'Dim sFileName As String' Display the File Open dialog and capture the filename selected and pass it to a' variableWith Application.Dialogs(wdDialogFileOpen)    .Display    sFileName = .NameEnd With' Test to verify the filename has a value' If no file is chosen or if the Open dialog is dismissed, ' the following code is skippedIf sFileName <> "" Then    ' Use the filename as a variable to be opened using Open and Repair feature    Documents.Open FileName:=sFileName, OpenAndRepair:=TrueEnd IfEnd Sub
  9. من القائمة ملف ، انقر فوق إغلاق ورجوع إلى Microsoft Word.
  10. من القائمة ملف ، اضغط SHIFT وانقر فوق حفظ الكل.
ملاحظات
  • سيتم تشغيل الماكرو FileOpen جديدة فقط إذا قمت بفتح مستند باستخدام أي من الطرق التالية:
    • انقر فوق فتح في القائمة ملف .
    • انقر فوق فتح في شريط الأدوات قياسي .
  • لن يتم تشغيل الماكرو FileOpen جديدة إذا قمت بفتح مستند باستخدام أي من الطرق التالية:
    • افتح المستند في "مستكشف Windows".
    • يمكنك فتح المستند من قائمة الملفات المستخدمة مؤخرا (MRU).
word2003 word2002 wd2003 wd2002 wd2k3 wd2k2 WD2007 word2010 wd2010

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 893672 - آخر مراجعة: 11/26/2016 06:31:00 - المراجعة: 5.0

Microsoft Office Word 2007, Microsoft Word 2002 Standard Edition, Microsoft Word 2010

  • kbopenfile kbprogramming kbautomation kbvba kbhowto kbmt KB893672 KbMtar
تعليقات