أنت غير متصل حاليًا، وفي انتظار الإنترنت الخاص بك ليقوم بإعادة الاتصال

FIX: الوظائف الإضافية أو المستندات الذكية أو العلامات الذكية التي تم إنشاؤها باستخدام Microsoft Visual Studio 2005 لا تقم بتشغيل في Office

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية908002
الأعراض
عند استخدام Microsoft Visual Studio 2005 في إنشاء الوظائف الإضافية أو المستندات الذكية أو العلامات الذكية قد تواجه الأعراض التالية:
  • لا يمكن تحميل الوظائف الإضافية أو المستندات الذكية أو العلامات الذكية في أي من تطبيقات Microsoft Office.
  • لا تقم بتشغيل الوظائف الإضافية أو المستندات الذكية أو العلامات الذكية في أي إصدار من Microsoft Office.
تحدث هذه المشكلة عند إنشاء الوظائف الإضافية أو المستندات الذكية أو العلامات الذكية على جهاز كمبيوتر مثبت عليه Microsoft .NET Framework 2.0 مثبت.

ملاحظة لا تحدث هذه المشكلة عند تسجيل الدخول باستخدام حساب مستخدم Microsoft Windows ذو إذن مقيد.
الحل
يسمح لك لبرنامج Visual Studio 2005 الموضحة في هذه المقالة إعادة توزيع الإصلاحات المطلوبة في Office و .NET Framework مع الحلول التي تكتبها في Visual Studio 2005. يضيف هذا التحديث جديد المشتركة "تحديث" الوظيفة الإضافية الدعم لـ Microsoft .NET Framework 2.0 (KB908002) الخيار إلى قائمة متطلبات Visual Studio 2005. عند إنشاء مشروع إعداد المدارة الوظيفة الإضافية أو المستندات الذكية أو العلامات الذكية يجب تمكين هذا الخيار في المشروع الإعداد الذي سيتضمن التحديثات القابلة لإعادة التوزيع المطلوبة إلى Office وإلى .NET Framework.

لحل هذه المشكلة، لمطوري Visual Studio 2005 يتوفر إصدار القابل لإعادة التوزيع تحديث لبرنامج Visual Studio 2005.

يتوفر الملف التالي للتنزيل من "مركز التنزيل لـ Microsoft":
DownloadDownload the VS2005-KB908002-ENU-x86.EXE package now.

للحصول على مزيد من المعلومات حول كيفية تنزيل ملفات دعم Microsoft، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف لـ Microsoft:
119591كيفية الحصول على ملفات دعم Microsoft من الخدمات عبر إنترنت
قامت Microsoft بفحص هذا الملف بحثًا عن الفيروسات. استخدام Microsoft أحدث من برنامج كشف الفيروس المتوفر على التاريخ الذي تم نشر الملف. يتم تخزين الملف على ملقمات محسنة الأمان التي تساعد على منع إجراء أية تغييرات غير مصرح به إلى الملف.

لتثبيت هذا التحديث لـ Visual Studio 2005 نوصي اتبع الخطوات التالية:
  1. حفظ حزمة التنزيل على جهاز الكمبيوتر الخاص بك.
  2. انقر نقراً مزدوجاً فوق حزمة التنزيل لتشغيل الحزمة.
  3. قراءة ومن ثم قبول "شروط ترخيص برامج Microsoft.
بعد تثبيت هذا التحديث، يجب عليك تضمين المشتركة "تحديث" الوظيفة الإضافية الدعم لـ Microsoft .NET Framework 2.0 (KB908002) الخيار بين المتطلبات المسبقة في المشروع إعداد الحل عند قيامك بإنشاء مشروع الوظيفة الإضافية مشتركة في Visual Studio 2005. للقيام بذلك، اتبع الخطوات التالية:
  1. في "مستكشف الحلول" انقر بزر الماوس الأيمن فوق المشروع إعداد الحل ومن ثم انقر فوق خصائص.
  2. انقر فوق "المتطلبات المسبقة.
  3. انقر لتحديد المشتركة الوظيفة الإضافية دعم تحديث لـ Microsoft .NET Framework 2.0 (KB908002) خانة الاختيار.
ملاحظة يجب تمكين لهذا المتطلب بشكل منفصل كليهما Debug كما إنشاء الإصدار.

ملاحظة يتم تثبيت هذا التحديث على أساس كل مستخدم. لذلك، قم بتثبيت التحديث لكل حساب مستخدم التي تتطلب التحديث.

عند إنشاء المشروع إعداد Visual Studio 2005 تتضمن التحديثات القابلة لإعادة التوزيع مع المشروع الخاص بك في مجلد يُسمى KB908002. يوجد هذا المجلد في تطبيق إعداد المجلد. محتويات المجلد KB908002 مطلوبة من أجل حل إعداد منطق تسلسل العمل بشكل صحيح. الملف Setup.exe بناء Visual Studio 2005 مع الإعداد المشروع سيتم تطبيق التحديثات على الكمبيوتر الوجهة عند تثبيت الحل.

ملاحظة .NET Framework 2.0 و Microsoft Windows Installer 2.0 مطلوبة من أجل الإصلاحات ليتم تثبيتها بشكل صحيح على الكمبيوتر الوجهة.

ملاحظة يحتوي هذا الملف .msi لم مواصفات ALLUSERS. لذلك، عند تثبيت هذا الملف .msi يتم تثبيت الملف في المستخدم سياق لكل مستخدم بدلاً من كل جهاز.
تصريح
أقرت Microsoft أن هذه مشكلة في منتجات Microsoft المسردة في قسم "تنطبق على".
معلومات أخرى

خطوات إعادة إنشاء المشكلة

  1. بدء تشغيل Microsoft Visual Studio 2005.
  2. إنشاء مشتركة الوظيفة الإضافية. للقيام بذلك، اتبع الخطوات التالية:
    1. من القائمة ملف، انقر فوق جديد ثم انقر فوق المشروع.
    2. في مربع الحوار مشروع جديد ، انقر فوق أنواع Project أخرى ثم انقر فوق القابلية للتوسعة.
    3. انقر فوق الوظيفة الإضافية المشتركة ، اكتب اسماً في المربع الاسم ثم انقر فوق موافق.
    4. اتبع الإرشادات في معالج المشتركة الوظيفة الإضافية إنشاء وظيفة الإضافية Microsoft Word.
  3. إنشاء المشروع. للقيام بذلك، اتبع الخطوات التالية:
    1. من القائمة المشروع انقر فوق خصائص YourProjectName.
    2. ضمن علامة التبويب YourProjectName ، انقر فوق إنشاء ثم انقر فوق تحرير في قائمة التكوين.
    3. في القائمة إنشاء ، انقر فوق بنية الحل.
  4. من القائمة ملف، انقر فوق "إنهاء" لإنهاء Visual Studio.
  5. نشر الوظيفة الإضافية. للقيام بذلك، اتبع الخطوات التالية:
    1. انقر فوق ابدأ ثم انقر فوق المستندات.
    2. افتح المجلد التالي:
      Visual Studio 2005\Projects\ YourProjectName \ Setup\Debug YourProjectName
      افتراضياً، يتم حفظ المشروع التي يمكنك إنشاؤها في الخطوة 3 إلى المجلد Visual Studio 2005.
    3. نسخ الملفات التالية إلى سطح المكتب على كمبيوتر آخر:
      • Setup.exe
      • YourProjectNameSetup.msi
    4. انقر نقراً مزدوجاً فوق الملف Setup.exe ومن ثم قبول كافة الإعدادات الافتراضية.
  6. بدء تشغيل Microsoft Word.
  7. من القائمة أدوات، انقر فوق قوالب ووظائف إضافية.
  8. انقر فوق إضافة. تتلقى رسالة خطأ في مربع حوار وظائف COM الإضافية.
مراجع
لمزيد من المعلومات، انقر فوق أرقام المقالات التالية لعرضها في "قاعدة المعارف لـ Microsoft:
907417وصف التحديث الخاص بـ Office 2003: ٨ نوفمبر ٢٠٠٥
ملاحظة إصدار Otkloadr.dll التحديث الموضح في قاعدة معارفMicrosoft المقالة 907417 يتيح للمستخدمين النهائيين من Office 2003 إصلاح فقط. لم عنوان تحتوي هذه المقالة على ارتباطات المشكلة Extensibility.dll أو إصدارات Office التي تختلف من Office 2003.

لمزيد من المعلومات، انقر فوق أرقام المقالات التالية لعرضها في "قاعدة المعارف لـ Microsoft:
908003FIX: تعطل Office 2003 عند محاولة إغلاق مستند Word أو جدول بيانات Excel من عنصر تحكم WinForm في أدوات Studio Visual حل 2003 الإصدار نظام Office
908004FIX: أنت لا يمكن تشغيل تخصيص تم إنشاؤه في Microsoft Visual Studio أدوات نظام Microsoft Office الإصدار 2003
خطأ في وقت التشغيل mscoree.dll

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 908002 - آخر مراجعة: 12/03/2007 18:47:07 - المراجعة: 4.4

Microsoft .NET Framework 2.0, Microsoft Visual Studio 2005 Tools for the Microsoft Office System, Microsoft Visual Studio 2005 Standard Edition, Microsoft Visual Studio 2005 Professional Edition, Microsoft Visual Studio 2005 Express Edition, Microsoft Visual Studio 2005 Team System Team Foundation:, Microsoft Visual Studio 2005 Team System Architect Edition, Microsoft Visual Studio 2005 Team System Developer Edition, Microsoft Office 2003, All Editions, Microsoft Office 2000 Standard Edition, Microsoft Office XP, Microsoft Office 97 Standard Edition, Microsoft Office Professional 2007, Microsoft Office Standard 2007

  • kbmt kbnofix kbbug kbtshoot KB908002 KbMtar
تعليقات
ody>did=1&t=">