ظهور رسالة خطأ عند محاولة تثبيت Microsoft Dynamics CRM client for Outlook أو ترقيته أو تكوينه على الكمبيوتر

الأعراض
عند محاولة تثبيت Microsoft Dynamics CRM client for Microsoft Office Outlook أو ترقيته على الكمبيوتر، تظهر رسالة الخطأ التالية:
فشل إجراء Microsoft.Crm.Config.Client.InstallAbpAction.
تم رفض الوصول. (استثناء من HRESULT: 0x80070005 ‏(E_ACCESSDENIED))
بالإضافة إلى ذلك، تظهر إحدى رسالتي الخطأ التاليتين.
رسالة الخطأ الأولى
عند تثبيت Microsoft Dynamics CRM 4.0 client for Outlook على الكمبيوتر، تظهر لك رسالة الخطأ التالية في سجل التكوين:
12:58:46| Error| Configuration exception.System.Exception: Action Microsoft.Crm.Config.Client.InstallAbpAction failed. --->
System.UnauthorizedAccessException: تم رفض الوصول. (Exception from HRESULT: 0x80070005 ‏(E_ACCESSDENIED))
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal‏(Int32 errorCode, IntPtr errorInfo)
at Microsoft.Crm.Config.Client.InstallAbpAction.Do‏(IDictionary parameters)
at Microsoft.Crm.Setup.Common.Action.ExecuteAction‏(Action action, IDictionary parameters, Boolean undo)
--- End of inner exception stack trace ---
at Microsoft.Crm.Setup.Common.Action.ExecuteAction‏(Action action, IDictionary parameters, Boolean undo)
at Microsoft.Crm.Setup.Common.Installer.Install‏(IDictionary stateSaver)
at Microsoft.Crm.Setup.Common.ComposedInstaller.InternalInstall‏(IDictionary stateSaver)
at Microsoft.Crm.Setup.Common.ComposedInstaller.Install‏(IDictionary stateSaver)
at Microsoft.Crm.Config.Client.ClientConfig.Install(IDictionary data)
at Microsoft.Crm.Config.Client.ClientConfig.Run() 12:58:46|Verbose| Configuration Failed 12:58:46| Info| We were unable to successfully configure Microsoft Dynamics CRM for Outlook:

Action Microsoft.Crm.Config.Client.InstallAbpAction failed.
تم رفض الوصول. (Exception from HRESULT: 0x80070005 ‏(E_ACCESSDENIED))
رسالة الخطأ الثانية
عند ترقية Microsoft Dynamics CRM 3.0 client for Outlook على الكمبيوتر، تظهر لك رسالة الخطأ التالية في سجل التثبيت:
UpgradeDatabase.Action
UpgradeDatabase.Started
Searching for Database Files
Moving Database Files
Finished Database Actions
Assigning Permissions for S-1-5-21-682003330-616249376-1801674531-1112
C:\Program Files\Microsoft CRM\sql\v3_msde_mscrm.mdf
at System.Security.AccessControl.NativeObjectSecurity.CreateInternal‏(ResourceType resourceType, Boolean isContainer, String name, SafeHandle handle, AccessControlSections includeSections, Boolean createByName, ExceptionFromErrorCode exceptionFromErrorCode, Object exceptionContext)
at System.Security.AccessControl.FileSystemSecurity..ctor‏(Boolean isContainer, String name, AccessControlSections includeSections, Boolean isDirectory)
at System.Security.AccessControl.FileSecurity..ctor‏(String fileName, AccessControlSections includeSections)
at System.IO.FileInfo.GetAccessControl() at Microsoft.Crm.Setup.Client.DatabaseInstaller.Upgrade‏(Session session)
at Microsoft.Crm.Setup.Client.ClientSetup.UpgradeDatabase‏(Session session)
Action ended 10:33:09: InstallFinalize. Return value 3.
عند محاولة تكوين الإصدار Outlook Offline Client من Microsoft Dynamics CRM 4.0، يظهر لك باستمرار الخطأ التالي في نافذة إعادة المحاولة/إلغاء الأمر المشروطة:
فشل إجراء Microsoft.Crm.Config.Client.InstallPstAction. فشل LaunchOutlookInstallerProcess.
السبب
قد تحدث هذه المشكلة في حالة عدم إزالة ملف بيانات Microsoft Dynamics CRM وجهات اتصال Microsoft Dynamics CRM address book provider ‏(ABP) بشكل كامل.
الحل

الحل الأول

لحل هذه المشكلة، استخدم إحدى الطريقتين التاليتين، ثم حاول تثبيت Microsoft Dynamics CRM client for Outlook أو ترقيته على الكمبيوتر.

الطريقة الأولى: إذا كان Microsoft Office Outlook 2007 مثبتًا لديك

  1. قم بتشغيل برنامج Outlook 2007.
  2. من القائمة أدوات، انقر فوق إعدادات الحسابات.
  3. انقر فوق علامة التبويب ملفات البيانات.
  4. انقر فوق Microsoft CRM، ثم انقر فوق إزالة.
  5. انقر فوق علامة التبويب دفاتر العناوين.
  6. انقر فوق دفتر عنوان Microsoft CRM، ثم انقر فوق إزالة.
  7. قم بإنهاء برنامج Outlook 2007.

الطريقة الثانية: إذا كان Microsoft Office Outlook 2003 مثبتًا لديك

  1. قم بإنهاء برنامج Outlook 2003.
  2. انقر فوق ابدأ، ثم انقر فوق لوحة التحكم، ثم انقر فوق حسابات المستخدمين، ثم انقر فوق البريد.
  3. في مربع الحوار إعداد البريد، انقر فوق ملفات البيانات.
  4. انقر فوق Microsoft CRM، ثم انقر فوق إزالة، ثم انقر فوق إغلاق.
  5. في مربع الحوار إعداد البريد، انقر فوق حسابات البريد الإلكتروني.
  6. انقر فوق عرض الدلائل أو دفاتر العناوين الموجودة أو تغييرها، ثم انقر فوق التالي.
  7. انقر فوق دفتر عنوان Microsoft CRM، ثم انقر فوق إزالة.
  8. انقر فوق إغلاق لإغلاق مربع الحوار إعداد البريد.

الحل الثاني

اتبع الخطوات التالية:
  1. قم بتشغيل تطبيق Outlook.
  2. من القائمة أدوات، انقر فوق خيارات.
  3. في علامة التبويب إعداد البريد، انقر فوق حسابات البريد الإلكتروني.
  4. في علامة التبويب ملفات البيانات، حدد Microsoft CRM- غير متوفر، ثم انقر فوق إزالة.
crm3 crm30 crm3.0 crm4 crm40 crm4.0
خصائص

رقم الموضوع: 948312 - آخر مراجعة: 09/12/2011 00:19:00 - المراجعة: 2.0

Microsoft Dynamics CRM 4.0, Microsoft Dynamics CRM for Microsoft Office Outlook

  • kberrmsg kbmbsupgrade kbexpertisebeginner kbtshoot kbmbsmigrate kbprb KB948312
تعليقات