أنت غير متصل حاليًا، وفي انتظار الإنترنت الخاص بك ليقوم بإعادة الاتصال

تصحيح: "المحول BizTalk EMS تيبكو" عدم حذف الرسائل من قائمة انتظار جمس بعد المحول بنجاح تلقي الرسائل في BizTalk Server 2006 R2

هام: تمت ترجمة هذا المقال باستخدام برنامج ترجمة آلية لشركة مايكروسوفت بدلاً من الاستعانة بمترجم بشري. تقدم شركة مايكروسوفت كلاً من المقالات المترجمة بواسطة المترجمين البشر والمقالات المترجمة آليًا وبالتالي ستتمكن من الوصول إلى كل المقالات الموجودة في قاعدة المعرفة الخاصة بنا وباللغة الخاصة بك. بالرغم من ذلك، فإن المقالة المترجمة آليًا لا تكون دقيقة دائمًا وقد تحتوي على أخطاء إملائية أو لغوية أو نحوية، مثل تلك الأخطاء الصادرة عن متحدث أجنبي عندما يتحدث بلغتك. لا تتحمل شركة مايكروسوفت مسئولية عدم الدقة أو الأخطاء أو الضرر الناتج عن أية أخطاء في ترجمة المحتوى أو استخدامه من قبل عملائنا. تعمل شركة مايكروسوفت باستمرار على ترقية برنامج الترجمة الآلية

اضغط هنا لرابط المقالة باللغة الانجليزية961346
الأعراض
أطلع على السيناريو التالي في Microsoft BizTalk Server 2006 R2:
  • استخدم محول BizTalk Microsoft تيبكو المؤسسة رسالة خدمة (EMS) كمحول تلقي.
  • استخدام "المحول BizTalk EMS تيبكو" للبيانات من قائمة انتظار خدمة الرسالة Java (جمس) على ملقم EMS تيبكو الاستقصاء.
  • تعييناستخدام المعاملةالمعلمة إلى "نعم" في صفحة خصائص محول BizTalk ل EMS تيبكو.
في هذا السيناريو، بعد "المحول BizTalk EMS تيبكو" بنجاح تلقي الرسائل، لا يتم حذف الرسائل من قائمة انتظار جمس على الملقم تيبكو EMS.
السبب
تحدث هذه المشكلة نظراً لوجود مشكلة في المحول BizTalk EMS تيبكو.
الحل

معلومات الإصلاح العاجل

A يتوفر إصلاح عاجل معتمد من Microsoft. ولكن الغرض هذا الإصلاح العاجل لحل المشكلة الموضحة في هذه المقالة فقط. تطبيق هذا الإصلاح العاجل فقط على الأنظمة التي تواجه هذه المشكلة.

إذا كان يتوفر الإصلاح الجديد للتحميل، يتم تنزيل الإصلاح عاجل " المقطع متوفر "في أعلى مقالة قاعدة المعارف هذه. إذا كان هذا القسم لا تظهر، إرسال طلب إلى خدمة العملاء ل Microsoft ودعم الحصول على الإصلاح العاجل.

ملاحظةفي حالة حدوث مشاكل إضافية أو إذا كانت أي استكشاف مطلوبة قد يلزم الأمر إنشاء طلب خدمة منفصل. تكاليف الدعم المعتادة سيتم تطبيق على أسئلة الدعم الإضافية والمشكلات التي لا يعمل على حلها هذا الإصلاح العاجل المحدد. للحصول على قائمة كاملة من خدمة العملاء ل Microsoft و أرقام هاتف دعم أو لإنشاء طلب خدمة منفصل، قم بزيارة موقع Microsoft التالي:ملاحظةاللغات لعرض النموذج "توفر تنزيل الإصلاح العاجل" الذي يتوفر الإصلاح العاجل. إذا لم تشاهد اللغة الخاصة بك، يكون سبب لا يتوفر إصلاح عاجل لتلك اللغة.

المتطلبات الأساسية

يجب أن يكون لديك Microsoft BizTalk المحولات "تطبيقات المؤسسة" مثبتة لتطبيق هذا الإصلاح العاجل.

متطلبات إعادة التشغيل

لا يلزم الأمر إعادة تشغيل الكمبيوتر بعد تطبيق هذا الإصلاح العاجل. ومع ذلك، يجب إعادة تشغيل المثيل المضيف BizTalk بعد تطبيق هذا الإصلاح العاجل.

معلومات استبدال الإصلاح العاجل

يحل هذا الإصلاح العاجل محل الإصلاحات التي تم إصدارها مسبقاً.

الخطوات المتوفرة بعد التثبيت

بعد تطبيق هذا الإصلاح العاجل، يتوفر قيمة سجل جديدة تسمى ديليتيفتيربول. تعيين قيمة التسجيل ديليتيفتيربول ما إذا كان يتم حذف الرسائل من قائمة انتظار جمس بعد نجاح تلقيها عن طريق محول BizTalk ل EMS تيبكو.

إذا قمت بتعييناستخدام المعاملةمعلمةنعمعلى صفحة خصائص محول BizTalk EMS تيبكو وتريد التأكد من أن يتم حذف الرسائل من قائمة انتظار جمس بعد تلقي قبل محول BizTalk ل EMS تيبكو، يجب إجراء التغييرات على التسجيل التالية:
  1. انقر فوقبدء تشغيل، انقر فوقتشغيل، نوعregedit، ثم انقر فوقموافق.
  2. حدد موقع، ثم انقر فوق مفتاح التسجيل الفرعي التالي:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters\Config\Global\Adapters\TibcoEMS
  3. علىتحرير، أشر إلىجديد، ثم انقر فوققيمة السلسلة.
  4. نوعديليتيفتيربول، ثم اضغط Enter.
  5. علىتحريرالقائمة، انقر فوقتعديل.
  6. نوعصوابلتعيين القيمة.

    ملاحظات
    • هذه القيمة حساسة لحالة الأحرف.
    • في حالة عدم وجود قيمة التسجيل ديليتيفتيربول أو إذا تم تعيينها إلى أي قيمة أخرىصواب، لا يتم حذف الرسائل من قائمة انتظار جمس بعد تلقي الرسائل بواسطة محول BizTalk ل EMS تيبكو.
  7. قم بإعادة تشغيل المثيل المضيف BizTalk.

معلومات الملف

إصدار اللغة الإنجليزية من هذا الإصلاح العاجل على سمات الملف (أو سمات الملفات الأحدث) المسرودة في الجدول التالي. يتم سرد التواريخ والأوقات الخاصة بهذه الملفات "التوقيت العالمي" (UTC). عندما تقوم بعرض معلومات الملف، يتم تحويلها إلى التوقيت المحلي. لمعرفة الفرق بين التوقيت العالمي UTC والتوقيت المحلي، استخدمالمنطقة الزمنيةعلامة تبويب فيالتاريخ والوقتعنصر في "لوحة التحكم".
اسم الملفإصدار الملفحجم الملفتاريخالوقتالنظام الأساسي
Microsoft.biztalk.adapters.tibcoems.dll1.0.5018.075,64029 ديسمبر 200815: 31الإصدار x86
ملاحظةنظراً لتبعيات الملف، أحدث إصلاح عاجل التي يحتوي على هذه الملفات أيضا يحتوي على ملفات إضافية.
تصريح
Microsoft أقرت أن هذه مشكلة في منتجات Microsoft المسردة في قسم "تنطبق على".
معلومات أخرى
إذا قمت بتعييناستخدام المعاملةمعلمةبلاعلى صفحة خصائص محول BizTalk لمحول EMS تيبكو، يتم حذف الرسائل تلقائياً من قائمة انتظار جمس بعد تلقي قبل محول BizTalk ل EMS تيبكو.

لمزيد من المعلومات حول محول BizTalk EMS تيبكو، قم بزيارة مواقع ويب MSDN التالي:للحصول على مزيد من المعلومات حول مصطلحات تحديث البرامج، انقر فوق رقم المقالة التالي لعرض المقالة في قاعدة معارف Microsoft:
824684وصف للمصطلحات القياسية المستخدمة في وصف تحديثات برامج Microsoft

تحذير: تمت ترجمة هذه المقالة تلقائيًا

خصائص

رقم الموضوع: 961346 - آخر مراجعة: 02/16/2011 20:12:00 - المراجعة: 1.0

Microsoft BizTalk Server 2006 R2 Standard Edition, Microsoft BizTalk Server 2006 R2 Enterprise Edition, Microsoft BizTalk Server 2006 R2 Developer Edition, Microsoft BizTalk Server 2006 R2 Branch

  • kbbtsadapters kbautohotfix kbbiztalk2006r2sp1fix kbbug kbexpertiseinter kbfix kbhotfixserver kbqfe kbmt KB961346 KbMtar
تعليقات
Tracker.init(); &t=">